Updated to 57.0 Beta 7
This commit is contained in:
parent
fd700ad0ae
commit
4f71e47653
2
.gitignore
vendored
2
.gitignore
vendored
@ -253,3 +253,5 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-langpacks-57.0b5-20171005.tar.xz
|
/firefox-langpacks-57.0b5-20171005.tar.xz
|
||||||
/firefox-57.0b6.source.tar.xz
|
/firefox-57.0b6.source.tar.xz
|
||||||
/firefox-langpacks-57.0b6-20171009.tar.xz
|
/firefox-langpacks-57.0b6-20171009.tar.xz
|
||||||
|
/firefox-57.0b7.source.tar.xz
|
||||||
|
/firefox-langpacks-57.0b7-20171011.tar.xz
|
||||||
|
11
firefox.spec
11
firefox.spec
@ -77,7 +77,7 @@
|
|||||||
%global sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo 65536)
|
%global sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo 65536)
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define pre_version b6
|
%define pre_version b7
|
||||||
|
|
||||||
%global mozappdir %{_libdir}/%{name}
|
%global mozappdir %{_libdir}/%{name}
|
||||||
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
|
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
|
||||||
@ -99,13 +99,13 @@
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 57.0
|
Version: 57.0
|
||||||
Release: 0.2%{?pre_tag}%{?dist}
|
Release: 0.3%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20171009.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20171011.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
Source12: firefox-redhat-default-prefs.js
|
Source12: firefox-redhat-default-prefs.js
|
||||||
@ -155,7 +155,6 @@ Patch410: mozilla-1321521.patch
|
|||||||
Patch411: mozilla-1321521-2.patch
|
Patch411: mozilla-1321521-2.patch
|
||||||
Patch412: mozilla-1337988.patch
|
Patch412: mozilla-1337988.patch
|
||||||
Patch413: mozilla-1353817.patch
|
Patch413: mozilla-1353817.patch
|
||||||
Patch415: mozilla-1405267.patch
|
|
||||||
Patch416: mozilla-1399611.patch
|
Patch416: mozilla-1399611.patch
|
||||||
|
|
||||||
# Debian patches
|
# Debian patches
|
||||||
@ -335,7 +334,6 @@ This package contains results of tests executed during build.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch413 -p1 -b .1353817
|
%patch413 -p1 -b .1353817
|
||||||
%patch415 -p1 -b .1405267
|
|
||||||
%patch416 -p1 -b .1399611
|
%patch416 -p1 -b .1399611
|
||||||
|
|
||||||
# Debian extension patch
|
# Debian extension patch
|
||||||
@ -858,6 +856,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 11 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.3
|
||||||
|
- Updated to 57.0 Beta 7
|
||||||
|
|
||||||
* Mon Oct 9 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.2
|
* Mon Oct 9 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.2
|
||||||
- Updated to 57.0 Beta 6
|
- Updated to 57.0 Beta 6
|
||||||
|
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
diff -up firefox-57.0b5/widget/gtk/mozgtk/mozgtk.c.1405267 firefox-57.0b5/widget/gtk/mozgtk/mozgtk.c
|
|
||||||
--- firefox-57.0b5/widget/gtk/mozgtk/mozgtk.c.1405267 2017-09-19 06:18:28.000000000 +0200
|
|
||||||
+++ firefox-57.0b5/widget/gtk/mozgtk/mozgtk.c 2017-10-06 12:29:46.941289468 +0200
|
|
||||||
@@ -95,6 +95,7 @@ STUB(gdk_window_get_update_area)
|
|
||||||
STUB(gdk_window_get_user_data)
|
|
||||||
STUB(gdk_window_get_visual)
|
|
||||||
STUB(gdk_window_get_width)
|
|
||||||
+STUB(gdk_window_get_window_type)
|
|
||||||
STUB(gdk_window_hide)
|
|
||||||
STUB(gdk_window_input_shape_combine_region)
|
|
||||||
STUB(gdk_window_invalidate_rect)
|
|
||||||
@@ -520,7 +521,6 @@ STUB(gdk_error_trap_pop_ignored)
|
|
||||||
STUB(gdk_event_get_source_device)
|
|
||||||
STUB(gdk_screen_get_monitor_workarea)
|
|
||||||
STUB(gdk_window_get_type)
|
|
||||||
-STUB(gdk_window_get_window_type)
|
|
||||||
STUB(gdk_x11_window_get_xid)
|
|
||||||
STUB(gdk_x11_display_get_type)
|
|
||||||
STUB(gdk_wayland_display_get_type)
|
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (firefox-57.0b6.source.tar.xz) = 182fef4180ed511be61201925ea3c29bd3ca087c4380234fe434640b00fa46730f41d41cd61cf79ff6bd66c6f3749c9a19a19d8cb28281761ef74065e7e44eb8
|
SHA512 (firefox-57.0b7.source.tar.xz) = 86f9669263e5bae53556d27eedc8ae3f88f3f946bfe121e6c357f2719f38e1e0d448beab2844b8fd80bc200beedc6fbbbb20df7f7cac8d6399cdd024675f0fbe
|
||||||
SHA512 (firefox-langpacks-57.0b6-20171009.tar.xz) = 4e5ccece1a4e09db8ae04d5a22503f67da64e5d224f5d3c60f70344fd12520781e66c09d6b764ce64a72974dd69f3fb0fa1c747bafdf0e0b9fb9094d934fdc4b
|
SHA512 (firefox-langpacks-57.0b7-20171011.tar.xz) = c9df71681a3bcb0d5267ea77e03868a9bc4c2321cc0228b69e0ebd58f3ccca792abe747611908b0c2b4d2ffd561c195fac550f3f0a25e0b4e0f7464a78ef1c71
|
||||||
|
Loading…
Reference in New Issue
Block a user