- Fixed rhbz#531159 - disable firefox default browser check
- Disabled automatic updates
This commit is contained in:
parent
5a8c25a229
commit
4c3c3e64a0
91
firefox-default.patch
Normal file
91
firefox-default.patch
Normal file
@ -0,0 +1,91 @@
|
||||
diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul.default firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul
|
||||
--- firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul.default 2010-06-11 22:40:51.000000000 +0200
|
||||
+++ firefox-3.6.4/mozilla-1.9.2/browser/components/preferences/advanced.xul 2010-06-24 11:42:36.000000000 +0200
|
||||
@@ -185,10 +185,11 @@
|
||||
</groupbox>
|
||||
|
||||
#ifdef HAVE_SHELL_SERVICE
|
||||
+#ifdef MOZ_CRASHREPORTER
|
||||
<!-- System Defaults -->
|
||||
<groupbox id="systemDefaultsGroup" orient="vertical">
|
||||
<caption label="&systemDefaults.label;"/>
|
||||
-
|
||||
+#ifdef 0
|
||||
<hbox id="checkDefaultBox" align="center" flex="1">
|
||||
<checkbox id="alwaysCheckDefault" preference="browser.shell.checkDefaultBrowser"
|
||||
label="&alwaysCheckDefault.label;" accesskey="&alwaysCheckDefault.accesskey;"
|
||||
@@ -198,6 +199,7 @@
|
||||
oncommand="gAdvancedPane.checkNow()"
|
||||
preference="pref.general.disable_button.default_browser"/>
|
||||
</hbox>
|
||||
+#endif
|
||||
#ifdef MOZ_CRASHREPORTER
|
||||
<checkbox id="submitCrashesBox" flex="1"
|
||||
oncommand="gAdvancedPane.updateSubmitCrashes();"
|
||||
@@ -205,6 +207,7 @@
|
||||
#endif
|
||||
</groupbox>
|
||||
#endif
|
||||
+#endif
|
||||
</tabpanel>
|
||||
|
||||
<!-- Network -->
|
||||
diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp.default firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp
|
||||
--- firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp.default 2010-06-11 22:40:51.000000000 +0200
|
||||
+++ firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.cpp 2010-06-24 11:42:36.000000000 +0200
|
||||
@@ -140,27 +140,21 @@ NS_IMPL_ISUPPORTS1(nsGNOMEShellService,
|
||||
PRBool
|
||||
nsGNOMEShellService::KeyMatchesAppName(const char *aKeyValue) const
|
||||
{
|
||||
+ nsCAutoString appName;
|
||||
|
||||
- gchar *commandPath;
|
||||
if (mUseLocaleFilenames) {
|
||||
gchar *nativePath = g_filename_from_utf8(aKeyValue, -1, NULL, NULL, NULL);
|
||||
if (!nativePath) {
|
||||
NS_ERROR("Error converting path to filesystem encoding");
|
||||
return PR_FALSE;
|
||||
}
|
||||
-
|
||||
- commandPath = g_find_program_in_path(nativePath);
|
||||
+ appName.Assign(nativePath);
|
||||
g_free(nativePath);
|
||||
} else {
|
||||
- commandPath = g_find_program_in_path(aKeyValue);
|
||||
+ appName.Assign(aKeyValue);
|
||||
}
|
||||
-
|
||||
- if (!commandPath)
|
||||
- return PR_FALSE;
|
||||
-
|
||||
- PRBool matches = mAppPath.Equals(commandPath);
|
||||
- g_free(commandPath);
|
||||
- return matches;
|
||||
+ // Compare default browser command retrieved from gconf with MOZ_APP_NAME
|
||||
+ return appName.EqualsLiteral(MOZ_APP_NAME);
|
||||
}
|
||||
|
||||
NS_IMETHODIMP
|
||||
@@ -216,8 +210,8 @@ nsGNOMEShellService::SetDefaultBrowser(P
|
||||
nsCOMPtr<nsIGConfService> gconf = do_GetService(NS_GCONFSERVICE_CONTRACTID);
|
||||
|
||||
nsCAutoString schemeList;
|
||||
- nsCAutoString appKeyValue(mAppPath);
|
||||
- appKeyValue.Append(" \"%s\"");
|
||||
+ nsCAutoString appKeyValue(MOZ_APP_NAME);
|
||||
+ appKeyValue.Append(" %s");
|
||||
unsigned int i;
|
||||
|
||||
for (i = 0; i < NS_ARRAY_LENGTH(appProtocols); ++i) {
|
||||
diff -up firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h.default firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h
|
||||
--- firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h.default 2010-06-11 22:40:51.000000000 +0200
|
||||
+++ firefox-3.6.4/mozilla-1.9.2/browser/components/shell/src/nsGNOMEShellService.h 2010-06-24 11:42:36.000000000 +0200
|
||||
@@ -43,7 +43,7 @@
|
||||
class nsGNOMEShellService : public nsIShellService
|
||||
{
|
||||
public:
|
||||
- nsGNOMEShellService() : mCheckedThisSession(PR_FALSE) { }
|
||||
+ nsGNOMEShellService() : mCheckedThisSession(PR_TRUE) { }
|
||||
|
||||
NS_DECL_ISUPPORTS
|
||||
NS_DECL_NSISHELLSERVICE
|
12
firefox-disable-checkupdates.patch
Normal file
12
firefox-disable-checkupdates.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up mozilla-1.9.2/browser/base/content/utilityOverlay.js.checkForUpdates mozilla-1.9.2/browser/base/content/utilityOverlay.js
|
||||
--- mozilla-1.9.2/browser/base/content/utilityOverlay.js.checkForUpdates 2010-06-13 15:36:16.617677299 -0700
|
||||
+++ mozilla-1.9.2/browser/base/content/utilityOverlay.js 2010-06-13 15:39:54.485387418 -0700
|
||||
@@ -510,7 +510,7 @@ function buildHelpMenu()
|
||||
// Disable the UI if the update enabled pref has been locked by the
|
||||
// administrator or if we cannot update for some other reason
|
||||
var checkForUpdates = document.getElementById("checkForUpdates");
|
||||
- var canCheckForUpdates = updates.canCheckForUpdates;
|
||||
+ var canCheckForUpdates = updates.canCheckForUpdates && updates.canApplyUpdates;
|
||||
checkForUpdates.setAttribute("disabled", !canCheckForUpdates);
|
||||
if (!canCheckForUpdates)
|
||||
return;
|
14
firefox.spec
14
firefox.spec
@ -25,7 +25,7 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 3.6.4
|
||||
Release: 1%{?prever}%{?dist}
|
||||
Release: 2%{?prever}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
@ -48,6 +48,10 @@ Source100: find-external-requires
|
||||
Patch0: firefox-version.patch
|
||||
Patch1: mozilla-jemalloc-526152.patch
|
||||
|
||||
# Fedora patches
|
||||
Patch10: firefox-disable-checkupdates.patch
|
||||
Patch11: firefox-default.patch
|
||||
|
||||
# Upstream patches
|
||||
|
||||
%if %{official_branding}
|
||||
@ -95,6 +99,10 @@ sed -e 's/__RPM_VERSION_INTERNAL__/%{internal_version}/' %{P:%%PATCH0} \
|
||||
# For branding specific patches.
|
||||
%patch1 -p1 -b .526152
|
||||
|
||||
# Fedora patches
|
||||
%patch10 -p1 -b .checkupdates
|
||||
%patch11 -p2 -b .default
|
||||
|
||||
%if %{official_branding}
|
||||
# Required by Mozilla Corporation
|
||||
|
||||
@ -375,6 +383,10 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Tue Jun 24 2010 Martin Stransky <stransky@redhat.com> - 3.6.4-2
|
||||
- Fixed rhbz#531159 - disable firefox default browser check
|
||||
- Disabled automatic updates
|
||||
|
||||
* Wed Jun 23 2010 Jan Horak <jhorak@redhat.com> -3.6.4-1
|
||||
- Update to 3.6.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user