backported pango patches from FC6
This commit is contained in:
parent
ac0321ef67
commit
4a48addf3b
19
firefox-1.5-pango-cursor-position-more.patch
Normal file
19
firefox-1.5-pango-cursor-position-more.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -pruN -x '.moz*' -x .deps -x 'firefox*' -x '*.mk' -x 'config*' -x dist -x build -x toolkit -x '*o' -x '*a' -x '*html' mozilla.orig/layout/generic/nsTextFrame.cpp mozilla/layout/generic/nsTextFrame.cpp
|
||||
--- mozilla.orig/layout/generic/nsTextFrame.cpp 2006-08-26 13:33:35.000000000 +0900
|
||||
+++ mozilla/layout/generic/nsTextFrame.cpp 2006-12-13 20:54:32.000000000 +0900
|
||||
@@ -4261,12 +4261,10 @@ nsTextFrame::GetPointFromOffset(nsPresCo
|
||||
if (tc) {
|
||||
totalLength = tc->Text()->GetLength(); // raw value which includes whitespace
|
||||
}
|
||||
- if ((hitLength == textLength) && (inOffset = mContentLength) &&
|
||||
- (mContentOffset + mContentLength == totalLength)) {
|
||||
- // no need to re-measure when at the end of the last-in-flow
|
||||
- }
|
||||
+ if (hitLength > 0)
|
||||
+ inRendContext->GetRangeWidth(paintBuffer.mBuffer, textLength, 0, hitLength, (PRUint32&)width);
|
||||
else
|
||||
- inRendContext->GetWidth(paintBuffer.mBuffer, hitLength, width);
|
||||
+ width = 0;
|
||||
}
|
||||
if ((hitLength == textLength) && (TEXT_TRIMMED_WS & mState)) {
|
||||
//
|
53
firefox-1.5-pango-justified-range.patch
Normal file
53
firefox-1.5-pango-justified-range.patch
Normal file
@ -0,0 +1,53 @@
|
||||
diff -pruN -x '.moz*' -x .deps -x 'thunderbird*' -x '*.mk' -x 'config*' -x dist -x build -x toolkit -x '*o' -x '*a' -x '*html' -x 'firefox*' mozilla.orig/layout/generic/nsTextFrame.cpp mozilla/layout/generic/nsTextFrame.cpp
|
||||
--- mozilla.orig/layout/generic/nsTextFrame.cpp 2006-12-20 12:15:38.000000000 +0900
|
||||
+++ mozilla/layout/generic/nsTextFrame.cpp 2006-12-20 21:29:39.000000000 +0900
|
||||
@@ -2973,15 +2973,16 @@ nsTextFrame::RenderString(nsIRenderingCo
|
||||
|
||||
nsIFontMetrics* lastFont = aTextStyle.mLastFont;
|
||||
PRInt32 pendingCount;
|
||||
- PRUnichar* runStart = bp;
|
||||
+ PRUnichar* runStart = bp, *top = aBuffer;
|
||||
nscoord charWidth, width = 0;
|
||||
PRInt32 countSoFar = 0;
|
||||
+ PRUint32 offset;
|
||||
// Save the color we want to use for the text, since calls to
|
||||
// PaintTextDecorations in this method will call SetColor() on the rendering
|
||||
// context.
|
||||
nscolor textColor;
|
||||
aRenderingContext.GetColor(textColor);
|
||||
- for (; --aLength >= 0; aBuffer++) {
|
||||
+ for (offset = 0; offset < aLength; aBuffer++, offset++) {
|
||||
nsIFontMetrics* nextFont;
|
||||
nscoord glyphWidth = 0;
|
||||
PRUnichar ch = *aBuffer;
|
||||
@@ -3038,7 +3039,7 @@ nsTextFrame::RenderString(nsIRenderingCo
|
||||
else if (ch == ' ') {
|
||||
glyphWidth += aTextStyle.mSpaceWidth + aTextStyle.mWordSpacing + aTextStyle.mLetterSpacing;
|
||||
}
|
||||
- else if (IS_HIGH_SURROGATE(ch) && aLength > 0 &&
|
||||
+ else if (IS_HIGH_SURROGATE(ch) && (offset + 1) < aLength &&
|
||||
IS_LOW_SURROGATE(*(aBuffer+1))) {
|
||||
|
||||
// special handling for surrogate pair
|
||||
@@ -3046,7 +3047,7 @@ nsTextFrame::RenderString(nsIRenderingCo
|
||||
glyphWidth += charWidth + aTextStyle.mLetterSpacing;
|
||||
// copy the surrogate low
|
||||
*bp++ = ch;
|
||||
- --aLength;
|
||||
+ offset++;
|
||||
aBuffer++;
|
||||
ch = *aBuffer;
|
||||
// put the width into the space buffer
|
||||
@@ -3058,10 +3059,10 @@ nsTextFrame::RenderString(nsIRenderingCo
|
||||
glyphWidth = 0;
|
||||
}
|
||||
else {
|
||||
- aRenderingContext.GetWidth(ch, charWidth);
|
||||
+ aRenderingContext.GetRangeWidth(top, aLength, offset, offset + 1, (PRUint32&)charWidth);
|
||||
glyphWidth += charWidth + aTextStyle.mLetterSpacing;
|
||||
}
|
||||
- if (justifying && (!isEndOfLine || aLength > 0)
|
||||
+ if (justifying && (!isEndOfLine || (offset + 1) < aLength)
|
||||
&& IsJustifiableCharacter(ch, isCJ)) {
|
||||
glyphWidth += aTextStyle.mExtraSpacePerJustifiableCharacter;
|
||||
if ((PRUint32)--aTextStyle.mNumJustifiableCharacterToRender
|
39
firefox-1.5-pango-underline.patch
Normal file
39
firefox-1.5-pango-underline.patch
Normal file
@ -0,0 +1,39 @@
|
||||
diff -pruN -x '.moz*' -x .deps -x 'thunderbird*' -x '*.mk' -x 'config*' -x dist -x build -x toolkit -x '*o' -x '*a' -x '*html' mozilla.orig/layout/generic/nsTextFrame.cpp mozilla/layout/generic/nsTextFrame.cpp
|
||||
--- mozilla.orig/layout/generic/nsTextFrame.cpp 2006-12-20 12:53:26.000000000 +0900
|
||||
+++ mozilla/layout/generic/nsTextFrame.cpp 2006-12-20 15:43:14.000000000 +0900
|
||||
@@ -2097,11 +2097,11 @@ nsTextFrame::PaintTextDecorations(nsIRen
|
||||
nsRect rect = GetRect();
|
||||
while(aDetails){
|
||||
const nscoord* sp= aSpacing;
|
||||
- PRInt32 startOffset = 0;
|
||||
- PRInt32 textWidth = 0;
|
||||
- PRInt32 start = PR_MAX(0,(aDetails->mStart - (PRInt32)aIndex));
|
||||
- PRInt32 end = PR_MIN((PRInt32)aLength,(aDetails->mEnd - (PRInt32)aIndex));
|
||||
- PRInt32 i;
|
||||
+ PRUint32 startOffset = 0;
|
||||
+ PRUint32 textWidth = 0;
|
||||
+ PRUint32 start = PR_MAX(0,(aDetails->mStart - (PRInt32)aIndex));
|
||||
+ PRUint32 end = PR_MIN((PRInt32)aLength,(aDetails->mEnd - (PRInt32)aIndex));
|
||||
+ PRUint32 i;
|
||||
if ((start < end) && ((aLength - start) > 0))
|
||||
{
|
||||
//aDetails allready processed to have offsets from frame start not content offsets
|
||||
@@ -2117,7 +2117,7 @@ nsTextFrame::PaintTextDecorations(nsIRen
|
||||
}
|
||||
}
|
||||
else
|
||||
- aRenderingContext.GetWidth(aText, start, startOffset);
|
||||
+ aRenderingContext.GetRangeWidth(aText, aLength, 0, start, startOffset);
|
||||
}
|
||||
if (sp){
|
||||
for (i = start; i < end;i ++){
|
||||
@@ -2125,8 +2125,7 @@ nsTextFrame::PaintTextDecorations(nsIRen
|
||||
}
|
||||
}
|
||||
else
|
||||
- aRenderingContext.GetWidth(aText + start,
|
||||
- PRUint32(end - start), textWidth);
|
||||
+ aRenderingContext.GetRangeWidth(aText, aLength, start, end, textWidth);
|
||||
|
||||
}
|
||||
nscoord offset, size;
|
283
firefox-1.5-xft-rangewidth.patch
Normal file
283
firefox-1.5-xft-rangewidth.patch
Normal file
@ -0,0 +1,283 @@
|
||||
diff -pruN -x '.moz*' -x .libs -x .deps -x dist -x 'config*' -x 'firefox*' -x '*a' -x '*so' -x '*o' -x build -x '*html' mozilla.orig/gfx/src/gtk/nsFontMetricsXft.cpp mozilla/gfx/src/gtk/nsFontMetricsXft.cpp
|
||||
--- mozilla.orig/gfx/src/gtk/nsFontMetricsXft.cpp 2006-04-25 08:58:36.000000000 +0900
|
||||
+++ mozilla/gfx/src/gtk/nsFontMetricsXft.cpp 2007-02-08 01:50:05.000000000 +0900
|
||||
@@ -227,10 +227,14 @@ static nsresult EnumFontsXft (nsIAto
|
||||
|
||||
static void ConvertCharToUCS4 (const char *aString,
|
||||
PRUint32 aLength,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd,
|
||||
nsAutoFcChar32Buffer &aOutBuffer,
|
||||
PRUint32 *aOutLen);
|
||||
static void ConvertUnicharToUCS4 (const PRUnichar *aString,
|
||||
PRUint32 aLength,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd,
|
||||
nsAutoFcChar32Buffer &aOutBuffer,
|
||||
PRUint32 *aOutLen);
|
||||
static nsresult ConvertUCS4ToCustom (FcChar32 *aSrc, PRUint32 aSrcLen,
|
||||
@@ -507,7 +511,7 @@ nsFontMetricsXft::GetWidth(const PRUnich
|
||||
return NS_OK;
|
||||
}
|
||||
|
||||
- gint rawWidth = RawGetWidth(aString, aLength);
|
||||
+ gint rawWidth = RawGetWidth(aString, aLength, 0, aLength);
|
||||
|
||||
float f;
|
||||
f = mDeviceContext->DevUnitsToAppUnits();
|
||||
@@ -533,7 +537,7 @@ nsFontMetricsXft::GetTextDimensions(cons
|
||||
return NS_OK;
|
||||
|
||||
nsresult rv;
|
||||
- rv = EnumerateGlyphs(aString, aLength,
|
||||
+ rv = EnumerateGlyphs(aString, aLength, 0, aLength,
|
||||
&nsFontMetricsXft::TextDimensionsCallback,
|
||||
&aDimensions);
|
||||
|
||||
@@ -608,7 +612,7 @@ nsFontMetricsXft::DrawString(const char
|
||||
nsAutoDrawSpecBuffer drawBuffer(data.draw, &data.color);
|
||||
data.drawBuffer = &drawBuffer;
|
||||
|
||||
- return EnumerateGlyphs(aString, aLength,
|
||||
+ return EnumerateGlyphs(aString, aLength, 0, aLength,
|
||||
&nsFontMetricsXft::DrawStringCallback, &data);
|
||||
}
|
||||
|
||||
@@ -638,7 +642,7 @@ nsFontMetricsXft::DrawString(const PRUni
|
||||
nsAutoDrawSpecBuffer drawBuffer(data.draw, &data.color);
|
||||
data.drawBuffer = &drawBuffer;
|
||||
|
||||
- return EnumerateGlyphs(aString, aLength,
|
||||
+ return EnumerateGlyphs(aString, aLength, 0, aLength,
|
||||
&nsFontMetricsXft::DrawStringCallback, &data);
|
||||
}
|
||||
|
||||
@@ -662,7 +666,7 @@ nsFontMetricsXft::GetBoundingMetrics(con
|
||||
data.firstTime = PR_TRUE;
|
||||
|
||||
nsresult rv;
|
||||
- rv = EnumerateGlyphs(aString, aLength,
|
||||
+ rv = EnumerateGlyphs(aString, aLength, 0, aLength,
|
||||
&nsFontMetricsXft::BoundingMetricsCallback, &data);
|
||||
NS_ENSURE_SUCCESS(rv, rv);
|
||||
|
||||
@@ -700,7 +704,7 @@ nsFontMetricsXft::GetBoundingMetrics(con
|
||||
data.firstTime = PR_TRUE;
|
||||
|
||||
nsresult rv;
|
||||
- rv = EnumerateGlyphs(aString, aLength,
|
||||
+ rv = EnumerateGlyphs(aString, aLength, 0, aLength,
|
||||
&nsFontMetricsXft::BoundingMetricsCallback, &data);
|
||||
NS_ENSURE_SUCCESS(rv, rv);
|
||||
|
||||
@@ -758,7 +762,17 @@ nsFontMetricsXft::GetRangeWidth(const PR
|
||||
PRUint32 aEnd,
|
||||
PRUint32 &aWidth)
|
||||
{
|
||||
- return NS_ERROR_NOT_IMPLEMENTED;
|
||||
+ if (!aLength) {
|
||||
+ aWidth = 0;
|
||||
+ return NS_OK;
|
||||
+ }
|
||||
+
|
||||
+ gint rawWidth = RawGetWidth(aText, aLength, aStart, aEnd);
|
||||
+ float f = mDeviceContext->DevUnitsToAppUnits();
|
||||
+
|
||||
+ aWidth = NSToCoordRound(rawWidth * f);
|
||||
+
|
||||
+ return NS_OK;
|
||||
}
|
||||
|
||||
nsresult
|
||||
@@ -768,7 +782,17 @@ nsFontMetricsXft::GetRangeWidth(const ch
|
||||
PRUint32 aEnd,
|
||||
PRUint32 &aWidth)
|
||||
{
|
||||
- return NS_ERROR_NOT_IMPLEMENTED;
|
||||
+ if (!aLength) {
|
||||
+ aWidth = 0;
|
||||
+ return NS_OK;
|
||||
+ }
|
||||
+
|
||||
+ gint rawWidth = RawGetWidth(aText, aLength, aStart, aEnd);
|
||||
+ float f = mDeviceContext->DevUnitsToAppUnits();
|
||||
+
|
||||
+ aWidth = NSToCoordRound(rawWidth * f);
|
||||
+
|
||||
+ return NS_OK;
|
||||
}
|
||||
|
||||
PRUint32
|
||||
@@ -850,12 +874,12 @@ nsFontMetricsXft::CacheFontMetrics(void)
|
||||
// mSpaceWidth (width of a space)
|
||||
gint rawWidth;
|
||||
PRUnichar unispace(' ');
|
||||
- rawWidth = RawGetWidth(&unispace, 1);
|
||||
+ rawWidth = RawGetWidth(&unispace, 1, 0, 1);
|
||||
mSpaceWidth = NSToCoordRound(rawWidth * f);
|
||||
|
||||
// mAveCharWidth (width of an 'average' char)
|
||||
PRUnichar xUnichar('x');
|
||||
- rawWidth = RawGetWidth(&xUnichar, 1);
|
||||
+ rawWidth = RawGetWidth(&xUnichar, 1, 0, 1);
|
||||
mAveCharWidth = NSToCoordRound(rawWidth * f);
|
||||
|
||||
// mXHeight (height of an 'x' character)
|
||||
@@ -1226,12 +1250,27 @@ nsFontMetricsXft::DoMatch(PRBool aMatchA
|
||||
}
|
||||
|
||||
gint
|
||||
-nsFontMetricsXft::RawGetWidth(const PRUnichar* aString, PRUint32 aLength)
|
||||
+nsFontMetricsXft::RawGetWidth(const PRUnichar* aString, PRUint32 aLength, PRUint32 aStart, PRUint32 aEnd)
|
||||
+{
|
||||
+ nscoord width = 0;
|
||||
+ nsresult rv;
|
||||
+
|
||||
+ rv = EnumerateGlyphs(aString, aLength, aStart, aEnd,
|
||||
+ &nsFontMetricsXft::GetWidthCallback, &width);
|
||||
+
|
||||
+ if (NS_FAILED(rv))
|
||||
+ width = 0;
|
||||
+
|
||||
+ return width;
|
||||
+}
|
||||
+
|
||||
+gint
|
||||
+nsFontMetricsXft::RawGetWidth(const char* aString, PRUint32 aLength, PRUint32 aStart, PRUint32 aEnd)
|
||||
{
|
||||
nscoord width = 0;
|
||||
nsresult rv;
|
||||
|
||||
- rv = EnumerateGlyphs(aString, aLength,
|
||||
+ rv = EnumerateGlyphs(aString, aLength, aStart, aEnd,
|
||||
&nsFontMetricsXft::GetWidthCallback, &width);
|
||||
|
||||
if (NS_FAILED(rv))
|
||||
@@ -1457,6 +1496,8 @@ nsFontMetricsXft::EnumerateXftGlyphs(con
|
||||
nsresult
|
||||
nsFontMetricsXft::EnumerateGlyphs(const PRUnichar *aString,
|
||||
PRUint32 aLen,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd,
|
||||
GlyphEnumeratorCallback aCallback,
|
||||
void *aCallbackData)
|
||||
{
|
||||
@@ -1465,7 +1506,7 @@ nsFontMetricsXft::EnumerateGlyphs(const
|
||||
|
||||
NS_ENSURE_TRUE(aLen, NS_OK);
|
||||
|
||||
- ConvertUnicharToUCS4(aString, aLen, charBuffer, &len);
|
||||
+ ConvertUnicharToUCS4(aString, aLen, aStart, aEnd, charBuffer, &len);
|
||||
if (!len)
|
||||
return NS_ERROR_OUT_OF_MEMORY;
|
||||
|
||||
@@ -1475,6 +1516,8 @@ nsFontMetricsXft::EnumerateGlyphs(const
|
||||
nsresult
|
||||
nsFontMetricsXft::EnumerateGlyphs(const char *aString,
|
||||
PRUint32 aLen,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd,
|
||||
GlyphEnumeratorCallback aCallback,
|
||||
void *aCallbackData)
|
||||
{
|
||||
@@ -1484,7 +1527,7 @@ nsFontMetricsXft::EnumerateGlyphs(const
|
||||
NS_ENSURE_TRUE(aLen, NS_OK);
|
||||
|
||||
// Convert the incoming string into an array of UCS4 chars
|
||||
- ConvertCharToUCS4(aString, aLen, charBuffer, &len);
|
||||
+ ConvertCharToUCS4(aString, aLen, aStart, aEnd, charBuffer, &len);
|
||||
if (!len)
|
||||
return NS_ERROR_OUT_OF_MEMORY;
|
||||
|
||||
@@ -2343,7 +2386,7 @@ EnumFontsXft(nsIAtom* aLangGroup, const
|
||||
|
||||
/* static */
|
||||
void
|
||||
-ConvertCharToUCS4(const char *aString, PRUint32 aLength,
|
||||
+ConvertCharToUCS4(const char *aString, PRUint32 aLength, PRUint32 aStart, PRUint32 aEnd,
|
||||
nsAutoFcChar32Buffer &aOutBuffer, PRUint32 *aOutLen)
|
||||
{
|
||||
*aOutLen = 0;
|
||||
@@ -2352,19 +2395,21 @@ ConvertCharToUCS4(const char *aString, P
|
||||
if (!aOutBuffer.EnsureElemCapacity(aLength))
|
||||
return;
|
||||
outBuffer = aOutBuffer.get();
|
||||
+ if (aEnd > aLength)
|
||||
+ aEnd = aLength;
|
||||
|
||||
- for (PRUint32 i = 0; i < aLength; ++i) {
|
||||
- outBuffer[i] = PRUint8(aString[i]); // to convert char >= 0x80 correctly
|
||||
+ for (PRUint32 i = aStart; i < aLength && i < aEnd; ++i) {
|
||||
+ outBuffer[i - aStart] = PRUint8(aString[i]); // to convert char >= 0x80 correctly
|
||||
}
|
||||
|
||||
- *aOutLen = aLength;
|
||||
+ *aOutLen = aEnd - aStart;
|
||||
}
|
||||
|
||||
// Convert the incoming string into an array of UCS4 chars
|
||||
|
||||
/* static */
|
||||
void
|
||||
-ConvertUnicharToUCS4(const PRUnichar *aString, PRUint32 aLength,
|
||||
+ConvertUnicharToUCS4(const PRUnichar *aString, PRUint32 aLength, PRUint32 aStart, PRUint32 aEnd,
|
||||
nsAutoFcChar32Buffer &aOutBuffer, PRUint32 *aOutLen)
|
||||
{
|
||||
*aOutLen = 0;
|
||||
@@ -2378,7 +2423,7 @@ ConvertUnicharToUCS4(const PRUnichar *aS
|
||||
|
||||
// Walk the passed in string looking for surrogates to convert to
|
||||
// their full ucs4 representation.
|
||||
- for (PRUint32 i = 0; i < aLength; ++i) {
|
||||
+ for (PRUint32 i = aStart; i < aLength && i < aEnd; ++i) {
|
||||
PRUnichar c = aString[i];
|
||||
|
||||
// Optimized for the non-surrogate case
|
||||
@@ -2693,12 +2738,12 @@ ConvertUCS4ToCustom(FcChar32 *aSrc, PRU
|
||||
#endif
|
||||
// Convert 16bit custom font codes to UCS4
|
||||
ConvertUnicharToUCS4(NS_REINTERPRET_CAST(PRUnichar *, med),
|
||||
- medLen >> 1, aResult, &aDestLen);
|
||||
+ medLen >> 1, 0, medLen >> 1, aResult, &aDestLen);
|
||||
rv = aDestLen ? rv : NS_ERROR_OUT_OF_MEMORY;
|
||||
}
|
||||
else {
|
||||
// Convert 8bit custom font codes to UCS4
|
||||
- ConvertCharToUCS4(med, medLen, aResult, &aDestLen);
|
||||
+ ConvertCharToUCS4(med, medLen, 0, medLen, aResult, &aDestLen);
|
||||
rv = aDestLen ? rv : NS_ERROR_OUT_OF_MEMORY;
|
||||
}
|
||||
|
||||
diff -pruN -x '.moz*' -x .libs -x .deps -x dist -x 'config*' -x 'firefox*' -x '*a' -x '*so' -x '*o' -x build -x '*html' mozilla.orig/gfx/src/gtk/nsFontMetricsXft.h mozilla/gfx/src/gtk/nsFontMetricsXft.h
|
||||
--- mozilla.orig/gfx/src/gtk/nsFontMetricsXft.h 2005-05-03 05:48:30.000000000 +0900
|
||||
+++ mozilla/gfx/src/gtk/nsFontMetricsXft.h 2007-02-08 01:38:27.000000000 +0900
|
||||
@@ -259,7 +259,13 @@ private:
|
||||
void DoMatch (PRBool aMatchAll);
|
||||
|
||||
gint RawGetWidth (const PRUnichar* aString,
|
||||
- PRUint32 aLength);
|
||||
+ PRUint32 aLength,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd);
|
||||
+ gint RawGetWidth (const char* aString,
|
||||
+ PRUint32 aLength,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd);
|
||||
nsresult SetupMiniFont (void);
|
||||
nsresult DrawUnknownGlyph (FcChar32 aChar,
|
||||
nscoord aX,
|
||||
@@ -272,10 +278,14 @@ private:
|
||||
void *aCallbackData);
|
||||
nsresult EnumerateGlyphs (const char *aString,
|
||||
PRUint32 aLen,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd,
|
||||
GlyphEnumeratorCallback aCallback,
|
||||
void *aCallbackData);
|
||||
nsresult EnumerateGlyphs (const PRUnichar *aString,
|
||||
PRUint32 aLen,
|
||||
+ PRUint32 aStart,
|
||||
+ PRUint32 aEnd,
|
||||
GlyphEnumeratorCallback aCallback,
|
||||
void *aCallbackData);
|
||||
void PrepareToDraw (nsRenderingContextGTK *aContext,
|
1932
firefox-2.0-pango-ligatures.patch
Normal file
1932
firefox-2.0-pango-ligatures.patch
Normal file
File diff suppressed because it is too large
Load Diff
16
firefox.spec
16
firefox.spec
@ -12,7 +12,7 @@
|
||||
Summary: Mozilla Firefox Web browser.
|
||||
Name: firefox
|
||||
Version: 2.0.0.4
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPL/LGPL
|
||||
Group: Applications/Internet
|
||||
@ -60,6 +60,12 @@ Patch81: firefox-1.5-nopangoxft.patch
|
||||
Patch82: firefox-1.5-pango-mathml.patch
|
||||
Patch83: firefox-1.5-pango-cursor-position.patch
|
||||
Patch84: firefox-2.0-pango-printing.patch
|
||||
Patch85: firefox-2.0-pango-ligatures.patch
|
||||
Patch86: firefox-1.5-pango-cursor-position-more.patch
|
||||
Patch87: firefox-1.5-pango-justified-range.patch
|
||||
Patch88: firefox-1.5-pango-underline.patch
|
||||
Patch89: firefox-1.5-xft-rangewidth.patch
|
||||
|
||||
|
||||
# Other
|
||||
Patch100: firefox-1.5-thread-cleanup.patch
|
||||
@ -157,6 +163,11 @@ removed in favor of xulrunner-devel.
|
||||
#%patch82 -p1 -b .pango-mathml
|
||||
%patch83 -p1 -b .pango-cursor-position
|
||||
%patch84 -p0 -b .pango-printing
|
||||
%patch85 -p1 -b .pango-ligatures
|
||||
%patch86 -p1 -b .pango-cursor-position-more
|
||||
%patch87 -p1 -b .pango-justified-range
|
||||
%patch88 -p1 -b .pango-underline
|
||||
%patch89 -p1 -b .nopangoxft2
|
||||
|
||||
%patch100 -p1 -b .thread-cleanup
|
||||
%patch102 -p0 -b .theme-change
|
||||
@ -418,6 +429,9 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Fri Jun 29 2007 Martin Stransky <stransky@redhat.com> 2.0.0.4-3
|
||||
- backported pango patches from FC6 (1.5.0.12)
|
||||
|
||||
* Sun Jun 3 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.4-2
|
||||
- Properly clean up threads with newer NSPR
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user