Update to 68.0.2

This commit is contained in:
Jan Horak 2019-08-14 16:04:42 +02:00
parent 552b94bac7
commit 4321d587c5
4 changed files with 19 additions and 28 deletions

2
.gitignore vendored
View File

@ -356,3 +356,5 @@ firefox-3.6.4.source.tar.bz2
/firefox-langpacks-68.0-20190708.tar.xz
/firefox-68.0.1.source.tar.xz
/firefox-langpacks-68.0.1-20190722.tar.xz
/firefox-68.0.2.source.tar.xz
/firefox-langpacks-68.0.2-20190814.tar.xz

View File

@ -1,16 +0,0 @@
diff -up firefox-68.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-68.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
diff -up firefox-68.0/media/webrtc/trunk/Makefile.old firefox-68.0/media/webrtc/trunk/Makefile
diff -up firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc.old firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc
--- firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc.old 2019-07-10 20:10:04.420328534 +0200
+++ firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc 2019-07-10 20:13:48.766658793 +0200
@@ -62,6 +62,10 @@ typedef void* SockOptArg;
#if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(WEBRTC_BSD) && !defined(__native_client__)
+#ifndef SIOCGSTAMP
+#define SIOCGSTAMP 0x8906 /* Get stamp (timeval) */
+#endif
+
int64_t GetSocketRecvTimestamp(int socket) {
struct timeval tv_ioctl;
int ret = ioctl(socket, SIOCGSTAMP, &tv_ioctl);

View File

@ -23,6 +23,8 @@ ExcludeArch: s390x
# Build PGO+LTO on x86_64 and aarch64 only due to build issues
# on other arches.
%ifarch x86_64 aarch64
# FIXME disable PGO because of -j1 build would take ages
%global disable_multiprocess_compilation 1
%if %{release_build}
%global build_with_pgo 0
%else
@ -87,13 +89,13 @@ ExcludeArch: s390x
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 68.0.1
Release: 3%{?pre_tag}%{?dist}
Version: 68.0.2
Release: 1%{?pre_tag}%{?dist}
URL: https://www.mozilla.org/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
%if %{with langpacks}
Source1: firefox-langpacks-%{version}%{?pre_version}-20190722.tar.xz
Source1: firefox-langpacks-%{version}%{?pre_version}-20190814.tar.xz
%endif
Source2: cbindgen-vendor.tar.xz
Source10: firefox-mozconfig
@ -134,7 +136,6 @@ Patch224: mozilla-1170092.patch
#ARM run-time patch
Patch226: rhbz-1354671.patch
Patch227: firefox-locale-debug.patch
Patch228: firefox-SIOCGSTAMP.patch
# Upstream patches
Patch402: mozilla-1196777.patch
@ -340,7 +341,6 @@ This package contains results of tests executed during build.
%patch226 -p1 -b .1354671
%endif
%patch227 -p1 -b .locale-debug
%patch228 -p1 -b .SIOCGSTAMP
%patch402 -p1 -b .1196777
#%patch413 -p1 -b .1353817
@ -558,17 +558,19 @@ echo "ac_add_options --enable-lto" >> .mozconfig
MOZ_SMP_FLAGS=-j1
# On x86_64 architectures, Mozilla can build up to 4 jobs at once in parallel,
# however builds tend to fail on other arches when building in parallel.
%if !%{?disable_multiprocess_compilation}
%ifarch %{ix86}
[ -z "$RPM_BUILD_NCPUS" ] && \
RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
#[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
%endif
%ifarch x86_64 ppc ppc64 ppc64le aarch64
[ -z "$RPM_BUILD_NCPUS" ] && \
RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
#[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
#[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
#[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
%endif
%endif
export MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
@ -577,7 +579,7 @@ export STRIP=/bin/true
%if 0%{?build_with_pgo}
GDK_BACKEND=x11 xvfb-run ./mach build 2>&1 | cat -
%else
env RUST_LOG=debug strace -y -f ./mach build -v 2>&1 | cat -
./mach build -v 2>&1 | cat -
%endif
# create debuginfo for crash-stats.mozilla.com
@ -929,6 +931,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
* Wed Aug 14 2019 Jan Horak <jhorak@redhat.com> - 68.0.2-1
- Update to 68.0.2
* Mon Aug 5 2019 Jan Horak <jhorak@redhat.com> - 68.0.1-3
- Added workaround fix for webrtc indicator

View File

@ -1,3 +1,3 @@
SHA512 (firefox-68.0.2.source.tar.xz) = 5c289825fd0de062b9943eabcc16e09c1821c04717e689aa8df03162e722b72ea698195f3ea93e1e746c481dacd77d125301dba951468d134b986e35eb4ef5bb
SHA512 (firefox-langpacks-68.0.2-20190814.tar.xz) = f0031f7cb6277e5216c63956aeb4e88b2ce76ba0c65f293822970740882f95803ef083525e7c3a23e92252f2322a7fb0e43ac2359416f40c98480b9587f698be
SHA512 (cbindgen-vendor.tar.xz) = bdd1535c9923a082cdca263ff2c1765814b00b6a1c74be95bac4dbf7d0b7b29c1c27f0fed6feae99c88521c96e2865f0ea3cf784bd9a32a44cec6ee4df850662
SHA512 (firefox-68.0.1.source.tar.xz) = 96b45135cf0b2368013afccb8c375de54d591a4e11016e8b65fc83904cedc362096dd15814cd02be23f6e52e392c605817b86a59ee2300d3e7a754d345399c81
SHA512 (firefox-langpacks-68.0.1-20190722.tar.xz) = cb4f356bdc770f0d3ca41bed6015c3c53c8675c99ac2340c011e319384b3178d895a85a8a1852e65370c7f97ea603eb93eee85db546db206fa9362bf8cff7b72