Added fix for aarch64 crashes (rhbz#1354671)
This commit is contained in:
parent
d6041ad5fb
commit
402aa35821
12
firefox.spec
12
firefox.spec
@ -97,7 +97,7 @@ ExcludeArch: armv7hl
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 51.0
|
Version: 51.0
|
||||||
Release: 2%{?pre_tag}%{?dist}
|
Release: 3%{?pre_tag}%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -133,6 +133,8 @@ Patch219: rhbz-1173156.patch
|
|||||||
Patch221: firefox-fedora-ua.patch
|
Patch221: firefox-fedora-ua.patch
|
||||||
Patch224: mozilla-1170092.patch
|
Patch224: mozilla-1170092.patch
|
||||||
Patch225: mozilla-1005640-accept-lang.patch
|
Patch225: mozilla-1005640-accept-lang.patch
|
||||||
|
#ARM run-time patch
|
||||||
|
Patch226: rhbz-1354671.patch
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
Patch304: mozilla-1253216.patch
|
Patch304: mozilla-1253216.patch
|
||||||
@ -279,6 +281,11 @@ cd %{tarballdir}
|
|||||||
%patch221 -p2 -b .fedora-ua
|
%patch221 -p2 -b .fedora-ua
|
||||||
%patch224 -p1 -b .1170092
|
%patch224 -p1 -b .1170092
|
||||||
%patch225 -p1 -b .1005640-accept-lang
|
%patch225 -p1 -b .1005640-accept-lang
|
||||||
|
#ARM run-time patch
|
||||||
|
%ifarch aarch64
|
||||||
|
%patch226 -p1 -b .1354671
|
||||||
|
%endif
|
||||||
|
|
||||||
%patch304 -p1 -b .1253216
|
%patch304 -p1 -b .1253216
|
||||||
%patch402 -p1 -b .1196777
|
%patch402 -p1 -b .1196777
|
||||||
%patch406 -p1 -b .256180
|
%patch406 -p1 -b .256180
|
||||||
@ -776,6 +783,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 24 2017 Martin Stransky <stransky@redhat.com> - 51.0-3
|
||||||
|
- Added fix for aarch64 crashes (rhbz#1354671)
|
||||||
|
|
||||||
* Thu Jan 19 2017 Martin Stransky <stransky@redhat.com> - 51.0-2
|
* Thu Jan 19 2017 Martin Stransky <stransky@redhat.com> - 51.0-2
|
||||||
- Update to 51.0 (B2)
|
- Update to 51.0 (B2)
|
||||||
|
|
||||||
|
16
rhbz-1354671.patch
Normal file
16
rhbz-1354671.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
@@ -, +, @@
|
||||||
|
---
|
||||||
|
layout/base/nsIPresShell.h | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
--- a/layout/base/nsIPresShell.h
|
||||||
|
+++ a/layout/base/nsIPresShell.h
|
||||||
|
@@ -224,7 +224,7 @@ public:
|
||||||
|
* to the same aSize value. AllocateFrame returns zero-filled memory.
|
||||||
|
* AllocateFrame is infallible and will abort on out-of-memory.
|
||||||
|
*/
|
||||||
|
- void* AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
||||||
|
+ void* __attribute__((optimize("no-lifetime-dse"))) AllocateFrame(nsQueryFrame::FrameIID aID, size_t aSize)
|
||||||
|
{
|
||||||
|
void* result = mFrameArena.AllocateByFrameID(aID, aSize);
|
||||||
|
RecordAlloc(result);
|
||||||
|
--
|
Loading…
Reference in New Issue
Block a user