- Fix up some rpmlint warnings
- Use only one pref for the homepage for now - Drop some old patches and some obsolote Obsoletes
This commit is contained in:
parent
0524fe12e1
commit
3f0fba2562
@ -1,18 +0,0 @@
|
|||||||
? browser/components/preferences/~advanced.xul
|
|
||||||
Index: browser/components/preferences/advanced.xul
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/mozilla/browser/components/preferences/advanced.xul,v
|
|
||||||
retrieving revision 1.3
|
|
||||||
diff -d -u -p -r1.3 advanced.xul
|
|
||||||
--- browser/components/preferences/advanced.xul 10 Mar 2005 18:43:57 -0000 1.3
|
|
||||||
+++ browser/components/preferences/advanced.xul 20 Jun 2005 08:09:44 -0000
|
|
||||||
@@ -55,9 +55,6 @@
|
|
||||||
type="bool"/>
|
|
||||||
<preference id="general.autoScroll" name="general.autoScroll" type="bool"/>
|
|
||||||
<preference id="general.smoothScroll" name="general.smoothScroll" type="bool"/>
|
|
||||||
- <preference id="app.update.autoUpdateEnabled" name="app.update.autoUpdateEnabled" type="bool"/>
|
|
||||||
- <preference id="app.update.autoInstallEnabled" name="app.update.autoInstallEnabled" type="bool"/>
|
|
||||||
- <preference id="app.update.autoInstallMode" name="app.update.autoInstallMode" type="int"/>
|
|
||||||
<preference id="extensions.update.autoUpdateEnabled"
|
|
||||||
name="extensions.update.autoUpdateEnabled"
|
|
||||||
type="bool"/>
|
|
@ -1,37 +0,0 @@
|
|||||||
--- mozilla/gfx/src/gtk/mozilla-decoder.cpp.noxft 2004-11-07 18:59:23.000000000 -0500
|
|
||||||
+++ mozilla/gfx/src/gtk/mozilla-decoder.cpp 2006-08-06 18:24:37.000000000 -0400
|
|
||||||
@@ -40,10 +40,9 @@
|
|
||||||
#define PANGO_ENABLE_ENGINE
|
|
||||||
|
|
||||||
#include "mozilla-decoder.h"
|
|
||||||
-#include <pango/pangoxft.h>
|
|
||||||
#include <pango/pangofc-fontmap.h>
|
|
||||||
#include <pango/pangofc-font.h>
|
|
||||||
-#include <gdk/gdkx.h>
|
|
||||||
+#include <gdk/gdkpango.h>
|
|
||||||
|
|
||||||
#include "nsString.h"
|
|
||||||
#include "nsIPersistentProperties2.h"
|
|
||||||
@@ -145,6 +144,13 @@ mozilla_decoders_init(void)
|
|
||||||
if (initialized)
|
|
||||||
return 0;
|
|
||||||
|
|
||||||
+ PangoContext* context = gdk_pango_context_get ();
|
|
||||||
+ PangoFontMap* fontmap = pango_context_get_font_map (context);
|
|
||||||
+ g_object_unref (context);
|
|
||||||
+
|
|
||||||
+ if (!PANGO_IS_FC_FONT_MAP (fontmap))
|
|
||||||
+ return -1;
|
|
||||||
+
|
|
||||||
encoder_hash = g_hash_table_new(g_str_hash, g_str_equal);
|
|
||||||
cmap_hash = g_hash_table_new(g_str_hash, g_str_equal);
|
|
||||||
wide_hash = g_hash_table_new(g_str_hash, g_str_equal);
|
|
||||||
@@ -208,7 +214,7 @@ mozilla_decoders_init(void)
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
- pango_fc_font_map_add_decoder_find_func(PANGO_FC_FONT_MAP(pango_xft_get_font_map(GDK_DISPLAY(),gdk_x11_get_default_screen())),
|
|
||||||
+ pango_fc_font_map_add_decoder_find_func(PANGO_FC_FONT_MAP(fontmap),
|
|
||||||
mozilla_find_decoder,
|
|
||||||
NULL,
|
|
||||||
NULL);
|
|
@ -1,42 +0,0 @@
|
|||||||
--- mozilla/gfx/src/gtk/nsFontMetricsPango.cpp.mathml 2006-02-23 16:01:42.000000000 -0500
|
|
||||||
+++ mozilla/gfx/src/gtk/nsFontMetricsPango.cpp 2006-08-22 20:06:40.000000000 -0400
|
|
||||||
@@ -829,30 +829,27 @@ nsFontMetricsPango::GetBoundingMetrics(c
|
|
||||||
goto loser;
|
|
||||||
}
|
|
||||||
|
|
||||||
- pango_layout_set_text(layout, text, strlen(text));
|
|
||||||
+ pango_layout_set_text(layout, text, -1);
|
|
||||||
FixupSpaceWidths(layout, text);
|
|
||||||
|
|
||||||
- // Get the logical extents
|
|
||||||
PangoLayoutLine *line;
|
|
||||||
if (pango_layout_get_line_count(layout) != 1) {
|
|
||||||
printf("Warning: more than one line!\n");
|
|
||||||
}
|
|
||||||
line = pango_layout_get_line(layout, 0);
|
|
||||||
|
|
||||||
- // Get the ink extents
|
|
||||||
- PangoRectangle rect;
|
|
||||||
- pango_layout_line_get_extents(line, NULL, &rect);
|
|
||||||
+ // Get the ink and logical extents
|
|
||||||
+ PangoRectangle ink, logical;
|
|
||||||
+ pango_layout_line_get_extents(line, &ink, &logical);
|
|
||||||
|
|
||||||
float P2T;
|
|
||||||
P2T = mDeviceContext->DevUnitsToAppUnits();
|
|
||||||
|
|
||||||
- aBoundingMetrics.leftBearing =
|
|
||||||
- NSToCoordRound(rect.x * P2T / PANGO_SCALE);
|
|
||||||
- aBoundingMetrics.rightBearing =
|
|
||||||
- NSToCoordRound(rect.width * P2T / PANGO_SCALE);
|
|
||||||
- aBoundingMetrics.width = NSToCoordRound((rect.x + rect.width) * P2T / PANGO_SCALE);
|
|
||||||
- aBoundingMetrics.ascent = NSToCoordRound(rect.y * P2T / PANGO_SCALE);
|
|
||||||
- aBoundingMetrics.descent = NSToCoordRound(rect.height * P2T / PANGO_SCALE);
|
|
||||||
+ aBoundingMetrics.leftBearing = NSToCoordRound(PANGO_LBEARING(ink) * P2T / PANGO_SCALE);
|
|
||||||
+ aBoundingMetrics.rightBearing = NSToCoordRound(PANGO_RBEARING(ink) * P2T / PANGO_SCALE);
|
|
||||||
+ aBoundingMetrics.ascent = NSToCoordRound(PANGO_ASCENT(ink) * P2T / PANGO_SCALE);
|
|
||||||
+ aBoundingMetrics.descent = NSToCoordRound(PANGO_DESCENT(ink) * P2T / PANGO_SCALE);
|
|
||||||
+ aBoundingMetrics.width = NSToCoordRound(logical.width * P2T / PANGO_SCALE);
|
|
||||||
|
|
||||||
loser:
|
|
||||||
g_free(text);
|
|
@ -1,15 +0,0 @@
|
|||||||
https://bugzilla.mozilla.org/show_bug.cgi?id=389801
|
|
||||||
|
|
||||||
--- mozilla/gfx/src/gtk/gtk2drawing.c.fixgtk212 2005-09-13 05:30:53.000000000 +0200
|
|
||||||
+++ mozilla/gfx/src/gtk/gtk2drawing.c 2007-09-06 09:42:34.000000000 +0200
|
|
||||||
@@ -551,8 +551,8 @@ moz_gtk_option_menu_get_metrics(gboolean
|
|
||||||
else
|
|
||||||
*indicator_spacing = default_indicator_spacing;
|
|
||||||
|
|
||||||
- g_free(tmp_indicator_size);
|
|
||||||
- g_free(tmp_indicator_spacing);
|
|
||||||
+ gtk_requisition_free(tmp_indicator_size);
|
|
||||||
+ gtk_border_free(tmp_indicator_spacing);
|
|
||||||
|
|
||||||
return MOZ_GTK_SUCCESS;
|
|
||||||
}
|
|
@ -1,16 +0,0 @@
|
|||||||
Index: browser/locales/en-US/chrome/browser-region/region.properties
|
|
||||||
===================================================================
|
|
||||||
RCS file: /cvsroot/mozilla/browser/locales/en-US/chrome/browser-region/region.properties,v
|
|
||||||
retrieving revision 1.1.2.3
|
|
||||||
diff -d -u -p -0 -r1.1.2.3 region.properties
|
|
||||||
--- browser/locales/en-US/chrome/browser-region/region.properties 29 Aug 2004 07:29:59 -0000 1.1.2.3
|
|
||||||
+++ browser/locales/en-US/chrome/browser-region/region.properties 25 Sep 2004 03:07:18 -0000
|
|
||||||
@@ -3 +3 @@ general.useragent.contentlocale=US
|
|
||||||
-homePageDefault=http://start.mozilla.org/firefox
|
|
||||||
+homePageDefault=file:///usr/share/doc/HTML/index.html
|
|
||||||
@@ -10 +10 @@ promoteURL=http://www.spreadfirefox.com/
|
|
||||||
-browser.startup.homepage=http://start.mozilla.org/firefox
|
|
||||||
+browser.startup.homepage=file:///usr/share/doc/HTML/index.html
|
|
||||||
@@ -15 +15 @@ browser.search.defaulturl=http://www.goo
|
|
||||||
-startup.homepage_override_url=http://www.mozilla.org/products/firefox/releases/whatsnew/
|
|
||||||
+startup.homepage_override_url=file:///usr/share/doc/HTML/index.html
|
|
29
firefox.spec
29
firefox.spec
@ -9,10 +9,10 @@
|
|||||||
|
|
||||||
%define official_branding 1
|
%define official_branding 1
|
||||||
|
|
||||||
Summary: Mozilla Firefox Web browser.
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 2.0.0.10
|
Version: 2.0.0.10
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/firefox/
|
URL: http://www.mozilla.org/projects/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -38,10 +38,8 @@ Source101: add-gecko-provides.in
|
|||||||
Patch1: firefox-2.0-link-layout.patch
|
Patch1: firefox-2.0-link-layout.patch
|
||||||
|
|
||||||
# customization patches
|
# customization patches
|
||||||
Patch20: firefox-redhat-homepage.patch
|
|
||||||
Patch21: firefox-0.7.3-psfonts.patch
|
Patch21: firefox-0.7.3-psfonts.patch
|
||||||
Patch22: firefox-1.1-default-applications.patch
|
Patch22: firefox-1.1-default-applications.patch
|
||||||
Patch23: firefox-1.1-software-update.patch
|
|
||||||
|
|
||||||
# local bugfixes
|
# local bugfixes
|
||||||
Patch40: firefox-1.5-bullet-bill.patch
|
Patch40: firefox-1.5-bullet-bill.patch
|
||||||
@ -49,8 +47,6 @@ Patch41: firefox-2.0.0.4-undo-uriloader.patch
|
|||||||
Patch42: firefox-1.1-uriloader.patch
|
Patch42: firefox-1.1-uriloader.patch
|
||||||
|
|
||||||
# font system fixes
|
# font system fixes
|
||||||
Patch81: firefox-1.5-nopangoxft.patch
|
|
||||||
Patch82: firefox-1.5-pango-mathml.patch
|
|
||||||
Patch83: firefox-1.5-pango-cursor-position.patch
|
Patch83: firefox-1.5-pango-cursor-position.patch
|
||||||
Patch84: firefox-2.0-pango-printing.patch
|
Patch84: firefox-2.0-pango-printing.patch
|
||||||
Patch85: firefox-2.0-pango-ligatures.patch
|
Patch85: firefox-2.0-pango-ligatures.patch
|
||||||
@ -64,8 +60,8 @@ Patch89: firefox-1.5-xft-rangewidth.patch
|
|||||||
Patch102: firefox-1.5-theme-change.patch
|
Patch102: firefox-1.5-theme-change.patch
|
||||||
Patch104: firefox-1.5-ppc64.patch
|
Patch104: firefox-1.5-ppc64.patch
|
||||||
Patch105: firefox-2.0-dnd.patch
|
Patch105: firefox-2.0-dnd.patch
|
||||||
Patch106: firefox-2.0-indicator-crash.patch
|
|
||||||
#Patch110: firefox-2.0-startup-notify.patch
|
Patch110: firefox-2.0-startup-notify.patch
|
||||||
Patch111: firefox-path.patch
|
Patch111: firefox-path.patch
|
||||||
Patch112: firefox-2.0-enable-debug.patch
|
Patch112: firefox-2.0-enable-debug.patch
|
||||||
|
|
||||||
@ -105,7 +101,6 @@ Requires: nspr >= %{nspr_version}
|
|||||||
Requires: nss >= %{nss_version}
|
Requires: nss >= %{nss_version}
|
||||||
Requires: desktop-file-utils >= %{desktop_file_utils_version}
|
Requires: desktop-file-utils >= %{desktop_file_utils_version}
|
||||||
Requires: system-bookmarks
|
Requires: system-bookmarks
|
||||||
Obsoletes: phoenix, mozilla-firebird, MozillaFirebird
|
|
||||||
Obsoletes: mozilla <= 37:1.7.13
|
Obsoletes: mozilla <= 37:1.7.13
|
||||||
Provides: webclient
|
Provides: webclient
|
||||||
%define mozappdir %{_libdir}/firefox-%{version}
|
%define mozappdir %{_libdir}/firefox-%{version}
|
||||||
@ -143,15 +138,13 @@ removed in favor of xulrunner-devel.
|
|||||||
%setup -q -n mozilla
|
%setup -q -n mozilla
|
||||||
%patch1 -p1 -b .link-layout
|
%patch1 -p1 -b .link-layout
|
||||||
|
|
||||||
#%patch20 -p0
|
|
||||||
%patch21 -p1 -b .psfonts
|
%patch21 -p1 -b .psfonts
|
||||||
%patch22 -p0 -b .default-applications
|
%patch22 -p0 -b .default-applications
|
||||||
#%patch23 -p0
|
|
||||||
%patch40 -p1 -b .bullet-bill
|
%patch40 -p1 -b .bullet-bill
|
||||||
%patch41 -p1 -b .undo-uriloader
|
%patch41 -p1 -b .undo-uriloader
|
||||||
%patch42 -p0 -b .uriloader
|
%patch42 -p0 -b .uriloader
|
||||||
#%patch81 -p1 -b .nopangoxft
|
|
||||||
#%patch82 -p1 -b .pango-mathml
|
|
||||||
%patch83 -p1 -b .pango-cursor-position
|
%patch83 -p1 -b .pango-cursor-position
|
||||||
%patch84 -p0 -b .pango-printing
|
%patch84 -p0 -b .pango-printing
|
||||||
%patch85 -p1 -b .pango-ligatures
|
%patch85 -p1 -b .pango-ligatures
|
||||||
@ -163,7 +156,6 @@ removed in favor of xulrunner-devel.
|
|||||||
%patch102 -p0 -b .theme-change
|
%patch102 -p0 -b .theme-change
|
||||||
%patch104 -p1 -b .ppc64
|
%patch104 -p1 -b .ppc64
|
||||||
%patch105 -p0 -b .dnd
|
%patch105 -p0 -b .dnd
|
||||||
#%patch106 -p1 -b .indicator-crash
|
|
||||||
#%patch110 -p0 -b .startup-notify
|
#%patch110 -p0 -b .startup-notify
|
||||||
%patch111 -p1 -b .path
|
%patch111 -p1 -b .path
|
||||||
%patch112 -p1 -b .debug
|
%patch112 -p1 -b .debug
|
||||||
@ -241,8 +233,10 @@ desktop-file-install --vendor mozilla \
|
|||||||
# set up our default homepage
|
# set up our default homepage
|
||||||
%{__cat} >> rh-default-prefs << EOF
|
%{__cat} >> rh-default-prefs << EOF
|
||||||
pref("browser.startup.homepage", "%{homepage}");
|
pref("browser.startup.homepage", "%{homepage}");
|
||||||
|
/*
|
||||||
pref("startup.homepage_override_url", "%{homepage}");
|
pref("startup.homepage_override_url", "%{homepage}");
|
||||||
pref("startup.homepage_welcome_url", "%{homepage}");
|
pref("startup.homepage_welcome_url", "%{homepage}");
|
||||||
|
*/
|
||||||
EOF
|
EOF
|
||||||
|
|
||||||
# place the preferences
|
# place the preferences
|
||||||
@ -403,7 +397,7 @@ fi
|
|||||||
%ghost %{mozappdir}/components/xpti.dat
|
%ghost %{mozappdir}/components/xpti.dat
|
||||||
%{mozappdir}/components/*.so
|
%{mozappdir}/components/*.so
|
||||||
%{mozappdir}/components/*.xpt
|
%{mozappdir}/components/*.xpt
|
||||||
%{mozappdir}/components/*.js
|
%attr(644, root, root) %{mozappdir}/components/*.js
|
||||||
%{mozappdir}/defaults
|
%{mozappdir}/defaults
|
||||||
%{mozappdir}/extensions
|
%{mozappdir}/extensions
|
||||||
%{mozappdir}/greprefs
|
%{mozappdir}/greprefs
|
||||||
@ -444,6 +438,11 @@ fi
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 9 2007 Christopher Aillon <caillon@redhat.com> 2.0.0.10-4
|
||||||
|
- Fix up some rpmlint warnings
|
||||||
|
- Use only one pref for the homepage for now
|
||||||
|
- Drop some old patches and some obsolote Obsoletes
|
||||||
|
|
||||||
* Tue Dec 4 2007 Martin Stransky <stransky@redhat.com> 2.0.0.10-3
|
* Tue Dec 4 2007 Martin Stransky <stransky@redhat.com> 2.0.0.10-3
|
||||||
- fixed an icon location
|
- fixed an icon location
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user