Merge branch 'master' into f26
This commit is contained in:
commit
38da98e3f8
10
.gitignore
vendored
10
.gitignore
vendored
@ -249,3 +249,13 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-56.0.source.tar.xz
|
||||
/firefox-langpacks-56.0-20170925.tar.xz
|
||||
/firefox-langpacks-56.0-20170927.tar.xz
|
||||
/firefox-57.0b5.source.tar.xz
|
||||
/firefox-langpacks-57.0b5-20171005.tar.xz
|
||||
/firefox-57.0b6.source.tar.xz
|
||||
/firefox-langpacks-57.0b6-20171009.tar.xz
|
||||
/firefox-57.0b7.source.tar.xz
|
||||
/firefox-langpacks-57.0b7-20171011.tar.xz
|
||||
/firefox-57.0b8.source.tar.xz
|
||||
/firefox-langpacks-57.0b8-20171016.tar.xz
|
||||
/firefox-57.0b9.source.tar.xz
|
||||
/firefox-langpacks-57.0b9-20171019.tar.xz
|
||||
|
@ -1,19 +1,19 @@
|
||||
diff -up firefox-55.0.2/js/src/jit/AtomicOperations.h.jit-atomic-lucky firefox-55.0.2/js/src/jit/AtomicOperations.h
|
||||
--- firefox-55.0.2/js/src/jit/AtomicOperations.h.jit-atomic-lucky 2017-07-31 18:20:47.000000000 +0200
|
||||
+++ firefox-55.0.2/js/src/jit/AtomicOperations.h 2017-08-29 12:59:52.870926044 +0200
|
||||
@@ -348,7 +348,7 @@ AtomicOperations::isLockfree(int32_t siz
|
||||
# elif defined(__sh__)
|
||||
diff -up firefox-57.0b5/js/src/jit/AtomicOperations.h.jit-atomic-lucky firefox-57.0b5/js/src/jit/AtomicOperations.h
|
||||
--- firefox-57.0b5/js/src/jit/AtomicOperations.h.jit-atomic-lucky 2017-10-06 12:34:02.338973607 +0200
|
||||
+++ firefox-57.0b5/js/src/jit/AtomicOperations.h 2017-10-06 12:38:24.632622215 +0200
|
||||
@@ -415,7 +415,7 @@ AtomicOperations::isLockfreeJS(int32_t s
|
||||
#elif defined(__s390__) || defined(__s390x__)
|
||||
# include "jit/none/AtomicOperations-feeling-lucky.h"
|
||||
#else
|
||||
-# include "jit/none/AtomicOperations-none.h" // These MOZ_CRASH() always
|
||||
-# error "No AtomicOperations support provided for this platform"
|
||||
+# include "jit/none/AtomicOperations-feeling-lucky.h"
|
||||
#endif
|
||||
#elif defined(JS_CODEGEN_X86) || defined(JS_CODEGEN_X64)
|
||||
# include "jit/x86-shared/AtomicOperations-x86-shared.h"
|
||||
diff -up firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h.jit-atomic-lucky firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h
|
||||
--- firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h.jit-atomic-lucky 2017-08-29 14:10:52.665031524 +0200
|
||||
+++ firefox-55.0.2/js/src/jit/none/AtomicOperations-feeling-lucky.h 2017-08-29 14:09:40.756060235 +0200
|
||||
@@ -60,6 +60,14 @@
|
||||
|
||||
#endif // jit_AtomicOperations_h
|
||||
diff -up firefox-57.0b5/js/src/jit/none/AtomicOperations-feeling-lucky.h.jit-atomic-lucky firefox-57.0b5/js/src/jit/none/AtomicOperations-feeling-lucky.h
|
||||
--- firefox-57.0b5/js/src/jit/none/AtomicOperations-feeling-lucky.h.jit-atomic-lucky 2017-09-19 06:18:28.000000000 +0200
|
||||
+++ firefox-57.0b5/js/src/jit/none/AtomicOperations-feeling-lucky.h 2017-10-06 12:34:02.338973607 +0200
|
||||
@@ -79,6 +79,14 @@
|
||||
# define GNUC_COMPATIBLE
|
||||
#endif
|
||||
|
||||
|
@ -1,44 +0,0 @@
|
||||
diff -up firefox-53.0/dom/u2f/U2F.cpp.prbool firefox-53.0/dom/u2f/U2F.cpp
|
||||
--- firefox-53.0/dom/u2f/U2F.cpp.prbool 2017-04-11 06:15:14.000000000 +0200
|
||||
+++ firefox-53.0/dom/u2f/U2F.cpp 2017-04-18 09:19:20.524285200 +0200
|
||||
@@ -4,6 +4,7 @@
|
||||
* License, v. 2.0. If a copy of the MPL was not distributed with this
|
||||
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */
|
||||
|
||||
+#include "prtypes.h"
|
||||
#include "hasht.h"
|
||||
#include "mozilla/dom/CallbackFunction.h"
|
||||
#include "mozilla/dom/ContentChild.h"
|
||||
diff -up firefox-53.0/security/certverifier/CTLogVerifier.cpp.prbool firefox-53.0/security/certverifier/CTLogVerifier.cpp
|
||||
--- firefox-53.0/security/certverifier/CTLogVerifier.cpp.prbool 2017-04-18 09:19:20.524285200 +0200
|
||||
+++ firefox-53.0/security/certverifier/CTLogVerifier.cpp 2017-04-18 09:52:34.189402811 +0200
|
||||
@@ -9,6 +9,7 @@
|
||||
#include <stdint.h>
|
||||
|
||||
#include "CTSerialization.h"
|
||||
+#include "prtypes.h"
|
||||
#include "hasht.h"
|
||||
#include "mozilla/ArrayUtils.h"
|
||||
#include "mozilla/Assertions.h"
|
||||
diff -up firefox-53.0/security/certverifier/CTObjectsExtractor.cpp.prbool firefox-53.0/security/certverifier/CTObjectsExtractor.cpp
|
||||
--- firefox-53.0/security/certverifier/CTObjectsExtractor.cpp.prbool 2017-01-16 17:16:51.000000000 +0100
|
||||
+++ firefox-53.0/security/certverifier/CTObjectsExtractor.cpp 2017-04-18 09:19:20.525285196 +0200
|
||||
@@ -6,6 +6,7 @@
|
||||
|
||||
#include "CTObjectsExtractor.h"
|
||||
|
||||
+#include "prtypes.h"
|
||||
#include "hasht.h"
|
||||
#include "mozilla/Assertions.h"
|
||||
#include "mozilla/Casting.h"
|
||||
diff -up firefox-53.0/security/certverifier/OCSPCache.h.prbool firefox-53.0/security/certverifier/OCSPCache.h
|
||||
--- firefox-53.0/security/certverifier/OCSPCache.h.prbool 2017-04-11 06:15:19.000000000 +0200
|
||||
+++ firefox-53.0/security/certverifier/OCSPCache.h 2017-04-18 09:19:20.525285196 +0200
|
||||
@@ -25,6 +25,7 @@
|
||||
#ifndef mozilla_psm_OCSPCache_h
|
||||
#define mozilla_psm_OCSPCache_h
|
||||
|
||||
+#include "prtypes.h"
|
||||
#include "hasht.h"
|
||||
#include "mozilla/Mutex.h"
|
||||
#include "mozilla/Vector.h"
|
@ -12,9 +12,7 @@ ac_add_options --disable-tests
|
||||
#ac_add_options --enable-libnotify
|
||||
ac_add_options --enable-necko-wifi
|
||||
ac_add_options --enable-startup-notification
|
||||
#ac_add_options --disable-cpp-exceptions
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --enable-url-classifier
|
||||
ac_add_options --enable-chrome-format=omni
|
||||
ac_add_options --enable-pulseaudio
|
||||
ac_add_options --with-system-icu
|
||||
|
60
firefox.spec
60
firefox.spec
@ -2,9 +2,6 @@
|
||||
ExcludeArch: armv7hl
|
||||
%endif
|
||||
|
||||
# Use ALSA backend?
|
||||
%define alsa_backend 0
|
||||
|
||||
# Use system nspr/nss?
|
||||
%define system_nss 1
|
||||
|
||||
@ -68,12 +65,12 @@ ExcludeArch: armv7hl
|
||||
%endif
|
||||
|
||||
%if %{?system_nss}
|
||||
%global nspr_version 4.10.10
|
||||
%global nspr_version 4.17.0
|
||||
# NSS/NSPR quite often ends in build override, so as requirement the version
|
||||
# we're building against could bring us some broken dependencies from time to time.
|
||||
#%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
|
||||
%global nspr_build_version %{nspr_version}
|
||||
%global nss_version 3.32.1
|
||||
%global nss_version 3.33
|
||||
#%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
|
||||
%global nss_build_version %{nss_version}
|
||||
%endif
|
||||
@ -84,9 +81,12 @@ ExcludeArch: armv7hl
|
||||
%global sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo 65536)
|
||||
%endif
|
||||
|
||||
%define pre_version b9
|
||||
|
||||
%global mozappdir %{_libdir}/%{name}
|
||||
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
|
||||
%global langpackdir %{mozappdir}/langpacks
|
||||
%global tarballdir %{name}-%{version}%{?pre_version}
|
||||
|
||||
%define official_branding 1
|
||||
%define build_langpacks 1
|
||||
@ -102,14 +102,14 @@ ExcludeArch: armv7hl
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 56.0
|
||||
Release: 5%{?pre_tag}%{?dist}
|
||||
Version: 57.0
|
||||
Release: 0.5%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20170927.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20171019.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -126,16 +126,13 @@ Patch0: firefox-install-dir.patch
|
||||
Patch3: mozilla-build-arm.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
|
||||
Patch18: xulrunner-24.0-jemalloc-ppc.patch
|
||||
Patch20: firefox-build-prbool.patch
|
||||
Patch25: rhbz-1219542-s390-build.patch
|
||||
Patch26: build-icu-big-endian.patch
|
||||
Patch27: mozilla-1335250.patch
|
||||
# Also fixes s390x: https://bugzilla.mozilla.org/show_bug.cgi?id=1376268
|
||||
Patch29: build-big-endian.patch
|
||||
Patch30: fedora-build.patch
|
||||
Patch31: build-ppc64-s390x-curl.patch
|
||||
Patch32: build-rust-ppc64le.patch
|
||||
Patch34: build-cubeb-pulse-arm.patch
|
||||
Patch35: build-ppc-jit.patch
|
||||
Patch36: build-missing-xlocale-h.patch
|
||||
# Always feel lucky for unsupported platforms:
|
||||
@ -153,7 +150,6 @@ Patch225: mozilla-1005640-accept-lang.patch
|
||||
#ARM run-time patch
|
||||
Patch226: rhbz-1354671.patch
|
||||
Patch229: firefox-nss-version.patch
|
||||
Patch230: rhbz-1497932.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch402: mozilla-1196777.patch
|
||||
@ -163,7 +159,7 @@ Patch410: mozilla-1321521.patch
|
||||
Patch411: mozilla-1321521-2.patch
|
||||
Patch412: mozilla-1337988.patch
|
||||
Patch413: mozilla-1353817.patch
|
||||
Patch415: mozilla-1405267.patch
|
||||
Patch416: mozilla-1399611.patch
|
||||
|
||||
# Debian patches
|
||||
Patch500: mozilla-440908.patch
|
||||
@ -195,9 +191,6 @@ BuildRequires: pkgconfig(xrender)
|
||||
BuildRequires: pkgconfig(hunspell)
|
||||
%endif
|
||||
BuildRequires: pkgconfig(libstartup-notification-1.0)
|
||||
%if %{?alsa_backend}
|
||||
BuildRequires: pkgconfig(alsa)
|
||||
%endif
|
||||
BuildRequires: pkgconfig(libnotify) >= %{libnotify_version}
|
||||
BuildRequires: pkgconfig(dri)
|
||||
BuildRequires: pkgconfig(libcurl)
|
||||
@ -302,7 +295,7 @@ This package contains results of tests executed during build.
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -n %{tarballdir}
|
||||
|
||||
# Build patches, can't change backup suffix from default because during build
|
||||
# there is a compare of config and js/config directories and .orig suffix is
|
||||
@ -311,15 +304,12 @@ This package contains results of tests executed during build.
|
||||
|
||||
|
||||
%patch18 -p1 -b .jemalloc-ppc
|
||||
%patch20 -p1 -b .prbool
|
||||
%ifarch s390
|
||||
%patch25 -p1 -b .rhbz-1219542-s390
|
||||
%endif
|
||||
%patch29 -p1 -b .big-endian
|
||||
%patch30 -p1 -b .fedora-build
|
||||
%patch31 -p1 -b .ppc64-s390x-curl
|
||||
%patch32 -p1 -b .rust-ppc64le
|
||||
# don't need that %patch34 -p1 -b .cubeb-pulse-arm
|
||||
%ifarch ppc ppc64 ppc64le
|
||||
%patch35 -p1 -b .ppc-jit
|
||||
%endif
|
||||
@ -327,8 +317,6 @@ This package contains results of tests executed during build.
|
||||
|
||||
%patch3 -p1 -b .arm
|
||||
|
||||
# For branding specific patches.
|
||||
|
||||
# Fedora patches
|
||||
%patch215 -p1 -b .addons
|
||||
%patch219 -p2 -b .rhbz-1173156
|
||||
@ -339,7 +327,6 @@ This package contains results of tests executed during build.
|
||||
%ifarch aarch64
|
||||
%patch226 -p1 -b .1354671
|
||||
%endif
|
||||
%patch230 -p1 -b .1497932
|
||||
|
||||
%patch402 -p1 -b .1196777
|
||||
%patch406 -p1 -b .256180
|
||||
@ -349,8 +336,9 @@ This package contains results of tests executed during build.
|
||||
%patch412 -p1 -b .1337988
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%patch413 -p1 -b .1353817
|
||||
%patch415 -p1 -b .1405267
|
||||
%patch416 -p1 -b .1399611
|
||||
|
||||
# Debian extension patch
|
||||
%patch500 -p1 -b .440908
|
||||
@ -397,10 +385,6 @@ echo "ac_add_options --enable-system-ffi" >> .mozconfig
|
||||
echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
||||
%endif
|
||||
|
||||
%if %{?alsa_backend}
|
||||
echo "ac_add_options --enable-alsa" >> .mozconfig
|
||||
%endif
|
||||
|
||||
%if %{?system_hunspell}
|
||||
echo "ac_add_options --enable-system-hunspell" >> .mozconfig
|
||||
%else
|
||||
@ -471,6 +455,9 @@ echo "ac_add_options --without-system-icu" >> .mozconfig
|
||||
echo "ac_add_options --disable-ion" >> .mozconfig
|
||||
%endif
|
||||
|
||||
%ifarch %{ix86}
|
||||
echo "ac_add_options --disable-stylo" >> .mozconfig
|
||||
%endif
|
||||
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
@ -873,8 +860,21 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Fri Oct 6 2017 Martin Stransky <stransky@redhat.com> - 56.0-5
|
||||
- Enable Stylo again.
|
||||
* Thu Oct 19 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.5
|
||||
- Updated to 57.0 Beta 9
|
||||
|
||||
* Mon Oct 16 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.4
|
||||
- Updated to 57.0 Beta 8
|
||||
|
||||
* Wed Oct 11 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.3
|
||||
- Updated to 57.0 Beta 7
|
||||
|
||||
* Mon Oct 9 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.2
|
||||
- Updated to 57.0 Beta 6
|
||||
|
||||
* Thu Oct 5 2017 Martin Stransky <stransky@redhat.com> - 57.0-0.1
|
||||
- Updated to 57.0 Beta 5
|
||||
- Added patch for mozbz#1399611 - CSD emulation
|
||||
|
||||
* Wed Oct 4 2017 Martin Stransky <stransky@redhat.com> - 56.0-4
|
||||
- Fixed rhbz#1497932 - Plug-Ins for example flash fails
|
||||
|
1744
mozilla-1399611.patch
Normal file
1744
mozilla-1399611.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,19 +0,0 @@
|
||||
diff -up firefox-56.0/widget/gtk/mozgtk/mozgtk.c.1405267 firefox-56.0/widget/gtk/mozgtk/mozgtk.c
|
||||
--- firefox-56.0/widget/gtk/mozgtk/mozgtk.c.1405267 2017-09-14 22:16:02.000000000 +0200
|
||||
+++ firefox-56.0/widget/gtk/mozgtk/mozgtk.c 2017-10-04 09:16:58.512697973 +0200
|
||||
@@ -96,6 +96,7 @@ STUB(gdk_window_get_update_area)
|
||||
STUB(gdk_window_get_user_data)
|
||||
STUB(gdk_window_get_visual)
|
||||
STUB(gdk_window_get_width)
|
||||
+STUB(gdk_window_get_window_type)
|
||||
STUB(gdk_window_hide)
|
||||
STUB(gdk_window_input_shape_combine_region)
|
||||
STUB(gdk_window_invalidate_rect)
|
||||
@@ -520,7 +521,6 @@ STUB(gdk_display_get_device_manager)
|
||||
STUB(gdk_error_trap_pop_ignored)
|
||||
STUB(gdk_event_get_source_device)
|
||||
STUB(gdk_window_get_type)
|
||||
-STUB(gdk_window_get_window_type)
|
||||
STUB(gdk_x11_window_get_xid)
|
||||
STUB(gdk_x11_display_get_type)
|
||||
STUB(gdk_wayland_display_get_type)
|
@ -1,21 +0,0 @@
|
||||
diff -up firefox-56.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-56.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
|
||||
diff -up firefox-56.0/media/webrtc/trunk/Makefile.old firefox-56.0/media/webrtc/trunk/Makefile
|
||||
diff -up firefox-56.0/widget/gtk/mozgtk/mozgtk.c.old firefox-56.0/widget/gtk/mozgtk/mozgtk.c
|
||||
--- firefox-56.0/widget/gtk/mozgtk/mozgtk.c.old 2017-10-04 09:21:56.155553585 +0200
|
||||
+++ firefox-56.0/widget/gtk/mozgtk/mozgtk.c 2017-10-04 09:22:35.562427061 +0200
|
||||
@@ -61,7 +61,6 @@ STUB(gdk_screen_get_height_mm)
|
||||
STUB(gdk_screen_get_n_monitors)
|
||||
STUB(gdk_screen_get_monitor_at_window)
|
||||
STUB(gdk_screen_get_monitor_geometry)
|
||||
-STUB(gdk_screen_get_monitor_workarea)
|
||||
STUB(gdk_screen_get_monitor_height_mm)
|
||||
STUB(gdk_screen_get_number)
|
||||
STUB(gdk_screen_get_resolution)
|
||||
@@ -550,6 +549,7 @@ STUB(gtk_render_line)
|
||||
STUB(gtk_render_option)
|
||||
STUB(gtk_render_slider)
|
||||
STUB(gtk_scale_new)
|
||||
+STUB(gdk_screen_get_monitor_workarea)
|
||||
STUB(gtk_scrollbar_new)
|
||||
STUB(gtk_style_context_add_class)
|
||||
STUB(gtk_style_context_add_region)
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (firefox-56.0.source.tar.xz) = 3aeb0ff54e10c83894f61734daa4f0801a1bb499d4667adad9c78520e588eae809d0e4d61e9227206466d62c3b453e2ce9ca8198f59f5354cd1b6804c00f0990
|
||||
SHA512 (firefox-langpacks-56.0-20170927.tar.xz) = e74d85410891b6faa388d37043d764a6c01a2c83479d9912aa3d0b23684ed66ca639eb3cdb579cafef6c3156b0d774a66987a605e0f9e25c2d4eed967ef7b627
|
||||
SHA512 (firefox-57.0b9.source.tar.xz) = 5d09a07ae48198de8d8ada4018afb4c1cfe16d9294bbbd502d3f23915c43496604f19761a409a41a23ec712d622a556b0b6dc9efd186f4528724e52c8305dda1
|
||||
SHA512 (firefox-langpacks-57.0b9-20171019.tar.xz) = 07a3182edf634a5151e4c599e9f8a886e286c1e708f5743db10efeeb5526b4aa120153491da926c5bfcd69cb0e683ff83f2637fca53c78b9e256151768c20712
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up firefox-48.0/memory/mozjemalloc/jemalloc.c.jemalloc-ppc firefox-48.0/memory/mozjemalloc/jemalloc.c
|
||||
--- firefox-48.0/memory/mozjemalloc/mozjemalloc.cpp.jemalloc-ppc 2016-07-26 10:51:46.385434384 +0200
|
||||
+++ firefox-48.0/memory/mozjemalloc/mozjemalloc.cpp 2016-07-26 10:53:49.061023106 +0200
|
||||
@@ -1090,7 +1090,7 @@ static const bool config_recycle = false
|
||||
diff -up firefox-57.0b5/memory/build/mozjemalloc.cpp.old firefox-57.0b5/memory/build/mozjemalloc.cpp
|
||||
--- firefox-57.0b5/memory/build/mozjemalloc.cpp.old 2017-10-06 12:00:27.938687498 +0200
|
||||
+++ firefox-57.0b5/memory/build/mozjemalloc.cpp 2017-10-06 12:02:45.232151309 +0200
|
||||
@@ -780,7 +780,7 @@ struct arena_t {
|
||||
* controlling the malloc behavior are defined as compile-time constants
|
||||
* for best performance and cannot be altered at runtime.
|
||||
*/
|
||||
|
Loading…
Reference in New Issue
Block a user