Merge remote-tracking branch 'alma-origin/c8' into HEAD
This commit is contained in:
commit
366328e182
@ -1,5 +1,5 @@
|
|||||||
c822547dbc12e2baebdfdfb38b665e23f0c2513a SOURCES/cbindgen-vendor.tar.xz
|
c822547dbc12e2baebdfdfb38b665e23f0c2513a SOURCES/cbindgen-vendor.tar.xz
|
||||||
986181f538d2a6951f95b4e1a754854b8e0048ff SOURCES/firefox-91.6.0esr.processed-source.tar.xz
|
d208b4a6bafc320267bb65a486365f2cd1f8aa5a SOURCES/firefox-91.7.0esr.processed-source.tar.xz
|
||||||
ea7fce0f4ee0101b6d9ef8b4d050fe8a16becff9 SOURCES/firefox-langpacks-91.6.0esr-20220202.tar.xz
|
fe2cdd6db0edb7d3da3c645e4efc003b6afedb6c SOURCES/firefox-langpacks-91.7.0esr-20220307.tar.xz
|
||||||
b5fd1332d8e0d37339ae170c7bebcb63a40b22e0 SOURCES/nspr-4.32.0-1.el8_1.src.rpm
|
b5fd1332d8e0d37339ae170c7bebcb63a40b22e0 SOURCES/nspr-4.32.0-1.el8_1.src.rpm
|
||||||
8fff814901e03c2518ede2f8992d898f5ba61ed9 SOURCES/nss-3.67.0-7.el8_1.src.rpm
|
8fff814901e03c2518ede2f8992d898f5ba61ed9 SOURCES/nss-3.67.0-7.el8_1.src.rpm
|
||||||
|
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,5 +1,5 @@
|
|||||||
SOURCES/cbindgen-vendor.tar.xz
|
SOURCES/cbindgen-vendor.tar.xz
|
||||||
SOURCES/firefox-91.6.0esr.processed-source.tar.xz
|
SOURCES/firefox-91.7.0esr.processed-source.tar.xz
|
||||||
SOURCES/firefox-langpacks-91.6.0esr-20220202.tar.xz
|
SOURCES/firefox-langpacks-91.7.0esr-20220307.tar.xz
|
||||||
SOURCES/nspr-4.32.0-1.el8_1.src.rpm
|
SOURCES/nspr-4.32.0-1.el8_1.src.rpm
|
||||||
SOURCES/nss-3.67.0-7.el8_1.src.rpm
|
SOURCES/nss-3.67.0-7.el8_1.src.rpm
|
||||||
|
49
SOURCES/expat-CVE-2022-25235.patch
Normal file
49
SOURCES/expat-CVE-2022-25235.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
diff -up firefox-91.7.0/parser/expat/lib/xmltok.c.expat-CVE-2022-25235 firefox-91.7.0/parser/expat/lib/xmltok.c
|
||||||
|
--- firefox-91.7.0/parser/expat/lib/xmltok.c.expat-CVE-2022-25235 2022-03-02 17:57:38.364361168 +0100
|
||||||
|
+++ firefox-91.7.0/parser/expat/lib/xmltok.c 2022-03-02 17:58:22.235512399 +0100
|
||||||
|
@@ -65,13 +65,6 @@
|
||||||
|
+ ((((byte)[2]) >> 5) & 1)] \
|
||||||
|
& (1u << (((byte)[2]) & 0x1F)))
|
||||||
|
|
||||||
|
-#define UTF8_GET_NAMING(pages, p, n) \
|
||||||
|
- ((n) == 2 \
|
||||||
|
- ? UTF8_GET_NAMING2(pages, (const unsigned char *)(p)) \
|
||||||
|
- : ((n) == 3 \
|
||||||
|
- ? UTF8_GET_NAMING3(pages, (const unsigned char *)(p)) \
|
||||||
|
- : 0))
|
||||||
|
-
|
||||||
|
/* Detection of invalid UTF-8 sequences is based on Table 3.1B
|
||||||
|
of Unicode 3.2: http://www.unicode.org/unicode/reports/tr28/
|
||||||
|
with the additional restriction of not allowing the Unicode
|
||||||
|
diff -up firefox-91.7.0/parser/expat/lib/xmltok_impl.c.expat-CVE-2022-25235 firefox-91.7.0/parser/expat/lib/xmltok_impl.c
|
||||||
|
--- firefox-91.7.0/parser/expat/lib/xmltok_impl.c.expat-CVE-2022-25235 2022-03-02 17:57:38.365361172 +0100
|
||||||
|
+++ firefox-91.7.0/parser/expat/lib/xmltok_impl.c 2022-03-02 18:04:51.240853247 +0100
|
||||||
|
@@ -34,7 +34,7 @@
|
||||||
|
case BT_LEAD ## n: \
|
||||||
|
if (end - ptr < n) \
|
||||||
|
return XML_TOK_PARTIAL_CHAR; \
|
||||||
|
- if (!IS_NAME_CHAR(enc, ptr, n)) { \
|
||||||
|
+ if (IS_INVALID_CHAR(enc, ptr, n) || ! IS_NAME_CHAR(enc, ptr, n)) { \
|
||||||
|
*nextTokPtr = ptr; \
|
||||||
|
return XML_TOK_INVALID; \
|
||||||
|
} \
|
||||||
|
@@ -62,7 +62,7 @@
|
||||||
|
case BT_LEAD ## n: \
|
||||||
|
if (end - ptr < n) \
|
||||||
|
return XML_TOK_PARTIAL_CHAR; \
|
||||||
|
- if (!IS_NMSTRT_CHAR(enc, ptr, n)) { \
|
||||||
|
+ if (IS_INVALID_CHAR(enc, ptr, n) || ! IS_NMSTRT_CHAR(enc, ptr, n)) { \
|
||||||
|
*nextTokPtr = ptr; \
|
||||||
|
return XML_TOK_INVALID; \
|
||||||
|
} \
|
||||||
|
@@ -1090,6 +1090,10 @@ PREFIX(prologTok)(const ENCODING *enc, c
|
||||||
|
case BT_LEAD ## n: \
|
||||||
|
if (end - ptr < n) \
|
||||||
|
return XML_TOK_PARTIAL_CHAR; \
|
||||||
|
+ if (IS_INVALID_CHAR(enc, ptr, n)) { \
|
||||||
|
+ *nextTokPtr = ptr; \
|
||||||
|
+ return XML_TOK_INVALID; \
|
||||||
|
+ } \
|
||||||
|
if (IS_NMSTRT_CHAR(enc, ptr, n)) { \
|
||||||
|
ptr += n; \
|
||||||
|
tok = XML_TOK_NAME; \
|
40
SOURCES/expat-CVE-2022-25236.patch
Normal file
40
SOURCES/expat-CVE-2022-25236.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
diff -up firefox-91.7.0/parser/expat/lib/xmlparse.c.expat-CVE-2022-25236 firefox-91.7.0/parser/expat/lib/xmlparse.c
|
||||||
|
--- firefox-91.7.0/parser/expat/lib/xmlparse.c.expat-CVE-2022-25236 2022-03-02 18:08:40.085642028 +0100
|
||||||
|
+++ firefox-91.7.0/parser/expat/lib/xmlparse.c 2022-03-02 18:13:31.838667958 +0100
|
||||||
|
@@ -700,8 +700,7 @@ XML_ParserCreate(const XML_Char *encodin
|
||||||
|
XML_Parser XMLCALL
|
||||||
|
XML_ParserCreateNS(const XML_Char *encodingName, XML_Char nsSep)
|
||||||
|
{
|
||||||
|
- XML_Char tmp[2];
|
||||||
|
- *tmp = nsSep;
|
||||||
|
+ XML_Char tmp[2] = {nsSep, 0};
|
||||||
|
return XML_ParserCreate_MM(encodingName, NULL, tmp);
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
@@ -1276,8 +1275,7 @@ XML_ExternalEntityParserCreate(XML_Parse
|
||||||
|
would be otherwise.
|
||||||
|
*/
|
||||||
|
if (ns) {
|
||||||
|
- XML_Char tmp[2];
|
||||||
|
- *tmp = namespaceSeparator;
|
||||||
|
+ XML_Char tmp[2] = {parser->m_namespaceSeparator, 0};
|
||||||
|
parser = parserCreate(encodingName, &parser->m_mem, tmp, newDtd);
|
||||||
|
}
|
||||||
|
else {
|
||||||
|
@@ -3667,6 +3665,16 @@ addBinding(XML_Parser parser, PREFIX *pr
|
||||||
|
if (!mustBeXML && isXMLNS
|
||||||
|
&& (len > xmlnsLen || uri[len] != xmlnsNamespace[len]))
|
||||||
|
isXMLNS = XML_FALSE;
|
||||||
|
+ // NOTE: While Expat does not validate namespace URIs against RFC 3986,
|
||||||
|
+ // we have to at least make sure that the XML processor on top of
|
||||||
|
+ // Expat (that is splitting tag names by namespace separator into
|
||||||
|
+ // 2- or 3-tuples (uri-local or uri-local-prefix)) cannot be confused
|
||||||
|
+ // by an attacker putting additional namespace separator characters
|
||||||
|
+ // into namespace declarations. That would be ambiguous and not to
|
||||||
|
+ // be expected.
|
||||||
|
+ if (parser->m_ns && (uri[len] == parser->m_namespaceSeparator)) {
|
||||||
|
+ return XML_ERROR_SYNTAX;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
isXML = isXML && len == xmlLen;
|
||||||
|
isXMLNS = isXMLNS && len == xmlnsLen;
|
24
SOURCES/expat-CVE-2022-25315.patch
Normal file
24
SOURCES/expat-CVE-2022-25315.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -up firefox-91.7.0/parser/expat/lib/xmlparse.c.expat-CVE-2022-25315 firefox-91.7.0/parser/expat/lib/xmlparse.c
|
||||||
|
--- firefox-91.7.0/parser/expat/lib/xmlparse.c.expat-CVE-2022-25315 2022-03-02 18:17:50.966583254 +0100
|
||||||
|
+++ firefox-91.7.0/parser/expat/lib/xmlparse.c 2022-03-02 18:19:27.636924735 +0100
|
||||||
|
@@ -2479,6 +2479,7 @@ storeRawNames(XML_Parser parser)
|
||||||
|
while (tag) {
|
||||||
|
int bufSize;
|
||||||
|
int nameLen = sizeof(XML_Char) * (tag->name.strLen + 1);
|
||||||
|
+ size_t rawNameLen;
|
||||||
|
char *rawNameBuf = tag->buf + nameLen;
|
||||||
|
/* Stop if already stored. Since tagStack is a stack, we can stop
|
||||||
|
at the first entry that has already been copied; everything
|
||||||
|
@@ -2490,7 +2491,11 @@ storeRawNames(XML_Parser parser)
|
||||||
|
/* For re-use purposes we need to ensure that the
|
||||||
|
size of tag->buf is a multiple of sizeof(XML_Char).
|
||||||
|
*/
|
||||||
|
- bufSize = nameLen + ROUND_UP(tag->rawNameLength, sizeof(XML_Char));
|
||||||
|
+ rawNameLen = ROUND_UP(tag->rawNameLength, sizeof(XML_Char));
|
||||||
|
+ /* Detect and prevent integer overflow. */
|
||||||
|
+ if (rawNameLen > (size_t)INT_MAX - nameLen)
|
||||||
|
+ return XML_FALSE;
|
||||||
|
+ bufSize = nameLen + (int)rawNameLen;
|
||||||
|
if (bufSize > tag->bufEnd - tag->buf) {
|
||||||
|
char *temp = (char *)REALLOC(tag->buf, bufSize);
|
||||||
|
if (temp == NULL)
|
@ -61,8 +61,6 @@ if [ ! -r $MOZ_LIB_DIR/firefox/$MOZ_FIREFOX_FILE ]; then
|
|||||||
MOZ_LIB_DIR="$SECONDARY_LIB_DIR"
|
MOZ_LIB_DIR="$SECONDARY_LIB_DIR"
|
||||||
fi
|
fi
|
||||||
MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox"
|
MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox"
|
||||||
MOZ_LANGPACKS_DIR="$MOZ_DIST_BIN/langpacks"
|
|
||||||
MOZ_EXTENSIONS_PROFILE_DIR="$HOME/.mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
|
|
||||||
MOZ_PROGRAM="$MOZ_DIST_BIN/$MOZ_FIREFOX_FILE"
|
MOZ_PROGRAM="$MOZ_DIST_BIN/$MOZ_FIREFOX_FILE"
|
||||||
MOZ_LAUNCHER="$MOZ_DIST_BIN/run-mozilla.sh"
|
MOZ_LAUNCHER="$MOZ_DIST_BIN/run-mozilla.sh"
|
||||||
|
|
||||||
@ -100,12 +98,6 @@ export MOZ_PLUGIN_PATH
|
|||||||
##
|
##
|
||||||
export MOZ_APP_LAUNCHER="%PREFIX%/bin/firefox"
|
export MOZ_APP_LAUNCHER="%PREFIX%/bin/firefox"
|
||||||
|
|
||||||
##
|
|
||||||
## Set FONTCONFIG_PATH for Xft/fontconfig
|
|
||||||
##
|
|
||||||
FONTCONFIG_PATH="/etc/fonts:${MOZILLA_FIVE_HOME}/res/Xft"
|
|
||||||
export FONTCONFIG_PATH
|
|
||||||
|
|
||||||
##
|
##
|
||||||
## In order to better support certain scripts (such as Indic and some CJK
|
## In order to better support certain scripts (such as Indic and some CJK
|
||||||
## scripts), Fedora builds its Firefox, with permission from the Mozilla
|
## scripts), Fedora builds its Firefox, with permission from the Mozilla
|
||||||
@ -135,76 +127,6 @@ export G_SLICE=always-malloc
|
|||||||
##
|
##
|
||||||
export MOZ_USE_XINPUT2=1
|
export MOZ_USE_XINPUT2=1
|
||||||
|
|
||||||
# OK, here's where all the real work gets done
|
|
||||||
|
|
||||||
|
|
||||||
##
|
|
||||||
## To disable the use of Firefox localization, set MOZ_DISABLE_LANGPACKS=1
|
|
||||||
## in your environment before launching Firefox.
|
|
||||||
##
|
|
||||||
#
|
|
||||||
# MOZ_DISABLE_LANGPACKS=1
|
|
||||||
# export MOZ_DISABLE_LANGPACKS
|
|
||||||
#
|
|
||||||
|
|
||||||
##
|
|
||||||
## Automatically installed langpacks are tracked by .fedora-langpack-install
|
|
||||||
## config file.
|
|
||||||
##
|
|
||||||
FEDORA_LANGPACK_CONFIG="$MOZ_EXTENSIONS_PROFILE_DIR/.fedora-langpack-install"
|
|
||||||
|
|
||||||
MOZILLA_DOWN=0
|
|
||||||
if ! [ $MOZ_DISABLE_LANGPACKS ] || [ $MOZ_DISABLE_LANGPACKS -eq 0 ]; then
|
|
||||||
if [ -x $MOZ_DIST_BIN/$MOZ_FIREFOX_FILE ]; then
|
|
||||||
# Is firefox running?
|
|
||||||
pidof firefox > /dev/null 2>&1
|
|
||||||
MOZILLA_DOWN=$?
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Modify language pack configuration only when firefox is not running
|
|
||||||
# and language packs are not disabled
|
|
||||||
if [ $MOZILLA_DOWN -ne 0 ]; then
|
|
||||||
|
|
||||||
# Clear already installed langpacks
|
|
||||||
mkdir -p $MOZ_EXTENSIONS_PROFILE_DIR
|
|
||||||
if [ -f $FEDORA_LANGPACK_CONFIG ]; then
|
|
||||||
rm `cat $FEDORA_LANGPACK_CONFIG` > /dev/null 2>&1
|
|
||||||
rm $FEDORA_LANGPACK_CONFIG > /dev/null 2>&1
|
|
||||||
# remove all empty langpacks dirs while they block installation of langpacks
|
|
||||||
rmdir $MOZ_EXTENSIONS_PROFILE_DIR/langpack* > /dev/null 2>&1
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Get locale from system
|
|
||||||
CURRENT_LOCALE=$LC_ALL
|
|
||||||
CURRENT_LOCALE=${CURRENT_LOCALE:-$LC_MESSAGES}
|
|
||||||
CURRENT_LOCALE=${CURRENT_LOCALE:-$LANG}
|
|
||||||
|
|
||||||
# Try with a local variant first, then without a local variant
|
|
||||||
SHORTMOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*||g"`
|
|
||||||
MOZLOCALE=`echo $CURRENT_LOCALE | sed "s|_\([^.]*\).*|-\1|g"`
|
|
||||||
|
|
||||||
function create_langpack_link() {
|
|
||||||
local language=$*
|
|
||||||
local langpack=langpack-${language}@firefox.mozilla.org.xpi
|
|
||||||
if [ -f $MOZ_LANGPACKS_DIR/$langpack ]; then
|
|
||||||
rm -rf $MOZ_EXTENSIONS_PROFILE_DIR/$langpack
|
|
||||||
# If the target file is a symlink (the fallback langpack),
|
|
||||||
# install the original file instead of the fallback one
|
|
||||||
if [ -h $MOZ_LANGPACKS_DIR/$langpack ]; then
|
|
||||||
langpack=`readlink $MOZ_LANGPACKS_DIR/$langpack`
|
|
||||||
fi
|
|
||||||
ln -s $MOZ_LANGPACKS_DIR/$langpack \
|
|
||||||
$MOZ_EXTENSIONS_PROFILE_DIR/$langpack
|
|
||||||
echo $MOZ_EXTENSIONS_PROFILE_DIR/$langpack > $FEDORA_LANGPACK_CONFIG
|
|
||||||
return 0
|
|
||||||
fi
|
|
||||||
return 1
|
|
||||||
}
|
|
||||||
|
|
||||||
create_langpack_link $MOZLOCALE || create_langpack_link $SHORTMOZLOCALE || true
|
|
||||||
fi
|
|
||||||
|
|
||||||
# BEAST fix (rhbz#1005611)
|
# BEAST fix (rhbz#1005611)
|
||||||
NSS_SSL_CBC_RANDOM_IV=${NSS_SSL_CBC_RANDOM_IV-1}
|
NSS_SSL_CBC_RANDOM_IV=${NSS_SSL_CBC_RANDOM_IV-1}
|
||||||
export NSS_SSL_CBC_RANDOM_IV
|
export NSS_SSL_CBC_RANDOM_IV
|
||||||
@ -244,28 +166,5 @@ done
|
|||||||
# Don't throw "old profile" dialog box.
|
# Don't throw "old profile" dialog box.
|
||||||
export MOZ_ALLOW_DOWNGRADE=1
|
export MOZ_ALLOW_DOWNGRADE=1
|
||||||
|
|
||||||
# Make sure at-spi-bus is running
|
|
||||||
if ! dbus-send --session \
|
|
||||||
--dest=org.freedesktop.DBus \
|
|
||||||
--type=method_call \
|
|
||||||
--print-reply \
|
|
||||||
/org/freedesktop/DBus \
|
|
||||||
org.freedesktop.DBus.ListNames \
|
|
||||||
| grep org.a11y.Bus > /dev/null; then
|
|
||||||
if [ -f "$MOZ_LIB_DIR/firefox/bundled/libexec/at-spi-bus-launcher" ]; then
|
|
||||||
echo "Starting a11y dbus service..."
|
|
||||||
$MOZ_LIB_DIR/firefox/bundled/libexec/at-spi-bus-launcher &
|
|
||||||
else
|
|
||||||
echo "Running without a11y support!"
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Run the browser
|
# Run the browser
|
||||||
debugging=0
|
|
||||||
if [ $debugging = 1 ]
|
|
||||||
then
|
|
||||||
echo $MOZ_LAUNCHER $script_args $MOZ_PROGRAM "$@"
|
|
||||||
fi
|
|
||||||
|
|
||||||
|
|
||||||
exec $MOZ_LAUNCHER $script_args $MOZ_PROGRAM "$@"
|
exec $MOZ_LAUNCHER $script_args $MOZ_PROGRAM "$@"
|
||||||
|
@ -121,7 +121,7 @@ end}
|
|||||||
|
|
||||||
%global mozappdir %{_libdir}/%{name}
|
%global mozappdir %{_libdir}/%{name}
|
||||||
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
|
%global mozappdirdev %{_libdir}/%{name}-devel-%{version}
|
||||||
%global langpackdir %{mozappdir}/langpacks
|
%global langpackdir %{mozappdir}/browser/extensions
|
||||||
%global tarballdir %{name}-%{version}
|
%global tarballdir %{name}-%{version}
|
||||||
%global pre_version esr
|
%global pre_version esr
|
||||||
|
|
||||||
@ -130,8 +130,8 @@ end}
|
|||||||
|
|
||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 91.6.0
|
Version: 91.7.0
|
||||||
Release: 1%{?dist}
|
Release: 3%{?dist}
|
||||||
URL: https://www.mozilla.org/firefox/
|
URL: https://www.mozilla.org/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
%if 0%{?rhel} == 9
|
%if 0%{?rhel} == 9
|
||||||
@ -155,7 +155,8 @@ ExcludeArch: aarch64 s390 ppc
|
|||||||
# Link to official tarball: https://hg.mozilla.org/releases/mozilla-release/archive/firefox-%%{version}%%{?pre_version}.source.tar.xz
|
# Link to official tarball: https://hg.mozilla.org/releases/mozilla-release/archive/firefox-%%{version}%%{?pre_version}.source.tar.xz
|
||||||
Source0: firefox-%{version}%{?pre_version}.processed-source.tar.xz
|
Source0: firefox-%{version}%{?pre_version}.processed-source.tar.xz
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20220202.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20220307.tar.xz
|
||||||
|
|
||||||
%endif
|
%endif
|
||||||
Source2: cbindgen-vendor.tar.xz
|
Source2: cbindgen-vendor.tar.xz
|
||||||
Source3: process-official-tarball
|
Source3: process-official-tarball
|
||||||
@ -203,6 +204,9 @@ Patch513: mozilla-bmo998749.patch
|
|||||||
Patch514: mozilla-s390x-skia-gradient.patch
|
Patch514: mozilla-s390x-skia-gradient.patch
|
||||||
Patch515: mozilla-bmo1626236.patch
|
Patch515: mozilla-bmo1626236.patch
|
||||||
Patch518: D110204-fscreen.diff
|
Patch518: D110204-fscreen.diff
|
||||||
|
Patch519: expat-CVE-2022-25235.patch
|
||||||
|
Patch520: expat-CVE-2022-25236.patch
|
||||||
|
Patch521: expat-CVE-2022-25315.patch
|
||||||
|
|
||||||
# Flatpak patches
|
# Flatpak patches
|
||||||
|
|
||||||
@ -450,6 +454,9 @@ echo "use_rustts %{?use_rustts}"
|
|||||||
#%patch514 -p1 -b .mozilla-s390x-skia-gradient
|
#%patch514 -p1 -b .mozilla-s390x-skia-gradient
|
||||||
%patch515 -p1 -b .mozilla-bmo1626236
|
%patch515 -p1 -b .mozilla-bmo1626236
|
||||||
%patch518 -p1 -b .D110204-fscreen.diff
|
%patch518 -p1 -b .D110204-fscreen.diff
|
||||||
|
%patch519 -p1 -b .expat-CVE-2022-25235
|
||||||
|
%patch520 -p1 -b .expat-CVE-2022-25236
|
||||||
|
%patch521 -p1 -b .expat-CVE-2022-25315
|
||||||
|
|
||||||
|
|
||||||
%patch1001 -p1 -b .ppc64le-inline
|
%patch1001 -p1 -b .ppc64le-inline
|
||||||
@ -651,7 +658,7 @@ function build_bundled_package() {
|
|||||||
echo $PKG_CONFIG_PATH
|
echo $PKG_CONFIG_PATH
|
||||||
|
|
||||||
rpm -ivh %{SOURCE403}
|
rpm -ivh %{SOURCE403}
|
||||||
rpmbuild --nodeps --define '_prefix %{bundled_install_path}' -ba %{_specdir}/nss.spec
|
rpmbuild --nodeps --define '_prefix %{bundled_install_path}' --without=tests -ba %{_specdir}/nss.spec
|
||||||
pushd %{_buildrootdir}
|
pushd %{_buildrootdir}
|
||||||
#cleanup
|
#cleanup
|
||||||
#rm -rf {_buildrootdir}/usr/lib/debug/*
|
#rm -rf {_buildrootdir}/usr/lib/debug/*
|
||||||
@ -885,9 +892,9 @@ ls %{_buildrootdir}
|
|||||||
export MACH_USE_SYSTEM_PYTHON=1
|
export MACH_USE_SYSTEM_PYTHON=1
|
||||||
%if 0%{?use_llvmts}
|
%if 0%{?use_llvmts}
|
||||||
#scl enable llvm-toolset-%{llvm_version} './mach build -v'
|
#scl enable llvm-toolset-%{llvm_version} './mach build -v'
|
||||||
./mach build -v
|
./mach build -v || exit 1
|
||||||
%else
|
%else
|
||||||
./mach build -v
|
./mach build -v || exit 1
|
||||||
%endif
|
%endif
|
||||||
# Look for the reason we get: /usr/lib/rpm/debugedit: canonicalization unexpectedly shrank by one character
|
# Look for the reason we get: /usr/lib/rpm/debugedit: canonicalization unexpectedly shrank by one character
|
||||||
readelf -wl objdir/dist/bin/libxul.so | grep "/"
|
readelf -wl objdir/dist/bin/libxul.so | grep "/"
|
||||||
@ -1255,6 +1262,19 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 07 2022 Eike Rathke <erack@redhat.com> - 91.7.0-3
|
||||||
|
- Update to 91.7.0 build3
|
||||||
|
|
||||||
|
* Wed Mar 02 2022 Jan Horak <jhorak@redhat.com> - 91.7.0-2
|
||||||
|
- Added expat backports of CVE-2022-25235, CVE-2022-25236 and CVE-2022-25315
|
||||||
|
|
||||||
|
* Tue Mar 01 2022 Eike Rathke <erack@redhat.com> - 91.7.0-1
|
||||||
|
- Update to 91.7.0 build2
|
||||||
|
|
||||||
|
* Fri Feb 25 2022 Jan Horak <jhorak@redhat.com> - 91.6.0-2
|
||||||
|
- Install langpacks to the browser/extensions to make them available in UI:
|
||||||
|
rhbz#2030190
|
||||||
|
|
||||||
* Wed Feb 02 2022 Eike Rathke <erack@redhat.com> - 91.6.0-1
|
* Wed Feb 02 2022 Eike Rathke <erack@redhat.com> - 91.6.0-1
|
||||||
- Update to 91.6.0 build1
|
- Update to 91.6.0 build1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user