Update to Firefox 45 Build 1 - test builds

This commit is contained in:
Martin Stransky 2016-03-02 13:58:14 +01:00
parent 93db231423
commit 2f2c47fa90
7 changed files with 21 additions and 91 deletions

1
.gitignore vendored
View File

@ -182,3 +182,4 @@ firefox-3.6.4.source.tar.bz2
/firefox-44.0.2.source.tar.xz
/firefox-langpacks-44.0.2-20160210.tar.xz
/firefox-langpacks-44.0.2-20160211.tar.xz
/firefox-45.0.source.tar.xz

View File

@ -1,6 +1,6 @@
diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/mozilla-release/config/baseconfig.mk
--- mozilla-release/config/baseconfig.mk.orig 2014-04-22 15:38:52.948165295 +0200
+++ mozilla-release/config/baseconfig.mk 2014-04-22 15:42:20.387481673 +0200
diff -up firefox-45.0/firefox-45.0/config/baseconfig.mk.orig firefox-45.0/firefox-45.0/config/baseconfig.mk
--- firefox-45.0/config/baseconfig.mk.orig 2016-03-02 13:26:31.981927073 +0100
+++ firefox-45.0/config/baseconfig.mk 2016-03-02 13:30:09.044756473 +0100
@@ -4,7 +4,7 @@
# whether a normal build is happening or whether the check is running.
includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
@ -8,5 +8,5 @@ diff -up firefox-29.0/mozilla-release/config/baseconfig.mk.orig firefox-29.0/moz
-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION)
+installdir = $(libdir)/$(MOZ_APP_NAME)
sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION)
ifndef TOP_DIST
TOP_DIST = dist
ifeq (.,$(DEPTH))
DIST = dist

View File

@ -1,14 +0,0 @@
diff --git a/media/webrtc/trunk/build/build_config.h b/media/webrtc/trunk/build/build_config.h
index 1a9579e..4f311c5 100644
--- a/media/webrtc/trunk/build/build_config.h
+++ b/media/webrtc/trunk/build/build_config.h
@@ -156,6 +156,9 @@
#elif defined(__alpha__)
#define ARCH_CPU_ALPHA 1
#define ARCH_CPU_64_BITS 1
+#elif defined(__aarch64__)
+#define ARCH_CPU_AARCH64 1
+#define ARCH_CPU_64_BITS 1
#else
#error Please add support for your architecture in build/build_config.h
#endif

View File

@ -77,14 +77,14 @@
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 44.0.2
Release: 3%{?pre_tag}%{?dist}
Version: 45.0
Release: 1%{?pre_tag}%{?dist}
URL: https://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
%if %{build_langpacks}
Source1: firefox-langpacks-%{version}%{?pre_version}-20160211.tar.xz
Source1: firefox-langpacks-%{version}%{?pre_version}-20160302.tar.xz
%endif
Source10: firefox-mozconfig
Source12: firefox-redhat-default-prefs.js
@ -118,7 +118,6 @@ Patch222: firefox-gtk3-20.patch
Patch223: rhbz-1291190-appchooser-crash.patch
# Upstream patches
Patch300: mozilla-1234026.patch
Patch301: mozilla-1205199.patch
# Gtk3 upstream patches
@ -127,8 +126,6 @@ Patch301: mozilla-1205199.patch
# Update https://bugzilla.mozilla.org/show_bug.cgi?id=1142056
# when removed
Patch500: aarch64-fix-skia.patch
# Add AArch64 architecture definition for webrtc
Patch501: firefox-webrtc-aarch64.patch
%if %{?system_nss}
BuildRequires: pkgconfig(nspr) >= %{nspr_version}
@ -242,7 +239,7 @@ cd %{tarballdir}
# Build patches, can't change backup suffix from default because during build
# there is a compare of config and js/config directories and .orig suffix is
# ignored during this compare.
%patch0 -p1
%patch0 -p1
%patch18 -p2 -b .jemalloc-ppc
%patch19 -p2 -b .s390-inlines
@ -269,11 +266,9 @@ cd %{tarballdir}
%endif
%patch223 -p1 -b .appchooser-crash
%patch300 -p1 -b .1234026
%patch301 -p1 -b .1205199
%patch500 -p1
%patch501 -p1
%{__rm} -f .mozconfig
%{__cp} %{SOURCE10} .mozconfig
@ -771,6 +766,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
* Wed Mar 2 2016 Martin Stransky <stransky@redhat.com> - 45.0-1
- Update to 45.0
* Thu Feb 11 2016 Martin Stransky <stransky@redhat.com> - 44.0.2-3
- Added patch for mozbz#1205199

View File

@ -1,57 +0,0 @@
From 01c739425470990efd607fdf57c9b24033c71300 Mon Sep 17 00:00:00 2001
From: Mike Hommey <mh+mozilla@glandium.org>
Date: Wed, 23 Dec 2015 12:11:45 +0900
Subject: [PATCH] Bug 1234026 - Pass a --display option to gtk_init in content
processes
---
dom/ipc/ContentChild.cpp | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)
diff --git a/dom/ipc/ContentChild.cpp b/dom/ipc/ContentChild.cpp
index 14a7302..cfec4b7 100644
--- a/dom/ipc/ContentChild.cpp
+++ b/dom/ipc/ContentChild.cpp
@@ -615,17 +615,38 @@ NS_INTERFACE_MAP_BEGIN(ContentChild)
NS_INTERFACE_MAP_END
bool
ContentChild::Init(MessageLoop* aIOLoop,
base::ProcessId aParentPid,
IPC::Channel* aChannel)
{
#ifdef MOZ_WIDGET_GTK
- gtk_init(nullptr, nullptr);
+ // We need to pass a display down to gtk_init because it's not going to
+ // use the one from the environment on its own when deciding which backend
+ // to use, and when starting under XWayland, it may choose to start with
+ // the wayland backend instead of the x11 backend.
+ // We could use gdk_display_open, and gdk_display_manager_set_default_display
+ // but then we'd have to hold onto it and gdk_display_close it at the
+ // right moment, so it's simpler to just pass down a fake argv list.
+ // The DISPLAY environment variable is normally set by the parent process.
+ const char *display_name = PR_GetEnv("DISPLAY");
+ if (display_name) {
+ int argc = 3;
+ const char *argv[] = {
+ nullptr,
+ "--display",
+ display_name,
+ nullptr
+ };
+ char** argv_ = const_cast<char**>(argv);
+ gtk_init(&argc, &argv_);
+ } else {
+ gtk_init(nullptr, nullptr);
+ }
#endif
#ifdef MOZ_WIDGET_QT
// sigh, seriously
nsQAppInstance::AddRef();
#endif
#ifdef MOZ_X11
--
2.6.1

View File

@ -1,18 +1,19 @@
diff -up firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi.arm firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi
--- firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi.arm 2015-03-05 11:28:19.000000000 +0100
+++ firefox-36.0.1/mozilla-release/media/webrtc/trunk/webrtc/build/common.gypi 2015-03-09 10:02:17.875243261 +0100
@@ -235,19 +235,6 @@
diff -up firefox-45.0/firefox-45.0/media/webrtc/trunk/webrtc/build/common.gypi.arm firefox-45.0/firefox-45.0/media/webrtc/trunk/webrtc/build/common.gypi
--- firefox-45.0/firefox-45.0/media/webrtc/trunk/webrtc/build/common.gypi.arm 2016-03-02 13:32:46.828341623 +0100
+++ firefox-45.0/firefox-45.0/media/webrtc/trunk/webrtc/build/common.gypi 2016-03-02 13:35:16.658897278 +0100
@@ -312,20 +312,6 @@
'defines': [
'WEBRTC_ARCH_ARM',
],
- 'conditions': [
- ['arm_version==7', {
- ['arm_version>=7', {
- 'defines': ['WEBRTC_ARCH_ARM_V7',
- 'WEBRTC_BUILD_NEON_LIBS'],
- 'conditions': [
- ['arm_neon==1', {
- 'defines': ['WEBRTC_ARCH_ARM_NEON',],
- }, {
- }],
- ['arm_neon==0 and (OS=="android" or moz_widget_toolkit_gonk==1)', {
- 'defines': ['WEBRTC_DETECT_ARM_NEON',],
- }],
- ],

View File

@ -1,2 +1,3 @@
9596accec2ce7031eaab5c33373a1af4 firefox-44.0.2.source.tar.xz
0e99930bf51599caf47c65f123916a4c firefox-langpacks-44.0.2-20160211.tar.xz
ebd548f196e604113c30ea3fb4ccc81e firefox-45.0.source.tar.xz