Enabled PGO, added fix for mozilla#1640982
This commit is contained in:
parent
80b8c3f8c4
commit
291d884885
@ -40,7 +40,7 @@ ExcludeArch: s390x
|
||||
# on other arches.
|
||||
%ifarch x86_64 aarch64
|
||||
%if %{release_build}
|
||||
%global build_with_pgo 0
|
||||
%global build_with_pgo 1
|
||||
%else
|
||||
%global build_with_pgo 0
|
||||
%endif
|
||||
@ -163,6 +163,7 @@ Patch47: fedora-shebang-build.patch
|
||||
Patch48: build-arm-wasm.patch
|
||||
Patch49: build-arm-libaom.patch
|
||||
#Patch50: Bug-1610814-Fix-NEON-compile-error-with-gcc-and-RGB-.patch
|
||||
Patch51: mozilla-1640982.patch
|
||||
|
||||
# Fedora specific patches
|
||||
Patch215: firefox-enable-addons.patch
|
||||
@ -367,6 +368,7 @@ This package contains results of tests executed during build.
|
||||
%patch48 -p1 -b .build-arm-wasm
|
||||
%patch49 -p1 -b .build-arm-libaom
|
||||
#%patch50 -p1 -b .build-arm-SwizzleNEON
|
||||
%patch51 -p1 -b .mozilla-1640982
|
||||
|
||||
# Fedora patches
|
||||
%patch215 -p1 -b .addons
|
||||
|
16
mozilla-1640982.patch
Normal file
16
mozilla-1640982.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
|
||||
--- a/config/makefiles/rust.mk
|
||||
+++ b/config/makefiles/rust.mk
|
||||
@@ -61,7 +61,11 @@
|
||||
# Enable link-time optimization for release builds, but not when linking
|
||||
# gkrust_gtest.
|
||||
ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
|
||||
+# Pass -Clto for older versions of rust, and CARGO_PROFILE_RELEASE_LTO=true
|
||||
+# for newer ones that support it. Combining the latter with -Clto works, so
|
||||
+# set both everywhere.
|
||||
cargo_rustc_flags += -Clto
|
||||
+export CARGO_PROFILE_RELEASE_LTO=true
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user