Added missing patch
This commit is contained in:
parent
360a07539e
commit
258ccb4f88
@ -1,60 +0,0 @@
|
|||||||
# HG changeset patch
|
|
||||||
# User Michael Wu <mwu@mozilla.com>
|
|
||||||
# Parent 4d0e9de89591f6494d80b28a82aa360cf2638ff2
|
|
||||||
Bug 633645 - Add startup cache to omnijar during make package, r= a= try: -b o -p macosx,macosx64 -u all -t none
|
|
||||||
|
|
||||||
|
|
||||||
diff -up firefox-5.0/mozilla-release/browser/installer/Makefile.in.cache firefox-5.0/mozilla-release/browser/installer/Makefile.in
|
|
||||||
--- firefox-5.0/mozilla-release/browser/installer/Makefile.in.cache 2011-06-15 23:57:18.000000000 +0200
|
|
||||||
+++ firefox-5.0/mozilla-release/browser/installer/Makefile.in 2011-06-21 16:28:07.513443952 +0200
|
|
||||||
@@ -117,20 +119,6 @@ ifndef LIBXUL_SDK
|
|
||||||
INSTALL_SDK = 1
|
|
||||||
endif
|
|
||||||
|
|
||||||
-ifneq (1_,$(if $(CROSS_COMPILE),1,0)_$(UNIVERSAL_BINARY))
|
|
||||||
-ifdef RUN_TEST_PROGRAM
|
|
||||||
-_ABS_RUN_TEST_PROGRAM = $(call core_abspath,$(RUN_TEST_PROGRAM))
|
|
||||||
-endif
|
|
||||||
-
|
|
||||||
-GENERATE_CACHE = \
|
|
||||||
- $(_ABS_RUN_TEST_PROGRAM) $(_ABS_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$$PWD" -f $(topsrcdir)/browser/installer/precompile_cache.js -e 'populate_startupcache("omni.jar", "startupCache.zip");' && \
|
|
||||||
- rm -rf jsloader && \
|
|
||||||
- $(UNZIP) startupCache.zip && \
|
|
||||||
- rm startupCache.zip && \
|
|
||||||
- find jsloader | xargs touch -t 201001010000 && \
|
|
||||||
- $(ZIP) -r9mX omni.jar jsloader
|
|
||||||
-endif
|
|
||||||
-
|
|
||||||
include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
|
|
||||||
|
|
||||||
ifeq (bundle, $(MOZ_FS_LAYOUT))
|
|
||||||
diff -up firefox-5.0/mozilla-release/browser/installer/package-manifest.in.cache firefox-5.0/mozilla-release/browser/installer/package-manifest.in
|
|
||||||
--- firefox-5.0/mozilla-release/browser/installer/package-manifest.in.cache 2011-06-15 23:58:10.000000000 +0200
|
|
||||||
+++ firefox-5.0/mozilla-release/browser/installer/package-manifest.in 2011-06-21 16:27:14.003407707 +0200
|
|
||||||
@@ -88,6 +88,7 @@
|
|
||||||
|
|
||||||
[browser]
|
|
||||||
; [Base Browser Files]
|
|
||||||
+@BINPATH@/jsloader/
|
|
||||||
#ifndef XP_UNIX
|
|
||||||
@BINPATH@/@MOZ_APP_NAME@.exe
|
|
||||||
#else
|
|
||||||
diff -up firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk
|
|
||||||
--- firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache 2011-06-15 23:58:10.000000000 +0200
|
|
||||||
+++ firefox-5.0/mozilla-release/toolkit/mozapps/installer/packager.mk 2011-06-21 16:28:29.785042798 +0200
|
|
||||||
@@ -380,7 +380,6 @@ MAKE_SDK = $(CREATE_FINAL_TAR) - $(MOZ_A
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifdef MOZ_OMNIJAR
|
|
||||||
-GENERATE_CACHE ?= true
|
|
||||||
|
|
||||||
OMNIJAR_FILES = \
|
|
||||||
chrome \
|
|
||||||
@@ -409,7 +408,6 @@ PACK_OMNIJAR = \
|
|
||||||
mv components.manifest components && \
|
|
||||||
find . | xargs touch -t 201001010000 && \
|
|
||||||
zip -r9mX omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
|
|
||||||
- $(GENERATE_CACHE) && \
|
|
||||||
$(OPTIMIZE_JARS_CMD) --optimize $(_ABS_DIST)/jarlog/ ./ ./ && \
|
|
||||||
mv binary.manifest components && \
|
|
||||||
printf "manifest components/binary.manifest\n" > chrome.manifest
|
|
53
firefox-6.0-cache-build.patch
Normal file
53
firefox-6.0-cache-build.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
diff -up firefox-6.0/mozilla-release/browser/installer/Makefile.in.cache firefox-6.0/mozilla-release/browser/installer/Makefile.in
|
||||||
|
--- firefox-6.0/mozilla-release/browser/installer/Makefile.in.cache 2011-08-16 15:55:27.000000000 +0200
|
||||||
|
+++ firefox-6.0/mozilla-release/browser/installer/Makefile.in 2011-08-16 15:56:29.854358878 +0200
|
||||||
|
@@ -110,19 +110,6 @@ ifndef LIBXUL_SDK
|
||||||
|
INSTALL_SDK = 1
|
||||||
|
endif
|
||||||
|
|
||||||
|
-ifneq (1_,$(if $(CROSS_COMPILE),1,0)_$(UNIVERSAL_BINARY))
|
||||||
|
-ifdef RUN_TEST_PROGRAM
|
||||||
|
-_ABS_RUN_TEST_PROGRAM = $(call core_abspath,$(RUN_TEST_PROGRAM))
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
-GENERATE_CACHE = \
|
||||||
|
- $(_ABS_RUN_TEST_PROGRAM) $(LIBXUL_DIST)/bin/xpcshell$(BIN_SUFFIX) -g "$$PWD" -a "$$PWD" -f $(topsrcdir)/browser/installer/precompile_cache.js -e 'populate_startupcache("omni.jar", "startupCache.zip");' && \
|
||||||
|
- rm -rf jsloader && \
|
||||||
|
- $(UNZIP) startupCache.zip && \
|
||||||
|
- rm startupCache.zip && \
|
||||||
|
- $(ZIP) -r9m omni.jar jsloader
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
|
||||||
|
|
||||||
|
ifeq (bundle, $(MOZ_FS_LAYOUT))
|
||||||
|
diff -up firefox-6.0/mozilla-release/browser/installer/package-manifest.in.cache firefox-6.0/mozilla-release/browser/installer/package-manifest.in
|
||||||
|
--- firefox-6.0/mozilla-release/browser/installer/package-manifest.in.cache 2011-08-11 23:40:51.000000000 +0200
|
||||||
|
+++ firefox-6.0/mozilla-release/browser/installer/package-manifest.in 2011-08-16 15:55:27.791593231 +0200
|
||||||
|
@@ -86,6 +86,7 @@
|
||||||
|
|
||||||
|
[browser]
|
||||||
|
; [Base Browser Files]
|
||||||
|
+@BINPATH@/jsloader/
|
||||||
|
#ifndef XP_UNIX
|
||||||
|
@BINPATH@/@MOZ_APP_NAME@.exe
|
||||||
|
#else
|
||||||
|
diff -up firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk
|
||||||
|
--- firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk.cache 2011-08-11 23:41:31.000000000 +0200
|
||||||
|
+++ firefox-6.0/mozilla-release/toolkit/mozapps/installer/packager.mk 2011-08-16 15:56:57.869808700 +0200
|
||||||
|
@@ -363,7 +363,6 @@ MAKE_SDK = $(CREATE_FINAL_TAR) - $(MOZ_A
|
||||||
|
endif
|
||||||
|
|
||||||
|
ifdef MOZ_OMNIJAR
|
||||||
|
-GENERATE_CACHE ?= true
|
||||||
|
|
||||||
|
OMNIJAR_FILES = \
|
||||||
|
chrome \
|
||||||
|
@@ -393,7 +392,6 @@ PACK_OMNIJAR = \
|
||||||
|
mv tmp.manifest $$m; \
|
||||||
|
done; \
|
||||||
|
$(ZIP) -r9m omni.jar $(OMNIJAR_FILES) -x $(NON_OMNIJAR_FILES) && \
|
||||||
|
- $(GENERATE_CACHE) && \
|
||||||
|
$(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR) ./ ./ && \
|
||||||
|
mv binary.manifest components && \
|
||||||
|
printf "manifest components/binary.manifest\n" > chrome.manifest
|
Loading…
Reference in New Issue
Block a user