Merge branch 'master' into f26
This commit is contained in:
commit
228321cc8b
4
.gitignore
vendored
4
.gitignore
vendored
@ -288,3 +288,7 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-langpacks-59.0.2-20180327.tar.xz
|
||||
/firefox-60.0b13.source.tar.xz
|
||||
/firefox-langpacks-60.0b13-20180418.tar.xz
|
||||
/firefox-60.0b15.source.tar.xz
|
||||
/firefox-langpacks-60.0b15-20180426.tar.xz
|
||||
/firefox-60.0b16.source.tar.xz
|
||||
/firefox-langpacks-60.0b16-20180427.tar.xz
|
||||
|
19
Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
Normal file
19
Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -up firefox-60.0/mfbt/LinuxSignal.h.mozilla-1238661 firefox-60.0/mfbt/LinuxSignal.h
|
||||
--- firefox-60.0/mfbt/LinuxSignal.h.mozilla-1238661 2018-04-27 08:55:38.848241768 +0200
|
||||
+++ firefox-60.0/mfbt/LinuxSignal.h 2018-04-27 09:06:47.946769859 +0200
|
||||
@@ -25,10 +25,13 @@ SignalTrampoline(int aSignal, siginfo_t*
|
||||
"nop; nop; nop; nop"
|
||||
: : : "memory");
|
||||
|
||||
+ // Because the assembler may generate additional insturctions below, we
|
||||
+ // need to ensure NOPs are inserted first by separating them out above.
|
||||
+
|
||||
asm volatile (
|
||||
- "b %0"
|
||||
+ "bx %0"
|
||||
:
|
||||
- : "X"(H)
|
||||
+ : "r"(H), "l"(aSignal), "l"(aInfo), "l"(aContext)
|
||||
: "memory");
|
||||
}
|
||||
|
21
build-aarch64-skia.patch
Normal file
21
build-aarch64-skia.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -up firefox-60.0/gfx/skia/skia/src/jumper/SkJumper_stages.cpp.aarch64-skia firefox-60.0/gfx/skia/skia/src/jumper/SkJumper_stages.cpp
|
||||
--- firefox-60.0/gfx/skia/skia/src/jumper/SkJumper_stages.cpp.aarch64-skia 2018-04-20 12:07:26.242037226 +0200
|
||||
+++ firefox-60.0/gfx/skia/skia/src/jumper/SkJumper_stages.cpp 2018-04-20 12:12:58.916428432 +0200
|
||||
@@ -666,7 +666,7 @@ SI F approx_powf(F x, F y) {
|
||||
}
|
||||
|
||||
SI F from_half(U16 h) {
|
||||
-#if defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
|
||||
+#if 0 && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
|
||||
return vcvt_f32_f16(h);
|
||||
|
||||
#elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
|
||||
@@ -686,7 +686,7 @@ SI F from_half(U16 h) {
|
||||
}
|
||||
|
||||
SI U16 to_half(F f) {
|
||||
-#if defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
|
||||
+#if 0 && defined(__aarch64__) && !defined(SK_BUILD_FOR_GOOGLE3) // Temporary workaround for some Google3 builds.
|
||||
return vcvt_f16_f32(f);
|
||||
|
||||
#elif defined(JUMPER_IS_HSW) || defined(JUMPER_IS_AVX512)
|
@ -1,7 +1,7 @@
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h 2017-09-29 17:25:04.651876330 +0200
|
||||
@@ -31,7 +31,7 @@
|
||||
diff -up firefox-60.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian firefox-60.0/gfx/skia/skia/include/core/SkColorPriv.h
|
||||
--- firefox-60.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian 2018-04-09 22:50:48.000000000 +0200
|
||||
+++ firefox-60.0/gfx/skia/skia/include/core/SkColorPriv.h 2018-04-18 11:51:38.748680174 +0200
|
||||
@@ -54,18 +54,19 @@ static inline U8CPU SkUnitScalarClampToB
|
||||
*
|
||||
* Here we enforce this constraint.
|
||||
*/
|
||||
@ -10,58 +10,36 @@ diff -up firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian firefo
|
||||
#ifdef SK_CPU_BENDIAN
|
||||
#define SK_RGBA_R32_SHIFT 24
|
||||
#define SK_RGBA_G32_SHIFT 16
|
||||
@@ -43,6 +43,7 @@
|
||||
#define SK_BGRA_R32_SHIFT 8
|
||||
#define SK_BGRA_A32_SHIFT 0
|
||||
#define SK_RGBA_B32_SHIFT 8
|
||||
#define SK_RGBA_A32_SHIFT 0
|
||||
#else
|
||||
+*/
|
||||
#define SK_RGBA_R32_SHIFT 0
|
||||
#define SK_RGBA_G32_SHIFT 8
|
||||
#define SK_RGBA_B32_SHIFT 16
|
||||
@@ -52,7 +53,7 @@
|
||||
#define SK_BGRA_G32_SHIFT 8
|
||||
#define SK_BGRA_R32_SHIFT 16
|
||||
#define SK_BGRA_A32_SHIFT 24
|
||||
#define SK_RGBA_A32_SHIFT 24
|
||||
-#endif
|
||||
+/*#endif*/
|
||||
|
||||
#if defined(SK_PMCOLOR_IS_RGBA) && defined(SK_PMCOLOR_IS_BGRA)
|
||||
#error "can't define PMCOLOR to be RGBA and BGRA"
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h.big-endian firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h 2017-09-29 17:25:04.651876330 +0200
|
||||
@@ -83,7 +83,8 @@ enum SkColorType {
|
||||
#define SkGetPackedA32(packed) ((uint32_t)((packed) << (24 - SK_A32_SHIFT)) >> 24)
|
||||
#define SkGetPackedR32(packed) ((uint32_t)((packed) << (24 - SK_R32_SHIFT)) >> 24)
|
||||
diff -up firefox-60.0/gfx/skia/skia/include/core/SkImageInfo.h.big-endian firefox-60.0/gfx/skia/skia/include/core/SkImageInfo.h
|
||||
--- firefox-60.0/gfx/skia/skia/include/core/SkImageInfo.h.big-endian 2018-04-09 22:50:48.000000000 +0200
|
||||
+++ firefox-60.0/gfx/skia/skia/include/core/SkImageInfo.h 2018-04-18 11:51:38.748680174 +0200
|
||||
@@ -84,7 +84,8 @@ enum SkColorType {
|
||||
#elif SK_PMCOLOR_BYTE_ORDER(R,G,B,A)
|
||||
kN32_SkColorType = kRGBA_8888_SkColorType,
|
||||
#else
|
||||
- #error "SK_*32_SHFIT values must correspond to BGRA or RGBA byte order"
|
||||
+ //#error "SK_*32_SHFIT values must correspond to BGRA or RGBA byte order"
|
||||
- #error "SK_*32_SHIFT values must correspond to BGRA or RGBA byte order"
|
||||
+ //#error "SK_*32_SHIFT values must correspond to BGRA or RGBA byte order"
|
||||
+ kN32_SkColorType = kBGRA_8888_SkColorType
|
||||
#endif
|
||||
};
|
||||
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h.big-endian firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h 2017-09-29 17:25:04.652876327 +0200
|
||||
@@ -74,8 +74,13 @@ static inline GrColor GrColorPackA4(unsi
|
||||
* Since premultiplied means that alpha >= color, we construct a color with
|
||||
* each component==255 and alpha == 0 to be "illegal"
|
||||
*/
|
||||
-#define GrColor_ILLEGAL (~(0xFF << GrColor_SHIFT_A))
|
||||
+//Just for big endian platforms, little has: (~(0xFF << GrColor_SHIFT_A))
|
||||
+#ifdef SK_CPU_BENDIAN
|
||||
+#define GrColor_ILLEGAL 0xFFFFFF00
|
||||
+#else
|
||||
+#define GrColor_ILLEGAL (~(0xFF << GrColor_SHIFT_A))
|
||||
|
||||
+#endif
|
||||
#define GrColor_WHITE 0xFFFFFFFF
|
||||
#define GrColor_TRANSPARENT_BLACK 0x0
|
||||
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h 2017-09-29 17:25:04.652876327 +0200
|
||||
@@ -326,15 +326,13 @@ enum GrPixelConfig {
|
||||
diff -up firefox-60.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian firefox-60.0/gfx/skia/skia/include/gpu/GrTypes.h
|
||||
--- firefox-60.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian 2018-04-09 22:50:48.000000000 +0200
|
||||
+++ firefox-60.0/gfx/skia/skia/include/gpu/GrTypes.h 2018-04-18 11:51:38.748680174 +0200
|
||||
@@ -344,15 +344,13 @@ enum GrPixelConfig {
|
||||
static const int kGrPixelConfigCnt = kLast_GrPixelConfig + 1;
|
||||
|
||||
// Aliases for pixel configs that match skia's byte order.
|
||||
@ -78,4 +56,29 @@ diff -up firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian firefox-56.
|
||||
+ static const GrPixelConfig kSkiaGamma8888_GrPixelConfig = kSBGRA_8888_GrPixelConfig;
|
||||
#endif
|
||||
|
||||
// Returns true if the pixel config is a GPU-specific compressed format
|
||||
/**
|
||||
diff -up firefox-60.0/gfx/skia/skia/src/core/SkColorData.h.big-endian firefox-60.0/gfx/skia/skia/src/core/SkColorData.h
|
||||
--- firefox-60.0/gfx/skia/skia/src/core/SkColorData.h.big-endian 2018-04-18 13:42:06.980476156 +0200
|
||||
+++ firefox-60.0/gfx/skia/skia/src/core/SkColorData.h 2018-04-18 13:42:50.493520552 +0200
|
||||
@@ -31,18 +31,19 @@
|
||||
*
|
||||
* Here we enforce this constraint.
|
||||
*/
|
||||
-
|
||||
+/*
|
||||
#ifdef SK_CPU_BENDIAN
|
||||
#define SK_BGRA_B32_SHIFT 24
|
||||
#define SK_BGRA_G32_SHIFT 16
|
||||
#define SK_BGRA_R32_SHIFT 8
|
||||
#define SK_BGRA_A32_SHIFT 0
|
||||
#else
|
||||
+*/
|
||||
#define SK_BGRA_B32_SHIFT 0
|
||||
#define SK_BGRA_G32_SHIFT 8
|
||||
#define SK_BGRA_R32_SHIFT 16
|
||||
#define SK_BGRA_A32_SHIFT 24
|
||||
-#endif
|
||||
+//#endif
|
||||
|
||||
#if defined(SK_PMCOLOR_IS_RGBA) && defined(SK_PMCOLOR_IS_BGRA)
|
||||
#error "can't define PMCOLOR to be RGBA and BGRA"
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up mozilla-aurora/build/autoconf/icu.m4.icu-endian mozilla-aurora/build/autoconf/icu.m4
|
||||
--- mozilla-aurora/build/autoconf/icu.m4.icu-endian 2016-12-09 09:11:01.227317790 +0100
|
||||
+++ mozilla-aurora/build/autoconf/icu.m4 2016-12-09 09:18:40.608712247 +0100
|
||||
diff -up firefox-60.0/build/autoconf/icu.m4.icu firefox-60.0/build/autoconf/icu.m4
|
||||
--- firefox-60.0/build/autoconf/icu.m4.icu 2018-04-24 13:13:03.938961958 +0200
|
||||
+++ firefox-60.0/build/autoconf/icu.m4 2018-04-24 13:14:44.472714375 +0200
|
||||
@@ -78,7 +78,7 @@ if test -n "$USE_ICU"; then
|
||||
# TODO: the l is actually endian-dependent
|
||||
# We could make this set as 'l' or 'b' for little or big, respectively,
|
||||
@ -8,5 +8,6 @@ diff -up mozilla-aurora/build/autoconf/icu.m4.icu-endian mozilla-aurora/build/au
|
||||
- ICU_DATA_FILE="icudt${version}l.dat"
|
||||
+ ICU_DATA_FILE="icudt${version}b.dat"
|
||||
|
||||
dnl We won't build ICU data as a separate file when building
|
||||
dnl JS standalone so that embedders don't have to deal with it.
|
||||
MOZ_ICU_DATA_ARCHIVE=
|
||||
fi
|
||||
|
||||
|
@ -1,122 +0,0 @@
|
||||
diff --git a/browser/base/moz.build b/browser/base/moz.build
|
||||
--- a/browser/base/moz.build
|
||||
+++ b/browser/base/moz.build
|
||||
@@ -55,15 +55,15 @@ BROWSER_CHROME_MANIFESTS += [
|
||||
DEFINES['MOZ_APP_VERSION'] = CONFIG['MOZ_APP_VERSION']
|
||||
DEFINES['MOZ_APP_VERSION_DISPLAY'] = CONFIG['MOZ_APP_VERSION_DISPLAY']
|
||||
|
||||
DEFINES['APP_LICENSE_BLOCK'] = '%s/content/overrides/app-license.html' % SRCDIR
|
||||
|
||||
if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'gtk3', 'cocoa'):
|
||||
DEFINES['CONTEXT_COPY_IMAGE_CONTENTS'] = 1
|
||||
|
||||
-if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'cocoa', 'gtk3'):
|
||||
+if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'cocoa'):
|
||||
DEFINES['CAN_DRAW_IN_TITLEBAR'] = 1
|
||||
|
||||
if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'gtk3'):
|
||||
DEFINES['MENUBAR_CAN_AUTOHIDE'] = 1
|
||||
|
||||
JAR_MANIFESTS += ['jar.mn']
|
||||
diff --git a/toolkit/modules/moz.build b/toolkit/modules/moz.build
|
||||
--- a/toolkit/modules/moz.build
|
||||
+++ b/toolkit/modules/moz.build
|
||||
@@ -260,17 +260,17 @@ if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'coco
|
||||
|
||||
EXTRA_JS_MODULES.third_party.jsesc += ['third_party/jsesc/jsesc.js']
|
||||
EXTRA_JS_MODULES.sessionstore += [
|
||||
'sessionstore/PrivacyLevel.jsm',
|
||||
'sessionstore/SessionHistory.jsm',
|
||||
'sessionstore/Utils.jsm',
|
||||
]
|
||||
|
||||
-if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'cocoa', 'gtk3'):
|
||||
+if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'cocoa'):
|
||||
DEFINES['CAN_DRAW_IN_TITLEBAR'] = 1
|
||||
|
||||
if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'gtk3'):
|
||||
DEFINES['MENUBAR_CAN_AUTOHIDE'] = 1
|
||||
|
||||
if CONFIG['MOZ_WIDGET_TOOLKIT'] in ('windows', 'gtk3', 'cocoa'):
|
||||
DEFINES['HAVE_SHELL_SERVICE'] = 1
|
||||
|
||||
diff --git a/widget/gtk/nsWindow.cpp b/widget/gtk/nsWindow.cpp
|
||||
--- a/widget/gtk/nsWindow.cpp
|
||||
+++ b/widget/gtk/nsWindow.cpp
|
||||
@@ -6852,72 +6852,19 @@ nsWindow::DoDrawTitlebar() const
|
||||
return mIsCSDEnabled && mSizeState == nsSizeMode_Normal;
|
||||
}
|
||||
|
||||
nsWindow::CSDSupportLevel
|
||||
nsWindow::GetCSDSupportLevel() {
|
||||
if (sCSDSupportLevel != CSD_SUPPORT_UNKNOWN) {
|
||||
return sCSDSupportLevel;
|
||||
}
|
||||
-
|
||||
- const char* currentDesktop = getenv("XDG_CURRENT_DESKTOP");
|
||||
- if (currentDesktop) {
|
||||
- if (strstr(currentDesktop, "GNOME") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FULL;
|
||||
- } else if (strstr(currentDesktop, "XFCE") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strstr(currentDesktop, "X-Cinnamon") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FULL;
|
||||
- } else if (strstr(currentDesktop, "KDE") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strstr(currentDesktop, "LXDE") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strstr(currentDesktop, "openbox") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strstr(currentDesktop, "i3") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_NONE;
|
||||
- } else if (strstr(currentDesktop, "MATE") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strstr(currentDesktop, "Unity") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strstr(currentDesktop, "Pantheon") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FULL;
|
||||
- } else if (strstr(currentDesktop, "LXQt") != nullptr) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FULL;
|
||||
- } else {
|
||||
-// Release or beta builds are not supposed to be broken
|
||||
-// so disable titlebar rendering on untested/unknown systems.
|
||||
-#if defined(RELEASE_OR_BETA)
|
||||
- sCSDSupportLevel = CSD_SUPPORT_NONE;
|
||||
-#else
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
-#endif
|
||||
- }
|
||||
- } else {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_NONE;
|
||||
- }
|
||||
-
|
||||
- // We don't support CSD_SUPPORT_FULL on Wayland
|
||||
- if (!GDK_IS_X11_DISPLAY(gdk_display_get_default()) &&
|
||||
- sCSDSupportLevel == CSD_SUPPORT_FULL) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- }
|
||||
-
|
||||
- // Allow MOZ_GTK_TITLEBAR_DECORATION to override our heuristics
|
||||
- const char* decorationOverride = getenv("MOZ_GTK_TITLEBAR_DECORATION");
|
||||
- if (decorationOverride) {
|
||||
- if (strcmp(decorationOverride, "none") == 0) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_NONE;
|
||||
- } else if (strcmp(decorationOverride, "client") == 0) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FLAT;
|
||||
- } else if (strcmp(decorationOverride, "system") == 0) {
|
||||
- sCSDSupportLevel = CSD_SUPPORT_FULL;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
+
|
||||
+ // Disabled due to Bug 1440461
|
||||
+ sCSDSupportLevel = CSD_SUPPORT_NONE;
|
||||
return sCSDSupportLevel;
|
||||
}
|
||||
|
||||
int32_t
|
||||
nsWindow::RoundsWidgetCoordinatesTo()
|
||||
{
|
||||
return GdkScaleFactor();
|
||||
}
|
||||
|
33
firefox.spec
33
firefox.spec
@ -84,7 +84,7 @@
|
||||
|
||||
%global official_branding 1
|
||||
%global build_langpacks 1
|
||||
%global pre_version b13
|
||||
%global pre_version b16
|
||||
|
||||
%global enable_mozilla_crashreporter 0
|
||||
%if !%{debug_build}
|
||||
@ -96,12 +96,12 @@
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 60.0
|
||||
Release: 0.1%{?pre_tag}%{?dist}
|
||||
Release: 0.2%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://hg.mozilla.org/releases/mozilla-release/archive/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20180418.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20180427.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -132,7 +132,7 @@ Patch35: build-ppc-jit.patch
|
||||
Patch37: build-jit-atomic-always-lucky.patch
|
||||
# Fixing missing cacheFlush when JS_CODEGEN_NONE is used (s390x)
|
||||
Patch38: build-cacheFlush-missing.patch
|
||||
Patch39: mozilla-fix-attr-order.patch
|
||||
Patch40: build-aarch64-skia.patch
|
||||
|
||||
# Fedora specific patches
|
||||
Patch215: firefox-enable-addons.patch
|
||||
@ -142,7 +142,6 @@ Patch224: mozilla-1170092.patch
|
||||
Patch225: mozilla-1005640-accept-lang.patch
|
||||
#ARM run-time patch
|
||||
Patch226: rhbz-1354671.patch
|
||||
Patch230: fedora-enable-csd.patch
|
||||
|
||||
# Upstream patches
|
||||
Patch402: mozilla-1196777.patch
|
||||
@ -152,6 +151,8 @@ Patch410: mozilla-1321521.patch
|
||||
Patch411: mozilla-1321521-2.patch
|
||||
Patch412: mozilla-1337988.patch
|
||||
Patch413: mozilla-1353817.patch
|
||||
Patch414: mozilla-1435212-ffmpeg-4.0.patch
|
||||
Patch415: Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
|
||||
|
||||
# Debian patches
|
||||
Patch500: mozilla-440908.patch
|
||||
@ -295,10 +296,11 @@ This package contains results of tests executed during build.
|
||||
%ifarch s390
|
||||
%patch25 -p1 -b .rhbz-1219542-s390
|
||||
%endif
|
||||
#%patch29 -p1 -b .big-endian
|
||||
%if 0%{?big_endian}
|
||||
%patch29 -p1 -b .big-endian
|
||||
%endif
|
||||
%patch37 -p1 -b .jit-atomic-lucky
|
||||
#%patch39 -p1 -b .fix-attr-order
|
||||
|
||||
%patch40 -p1 -b .aarch64-skia
|
||||
%patch3 -p1 -b .arm
|
||||
|
||||
# Fedora patches
|
||||
@ -311,11 +313,14 @@ This package contains results of tests executed during build.
|
||||
%ifarch aarch64
|
||||
%patch226 -p1 -b .1354671
|
||||
%endif
|
||||
#%patch230 -p1 -R -b .fedora-enable-csd.patch
|
||||
|
||||
%patch402 -p1 -b .1196777
|
||||
%patch406 -p1 -b .256180
|
||||
%patch413 -p1 -b .1353817
|
||||
%patch414 -p1 -b .ffmpeg-4.0
|
||||
%ifarch %{arm}
|
||||
%patch415 -p1 -b .mozilla-1238661
|
||||
%endif
|
||||
|
||||
# Patch for big endian platforms only
|
||||
%if 0%{?big_endian}
|
||||
@ -491,7 +496,7 @@ MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-g/-g1/')
|
||||
# (OOM when linking, rhbz#1238225)
|
||||
export MOZ_DEBUG_FLAGS=" "
|
||||
%endif
|
||||
%ifarch s390 %{arm} ppc aarch64
|
||||
%ifarch s390 %{arm} ppc aarch64 %{ix86}
|
||||
MOZ_LINK_FLAGS="-Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
%endif
|
||||
%ifarch %{arm}
|
||||
@ -831,9 +836,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{mozappdir}/plugin-container
|
||||
%{mozappdir}/gmp-clearkey
|
||||
%{mozappdir}/fonts/EmojiOneMozilla.ttf
|
||||
%if !%{?system_libicu}
|
||||
%{mozappdir}/icudt*.dat
|
||||
%endif
|
||||
%if !%{?system_nss}
|
||||
%{mozappdir}/libfreeblpriv3.chk
|
||||
%{mozappdir}/libnssdbm3.chk
|
||||
@ -844,8 +846,11 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Fri Apr 27 2018 Martin Stransky <stransky@redhat.com> - 60.0-0.2
|
||||
- Update to 60.0 Beta 16
|
||||
|
||||
* Tue Apr 24 2018 Martin Stransky <stransky@redhat.com> - 60.0-0.1
|
||||
- Update to 60.0 Beta 14
|
||||
- Update to 60.0 Beta 15
|
||||
|
||||
* Tue Mar 27 2018 Jan Horak <jhorak@redhat.com> - 59.0.2-1
|
||||
- Update to 59.0.2
|
||||
|
13688
mozilla-1435212-ffmpeg-4.0.patch
Normal file
13688
mozilla-1435212-ffmpeg-4.0.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,28 +0,0 @@
|
||||
diff -up mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/common_audio/vad/vad_core.c.fix-attr-order mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/common_audio/vad/vad_core.c
|
||||
--- mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/common_audio/vad/vad_core.c.fix-attr-order 2018-02-03 11:59:21.173058184 -0500
|
||||
+++ mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/common_audio/vad/vad_core.c 2018-02-03 11:59:44.727509671 -0500
|
||||
@@ -115,8 +115,8 @@ static int32_t WeightedAverage(int16_t*
|
||||
// undefined behavior, so not a good idea; this just makes UBSan ignore the
|
||||
// violation, so that our old code can continue to do what it's always been
|
||||
// doing.)
|
||||
-static inline int32_t OverflowingMulS16ByS32ToS32(int16_t a, int32_t b)
|
||||
- RTC_NO_SANITIZE("signed-integer-overflow") {
|
||||
+RTC_NO_SANITIZE("signed-integer-overflow") static inline int32_t OverflowingMulS16ByS32ToS32(int16_t a, int32_t b)
|
||||
+{
|
||||
return a * b;
|
||||
}
|
||||
|
||||
diff -up mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/modules/audio_coding/codecs/isac/fix/source/lattice.c.fix-attr-order mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/modules/audio_coding/codecs/isac/fix/source/lattice.c
|
||||
--- mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/modules/audio_coding/codecs/isac/fix/source/lattice.c.fix-attr-order 2018-02-03 12:00:01.033129964 -0500
|
||||
+++ mozilla-beta-64737c752ac4af4766ad6f82720818521f3aca24/media/webrtc/trunk/webrtc/modules/audio_coding/codecs/isac/fix/source/lattice.c 2018-02-03 12:00:45.758088456 -0500
|
||||
@@ -209,8 +209,8 @@ void WebRtcIsacfix_NormLatticeFilterMa(s
|
||||
// Left shift of an int32_t that's allowed to overflow. (It's still undefined
|
||||
// behavior, so not a good idea; this just makes UBSan ignore the violation, so
|
||||
// that our old code can continue to do what it's always been doing.)
|
||||
-static inline int32_t OverflowingLShiftS32(int32_t x, int shift)
|
||||
- RTC_NO_SANITIZE("shift") {
|
||||
+RTC_NO_SANITIZE("shift") static inline int32_t OverflowingLShiftS32(int32_t x, int shift)
|
||||
+{
|
||||
return x << shift;
|
||||
}
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (firefox-60.0b13.source.tar.xz) = 687c70f379a5c4991993bf840f87bd6ffafbf6e5fb8c0fe10655048a54c810870c3306a480aa75b18250d29350d4a1ecfbfe867a1173b4c4e5b2e447bf369f82
|
||||
SHA512 (firefox-langpacks-60.0b13-20180418.tar.xz) = dce66d5d3a85208691f801ec8780921154b3fab813f3a51cc02d6fdbc7ef1e18cd87dfc2757dd8b7edc3d505b39bad2c39d6cb7c4a6714b77c291a5fef75618f
|
||||
SHA512 (firefox-60.0b16.source.tar.xz) = 06fb60779e54f11a8e0e3f6c5950808da81cbb723175a58ccfe7d172799319acc2b7cdaaf221c7debea94dca74e1ab3ae1bdb60ee2d90a75a03fdd251855d8f4
|
||||
SHA512 (firefox-langpacks-60.0b16-20180427.tar.xz) = 6e284b5ee5446aeefa945689670719d60b4dcff908e5655c0c9dd8b31bfe7d4ae0724698fc2483addb9b1e1519685183371fe10e3f0b5dcba85a9a43b7f2cd43
|
||||
|
Loading…
Reference in New Issue
Block a user