- Fixed #242657 - firefox -g doesn't work

This commit is contained in:
Martin Stransky 2007-09-26 13:59:13 +00:00
parent 0f0b0db5c0
commit 22615371e7
3 changed files with 20 additions and 2 deletions

View File

@ -0,0 +1,12 @@
diff -up mozilla/browser/app/Makefile.in.old mozilla/browser/app/Makefile.in
--- mozilla/browser/app/Makefile.in.old 2006-08-29 04:03:07.000000000 +0200
+++ mozilla/browser/app/Makefile.in 2007-09-26 15:08:35.000000000 +0200
@@ -238,7 +238,7 @@ libs:: firefox
$(INSTALL) $< $(DIST)/bin
install:: firefox
- $(SYSINSTALL) $< $(DESTDIR)$(bindir)
+ $(SYSINSTALL) $< $(DESTDIR)$(mozappdir)
GARBAGE += firefox
GARBAGE += $(addprefix $(DIST)/bin/defaults/pref/, firefox.js)

View File

@ -60,7 +60,7 @@ if [ ! -x $MOZ_LIB_DIR/firefox-FIREFOX_VERSION/firefox-bin ]; then
fi
MOZ_DIST_BIN="$MOZ_LIB_DIR/firefox-FIREFOX_VERSION"
MOZ_EXTENSIONS_DIR="$MOZ_DIST_BIN/extensions"
MOZ_PROGRAM="$MOZ_DIST_BIN/firefox-bin"
MOZ_PROGRAM="$MOZ_DIST_BIN/firefox"
MOZ_CLIENT_PROGRAM="$MOZ_DIST_BIN/mozilla-xremote-client"
MOZ_CLIENT_PROGRAM_PARAM="-a firefox"

View File

@ -12,7 +12,7 @@
Summary: Mozilla Firefox Web browser.
Name: firefox
Version: 2.0.0.6
Release: 10%{?dist}
Release: 11%{?dist}
URL: http://www.mozilla.org/projects/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
Group: Applications/Internet
@ -67,6 +67,7 @@ Patch105: firefox-2.0-dnd.patch
Patch106: firefox-2.0-indicator-crash.patch
Patch110: firefox-2.0-startup-notify.patch
Patch111: firefox-path.patch
Patch112: firefox-2.0-enable-debug.patch
%if %{official_branding}
# Required by Mozilla Corporation
@ -165,6 +166,7 @@ removed in favor of xulrunner-devel.
%patch106 -p1 -b .indicator-crash
%patch110 -p0 -b .startup-notify
%patch111 -p1 -b .path
%patch112 -p1 -b .debug
# For branding specific patches.
@ -401,6 +403,7 @@ fi
%{mozappdir}/res
%{mozappdir}/searchplugins
%{mozappdir}/*.so
%{mozappdir}/firefox
%{mozappdir}/firefox-bin
%{mozappdir}/firefox-xremote-client
%{mozappdir}/mozilla-xremote-client
@ -431,6 +434,9 @@ fi
#---------------------------------------------------------------------
%changelog
* Mon Sep 26 2007 Martin Stransky <stransky@redhat.com> 2.0.0.6-11
- Fixed #242657 - firefox -g doesn't work
* Mon Sep 25 2007 Martin Stransky <stransky@redhat.com> 2.0.0.6-10
- Removed hardcoded MAX_PATH, PATH_MAX and MAXPATHLEN macros