Updated to 120.0.1
This commit is contained in:
parent
911eba94d0
commit
203cb80595
1
.gitignore
vendored
1
.gitignore
vendored
@ -609,3 +609,4 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-120.0.source.tar.xz
|
||||
/firefox-langpacks-120.0-20231114.tar.xz
|
||||
/firefox-langpacks-120.0-20231120.tar.xz
|
||||
/firefox-120.0.1.source.tar.xz
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff --git a/toolkit/components/resistfingerprinting/nsRFPService.cpp b/toolkit/components/resistfingerprinting/nsRFPService.cpp
|
||||
--- a/toolkit/components/resistfingerprinting/nsRFPService.cpp
|
||||
+++ b/toolkit/components/resistfingerprinting/nsRFPService.cpp
|
||||
@@ -1375,11 +1375,11 @@
|
||||
}
|
||||
#ifdef __clang__
|
||||
# pragma clang diagnostic pop
|
||||
#endif
|
||||
|
||||
- for (uint8_t i = 0; i <= numNoises; i++) {
|
||||
+ while (numNoises--) {
|
||||
// Choose which RGB channel to add a noise. The pixel data is in either
|
||||
// the BGRA or the ARGB format depending on the endianess. To choose the
|
||||
// color channel we need to add the offset according the endianess.
|
||||
uint32_t channel;
|
||||
if (aSurfaceFormat == gfx::SurfaceFormat::B8G8R8A8) {
|
||||
|
13
firefox.spec
13
firefox.spec
@ -168,13 +168,13 @@ ExcludeArch: i686
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 120.0
|
||||
Release: 3%{?pre_tag}%{?dist}
|
||||
Version: 120.0.1
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: https://www.mozilla.org/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Source0: https://archive.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{with langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20231120.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20231201.tar.xz
|
||||
%endif
|
||||
Source2: cbindgen-vendor.tar.xz
|
||||
Source3: dump_syms-vendor.tar.xz
|
||||
@ -249,7 +249,6 @@ Patch402: mozilla-1196777.patch
|
||||
Patch407: mozilla-1667096.patch
|
||||
Patch408: D167159.diff
|
||||
Patch411: mozilla-1762816.patch
|
||||
Patch412: D194727.1701168293.diff
|
||||
|
||||
# PGO/LTO patches
|
||||
Patch600: pgo.patch
|
||||
@ -542,7 +541,6 @@ This package contains results of tests executed during build.
|
||||
%patch407 -p1 -b .1667096
|
||||
%patch408 -p1 -b .D167159
|
||||
%patch411 -p1 -b .mozilla-1762816
|
||||
%patch412 -p1 -b .D194727
|
||||
|
||||
# PGO patches
|
||||
%if %{build_with_pgo}
|
||||
@ -876,7 +874,7 @@ mkdir -p %{buildroot}{%{_libdir},%{_bindir},%{_datadir}/applications}
|
||||
# We can't use desktop-file-install as it refuses to install firefox.desktop file.
|
||||
# We need to change it to org.mozilla.firefox.desktop and also update
|
||||
# gnome shell default applications.
|
||||
#
|
||||
#
|
||||
#desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE20}
|
||||
cp %{SOURCE20} %{buildroot}%{_datadir}/applications
|
||||
desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE31}
|
||||
@ -1151,6 +1149,9 @@ fi
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Fri Dec 01 2023 Martin Stransky <stransky@redhat.com>- 120.0.1-1
|
||||
- Updated to 120.0.1
|
||||
|
||||
* Mon Nov 27 2023 Martin Stransky <stransky@redhat.com>- 120.0-3
|
||||
- Add fix for rhbz#2251202
|
||||
|
||||
|
2
sources
2
sources
@ -1,5 +1,5 @@
|
||||
SHA512 (mochitest-python.tar.gz) = 089b1593068b76f4572af0086eaccf52a6a1299bfffb58593206d19bf021ae381f2380bbfeb4371586cd53706ff6dde3d240238b2caf19b96c57dfc2f4524e36
|
||||
SHA512 (cbindgen-vendor.tar.xz) = 3e7eaff088db918e95f5505e5feeb06e8b7b95cc62042a6d163a708fc76baea43d21bf49cf7e02bc64fdfc61e8d7704057dbb225098de56e110783104d166c54
|
||||
SHA512 (dump_syms-vendor.tar.xz) = 5769c052fa874a965eb8837776b01fb097e8930f45d0d0d2a93997c4fae8726184a192aee52302bde62e62897801b1463cae9283563d9d60e8b8ee80a250f2a3
|
||||
SHA512 (firefox-120.0.source.tar.xz) = 31d5f9e1d4173280c8de6d9b8551bc6bba5e2c49b84f944f50d42002d5b39c2fb743bc130f26c81160388a102b8301b94a0a378ecdfa6f943860f971a860df8c
|
||||
SHA512 (firefox-langpacks-120.0-20231120.tar.xz) = a97c4120e38e8fa2ed6c06957a9f8d29b40e4c4697438cc513e10f9fadbd23aab2e9f6f870ca3f21abe48a62e47e609f99437770ca0c5a562d26c9953b29b881
|
||||
SHA512 (firefox-120.0.1.source.tar.xz) = dd0e3eb234d58c39431d1f100834ef4bcc8cfb89ff471a37b948eda4dd3874b63b1979cda39a0db0dd3b4a579b5f09a7d2d1f39d26fd9f2b8d5635e4b8738b6c
|
||||
|
Loading…
Reference in New Issue
Block a user