Merge branch 'master' into f26
This commit is contained in:
commit
1fe3387a46
@ -1,6 +1,6 @@
|
||||
diff -up firefox-55.0.3/gfx/skia/skia/include/core/SkColorPriv.h.big-endian firefox-55.0.3/gfx/skia/skia/include/core/SkColorPriv.h
|
||||
--- firefox-55.0.3/gfx/skia/skia/include/core/SkColorPriv.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-55.0.3/gfx/skia/skia/include/core/SkColorPriv.h 2017-09-01 15:00:06.186520823 +0200
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/core/SkColorPriv.h 2017-09-29 17:25:04.651876330 +0200
|
||||
@@ -31,7 +31,7 @@
|
||||
*
|
||||
* Here we enforce this constraint.
|
||||
@ -27,9 +27,9 @@ diff -up firefox-55.0.3/gfx/skia/skia/include/core/SkColorPriv.h.big-endian fire
|
||||
|
||||
#if defined(SK_PMCOLOR_IS_RGBA) && defined(SK_PMCOLOR_IS_BGRA)
|
||||
#error "can't define PMCOLOR to be RGBA and BGRA"
|
||||
diff -up firefox-55.0.3/gfx/skia/skia/include/core/SkImageInfo.h.big-endian firefox-55.0.3/gfx/skia/skia/include/core/SkImageInfo.h
|
||||
--- firefox-55.0.3/gfx/skia/skia/include/core/SkImageInfo.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-55.0.3/gfx/skia/skia/include/core/SkImageInfo.h 2017-09-01 15:00:06.186520823 +0200
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h.big-endian firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/core/SkImageInfo.h 2017-09-29 17:25:04.651876330 +0200
|
||||
@@ -83,7 +83,8 @@ enum SkColorType {
|
||||
#elif SK_PMCOLOR_BYTE_ORDER(R,G,B,A)
|
||||
kN32_SkColorType = kRGBA_8888_SkColorType,
|
||||
@ -40,9 +40,9 @@ diff -up firefox-55.0.3/gfx/skia/skia/include/core/SkImageInfo.h.big-endian fire
|
||||
#endif
|
||||
};
|
||||
|
||||
diff -up firefox-55.0.3/gfx/skia/skia/include/gpu/GrColor.h.big-endian firefox-55.0.3/gfx/skia/skia/include/gpu/GrColor.h
|
||||
--- firefox-55.0.3/gfx/skia/skia/include/gpu/GrColor.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-55.0.3/gfx/skia/skia/include/gpu/GrColor.h 2017-09-01 15:00:06.186520823 +0200
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h.big-endian firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/gpu/GrColor.h 2017-09-29 17:25:04.652876327 +0200
|
||||
@@ -74,8 +74,13 @@ static inline GrColor GrColorPackA4(unsi
|
||||
* Since premultiplied means that alpha >= color, we construct a color with
|
||||
* each component==255 and alpha == 0 to be "illegal"
|
||||
@ -58,9 +58,9 @@ diff -up firefox-55.0.3/gfx/skia/skia/include/gpu/GrColor.h.big-endian firefox-5
|
||||
#define GrColor_WHITE 0xFFFFFFFF
|
||||
#define GrColor_TRANSPARENT_BLACK 0x0
|
||||
|
||||
diff -up firefox-55.0.3/gfx/skia/skia/include/gpu/GrTypes.h.big-endian firefox-55.0.3/gfx/skia/skia/include/gpu/GrTypes.h
|
||||
--- firefox-55.0.3/gfx/skia/skia/include/gpu/GrTypes.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-55.0.3/gfx/skia/skia/include/gpu/GrTypes.h 2017-09-01 15:00:06.187520823 +0200
|
||||
diff -up firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h
|
||||
--- firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h.big-endian 2017-07-31 18:20:55.000000000 +0200
|
||||
+++ firefox-56.0/gfx/skia/skia/include/gpu/GrTypes.h 2017-09-29 17:25:04.652876327 +0200
|
||||
@@ -326,15 +326,13 @@ enum GrPixelConfig {
|
||||
static const int kGrPixelConfigCnt = kLast_GrPixelConfig + 1;
|
||||
|
||||
@ -79,35 +79,3 @@ diff -up firefox-55.0.3/gfx/skia/skia/include/gpu/GrTypes.h.big-endian firefox-5
|
||||
#endif
|
||||
|
||||
// Returns true if the pixel config is a GPU-specific compressed format
|
||||
diff -up firefox-55.0.3/js/src/jit/none/MacroAssembler-none.h.big-endian firefox-55.0.3/js/src/jit/none/MacroAssembler-none.h
|
||||
--- firefox-55.0.3/js/src/jit/none/MacroAssembler-none.h.big-endian 2017-07-31 18:20:48.000000000 +0200
|
||||
+++ firefox-55.0.3/js/src/jit/none/MacroAssembler-none.h 2017-09-01 15:03:38.257602029 +0200
|
||||
@@ -48,7 +48,7 @@ static constexpr Register WasmIonExitReg
|
||||
|
||||
static constexpr Register WasmIonExitRegReturnData { Registers::invalid_reg };
|
||||
static constexpr Register WasmIonExitRegReturnType { Registers::invalid_reg };
|
||||
-static constexpr Register WasmIonExitTlsReg = { Registers::invalid_reg };
|
||||
+static constexpr Register WasmIonExitTlsReg { Registers::invalid_reg };
|
||||
static constexpr Register WasmIonExitRegD0 { Registers::invalid_reg };
|
||||
static constexpr Register WasmIonExitRegD1 { Registers::invalid_reg };
|
||||
static constexpr Register WasmIonExitRegD2 { Registers::invalid_reg };
|
||||
@@ -153,6 +153,8 @@ class Assembler : public AssemblerShared
|
||||
|
||||
static uintptr_t GetPointer(uint8_t*) { MOZ_CRASH(); }
|
||||
|
||||
+ static bool HasRoundInstruction(RoundingMode) { return false; }
|
||||
+
|
||||
void verifyHeapAccessDisassembly(uint32_t begin, uint32_t end,
|
||||
const Disassembler::HeapAccess& heapAccess)
|
||||
{
|
||||
@@ -196,9 +198,7 @@ class MacroAssemblerNone : public Assemb
|
||||
static bool SupportsSimd() { return false; }
|
||||
static bool SupportsUnalignedAccesses() { return false; }
|
||||
|
||||
- static bool HasRoundInstruction(RoundingMode) { return false; }
|
||||
-
|
||||
- void executableCopy(void*, bool) { MOZ_CRASH(); }
|
||||
+ void executableCopy(void*, bool flushICache = true) { MOZ_CRASH(); }
|
||||
void copyJumpRelocationTable(uint8_t*) { MOZ_CRASH(); }
|
||||
void copyDataRelocationTable(uint8_t*) { MOZ_CRASH(); }
|
||||
void copyPreBarrierTable(uint8_t*) { MOZ_CRASH(); }
|
||||
|
@ -1,14 +0,0 @@
|
||||
diff -up firefox-55.0/dom/base/nsWrapperCache.h.old firefox-55.0/dom/base/nsWrapperCache.h
|
||||
--- firefox-55.0/dom/base/nsWrapperCache.h.old 2017-08-03 12:02:06.720927791 +0200
|
||||
+++ firefox-55.0/dom/base/nsWrapperCache.h 2017-08-03 12:03:16.576707873 +0200
|
||||
@@ -41,7 +41,7 @@ class nsWindowRoot;
|
||||
// This may waste space for some other nsWrapperCache-derived objects that have
|
||||
// a 32-bit field as their first member, but those objects are unlikely to be as
|
||||
// numerous or performance-critical as DOM nodes.
|
||||
-#if defined(_M_X64) || defined(__x86_64__) || defined(__aarch64__)
|
||||
+#if defined(_M_X64) || defined(__x86_64__) || defined(__aarch64__) || defined(__PPC64__) || defined(__pcc64le__) || defined(__S390X__) || defined(__s390x__)
|
||||
static_assert(sizeof(void*) == 8, "These architectures should be 64-bit");
|
||||
#define BOOL_FLAGS_ON_WRAPPER_CACHE
|
||||
#else
|
||||
diff -up firefox-55.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-55.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
|
||||
diff -up firefox-55.0/media/webrtc/trunk/Makefile.old firefox-55.0/media/webrtc/trunk/Makefile
|
@ -131,7 +131,6 @@ Patch29: build-big-endian.patch
|
||||
Patch30: fedora-build.patch
|
||||
Patch31: build-ppc64-s390x-curl.patch
|
||||
Patch32: build-rust-ppc64le.patch
|
||||
Patch33: build-ppc-s390-dom.patch
|
||||
Patch34: build-cubeb-pulse-arm.patch
|
||||
Patch35: build-ppc-jit.patch
|
||||
Patch36: build-missing-xlocale-h.patch
|
||||
@ -311,11 +310,10 @@ This package contains results of tests executed during build.
|
||||
%ifarch s390
|
||||
%patch25 -p1 -b .rhbz-1219542-s390
|
||||
%endif
|
||||
# don't need that? %patch29 -p1 -b .big-endian
|
||||
%patch29 -p1 -b .big-endian
|
||||
%patch30 -p1 -b .fedora-build
|
||||
%patch31 -p1 -b .ppc64-s390x-curl
|
||||
%patch32 -p1 -b .rust-ppc64le
|
||||
# don't need that %patch33 -p1 -b .ppc-s390-dom
|
||||
# don't need that %patch34 -p1 -b .cubeb-pulse-arm
|
||||
%ifarch ppc ppc64 ppc64le
|
||||
%patch35 -p1 -b .ppc-jit
|
||||
|
Loading…
Reference in New Issue
Block a user