Fixed rhbz#1190774 - update usear agent string for Fedora
This commit is contained in:
parent
c93c372729
commit
1c8e85a305
21
firefox-fedora-ua.patch
Normal file
21
firefox-fedora-ua.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up firefox-35.0.1/mozilla-release/media/webrtc/trunk/Makefile.old firefox-35.0.1/mozilla-release/media/webrtc/trunk/Makefile
|
||||||
|
diff -up firefox-35.0.1/mozilla-release/netwerk/protocol/http/nsHttpHandler.cpp.old firefox-35.0.1/mozilla-release/netwerk/protocol/http/nsHttpHandler.cpp
|
||||||
|
--- firefox-35.0.1/mozilla-release/netwerk/protocol/http/nsHttpHandler.cpp.old 2015-01-23 07:00:06.000000000 +0100
|
||||||
|
+++ firefox-35.0.1/mozilla-release/netwerk/protocol/http/nsHttpHandler.cpp 2015-02-09 16:40:42.983220596 +0100
|
||||||
|
@@ -607,7 +607,7 @@ nsHttpHandler::BuildUserAgent()
|
||||||
|
mUserAgent.SetCapacity(mLegacyAppName.Length() +
|
||||||
|
mLegacyAppVersion.Length() +
|
||||||
|
#ifndef UA_SPARE_PLATFORM
|
||||||
|
- mPlatform.Length() +
|
||||||
|
+ mPlatform.Length() + 8 +
|
||||||
|
#endif
|
||||||
|
mOscpu.Length() +
|
||||||
|
mMisc.Length() +
|
||||||
|
@@ -631,6 +631,7 @@ nsHttpHandler::BuildUserAgent()
|
||||||
|
if (!mPlatform.IsEmpty()) {
|
||||||
|
mUserAgent += mPlatform;
|
||||||
|
mUserAgent.AppendLiteral("; ");
|
||||||
|
+ mUserAgent.AppendLiteral("Fedora; ");
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
if (!mCompatDevice.IsEmpty()) {
|
@ -107,7 +107,7 @@
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 35.0.1
|
Version: 35.0.1
|
||||||
Release: 4%{?pre_tag}%{?dist}
|
Release: 5%{?pre_tag}%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/firefox/
|
URL: http://www.mozilla.org/projects/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
@ -140,6 +140,7 @@ Patch204: rhbz-966424.patch
|
|||||||
Patch215: firefox-enable-addons.patch
|
Patch215: firefox-enable-addons.patch
|
||||||
Patch219: rhbz-1173156.patch
|
Patch219: rhbz-1173156.patch
|
||||||
Patch220: rhbz-1014858.patch
|
Patch220: rhbz-1014858.patch
|
||||||
|
Patch221: firefox-fedora-ua.patch
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
Patch300: mozilla-858919.patch
|
Patch300: mozilla-858919.patch
|
||||||
@ -295,6 +296,7 @@ cd %{tarballdir}
|
|||||||
%patch215 -p1 -b .addons
|
%patch215 -p1 -b .addons
|
||||||
%patch219 -p2 -b .rhbz-1173156
|
%patch219 -p2 -b .rhbz-1173156
|
||||||
%patch220 -p1 -b .rhbz-1014858
|
%patch220 -p1 -b .rhbz-1014858
|
||||||
|
%patch221 -p2 -b .fedora-ua
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
%patch300 -p1 -b .858919
|
%patch300 -p1 -b .858919
|
||||||
@ -764,6 +766,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 9 2015 Martin Stransky <stransky@redhat.com> - 35.0.1-5
|
||||||
|
- Fixed rhbz#1190774 - update usear agent string for Fedora
|
||||||
|
|
||||||
* Wed Feb 04 2015 Petr Machata <pmachata@redhat.com> - 35.0.1-4
|
* Wed Feb 04 2015 Petr Machata <pmachata@redhat.com> - 35.0.1-4
|
||||||
- Bump for rebuild.
|
- Bump for rebuild.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user