Merge branch 'master' into f27
This commit is contained in:
commit
0f11c94e99
13
firefox.spec
13
firefox.spec
@ -308,7 +308,7 @@ Requires: %{name}
|
|||||||
%description wayland
|
%description wayland
|
||||||
The firefox-wayland package contains launcher and desktop file
|
The firefox-wayland package contains launcher and desktop file
|
||||||
to run Firefox natively on Wayland.
|
to run Firefox natively on Wayland.
|
||||||
%files
|
%files wayland
|
||||||
%{_bindir}/firefox-wayland
|
%{_bindir}/firefox-wayland
|
||||||
%{_datadir}/applications/firefox-wayland.desktop
|
%{_datadir}/applications/firefox-wayland.desktop
|
||||||
%endif
|
%endif
|
||||||
@ -387,7 +387,7 @@ This package contains results of tests executed during build.
|
|||||||
%patch452 -p1 -b .mozilla-1460603
|
%patch452 -p1 -b .mozilla-1460603
|
||||||
%patch560 -p1 -b .rb244010
|
%patch560 -p1 -b .rb244010
|
||||||
%patch561 -p1 -b .rb244012
|
%patch561 -p1 -b .rb244012
|
||||||
#%patch562 -p1 -b .rb246410
|
%patch562 -p1 -b .rb246410
|
||||||
%patch563 -p1 -b .rb245262
|
%patch563 -p1 -b .rb245262
|
||||||
%patch564 -p1 -b .mozilla-1464808
|
%patch564 -p1 -b .mozilla-1464808
|
||||||
%patch565 -p1 -b .mozilla-1464823
|
%patch565 -p1 -b .mozilla-1464823
|
||||||
@ -861,9 +861,6 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%{_bindir}/firefox
|
%{_bindir}/firefox
|
||||||
%if %{?wayland_backend}
|
|
||||||
%{_bindir}/firefox-wayland
|
|
||||||
%endif
|
|
||||||
%{mozappdir}/firefox
|
%{mozappdir}/firefox
|
||||||
%{mozappdir}/firefox-bin
|
%{mozappdir}/firefox-bin
|
||||||
%doc %{_mandir}/man1/*
|
%doc %{_mandir}/man1/*
|
||||||
@ -883,8 +880,8 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
# That's Windows only
|
# That's Windows only
|
||||||
%ghost %{mozappdir}/browser/features/aushelper@mozilla.org.xpi
|
%ghost %{mozappdir}/browser/features/aushelper@mozilla.org.xpi
|
||||||
%attr(644, root, root) %{mozappdir}/browser/blocklist.xml
|
%attr(644, root, root) %{mozappdir}/browser/blocklist.xml
|
||||||
%dir %{mozappdir}/browser/extensions
|
#%dir %{mozappdir}/browser/extensions
|
||||||
%{mozappdir}/browser/extensions/*
|
#%{mozappdir}/browser/extensions/*
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
%dir %{langpackdir}
|
%dir %{langpackdir}
|
||||||
%endif
|
%endif
|
||||||
@ -917,7 +914,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
%{mozappdir}/platform.ini
|
%{mozappdir}/platform.ini
|
||||||
%{mozappdir}/plugin-container
|
%{mozappdir}/plugin-container
|
||||||
%{mozappdir}/gmp-clearkey
|
%{mozappdir}/gmp-clearkey
|
||||||
%{mozappdir}/fonts/EmojiOneMozilla.ttf
|
%{mozappdir}/fonts/TwemojiMozilla.ttf
|
||||||
%if !%{?system_nss}
|
%if !%{?system_nss}
|
||||||
%{mozappdir}/libfreeblpriv3.chk
|
%{mozappdir}/libfreeblpriv3.chk
|
||||||
%{mozappdir}/libnssdbm3.chk
|
%{mozappdir}/libnssdbm3.chk
|
||||||
|
@ -31,7 +31,7 @@ diff -up firefox-60.0.1/gfx/gl/GLLibraryEGL.cpp.mozilla-1460603 firefox-60.0.1/g
|
|||||||
+ nativeDisplay = sGdkWaylandDisplayGetWlDisplay(gdkDisplay);
|
+ nativeDisplay = sGdkWaylandDisplayGetWlDisplay(gdkDisplay);
|
||||||
+ if (!nativeDisplay) {
|
+ if (!nativeDisplay) {
|
||||||
+ NS_WARNING("Failed to get wl_display.");
|
+ NS_WARNING("Failed to get wl_display.");
|
||||||
+ return false;
|
+ return nullptr;
|
||||||
+ }
|
+ }
|
||||||
+ }
|
+ }
|
||||||
+#endif
|
+#endif
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up firefox-60.0.1/gfx/gl/GLScreenBuffer.cpp.rb246410 firefox-60.0.1/gfx/gl/GLScreenBuffer.cpp
|
diff -up firefox-61.0/gfx/gl/GLScreenBuffer.cpp.rb246410 firefox-61.0/gfx/gl/GLScreenBuffer.cpp
|
||||||
--- firefox-60.0.1/gfx/gl/GLScreenBuffer.cpp.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/gl/GLScreenBuffer.cpp.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/gl/GLScreenBuffer.cpp 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/gl/GLScreenBuffer.cpp 2018-06-19 12:25:27.612265592 +0200
|
||||||
@@ -29,7 +29,7 @@
|
@@ -29,7 +29,7 @@
|
||||||
#include "SharedSurfaceIO.h"
|
#include "SharedSurfaceIO.h"
|
||||||
#endif
|
#endif
|
||||||
@ -28,9 +28,9 @@ diff -up firefox-60.0.1/gfx/gl/GLScreenBuffer.cpp.rb246410 firefox-60.0.1/gfx/gl
|
|||||||
if (!factory && sGLXLibrary.UseTextureFromPixmap()) {
|
if (!factory && sGLXLibrary.UseTextureFromPixmap()) {
|
||||||
factory = SurfaceFactory_GLXDrawable::Create(gl, caps, ipcChannel, flags);
|
factory = SurfaceFactory_GLXDrawable::Create(gl, caps, ipcChannel, flags);
|
||||||
}
|
}
|
||||||
diff -up firefox-60.0.1/gfx/layers/client/TextureClient.cpp.rb246410 firefox-60.0.1/gfx/layers/client/TextureClient.cpp
|
diff -up firefox-61.0/gfx/layers/client/TextureClient.cpp.rb246410 firefox-61.0/gfx/layers/client/TextureClient.cpp
|
||||||
--- firefox-60.0.1/gfx/layers/client/TextureClient.cpp.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/layers/client/TextureClient.cpp.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/layers/client/TextureClient.cpp 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/layers/client/TextureClient.cpp 2018-06-19 12:25:27.612265592 +0200
|
||||||
@@ -45,10 +45,8 @@
|
@@ -45,10 +45,8 @@
|
||||||
#endif
|
#endif
|
||||||
#ifdef MOZ_X11
|
#ifdef MOZ_X11
|
||||||
@ -42,7 +42,7 @@ diff -up firefox-60.0.1/gfx/layers/client/TextureClient.cpp.rb246410 firefox-60.
|
|||||||
|
|
||||||
#ifdef XP_MACOSX
|
#ifdef XP_MACOSX
|
||||||
#include "mozilla/layers/MacIOSurfaceTextureClientOGL.h"
|
#include "mozilla/layers/MacIOSurfaceTextureClientOGL.h"
|
||||||
@@ -1122,7 +1120,6 @@ TextureClient::CreateForDrawing(TextureF
|
@@ -1127,7 +1125,6 @@ TextureClient::CreateForDrawing(TextureF
|
||||||
{
|
{
|
||||||
data = X11TextureData::Create(aSize, aFormat, aTextureFlags, aAllocator);
|
data = X11TextureData::Create(aSize, aFormat, aTextureFlags, aAllocator);
|
||||||
}
|
}
|
||||||
@ -50,7 +50,7 @@ diff -up firefox-60.0.1/gfx/layers/client/TextureClient.cpp.rb246410 firefox-60.
|
|||||||
if (!data && aLayersBackend == LayersBackend::LAYERS_OPENGL &&
|
if (!data && aLayersBackend == LayersBackend::LAYERS_OPENGL &&
|
||||||
type == gfxSurfaceType::Xlib &&
|
type == gfxSurfaceType::Xlib &&
|
||||||
aFormat != SurfaceFormat::A8 &&
|
aFormat != SurfaceFormat::A8 &&
|
||||||
@@ -1131,7 +1128,6 @@ TextureClient::CreateForDrawing(TextureF
|
@@ -1136,7 +1133,6 @@ TextureClient::CreateForDrawing(TextureF
|
||||||
data = X11TextureData::Create(aSize, aFormat, aTextureFlags, aAllocator);
|
data = X11TextureData::Create(aSize, aFormat, aTextureFlags, aAllocator);
|
||||||
}
|
}
|
||||||
#endif
|
#endif
|
||||||
@ -58,9 +58,9 @@ diff -up firefox-60.0.1/gfx/layers/client/TextureClient.cpp.rb246410 firefox-60.
|
|||||||
|
|
||||||
#ifdef XP_MACOSX
|
#ifdef XP_MACOSX
|
||||||
if (!data && gfxPrefs::UseIOSurfaceTextures()) {
|
if (!data && gfxPrefs::UseIOSurfaceTextures()) {
|
||||||
diff -up firefox-60.0.1/gfx/layers/composite/X11TextureHost.cpp.rb246410 firefox-60.0.1/gfx/layers/composite/X11TextureHost.cpp
|
diff -up firefox-61.0/gfx/layers/composite/X11TextureHost.cpp.rb246410 firefox-61.0/gfx/layers/composite/X11TextureHost.cpp
|
||||||
--- firefox-60.0.1/gfx/layers/composite/X11TextureHost.cpp.rb246410 2018-05-16 07:38:29.000000000 +0200
|
--- firefox-61.0/gfx/layers/composite/X11TextureHost.cpp.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/layers/composite/X11TextureHost.cpp 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/layers/composite/X11TextureHost.cpp 2018-06-19 12:25:27.612265592 +0200
|
||||||
@@ -7,10 +7,8 @@
|
@@ -7,10 +7,8 @@
|
||||||
#include "X11TextureHost.h"
|
#include "X11TextureHost.h"
|
||||||
#include "mozilla/layers/BasicCompositor.h"
|
#include "mozilla/layers/BasicCompositor.h"
|
||||||
@ -97,9 +97,9 @@ diff -up firefox-60.0.1/gfx/layers/composite/X11TextureHost.cpp.rb246410 firefox
|
|||||||
return X11TextureSourceBasic::ContentTypeToSurfaceFormat(type);
|
return X11TextureSourceBasic::ContentTypeToSurfaceFormat(type);
|
||||||
}
|
}
|
||||||
|
|
||||||
diff -up firefox-60.0.1/gfx/layers/ipc/ShadowLayerUtilsX11.cpp.rb246410 firefox-60.0.1/gfx/layers/ipc/ShadowLayerUtilsX11.cpp
|
diff -up firefox-61.0/gfx/layers/ipc/ShadowLayerUtilsX11.cpp.rb246410 firefox-61.0/gfx/layers/ipc/ShadowLayerUtilsX11.cpp
|
||||||
--- firefox-60.0.1/gfx/layers/ipc/ShadowLayerUtilsX11.cpp.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/layers/ipc/ShadowLayerUtilsX11.cpp.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/layers/ipc/ShadowLayerUtilsX11.cpp 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/layers/ipc/ShadowLayerUtilsX11.cpp 2018-06-19 12:25:27.612265592 +0200
|
||||||
@@ -74,11 +74,9 @@ SurfaceDescriptorX11::SurfaceDescriptorX
|
@@ -74,11 +74,9 @@ SurfaceDescriptorX11::SurfaceDescriptorX
|
||||||
mFormat = cairo_xlib_surface_get_visual(aSurf->CairoSurface())->visualid;
|
mFormat = cairo_xlib_surface_get_visual(aSurf->CairoSurface())->visualid;
|
||||||
}
|
}
|
||||||
@ -123,9 +123,9 @@ diff -up firefox-60.0.1/gfx/layers/ipc/ShadowLayerUtilsX11.cpp.rb246410 firefox-
|
|||||||
|
|
||||||
return surf->CairoStatus() ? nullptr : surf.forget();
|
return surf->CairoStatus() ? nullptr : surf.forget();
|
||||||
}
|
}
|
||||||
diff -up firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.cpp.rb246410 firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.cpp
|
diff -up firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.cpp.rb246410 firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.cpp
|
||||||
--- firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.cpp.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.cpp.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.cpp 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.cpp 2018-06-19 12:25:27.613265589 +0200
|
||||||
@@ -4,7 +4,7 @@
|
@@ -4,7 +4,7 @@
|
||||||
* License, v. 2.0. If a copy of the MPL was not distributed with this
|
* License, v. 2.0. If a copy of the MPL was not distributed with this
|
||||||
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */
|
* file, You can obtain one at http://mozilla.org/MPL/2.0/. */
|
||||||
@ -135,9 +135,9 @@ diff -up firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.cpp.rb246410 firef
|
|||||||
|
|
||||||
#include "X11TextureSourceOGL.h"
|
#include "X11TextureSourceOGL.h"
|
||||||
#include "gfxXlibSurface.h"
|
#include "gfxXlibSurface.h"
|
||||||
diff -up firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.h.rb246410 firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.h
|
diff -up firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.h.rb246410 firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.h
|
||||||
--- firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.h.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.h.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.h 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/layers/opengl/X11TextureSourceOGL.h 2018-06-19 12:25:27.613265589 +0200
|
||||||
@@ -7,7 +7,7 @@
|
@@ -7,7 +7,7 @@
|
||||||
#ifndef MOZILLA_GFX_X11TEXTURESOURCEOGL__H
|
#ifndef MOZILLA_GFX_X11TEXTURESOURCEOGL__H
|
||||||
#define MOZILLA_GFX_X11TEXTURESOURCEOGL__H
|
#define MOZILLA_GFX_X11TEXTURESOURCEOGL__H
|
||||||
@ -147,10 +147,10 @@ diff -up firefox-60.0.1/gfx/layers/opengl/X11TextureSourceOGL.h.rb246410 firefox
|
|||||||
|
|
||||||
#include "mozilla/layers/CompositorOGL.h"
|
#include "mozilla/layers/CompositorOGL.h"
|
||||||
#include "mozilla/layers/TextureHostOGL.h"
|
#include "mozilla/layers/TextureHostOGL.h"
|
||||||
diff -up firefox-60.0.1/gfx/thebes/gfxPlatformGtk.cpp.rb246410 firefox-60.0.1/gfx/thebes/gfxPlatformGtk.cpp
|
diff -up firefox-61.0/gfx/thebes/gfxPlatformGtk.cpp.rb246410 firefox-61.0/gfx/thebes/gfxPlatformGtk.cpp
|
||||||
--- firefox-60.0.1/gfx/thebes/gfxPlatformGtk.cpp.rb246410 2018-05-25 11:50:38.250890430 +0200
|
--- firefox-61.0/gfx/thebes/gfxPlatformGtk.cpp.rb246410 2018-06-19 12:25:27.598265633 +0200
|
||||||
+++ firefox-60.0.1/gfx/thebes/gfxPlatformGtk.cpp 2018-05-25 11:52:21.336628487 +0200
|
+++ firefox-61.0/gfx/thebes/gfxPlatformGtk.cpp 2018-06-19 12:26:35.751066530 +0200
|
||||||
@@ -41,11 +41,9 @@
|
@@ -42,11 +42,9 @@
|
||||||
#include "mozilla/Preferences.h"
|
#include "mozilla/Preferences.h"
|
||||||
#include "mozilla/X11Util.h"
|
#include "mozilla/X11Util.h"
|
||||||
|
|
||||||
@ -162,19 +162,19 @@ diff -up firefox-60.0.1/gfx/thebes/gfxPlatformGtk.cpp.rb246410 firefox-60.0.1/gf
|
|||||||
|
|
||||||
/* Undefine the Status from Xlib since it will conflict with system headers on OSX */
|
/* Undefine the Status from Xlib since it will conflict with system headers on OSX */
|
||||||
#if defined(__APPLE__) && defined(Status)
|
#if defined(__APPLE__) && defined(Status)
|
||||||
@@ -528,7 +526,7 @@ gfxPlatformGtk::GetPlatformCMSOutputProf
|
@@ -508,7 +506,7 @@ gfxPlatformGtk::CheckVariationFontSuppor
|
||||||
|
return major * 1000000 + minor * 1000 + patch >= 2007001;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
-#ifdef GL_PROVIDER_GLX
|
-#ifdef GL_PROVIDER_GLX
|
||||||
+#ifdef MOZ_X11
|
+#ifdef MOZ_X11
|
||||||
|
|
||||||
class GLXVsyncSource final : public VsyncSource
|
class GLXVsyncSource final : public VsyncSource
|
||||||
{
|
{
|
||||||
diff -up firefox-60.0.1/gfx/thebes/gfxPlatformGtk.h.rb246410 firefox-60.0.1/gfx/thebes/gfxPlatformGtk.h
|
diff -up firefox-61.0/gfx/thebes/gfxPlatformGtk.h.rb246410 firefox-61.0/gfx/thebes/gfxPlatformGtk.h
|
||||||
--- firefox-60.0.1/gfx/thebes/gfxPlatformGtk.h.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/thebes/gfxPlatformGtk.h.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/thebes/gfxPlatformGtk.h 2018-05-25 11:50:38.260890405 +0200
|
+++ firefox-61.0/gfx/thebes/gfxPlatformGtk.h 2018-06-19 12:25:27.613265589 +0200
|
||||||
@@ -117,7 +117,7 @@ public:
|
@@ -97,7 +97,7 @@ public:
|
||||||
|
|
||||||
bool AccelerateLayersByDefault() override;
|
bool AccelerateLayersByDefault() override;
|
||||||
|
|
||||||
@ -183,9 +183,9 @@ diff -up firefox-60.0.1/gfx/thebes/gfxPlatformGtk.h.rb246410 firefox-60.0.1/gfx/
|
|||||||
already_AddRefed<mozilla::gfx::VsyncSource> CreateHardwareVsyncSource() override;
|
already_AddRefed<mozilla::gfx::VsyncSource> CreateHardwareVsyncSource() override;
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
diff -up firefox-60.0.1/gfx/thebes/gfxXlibSurface.cpp.rb246410 firefox-60.0.1/gfx/thebes/gfxXlibSurface.cpp
|
diff -up firefox-61.0/gfx/thebes/gfxXlibSurface.cpp.rb246410 firefox-61.0/gfx/thebes/gfxXlibSurface.cpp
|
||||||
--- firefox-60.0.1/gfx/thebes/gfxXlibSurface.cpp.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/thebes/gfxXlibSurface.cpp.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/thebes/gfxXlibSurface.cpp 2018-05-25 11:51:59.741683360 +0200
|
+++ firefox-61.0/gfx/thebes/gfxXlibSurface.cpp 2018-06-19 12:25:27.613265589 +0200
|
||||||
@@ -25,9 +25,7 @@ using namespace mozilla::gfx;
|
@@ -25,9 +25,7 @@ using namespace mozilla::gfx;
|
||||||
|
|
||||||
gfxXlibSurface::gfxXlibSurface(Display *dpy, Drawable drawable, Visual *visual)
|
gfxXlibSurface::gfxXlibSurface(Display *dpy, Drawable drawable, Visual *visual)
|
||||||
@ -276,9 +276,9 @@ diff -up firefox-60.0.1/gfx/thebes/gfxXlibSurface.cpp.rb246410 firefox-60.0.1/gf
|
|||||||
GLXPixmap
|
GLXPixmap
|
||||||
gfxXlibSurface::GetGLXPixmap()
|
gfxXlibSurface::GetGLXPixmap()
|
||||||
{
|
{
|
||||||
diff -up firefox-60.0.1/gfx/thebes/gfxXlibSurface.h.rb246410 firefox-60.0.1/gfx/thebes/gfxXlibSurface.h
|
diff -up firefox-61.0/gfx/thebes/gfxXlibSurface.h.rb246410 firefox-61.0/gfx/thebes/gfxXlibSurface.h
|
||||||
--- firefox-60.0.1/gfx/thebes/gfxXlibSurface.h.rb246410 2018-05-16 07:38:30.000000000 +0200
|
--- firefox-61.0/gfx/thebes/gfxXlibSurface.h.rb246410 2018-06-19 01:03:35.000000000 +0200
|
||||||
+++ firefox-60.0.1/gfx/thebes/gfxXlibSurface.h 2018-05-25 11:50:38.261890402 +0200
|
+++ firefox-61.0/gfx/thebes/gfxXlibSurface.h 2018-06-19 12:25:27.613265589 +0200
|
||||||
@@ -12,9 +12,7 @@
|
@@ -12,9 +12,7 @@
|
||||||
#include <X11/Xlib.h>
|
#include <X11/Xlib.h>
|
||||||
#include "X11UndefineNone.h"
|
#include "X11UndefineNone.h"
|
||||||
|
Loading…
Reference in New Issue
Block a user