Killing some more dead patches
This commit is contained in:
parent
51f90aa18a
commit
0f0b0db5c0
@ -1,74 +0,0 @@
|
||||
Index: modules/libpr0n/src/imgLoader.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/modules/libpr0n/src/imgLoader.cpp,v
|
||||
retrieving revision 1.78.2.2
|
||||
diff -d -u -p -r1.78.2.2 imgLoader.cpp
|
||||
--- modules/libpr0n/src/imgLoader.cpp 16 Aug 2004 18:06:37 -0000 1.78.2.2
|
||||
+++ modules/libpr0n/src/imgLoader.cpp 15 Jul 2005 04:31:06 -0000
|
||||
@@ -896,7 +896,7 @@ void imgCacheValidator::AddProxy(imgRequ
|
||||
// the network.
|
||||
aProxy->AddToLoadGroup();
|
||||
|
||||
- mProxies.AppendElement(aProxy);
|
||||
+ mProxies.AppendObject(aProxy);
|
||||
}
|
||||
|
||||
/** nsIRequestObserver methods **/
|
||||
@@ -909,13 +909,10 @@ NS_IMETHODIMP imgCacheValidator::OnStart
|
||||
PRBool isFromCache;
|
||||
if (NS_SUCCEEDED(cacheChan->IsFromCache(&isFromCache)) && isFromCache) {
|
||||
|
||||
- PRUint32 count;
|
||||
- mProxies.Count(&count);
|
||||
+ PRUint32 count = mProxies.Count();
|
||||
for (PRInt32 i = count-1; i>=0; i--) {
|
||||
- imgRequestProxy *proxy;
|
||||
- mProxies.GetElementAt(i, (nsISupports**)&proxy);
|
||||
+ imgRequestProxy *proxy = NS_STATIC_CAST(imgRequestProxy *, mProxies[i]);
|
||||
mRequest->NotifyProxyListener(proxy);
|
||||
- NS_RELEASE(proxy);
|
||||
}
|
||||
|
||||
mRequest->SetLoadId(mContext);
|
||||
@@ -964,14 +961,11 @@ NS_IMETHODIMP imgCacheValidator::OnStart
|
||||
|
||||
mDestListener = NS_STATIC_CAST(nsIStreamListener*, pl);
|
||||
|
||||
- PRUint32 count;
|
||||
- mProxies.Count(&count);
|
||||
+ PRUint32 count = mProxies.Count();
|
||||
for (PRInt32 i = count-1; i>=0; i--) {
|
||||
- imgRequestProxy *proxy;
|
||||
- mProxies.GetElementAt(i, (nsISupports**)&proxy);
|
||||
+ imgRequestProxy *proxy = NS_STATIC_CAST(imgRequestProxy *, mProxies[i]);
|
||||
proxy->ChangeOwner(request);
|
||||
request->NotifyProxyListener(proxy);
|
||||
- NS_RELEASE(proxy);
|
||||
}
|
||||
|
||||
NS_RELEASE(request);
|
||||
Index: modules/libpr0n/src/imgLoader.h
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/modules/libpr0n/src/imgLoader.h,v
|
||||
retrieving revision 1.10.38.1
|
||||
diff -d -u -p -r1.10.38.1 imgLoader.h
|
||||
--- modules/libpr0n/src/imgLoader.h 16 Aug 2004 18:06:37 -0000 1.10.38.1
|
||||
+++ modules/libpr0n/src/imgLoader.h 15 Jul 2005 04:31:06 -0000
|
||||
@@ -90,7 +90,7 @@ private:
|
||||
* validate checker
|
||||
*/
|
||||
|
||||
-#include "nsSupportsArray.h"
|
||||
+#include "nsCOMArray.h"
|
||||
|
||||
class imgCacheValidator : public nsIStreamListener
|
||||
{
|
||||
@@ -109,7 +109,7 @@ private:
|
||||
nsCOMPtr<nsIStreamListener> mDestListener;
|
||||
|
||||
imgRequest *mRequest;
|
||||
- nsSupportsArray mProxies;
|
||||
+ nsCOMArray<imgIRequest> mProxies;
|
||||
|
||||
void *mContext;
|
||||
};
|
@ -1,23 +0,0 @@
|
||||
Index: browser/locales/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/browser/locales/Makefile.in,v
|
||||
retrieving revision 1.1.2.24
|
||||
diff -d -u -p -r1.1.2.24 Makefile.in
|
||||
--- browser/locales/Makefile.in 22 Oct 2004 16:47:44 -0000 1.1.2.24
|
||||
+++ browser/locales/Makefile.in 24 May 2005 17:37:59 -0000
|
||||
@@ -97,6 +97,7 @@ install:: $(addprefix $(AB_CD)/profile/,
|
||||
install:: $(addprefix $(AB_CD)/profile/chrome/,$(PROFILE_CHROME))
|
||||
$(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(mozappdir)/defaults/profile/chrome
|
||||
|
||||
+ifeq ($(AB_CD),en-US)
|
||||
SEARCH_PLUGINS = $(shell cat $(srcdir)/$(AB_CD)/searchplugins/list.txt)
|
||||
SEARCH_PLUGIN_PREFIX = $(addprefix $(srcdir)/$(AB_CD)/searchplugins/,$(SEARCH_PLUGINS))
|
||||
|
||||
@@ -105,6 +106,7 @@ libs realchrome:: $(addsuffix .src,$(SEA
|
||||
|
||||
install:: $(addsuffix .src,$(SEARCH_PLUGIN_PREFIX)) $(foreach base,$(SEARCH_PLUGIN_PREFIX),$(wildcard $(base).gif)$(wildcard $(base).png))
|
||||
$(SYSINSTALL) $(IFLAGS1) $^ $(DESTDIR)$(mozappdir)/searchplugins
|
||||
+endif
|
||||
|
||||
# Let's imagine we wanted to create a language JARfile without registering it
|
||||
# the following targets only work with JARed chrome: flat chrome is not supported
|
@ -1,25 +0,0 @@
|
||||
? nsprpub/config/system_wrappers
|
||||
Index: nsprpub/config/nspr-config.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/nsprpub/config/nspr-config.in,v
|
||||
retrieving revision 1.2.2.2
|
||||
diff -d -u -p -r1.2.2.2 nspr-config.in
|
||||
--- nsprpub/config/nspr-config.in 28 Feb 2003 01:52:53 -0000 1.2.2.2
|
||||
+++ nsprpub/config/nspr-config.in 4 Apr 2005 21:33:29 -0000
|
||||
@@ -3,6 +3,7 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
exec_prefix_set=no
|
||||
+libdir=@libdir@
|
||||
|
||||
major_version=@MOD_MAJOR_VERSION@
|
||||
minor_version=@MOD_MINOR_VERSION@
|
||||
@@ -95,7 +96,7 @@ if test "$echo_cflags" = "yes"; then
|
||||
fi
|
||||
|
||||
if test "$echo_libs" = "yes"; then
|
||||
- libdirs=-L${exec_prefix}/lib
|
||||
+ libdirs=-L${libdir}
|
||||
if test -n "$lib_plds"; then
|
||||
libdirs="$libdirs -lplds${major_version}"
|
||||
fi
|
@ -1,150 +0,0 @@
|
||||
Index: nsprpub/pr/include/md/_linux.cfg
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/nsprpub/pr/include/md/_linux.cfg,v
|
||||
retrieving revision 3.12.4.5
|
||||
diff -u -r3.12.4.5 _linux.cfg
|
||||
--- nsprpub/pr/include/md/_linux.cfg 9 Mar 2004 03:18:20 -0000 3.12.4.5
|
||||
+++ nsprpub/pr/include/md/_linux.cfg 19 Nov 2004 01:36:07 -0000
|
||||
@@ -505,95 +505,95 @@
|
||||
#define PR_BYTES_PER_WORD_LOG2 2
|
||||
#define PR_BYTES_PER_DWORD_LOG2 3
|
||||
|
||||
-#elif defined(__s390__)
|
||||
+#elif defined(__s390x__)
|
||||
|
||||
#define IS_BIG_ENDIAN 1
|
||||
#undef IS_LITTLE_ENDIAN
|
||||
+#define IS_64
|
||||
|
||||
#define PR_BYTES_PER_BYTE 1
|
||||
#define PR_BYTES_PER_SHORT 2
|
||||
#define PR_BYTES_PER_INT 4
|
||||
#define PR_BYTES_PER_INT64 8
|
||||
-#define PR_BYTES_PER_LONG 4
|
||||
+#define PR_BYTES_PER_LONG 8
|
||||
#define PR_BYTES_PER_FLOAT 4
|
||||
#define PR_BYTES_PER_DOUBLE 8
|
||||
-#define PR_BYTES_PER_WORD 4
|
||||
+#define PR_BYTES_PER_WORD 8
|
||||
#define PR_BYTES_PER_DWORD 8
|
||||
|
||||
#define PR_BITS_PER_BYTE 8
|
||||
#define PR_BITS_PER_SHORT 16
|
||||
#define PR_BITS_PER_INT 32
|
||||
#define PR_BITS_PER_INT64 64
|
||||
-#define PR_BITS_PER_LONG 32
|
||||
+#define PR_BITS_PER_LONG 64
|
||||
#define PR_BITS_PER_FLOAT 32
|
||||
#define PR_BITS_PER_DOUBLE 64
|
||||
-#define PR_BITS_PER_WORD 32
|
||||
+#define PR_BITS_PER_WORD 64
|
||||
|
||||
#define PR_BITS_PER_BYTE_LOG2 3
|
||||
#define PR_BITS_PER_SHORT_LOG2 4
|
||||
#define PR_BITS_PER_INT_LOG2 5
|
||||
#define PR_BITS_PER_INT64_LOG2 6
|
||||
-#define PR_BITS_PER_LONG_LOG2 5
|
||||
+#define PR_BITS_PER_LONG_LOG2 6
|
||||
#define PR_BITS_PER_FLOAT_LOG2 5
|
||||
#define PR_BITS_PER_DOUBLE_LOG2 6
|
||||
-#define PR_BITS_PER_WORD_LOG2 5
|
||||
+#define PR_BITS_PER_WORD_LOG2 6
|
||||
|
||||
#define PR_ALIGN_OF_SHORT 2
|
||||
#define PR_ALIGN_OF_INT 4
|
||||
-#define PR_ALIGN_OF_LONG 4
|
||||
-#define PR_ALIGN_OF_INT64 4
|
||||
+#define PR_ALIGN_OF_LONG 8
|
||||
+#define PR_ALIGN_OF_INT64 8
|
||||
#define PR_ALIGN_OF_FLOAT 4
|
||||
-#define PR_ALIGN_OF_DOUBLE 4
|
||||
-#define PR_ALIGN_OF_POINTER 4
|
||||
-#define PR_ALIGN_OF_WORD 4
|
||||
+#define PR_ALIGN_OF_DOUBLE 8
|
||||
+#define PR_ALIGN_OF_POINTER 8
|
||||
+#define PR_ALIGN_OF_WORD 8
|
||||
|
||||
-#define PR_BYTES_PER_WORD_LOG2 2
|
||||
+#define PR_BYTES_PER_WORD_LOG2 3
|
||||
#define PR_BYTES_PER_DWORD_LOG2 3
|
||||
|
||||
-#elif defined(__s390x__)
|
||||
+#elif defined(__s390__)
|
||||
|
||||
#define IS_BIG_ENDIAN 1
|
||||
#undef IS_LITTLE_ENDIAN
|
||||
-#define IS_64
|
||||
|
||||
#define PR_BYTES_PER_BYTE 1
|
||||
#define PR_BYTES_PER_SHORT 2
|
||||
#define PR_BYTES_PER_INT 4
|
||||
#define PR_BYTES_PER_INT64 8
|
||||
-#define PR_BYTES_PER_LONG 8
|
||||
+#define PR_BYTES_PER_LONG 4
|
||||
#define PR_BYTES_PER_FLOAT 4
|
||||
#define PR_BYTES_PER_DOUBLE 8
|
||||
-#define PR_BYTES_PER_WORD 8
|
||||
+#define PR_BYTES_PER_WORD 4
|
||||
#define PR_BYTES_PER_DWORD 8
|
||||
|
||||
#define PR_BITS_PER_BYTE 8
|
||||
#define PR_BITS_PER_SHORT 16
|
||||
#define PR_BITS_PER_INT 32
|
||||
#define PR_BITS_PER_INT64 64
|
||||
-#define PR_BITS_PER_LONG 64
|
||||
+#define PR_BITS_PER_LONG 32
|
||||
#define PR_BITS_PER_FLOAT 32
|
||||
#define PR_BITS_PER_DOUBLE 64
|
||||
-#define PR_BITS_PER_WORD 64
|
||||
+#define PR_BITS_PER_WORD 32
|
||||
|
||||
#define PR_BITS_PER_BYTE_LOG2 3
|
||||
#define PR_BITS_PER_SHORT_LOG2 4
|
||||
#define PR_BITS_PER_INT_LOG2 5
|
||||
#define PR_BITS_PER_INT64_LOG2 6
|
||||
-#define PR_BITS_PER_LONG_LOG2 6
|
||||
+#define PR_BITS_PER_LONG_LOG2 5
|
||||
#define PR_BITS_PER_FLOAT_LOG2 5
|
||||
#define PR_BITS_PER_DOUBLE_LOG2 6
|
||||
-#define PR_BITS_PER_WORD_LOG2 6
|
||||
+#define PR_BITS_PER_WORD_LOG2 5
|
||||
|
||||
#define PR_ALIGN_OF_SHORT 2
|
||||
#define PR_ALIGN_OF_INT 4
|
||||
-#define PR_ALIGN_OF_LONG 8
|
||||
-#define PR_ALIGN_OF_INT64 8
|
||||
+#define PR_ALIGN_OF_LONG 4
|
||||
+#define PR_ALIGN_OF_INT64 4
|
||||
#define PR_ALIGN_OF_FLOAT 4
|
||||
-#define PR_ALIGN_OF_DOUBLE 8
|
||||
-#define PR_ALIGN_OF_POINTER 8
|
||||
-#define PR_ALIGN_OF_WORD 8
|
||||
+#define PR_ALIGN_OF_DOUBLE 4
|
||||
+#define PR_ALIGN_OF_POINTER 4
|
||||
+#define PR_ALIGN_OF_WORD 4
|
||||
|
||||
-#define PR_BYTES_PER_WORD_LOG2 3
|
||||
+#define PR_BYTES_PER_WORD_LOG2 2
|
||||
#define PR_BYTES_PER_DWORD_LOG2 3
|
||||
|
||||
#else
|
||||
Index: nsprpub/pr/include/md/_linux.h
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/nsprpub/pr/include/md/_linux.h,v
|
||||
retrieving revision 3.34.2.8
|
||||
diff -u -r3.34.2.8 _linux.h
|
||||
--- nsprpub/pr/include/md/_linux.h 9 Mar 2004 03:18:20 -0000 3.34.2.8
|
||||
+++ nsprpub/pr/include/md/_linux.h 19 Nov 2004 01:36:07 -0000
|
||||
@@ -63,10 +63,10 @@
|
||||
#define _PR_SI_ARCHITECTURE "arm"
|
||||
#elif defined(__hppa__)
|
||||
#define _PR_SI_ARCHITECTURE "hppa"
|
||||
-#elif defined(__s390__)
|
||||
-#define _PR_SI_ARCHITECTURE "s390"
|
||||
#elif defined(__s390x__)
|
||||
#define _PR_SI_ARCHITECTURE "s390x"
|
||||
+#elif defined(__s390__)
|
||||
+#define _PR_SI_ARCHITECTURE "s390"
|
||||
#else
|
||||
#error "Unknown CPU architecture"
|
||||
#endif
|
@ -1,123 +0,0 @@
|
||||
Index: mozilla/security/coreconf/location.mk
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/coreconf/location.mk,v
|
||||
retrieving revision 1.9
|
||||
diff -u -r1.9 location.mk
|
||||
--- mozilla/security/coreconf/location.mk 25 Apr 2004 15:02:17 -0000 1.9
|
||||
+++ mozilla/security/coreconf/location.mk 11 Apr 2005 20:21:57 -0000
|
||||
@@ -61,6 +61,8 @@
|
||||
|
||||
DIST = $(SOURCE_PREFIX)/$(PLATFORM)
|
||||
|
||||
+NSPR_LIBDIR = $(DIST)/lib
|
||||
+
|
||||
ifdef BUILD_DEBUG_GC
|
||||
DEFINES += -DDEBUG_GC
|
||||
endif
|
||||
Index: mozilla/security/manager/Makefile.in
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/manager/Makefile.in,v
|
||||
retrieving revision 1.56
|
||||
diff -u -r1.56 Makefile.in
|
||||
--- mozilla/security/manager/Makefile.in 14 Mar 2005 10:00:58 -0000 1.56
|
||||
+++ mozilla/security/manager/Makefile.in 11 Apr 2005 20:21:57 -0000
|
||||
@@ -76,11 +76,22 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
+ABS_DIST := $(shell cd $(DIST) && pwd)
|
||||
+ifeq ($(OS_ARCH),WINNT)
|
||||
+ABS_DIST := $(shell cygpath -w $(ABS_DIST) | sed -e 's|\\\\|/|g')
|
||||
+endif
|
||||
+NSPR_LIBDIR = $(firstword $(filter -L%,$(NSPR_LIBS)))
|
||||
+ifneq (,$(strip $(NSPR_LIBDIR)))
|
||||
+NSPR_LIBDIR := $(subst -L,,$(subst -L$(DIST),-L$(ABS_DIST),$(NSPR_LIBDIR)))
|
||||
+else
|
||||
+NSPR_LIBDIR = $(ABS_DIST)/lib
|
||||
+endif
|
||||
# NSS makefiles are not safe for parallel execution.
|
||||
DEFAULT_GMAKE_FLAGS = MAKE="$(MAKE) -j1" -j1
|
||||
-DEFAULT_GMAKE_FLAGS += MOZILLA_INCLUDES="-I$(MOZ_BUILD_ROOT)/dist/include/nspr -I$(MOZ_BUILD_ROOT)/dist/include/dbm"
|
||||
-DEFAULT_GMAKE_FLAGS += SOURCE_MD_DIR=$(MOZ_BUILD_ROOT)/dist
|
||||
-DEFAULT_GMAKE_FLAGS += DIST=$(MOZ_BUILD_ROOT)/dist
|
||||
+DEFAULT_GMAKE_FLAGS += MOZILLA_INCLUDES="$(subst -I$(DIST),-I$(ABS_DIST),$(NSPR_CFLAGS) -I$(DIST)/include/dbm)"
|
||||
+DEFAULT_GMAKE_FLAGS += SOURCE_MD_DIR=$(ABS_DIST)
|
||||
+DEFAULT_GMAKE_FLAGS += DIST=$(ABS_DIST)
|
||||
+DEFAULT_GMAKE_FLAGS += NSPR_LIBDIR=$(NSPR_LIBDIR)
|
||||
DEFAULT_GMAKE_FLAGS += MOZILLA_CLIENT=1
|
||||
DEFAULT_GMAKE_FLAGS += NO_MDUPDATE=1
|
||||
ABS_topsrcdir := $(shell cd $(topsrcdir); pwd)
|
||||
Index: mozilla/security/nss/lib/ckfw/builtins/Makefile
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/nss/lib/ckfw/builtins/Makefile,v
|
||||
retrieving revision 1.14
|
||||
diff -u -r1.14 Makefile
|
||||
--- mozilla/security/nss/lib/ckfw/builtins/Makefile 20 Jan 2005 02:25:46 -0000 1.14
|
||||
+++ mozilla/security/nss/lib/ckfw/builtins/Makefile 11 Apr 2005 20:21:57 -0000
|
||||
@@ -53,23 +53,23 @@
|
||||
# This is merely an expedient hack and not the right solution.
|
||||
ifdef NS_USE_GCC
|
||||
EXTRA_LIBS += \
|
||||
- -L$(DIST)/lib \
|
||||
+ -L$(NSPR_LIBDIR) \
|
||||
-lplc4 \
|
||||
-lplds4 \
|
||||
-lnspr4 \
|
||||
$(NULL)
|
||||
else
|
||||
EXTRA_LIBS += \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
$(NULL)
|
||||
endif
|
||||
|
||||
else
|
||||
|
||||
EXTRA_LIBS += \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
$(NULL)
|
||||
|
||||
endif
|
||||
Index: mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile,v
|
||||
retrieving revision 1.18
|
||||
diff -u -r1.18 Makefile
|
||||
--- mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile 25 Apr 2004 15:03:08 -0000 1.18
|
||||
+++ mozilla/security/nss/lib/fortcrypt/swfort/pkcs11/Makefile 11 Apr 2005 20:21:57 -0000
|
||||
@@ -63,7 +63,7 @@
|
||||
$(DIST)/lib/$(LIB_PREFIX)softokn.$(LIB_SUFFIX) \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
|
||||
- -L$(DIST)/lib \
|
||||
+ -L$(NSPR_LIBDIR) \
|
||||
-lplc4 \
|
||||
-lplds4 \
|
||||
-lnspr4 \
|
||||
@@ -76,8 +76,8 @@
|
||||
$(DIST)/lib/softokn.lib \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/secutil.lib \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
- $(DIST)/lib/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plc4_s.lib \
|
||||
+ $(NSPR_LIBDIR)/$(NSPR31_LIB_PREFIX)plds4_s.lib \
|
||||
wsock32.lib \
|
||||
winmm.lib \
|
||||
$(NULL)
|
||||
@@ -98,8 +98,8 @@
|
||||
$(DIST)/lib/$(LIB_PREFIX)softokn.$(LIB_SUFFIX) \
|
||||
$(CRYPTO_LIB) \
|
||||
$(DIST)/lib/$(LIB_PREFIX)secutil.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
- $(DIST)/lib/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plc4.$(LIB_SUFFIX) \
|
||||
+ $(NSPR_LIBDIR)/$(LIB_PREFIX)plds4.$(LIB_SUFFIX) \
|
||||
$(NULL)
|
||||
|
||||
endif
|
@ -1,10 +0,0 @@
|
||||
Index: mozilla/modules/libpref/src/init/all.js
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/modules/libpref/src/init/all.js,v
|
||||
retrieving revision 3.515.2.3.2.23
|
||||
diff -d -u -p -0 -r3.515.2.3.2.23 all.js
|
||||
--- mozilla/modules/libpref/src/init/all.js 4 Nov 2004 23:39:57 -0000 3.515.2.3.2.23
|
||||
+++ mozilla/modules/libpref/src/init/all.js 4 Dec 2004 07:00:57 -0000
|
||||
@@ -70 +70 @@ pref("browser.display.use_document_color
|
||||
-pref("browser.display.use_system_colors", false);
|
||||
+pref("browser.display.use_system_colors", true);
|
@ -1,107 +0,0 @@
|
||||
diff -ur mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in mozilla-xx/xpcom/reflect/xptcall/src/md/unix/Makefile.in
|
||||
--- mozilla/xpcom/reflect/xptcall/src/md/unix/Makefile.in 2004-04-22 22:50:05.000000000 +0200
|
||||
+++ mozilla-xx/xpcom/reflect/xptcall/src/md/unix/Makefile.in 2004-12-03 11:19:41.560694658 +0100
|
||||
@@ -341,10 +341,12 @@
|
||||
#
|
||||
ifeq ($(OS_ARCH)$(OS_TEST),Linuxs390)
|
||||
CPPSRCS := xptcinvoke_linux_s390.cpp xptcstubs_linux_s390.cpp
|
||||
+CXXFLAGS += -fno-strict-aliasing -fno-inline -fomit-frame-pointer -mbackchain
|
||||
endif
|
||||
|
||||
ifeq ($(OS_ARCH)$(OS_TEST),Linuxs390x)
|
||||
CPPSRCS := xptcinvoke_linux_s390x.cpp xptcstubs_linux_s390x.cpp
|
||||
+CXXFLAGS += -fno-strict-aliasing -fno-inline -fomit-frame-pointer -mbackchain
|
||||
endif
|
||||
|
||||
|
||||
diff -ur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp
|
||||
--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp 2004-12-03 12:18:27.110694658 +0100
|
||||
+++ mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp 2004-12-03 12:27:05.100694658 +0100
|
||||
@@ -184,8 +184,6 @@
|
||||
}
|
||||
}
|
||||
|
||||
-volatile register void* r14 asm("r14");
|
||||
-
|
||||
XPTC_PUBLIC_API(nsresult)
|
||||
XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
|
||||
PRUint32 paramCount, nsXPTCVariant* params)
|
||||
@@ -199,8 +197,6 @@
|
||||
PRUint32 overflow = invoke_count_words (paramCount, params);
|
||||
PRUint32 result;
|
||||
|
||||
- volatile void* sav_r14 = r14;
|
||||
-
|
||||
__asm__ __volatile__
|
||||
(
|
||||
"lr 7,15\n\t"
|
||||
@@ -235,10 +231,8 @@
|
||||
"a" (invoke_copy_to_stack),
|
||||
"a" (that),
|
||||
"a" (method)
|
||||
- : "2", "3", "4", "5", "6", "7", "memory"
|
||||
+ : "2", "3", "4", "5", "6", "7", "14", "cc", "memory", "%f0", "%f2"
|
||||
);
|
||||
-
|
||||
- r14 = sav_r14;
|
||||
|
||||
return result;
|
||||
}
|
||||
diff -ur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp
|
||||
--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp 2004-12-03 12:18:27.110694658 +0100
|
||||
+++ mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp 2004-12-03 12:26:44.500694658 +0100
|
||||
@@ -178,8 +178,6 @@
|
||||
}
|
||||
}
|
||||
|
||||
-volatile register void* r14 asm("r14");
|
||||
-
|
||||
XPTC_PUBLIC_API(nsresult)
|
||||
XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
|
||||
PRUint32 paramCount, nsXPTCVariant* params)
|
||||
@@ -193,8 +191,6 @@
|
||||
PRUint64 overflow = invoke_count_words (paramCount, params);
|
||||
PRUint64 result;
|
||||
|
||||
- volatile void* sav_r14 = r14;
|
||||
-
|
||||
__asm__ __volatile__
|
||||
(
|
||||
"lgr 7,15\n\t"
|
||||
@@ -231,10 +227,9 @@
|
||||
"a" (invoke_copy_to_stack),
|
||||
"a" (that),
|
||||
"a" (method)
|
||||
- : "2", "3", "4", "5", "6", "7", "memory"
|
||||
+ : "2", "3", "4", "5", "6", "7", "14", "cc", "memory",
|
||||
+ "%f0", "%f1", "%f2", "%f3", "%f4", "%f5", "%f6", "%f7"
|
||||
);
|
||||
-
|
||||
- r14 = sav_r14;
|
||||
|
||||
return result;
|
||||
}
|
||||
diff -ur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp
|
||||
--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp 2004-12-03 12:18:27.110694658 +0100
|
||||
+++ mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp 2004-12-03 11:16:55.400694658 +0100
|
||||
@@ -177,7 +177,7 @@
|
||||
\
|
||||
__asm__ __volatile__ \
|
||||
( \
|
||||
- "lr %0,15\n\t" \
|
||||
+ "l %0,0(15)\n\t" \
|
||||
"ahi %0,96\n\t" \
|
||||
"stm 3,6,0(%3)\n\t" \
|
||||
"std 0,%1\n\t" \
|
||||
diff -ur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp
|
||||
--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp 2004-12-03 12:18:27.110694658 +0100
|
||||
+++ mozilla-xx/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp 2004-12-03 11:17:16.360694658 +0100
|
||||
@@ -177,7 +177,7 @@
|
||||
\
|
||||
__asm__ __volatile__ \
|
||||
( \
|
||||
- "lgr %0,15\n\t" \
|
||||
+ "lg %0,0(15)\n\t" \
|
||||
"aghi %0,160\n\t" \
|
||||
"stmg 3,6,0(%5)\n\t"\
|
||||
"std 0,%1\n\t" \
|
@ -1,26 +0,0 @@
|
||||
Index: security/coreconf/Linux.mk
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/security/coreconf/Linux.mk,v
|
||||
retrieving revision 1.18
|
||||
diff -d -u -p -r1.18 Linux.mk
|
||||
--- security/coreconf/Linux.mk 1 Feb 2005 23:39:18 -0000 1.18
|
||||
+++ security/coreconf/Linux.mk 20 Jun 2005 07:32:29 -0000
|
||||
@@ -56,6 +56,10 @@ ifeq ($(OS_TEST),m68k)
|
||||
OS_REL_CFLAGS = -DLINUX1_2 -D_XOPEN_SOURCE
|
||||
CPU_ARCH = m68k
|
||||
else
|
||||
+ifeq ($(OS_TEST),ppc64)
|
||||
+ OS_REL_CFLAGS = -DLINUX1_2 -D_XOPEN_SOURCE
|
||||
+ CPU_ARCH = ppc64
|
||||
+else
|
||||
ifeq ($(OS_TEST),ppc)
|
||||
OS_REL_CFLAGS = -DLINUX1_2 -D_XOPEN_SOURCE
|
||||
CPU_ARCH = ppc
|
||||
@@ -119,6 +123,7 @@ endif
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
+endif
|
||||
|
||||
|
||||
LIBC_TAG = _glibc
|
@ -1,28 +0,0 @@
|
||||
Index: mozilla/xpcom/threads/nsThread.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/xpcom/threads/nsThread.cpp,v
|
||||
retrieving revision 1.58.4.2
|
||||
diff -u -r1.58.4.2 nsThread.cpp
|
||||
--- mozilla/xpcom/threads/nsThread.cpp 1 Oct 2005 18:43:00 -0000 1.58.4.2
|
||||
+++ mozilla/xpcom/threads/nsThread.cpp 7 May 2007 19:10:58 -0000
|
||||
@@ -470,9 +470,17 @@
|
||||
nsThread::Shutdown()
|
||||
{
|
||||
if (gMainThread) {
|
||||
- // XXX nspr doesn't seem to be calling the main thread's destructor
|
||||
- // callback, so let's help it out:
|
||||
- nsThread::Exit(NS_STATIC_CAST(nsThread*, gMainThread));
|
||||
+ // In most recent versions of NSPR the main thread's destructor
|
||||
+ // callback will get called.
|
||||
+ // In older versions of NSPR it will not get called,
|
||||
+ // (unless we call PR_Cleanup).
|
||||
+ // Because of that we:
|
||||
+ // - call the function ourselves
|
||||
+ // - set the data pointer to NULL to ensure the function will
|
||||
+ // not get called again by NSPR
|
||||
+ // The PR_SetThreadPrivate call does both of these.
|
||||
+ // See also bugs 379550, 362768.
|
||||
+ PR_SetThreadPrivate(kIThreadSelfIndex, NULL);
|
||||
nsrefcnt cnt;
|
||||
NS_RELEASE2(gMainThread, cnt);
|
||||
NS_WARN_IF_FALSE(cnt == 0, "Main thread being held past XPCOM shutdown.");
|
@ -1,100 +0,0 @@
|
||||
Index: xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp,v
|
||||
retrieving revision 1.1
|
||||
diff -u -p -r1.1 xptcinvoke_linux_s390.cpp
|
||||
--- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp 27 Jan 2003 21:52:51 -0000 1.1
|
||||
+++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390.cpp 14 Oct 2004 09:14:05 -0000
|
||||
@@ -184,6 +184,8 @@ invoke_copy_to_stack(PRUint32 paramCount
|
||||
}
|
||||
}
|
||||
|
||||
+volatile register void* r14 asm("r14");
|
||||
+
|
||||
XPTC_PUBLIC_API(nsresult)
|
||||
XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
|
||||
PRUint32 paramCount, nsXPTCVariant* params)
|
||||
@@ -197,6 +199,8 @@ XPTC_InvokeByIndex(nsISupports* that, PR
|
||||
PRUint32 overflow = invoke_count_words (paramCount, params);
|
||||
PRUint32 result;
|
||||
|
||||
+ volatile void* sav_r14 = r14;
|
||||
+
|
||||
__asm__ __volatile__
|
||||
(
|
||||
"lr 7,15\n\t"
|
||||
@@ -233,6 +237,8 @@ XPTC_InvokeByIndex(nsISupports* that, PR
|
||||
"a" (method)
|
||||
: "2", "3", "4", "5", "6", "7", "memory"
|
||||
);
|
||||
+
|
||||
+ r14 = sav_r14;
|
||||
|
||||
return result;
|
||||
}
|
||||
Index: xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp,v
|
||||
retrieving revision 1.1
|
||||
diff -u -p -r1.1 xptcinvoke_linux_s390x.cpp
|
||||
--- xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp 27 Jan 2003 21:52:51 -0000 1.1
|
||||
+++ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_linux_s390x.cpp 14 Oct 2004 09:14:12 -0000
|
||||
@@ -178,6 +178,8 @@ invoke_copy_to_stack(PRUint32 paramCount
|
||||
}
|
||||
}
|
||||
|
||||
+volatile register void* r14 asm("r14");
|
||||
+
|
||||
XPTC_PUBLIC_API(nsresult)
|
||||
XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,
|
||||
PRUint32 paramCount, nsXPTCVariant* params)
|
||||
@@ -191,6 +193,8 @@ XPTC_InvokeByIndex(nsISupports* that, PR
|
||||
PRUint64 overflow = invoke_count_words (paramCount, params);
|
||||
PRUint64 result;
|
||||
|
||||
+ volatile void* sav_r14 = r14;
|
||||
+
|
||||
__asm__ __volatile__
|
||||
(
|
||||
"lgr 7,15\n\t"
|
||||
@@ -229,6 +233,8 @@ XPTC_InvokeByIndex(nsISupports* that, PR
|
||||
"a" (method)
|
||||
: "2", "3", "4", "5", "6", "7", "memory"
|
||||
);
|
||||
+
|
||||
+ r14 = sav_r14;
|
||||
|
||||
return result;
|
||||
}
|
||||
Index: xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp,v
|
||||
retrieving revision 1.1
|
||||
diff -u -p -r1.1 xptcstubs_linux_s390.cpp
|
||||
--- xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp 27 Jan 2003 21:52:52 -0000 1.1
|
||||
+++ xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390.cpp 14 Oct 2004 09:14:22 -0000
|
||||
@@ -177,7 +177,7 @@ nsresult nsXPTCStubBase::Stub##n() \
|
||||
\
|
||||
__asm__ __volatile__ \
|
||||
( \
|
||||
- "l %0,0(15)\n\t" \
|
||||
+ "lr %0,15\n\t" \
|
||||
"ahi %0,96\n\t" \
|
||||
"stm 3,6,0(%3)\n\t" \
|
||||
"std 0,%1\n\t" \
|
||||
Index: xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp
|
||||
===================================================================
|
||||
RCS file: /cvsroot/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp,v
|
||||
retrieving revision 1.1
|
||||
diff -u -p -r1.1 xptcstubs_linux_s390x.cpp
|
||||
--- xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp 27 Jan 2003 21:52:52 -0000 1.1
|
||||
+++ xpcom/reflect/xptcall/src/md/unix/xptcstubs_linux_s390x.cpp 14 Oct 2004 09:14:26 -0000
|
||||
@@ -177,7 +177,7 @@ nsresult nsXPTCStubBase::Stub##n() \
|
||||
\
|
||||
__asm__ __volatile__ \
|
||||
( \
|
||||
- "lg %0,0(15)\n\t" \
|
||||
+ "lgr %0,15\n\t" \
|
||||
"aghi %0,160\n\t" \
|
||||
"stmg 3,6,0(%5)\n\t"\
|
||||
"std 0,%1\n\t" \
|
Loading…
Reference in New Issue
Block a user