Merge branch 'master' into f30
This commit is contained in:
commit
034097e83e
16
firefox-SIOCGSTAMP.patch
Normal file
16
firefox-SIOCGSTAMP.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up firefox-68.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium.old firefox-68.0/media/libyuv/libyuv/tools_libyuv/autoroller/unittests/testdata/DEPS.chromium
|
||||||
|
diff -up firefox-68.0/media/webrtc/trunk/Makefile.old firefox-68.0/media/webrtc/trunk/Makefile
|
||||||
|
diff -up firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc.old firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc
|
||||||
|
--- firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc.old 2019-07-10 20:10:04.420328534 +0200
|
||||||
|
+++ firefox-68.0/media/webrtc/trunk/webrtc/rtc_base/physicalsocketserver.cc 2019-07-10 20:13:48.766658793 +0200
|
||||||
|
@@ -62,6 +62,10 @@ typedef void* SockOptArg;
|
||||||
|
|
||||||
|
#if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(WEBRTC_BSD) && !defined(__native_client__)
|
||||||
|
|
||||||
|
+#ifndef SIOCGSTAMP
|
||||||
|
+#define SIOCGSTAMP 0x8906 /* Get stamp (timeval) */
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
int64_t GetSocketRecvTimestamp(int socket) {
|
||||||
|
struct timeval tv_ioctl;
|
||||||
|
int ret = ioctl(socket, SIOCGSTAMP, &tv_ioctl);
|
@ -135,6 +135,7 @@ Patch224: mozilla-1170092.patch
|
|||||||
#ARM run-time patch
|
#ARM run-time patch
|
||||||
Patch226: rhbz-1354671.patch
|
Patch226: rhbz-1354671.patch
|
||||||
Patch227: firefox-locale-debug.patch
|
Patch227: firefox-locale-debug.patch
|
||||||
|
Patch228: firefox-SIOCGSTAMP.patch
|
||||||
|
|
||||||
# Upstream patches
|
# Upstream patches
|
||||||
Patch402: mozilla-1196777.patch
|
Patch402: mozilla-1196777.patch
|
||||||
@ -334,6 +335,7 @@ This package contains results of tests executed during build.
|
|||||||
%patch226 -p1 -b .1354671
|
%patch226 -p1 -b .1354671
|
||||||
%endif
|
%endif
|
||||||
%patch227 -p1 -b .locale-debug
|
%patch227 -p1 -b .locale-debug
|
||||||
|
%patch228 -p1 -b .SIOCGSTAMP
|
||||||
|
|
||||||
%patch402 -p1 -b .1196777
|
%patch402 -p1 -b .1196777
|
||||||
#%patch413 -p1 -b .1353817
|
#%patch413 -p1 -b .1353817
|
||||||
|
Loading…
Reference in New Issue
Block a user