Update to 43.0
This commit is contained in:
parent
e86e7ae58c
commit
028e614ec7
2
.gitignore
vendored
2
.gitignore
vendored
@ -167,3 +167,5 @@ firefox-3.6.4.source.tar.bz2
|
||||
/firefox-42.0.source.tar.xz
|
||||
/firefox-langpacks-42.0-20151029.tar.xz
|
||||
/firefox-langpacks-42.0-20151030.tar.xz
|
||||
/firefox-43.0.source.tar.xz
|
||||
/firefox-langpacks-43.0-20151210.tar.xz
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -up mozilla-release/browser/app/profile/firefox.js.addons mozilla-release/browser/app/profile/firefox.js
|
||||
--- mozilla-release/browser/app/profile/firefox.js.addons 2015-08-06 12:57:11.459795815 +0200
|
||||
+++ mozilla-release/browser/app/profile/firefox.js 2015-08-06 13:01:55.045869605 +0200
|
||||
@@ -69,7 +69,8 @@ pref("extensions.hotfix.certs.2.sha1Fing
|
||||
diff -up firefox-43.0/firefox-43.0/browser/app/profile/firefox.js.addons firefox-43.0/firefox-43.0/browser/app/profile/firefox.js
|
||||
--- firefox-43.0/browser/app/profile/firefox.js.addons 2015-12-10 10:18:32.942990945 +0100
|
||||
+++ firefox-43.0/browser/app/profile/firefox.js 2015-12-10 10:22:36.435169388 +0100
|
||||
@@ -71,7 +71,8 @@ pref("extensions.hotfix.certs.2.sha1Fing
|
||||
|
||||
// Disable add-ons that are not installed by the user in all scopes by default.
|
||||
// See the SCOPE constants in AddonManager.jsm for values to use here.
|
||||
@ -9,12 +9,12 @@ diff -up mozilla-release/browser/app/profile/firefox.js.addons mozilla-release/b
|
||||
+pref("extensions.autoDisableScopes", 0);
|
||||
+pref("extensions.showMismatchUI", false);
|
||||
|
||||
// Don't require signed add-ons by default
|
||||
pref("xpinstall.signatures.required", false);
|
||||
diff -up mozilla-release/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons mozilla-release/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
--- mozilla-release/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons 2015-08-04 22:24:47.000000000 +0200
|
||||
+++ mozilla-release/toolkit/mozapps/extensions/internal/XPIProvider.jsm 2015-08-06 12:57:11.461795823 +0200
|
||||
@@ -2293,11 +2293,7 @@ this.XPIProvider = {
|
||||
// Require signed add-ons by default
|
||||
pref("xpinstall.signatures.required", true);
|
||||
diff -up firefox-43.0/firefox-43.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons firefox-43.0/firefox-43.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm
|
||||
--- firefox-43.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm.addons 2015-12-08 19:06:45.000000000 +0100
|
||||
+++ firefox-43.0/toolkit/mozapps/extensions/internal/XPIProvider.jsm 2015-12-10 10:18:32.944990955 +0100
|
||||
@@ -2523,11 +2523,7 @@ this.XPIProvider = {
|
||||
|
||||
AddonManagerPrivate.markProviderSafe(this);
|
||||
|
||||
@ -27,7 +27,7 @@ diff -up mozilla-release/toolkit/mozapps/extensions/internal/XPIProvider.jsm.add
|
||||
Preferences.get(PREF_EM_SHOW_MISMATCH_UI, true)) {
|
||||
if (!Preferences.get(PREF_SHOWN_SELECTION_UI, false)) {
|
||||
// Flip a flag to indicate that we interrupted startup with an interactive prompt
|
||||
@@ -2317,6 +2313,9 @@ this.XPIProvider = {
|
||||
@@ -2547,6 +2543,9 @@ this.XPIProvider = {
|
||||
flushCaches = true;
|
||||
}
|
||||
}
|
||||
|
19
firefox.spec
19
firefox.spec
@ -85,14 +85,14 @@
|
||||
|
||||
Summary: Mozilla Firefox Web browser
|
||||
Name: firefox
|
||||
Version: 42.0
|
||||
Release: 5%{?pre_tag}%{?dist}
|
||||
Version: 43.0
|
||||
Release: 1%{?pre_tag}%{?dist}
|
||||
URL: http://www.mozilla.org/projects/firefox/
|
||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||
Group: Applications/Internet
|
||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.xz
|
||||
%if %{build_langpacks}
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20151030.tar.xz
|
||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20151210.tar.xz
|
||||
%endif
|
||||
Source10: firefox-mozconfig
|
||||
Source12: firefox-redhat-default-prefs.js
|
||||
@ -104,7 +104,7 @@ Source25: firefox-symbolic.svg
|
||||
|
||||
#Build patches
|
||||
Patch0: firefox-install-dir.patch
|
||||
Patch1: firefox-build.patch
|
||||
#Patch1: firefox-build.patch
|
||||
Patch3: mozilla-build-arm.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
|
||||
Patch18: xulrunner-24.0-jemalloc-ppc.patch
|
||||
@ -126,7 +126,6 @@ Patch221: firefox-fedora-ua.patch
|
||||
# Upstream patches
|
||||
|
||||
# Gtk3 upstream patches
|
||||
Patch425: mozilla-1192243.patch
|
||||
|
||||
# Fix Skia Neon stuff on AArch64
|
||||
Patch500: aarch64-fix-skia.patch
|
||||
@ -242,7 +241,7 @@ cd %{tarballdir}
|
||||
# there is a compare of config and js/config directories and .orig suffix is
|
||||
# ignored during this compare.
|
||||
%patch0 -p1
|
||||
%patch1 -p2 -b .build
|
||||
#%patch1 -p2 -b .build
|
||||
|
||||
%patch18 -p2 -b .jemalloc-ppc
|
||||
%patch19 -p2 -b .s390-inlines
|
||||
@ -264,11 +263,6 @@ cd %{tarballdir}
|
||||
#%patch220 -p1 -b .rhbz-1014858
|
||||
%patch221 -p2 -b .fedora-ua
|
||||
|
||||
# Upstream patches
|
||||
%if %{toolkit_gtk3}
|
||||
%patch425 -p1 -b .1192243
|
||||
%endif
|
||||
|
||||
%patch500 -p1
|
||||
|
||||
%{__rm} -f .mozconfig
|
||||
@ -762,6 +756,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
%changelog
|
||||
* Thu Dec 10 2015 Martin Stransky <stransky@redhat.com> - 43.0-1
|
||||
- Update to 43.0
|
||||
|
||||
* Mon Dec 7 2015 Martin Stransky <stransky@redhat.com> - 42.0-5
|
||||
- Removed nspluginwrapper support (rhbz#1289053)
|
||||
|
||||
|
@ -1,115 +0,0 @@
|
||||
# HG changeset patch
|
||||
# Parent 8cba870a352ca71b53cebee7688847756eb3f5f7
|
||||
# User Petr Jasicek <pjasicek@redhat.com>
|
||||
Bug 1192243 - Fix Gtk3 crash reporter's ScrolledWindow and width. r=karlt
|
||||
|
||||
diff --git a/toolkit/crashreporter/client/crashreporter_linux.cpp b/toolkit/crashreporter/client/crashreporter_linux.cpp
|
||||
--- a/toolkit/crashreporter/client/crashreporter_linux.cpp
|
||||
+++ b/toolkit/crashreporter/client/crashreporter_linux.cpp
|
||||
@@ -9,16 +9,18 @@
|
||||
#include <gtk/gtk.h>
|
||||
#include <string.h>
|
||||
|
||||
#include <cctype>
|
||||
|
||||
#include "crashreporter.h"
|
||||
#include "crashreporter_gtk_common.h"
|
||||
|
||||
+#define LABEL_MAX_CHAR_WIDTH 48
|
||||
+
|
||||
using std::string;
|
||||
using std::vector;
|
||||
|
||||
using namespace CrashReporter;
|
||||
|
||||
static GtkWidget* gViewReportButton = 0;
|
||||
static GtkWidget* gCommentTextLabel = 0;
|
||||
static GtkWidget* gCommentText = 0;
|
||||
@@ -178,19 +180,22 @@ static void ViewReportClicked(GtkButton*
|
||||
GTK_DIALOG_MODAL,
|
||||
GTK_STOCK_OK,
|
||||
GTK_RESPONSE_OK,
|
||||
nullptr));
|
||||
|
||||
GtkWidget* scrolled = gtk_scrolled_window_new(0, 0);
|
||||
gtk_container_add(GTK_CONTAINER(gtk_dialog_get_content_area(dialog)), scrolled);
|
||||
gtk_scrolled_window_set_policy(GTK_SCROLLED_WINDOW(scrolled),
|
||||
- GTK_POLICY_NEVER, GTK_POLICY_ALWAYS);
|
||||
+ GTK_POLICY_AUTOMATIC, GTK_POLICY_ALWAYS);
|
||||
gtk_scrolled_window_set_shadow_type(GTK_SCROLLED_WINDOW(scrolled),
|
||||
GTK_SHADOW_IN);
|
||||
+#if (MOZ_WIDGET_GTK >= 3)
|
||||
+ gtk_widget_set_vexpand(scrolled, TRUE);
|
||||
+#endif
|
||||
|
||||
GtkWidget* viewReportTextView = gtk_text_view_new();
|
||||
gtk_container_add(GTK_CONTAINER(scrolled), viewReportTextView);
|
||||
gtk_text_view_set_editable(GTK_TEXT_VIEW(viewReportTextView), FALSE);
|
||||
gtk_text_view_set_wrap_mode(GTK_TEXT_VIEW(viewReportTextView),
|
||||
GTK_WRAP_WORD);
|
||||
gtk_widget_set_size_request(GTK_WIDGET(viewReportTextView), -1, 100);
|
||||
|
||||
@@ -407,17 +412,21 @@ bool UIShowCrashUI(const StringTable& fi
|
||||
gStrings[ST_CRASHREPORTERHEADER].c_str());
|
||||
gtk_label_set_markup(GTK_LABEL(titleLabel), markup);
|
||||
g_free(markup);
|
||||
|
||||
GtkWidget* descriptionLabel =
|
||||
gtk_label_new(gStrings[ST_CRASHREPORTERDESCRIPTION].c_str());
|
||||
gtk_box_pack_start(GTK_BOX(vbox), descriptionLabel, TRUE, TRUE, 0);
|
||||
// force the label to line wrap
|
||||
+#if (MOZ_WIDGET_GTK == 2)
|
||||
gtk_widget_set_size_request(descriptionLabel, 400, -1);
|
||||
+#else
|
||||
+ gtk_label_set_max_width_chars(GTK_LABEL(descriptionLabel), LABEL_MAX_CHAR_WIDTH);
|
||||
+#endif
|
||||
gtk_label_set_line_wrap(GTK_LABEL(descriptionLabel), TRUE);
|
||||
gtk_label_set_selectable(GTK_LABEL(descriptionLabel), TRUE);
|
||||
gtk_misc_set_alignment(GTK_MISC(descriptionLabel), 0, 0.5);
|
||||
|
||||
// this is honestly how they suggest you indent a section
|
||||
GtkWidget* indentBox = gtk_hbox_new(FALSE, 0);
|
||||
gtk_box_pack_start(GTK_BOX(vbox), indentBox, FALSE, FALSE, 0);
|
||||
gtk_box_pack_start(GTK_BOX(indentBox), gtk_label_new(""), FALSE, FALSE, 6);
|
||||
@@ -451,16 +460,19 @@ bool UIShowCrashUI(const StringTable& fi
|
||||
g_signal_connect(gViewReportButton, "clicked", G_CALLBACK(ViewReportClicked), 0);
|
||||
|
||||
GtkWidget* scrolled = gtk_scrolled_window_new(0, 0);
|
||||
gtk_container_add(GTK_CONTAINER(innerVBox), scrolled);
|
||||
gtk_scrolled_window_set_policy(GTK_SCROLLED_WINDOW(scrolled),
|
||||
GTK_POLICY_NEVER, GTK_POLICY_ALWAYS);
|
||||
gtk_scrolled_window_set_shadow_type(GTK_SCROLLED_WINDOW(scrolled),
|
||||
GTK_SHADOW_IN);
|
||||
+#if (MOZ_WIDGET_GTK >= 3)
|
||||
+ gtk_scrolled_window_set_min_content_height(GTK_SCROLLED_WINDOW(scrolled), 100);
|
||||
+#endif
|
||||
|
||||
gCommentTextLabel = gtk_label_new(gStrings[ST_COMMENTGRAYTEXT].c_str());
|
||||
gCommentText = gtk_text_view_new();
|
||||
gtk_label_set_mnemonic_widget(GTK_LABEL(gCommentTextLabel), gCommentText);
|
||||
gtk_text_view_set_accepts_tab(GTK_TEXT_VIEW(gCommentText), FALSE);
|
||||
g_signal_connect(gCommentText, "focus-in-event", G_CALLBACK(CommentFocusChange), 0);
|
||||
g_signal_connect(gCommentText, "focus-out-event", G_CALLBACK(CommentFocusChange), 0);
|
||||
|
||||
@@ -509,17 +521,21 @@ bool UIShowCrashUI(const StringTable& fi
|
||||
g_free(dir);
|
||||
gThrobber = gtk_image_new_from_file(path);
|
||||
gtk_box_pack_start(GTK_BOX(progressBox), gThrobber, FALSE, FALSE, 0);
|
||||
|
||||
gProgressLabel =
|
||||
gtk_label_new(gStrings[ST_REPORTPRESUBMIT].c_str());
|
||||
gtk_box_pack_start(GTK_BOX(progressBox), gProgressLabel, TRUE, TRUE, 0);
|
||||
// force the label to line wrap
|
||||
+#if (MOZ_WIDGET_GTK == 2)
|
||||
gtk_widget_set_size_request(gProgressLabel, 400, -1);
|
||||
+#else
|
||||
+ gtk_label_set_max_width_chars(GTK_LABEL(gProgressLabel), LABEL_MAX_CHAR_WIDTH);
|
||||
+#endif
|
||||
gtk_label_set_line_wrap(GTK_LABEL(gProgressLabel), TRUE);
|
||||
|
||||
GtkWidget* buttonBox = gtk_hbutton_box_new();
|
||||
gtk_box_pack_end(GTK_BOX(vbox), buttonBox, FALSE, FALSE, 0);
|
||||
gtk_box_set_spacing(GTK_BOX(buttonBox), 6);
|
||||
gtk_button_box_set_layout(GTK_BUTTON_BOX(buttonBox), GTK_BUTTONBOX_END);
|
||||
|
||||
gCloseButton =
|
Loading…
Reference in New Issue
Block a user