Update to 38.0 Build 3
This commit is contained in:
parent
6098a708df
commit
013dc85d05
1
.gitignore
vendored
1
.gitignore
vendored
@ -138,3 +138,4 @@ firefox-3.6.4.source.tar.bz2
|
|||||||
/firefox-38.0.source.tar.bz2
|
/firefox-38.0.source.tar.bz2
|
||||||
/firefox-langpacks-38.0-20150505.tar.bz2
|
/firefox-langpacks-38.0-20150505.tar.bz2
|
||||||
/firefox-langpacks-38.0-20150505.tar.xz
|
/firefox-langpacks-38.0-20150505.tar.xz
|
||||||
|
/firefox-langpacks-38.0-20150511.tar.xz
|
||||||
|
@ -107,13 +107,13 @@
|
|||||||
Summary: Mozilla Firefox Web browser
|
Summary: Mozilla Firefox Web browser
|
||||||
Name: firefox
|
Name: firefox
|
||||||
Version: 38.0
|
Version: 38.0
|
||||||
Release: 2%{?pre_tag}%{?dist}
|
Release: 3%{?pre_tag}%{?dist}
|
||||||
URL: http://www.mozilla.org/projects/firefox/
|
URL: http://www.mozilla.org/projects/firefox/
|
||||||
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
License: MPLv1.1 or GPLv2+ or LGPLv2+
|
||||||
Group: Applications/Internet
|
Group: Applications/Internet
|
||||||
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
Source0: ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_version}/source/firefox-%{version}%{?pre_version}.source.tar.bz2
|
||||||
%if %{build_langpacks}
|
%if %{build_langpacks}
|
||||||
Source1: firefox-langpacks-%{version}%{?pre_version}-20150505.tar.xz
|
Source1: firefox-langpacks-%{version}%{?pre_version}-20150511.tar.xz
|
||||||
%endif
|
%endif
|
||||||
Source10: firefox-mozconfig
|
Source10: firefox-mozconfig
|
||||||
Source11: firefox-mozconfig-branded
|
Source11: firefox-mozconfig-branded
|
||||||
@ -135,6 +135,7 @@ Patch20: firefox-build-prbool.patch
|
|||||||
Patch21: firefox-ppc64le.patch
|
Patch21: firefox-ppc64le.patch
|
||||||
Patch23: mozilla-1005535.patch
|
Patch23: mozilla-1005535.patch
|
||||||
Patch24: firefox-debug.patch
|
Patch24: firefox-debug.patch
|
||||||
|
Patch25: rhbz-1219542-s390-build.patch
|
||||||
|
|
||||||
# Fedora specific patches
|
# Fedora specific patches
|
||||||
# Unable to install addons from https pages
|
# Unable to install addons from https pages
|
||||||
@ -286,6 +287,7 @@ cd %{tarballdir}
|
|||||||
%patch21 -p2 -b .ppc64le
|
%patch21 -p2 -b .ppc64le
|
||||||
%patch23 -p1 -b .1005535
|
%patch23 -p1 -b .1005535
|
||||||
%patch24 -p1 -b .debug
|
%patch24 -p1 -b .debug
|
||||||
|
%patch25 -p1 -b .rhbz-1219542-s390
|
||||||
|
|
||||||
%patch3 -p2 -b .arm
|
%patch3 -p2 -b .arm
|
||||||
|
|
||||||
@ -804,6 +806,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
|||||||
#---------------------------------------------------------------------
|
#---------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* MonMay 11 2015 Martin Stransky <stransky@redhat.com> - 38.0-3
|
||||||
|
- Update to 38.0 Build 3
|
||||||
|
|
||||||
* Wed May 6 2015 Martin Stransky <stransky@redhat.com> - 38.0-2
|
* Wed May 6 2015 Martin Stransky <stransky@redhat.com> - 38.0-2
|
||||||
- Added fix for mozbz#1161056 - combobox background color
|
- Added fix for mozbz#1161056 - combobox background color
|
||||||
|
|
||||||
|
23
rhbz-1219542-s390-build.patch
Normal file
23
rhbz-1219542-s390-build.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -up mozilla-release/js/src/configure.in.opt mozilla-release/js/src/configure.in
|
||||||
|
--- mozilla-release/js/src/configure.in.opt 2015-05-04 02:43:23.000000000 +0200
|
||||||
|
+++ mozilla-release/js/src/configure.in 2015-05-07 14:21:07.685405039 +0200
|
||||||
|
@@ -1492,7 +1492,7 @@ case "$host" in
|
||||||
|
*-linux*|*-kfreebsd*-gnu|*-gnu*)
|
||||||
|
HOST_CFLAGS="$HOST_CFLAGS -DXP_UNIX"
|
||||||
|
HOST_NSPR_MDCPUCFG='\"md/_linux.cfg\"'
|
||||||
|
- HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O3}"
|
||||||
|
+ HOST_OPTIMIZE_FLAGS="${HOST_OPTIMIZE_FLAGS=-O1}"
|
||||||
|
;;
|
||||||
|
|
||||||
|
*)
|
||||||
|
@@ -1674,8 +1674,8 @@ ia64*-hpux*)
|
||||||
|
# while; Intel recommends against using it.
|
||||||
|
MOZ_OPTIMIZE_FLAGS="-O2"
|
||||||
|
elif test "$GNU_CC" -o "$GNU_CXX"; then
|
||||||
|
- MOZ_PGO_OPTIMIZE_FLAGS="-O3"
|
||||||
|
- MOZ_OPTIMIZE_FLAGS="-O3"
|
||||||
|
+ MOZ_PGO_OPTIMIZE_FLAGS="-O1"
|
||||||
|
+ MOZ_OPTIMIZE_FLAGS="-O1"
|
||||||
|
if test -z "$CLANG_CC"; then
|
||||||
|
MOZ_OPTIMIZE_FLAGS="-freorder-blocks $MOZ_OPTIMIZE_FLAGS"
|
||||||
|
fi
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
d1c66ec031c0cb8aea3df7210dc6955c firefox-38.0.source.tar.bz2
|
28030dd8c3e84f05c3e362d70c657c9b firefox-38.0.source.tar.bz2
|
||||||
3bcb7abb6a1fac463e05d5fc488f579f firefox-langpacks-38.0-20150505.tar.xz
|
1f3e1922dbf235c7e341318f279185d5 firefox-langpacks-38.0-20150511.tar.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user