New upstream version 3.30

This commit is contained in:
Eric Sandeen 2022-04-07 08:46:08 -05:00
parent 258ff36978
commit d52722fe85
5 changed files with 9 additions and 47 deletions

2
.gitignore vendored
View File

@ -32,3 +32,5 @@
/fio-3.28.tar.bz2.asc
/fio-3.29.tar.bz2
/fio-3.29.tar.bz2.asc
/fio-3.30.tar.bz2
/fio-3.30.tar.bz2.asc

View File

@ -1,21 +0,0 @@
[PATCH 1/2] t/io_uring: link with libaio when necessary
When CONFIG_LIBAIO is enabled, we need t/io_uring to link with it.
(libaio_LIBS only affects the aio engine, AFAICT.)
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
---
diff --git a/Makefile b/Makefile
index 5d17bca..00e7953 100644
--- a/Makefile
+++ b/Makefile
@@ -99,6 +99,7 @@ endif
ifdef CONFIG_LIBAIO
libaio_SRCS = engines/libaio.c
cmdprio_SRCS = engines/cmdprio.c
+ LIBS += -laio
libaio_LIBS = -laio
ENGINES += libaio
endif

View File

@ -1,20 +0,0 @@
[PATCH 2/2] fio: use LDFLAGS when linking dynamic engines
Without this, locally defined LDFLAGS won't be applied when
linking the dynamically loaded IO engines.
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
---
diff --git a/Makefile b/Makefile
index 5d17bca..00e7953 100644
@@ -294,7 +295,7 @@ define engine_template =
$(1)_OBJS := $$($(1)_SRCS:.c=.o)
$$($(1)_OBJS): CFLAGS := -fPIC $$($(1)_CFLAGS) $(CFLAGS)
engines/fio-$(1).so: $$($(1)_OBJS)
- $$(QUIET_LINK)$(CC) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
+ $$(QUIET_LINK)$(CC) $(LDFLAGS) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
ENGS_OBJS += engines/fio-$(1).so
endef
else # !CONFIG_DYNAMIC_ENGINES

View File

@ -1,5 +1,5 @@
Name: fio
Version: 3.29
Version: 3.30
Release: 1%{?dist}
Summary: Multithreaded IO generation tool
@ -9,8 +9,6 @@ Source0: http://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2
Source1: https://brick.kernel.dk/snaps/%{name}-%{version}.tar.bz2.asc
Source2: https://git.kernel.org/pub/scm/docs/kernel/pgpkeys.git/plain/keys/F7D358FB2971E0A6.asc
Patch0: fio-3.29-link-t-io_uring-with-libaio.patch
Patch1: fio-3.29-use-LDFLAGS-for-dynamic-engines.patch
BuildRequires: gcc
BuildRequires: gnupg2
@ -167,7 +165,7 @@ EXTFLAGS="$RPM_OPT_FLAGS" LDFLAGS="$RPM_LD_FLAGS" make V=1 %{?_smp_mflags}
make install prefix=%{_prefix} mandir=%{_mandir} libdir=%{_libdir}/fio DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
%files
%doc README REPORTING-BUGS HOWTO examples
%doc README.rst REPORTING-BUGS HOWTO.rst examples
%doc MORAL-LICENSE GFIO-TODO SERVER-TODO STEADYSTATE-TODO
%license COPYING
%dir %{_datadir}/%{name}
@ -214,6 +212,9 @@ make install prefix=%{_prefix} mandir=%{_mandir} libdir=%{_libdir}/fio DESTDIR=$
%endif
%changelog
* Thu Apr 07 2022 Eric Sandeen <sandeen@redhat.com> 3.30-1
- New upstream version
* Wed Jan 26 2022 Eric Sandeen <sandeen@redhat.com> 3.29-1
- New upstream version
- Drop librbd for ppc64le as ceph no longer builds for that arch

View File

@ -1,2 +1,2 @@
SHA512 (fio-3.29.tar.bz2) = 546ff7f376396667336e5c0b37f5233399de24dcbc825f74062f88a5aca9f44ea2ce80e9b1450234486e8364f03936b0e105d0ddce72851cc5130b3f75fbf052
SHA512 (fio-3.29.tar.bz2.asc) = 70c785f8ad07f313e0aeccfd1103424d0b8945503fea87a58d733e2ce6a1d69588b8c63581b66ca5696b9d0720d7725ecac604d089bbefcaf831cc3d3bf92aab
SHA512 (fio-3.30.tar.bz2) = 1fb2ae9c28028147edabceff734fc41bf07ce504af98afdb0951920b724b15d647f2b0852262c177279ad6b4dbbf24be458db7f939d1c80069e0f8e7bc8aa10d
SHA512 (fio-3.30.tar.bz2.asc) = d1bebf8f2cdd91c2472264df069e3995bef28e4dd4c5664cad8b1302cf693f18b75ffe449daae8af851df38484f46a97a70a22247c154bf4dc956aa48acbfc6e