f522f10886
Required two local fix-up patches, sent upstream
21 lines
732 B
Diff
21 lines
732 B
Diff
[PATCH 2/2] fio: use LDFLAGS when linking dynamic engines
|
|
|
|
Without this, locally defined LDFLAGS won't be applied when
|
|
linking the dynamically loaded IO engines.
|
|
|
|
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
|
|
---
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 5d17bca..00e7953 100644
|
|
@@ -294,7 +295,7 @@ define engine_template =
|
|
$(1)_OBJS := $$($(1)_SRCS:.c=.o)
|
|
$$($(1)_OBJS): CFLAGS := -fPIC $$($(1)_CFLAGS) $(CFLAGS)
|
|
engines/fio-$(1).so: $$($(1)_OBJS)
|
|
- $$(QUIET_LINK)$(CC) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
|
|
+ $$(QUIET_LINK)$(CC) $(LDFLAGS) -shared -rdynamic -fPIC -Wl,-soname,fio-$(1).so.1 -o $$@ $$< $$($(1)_LIBS)
|
|
ENGS_OBJS += engines/fio-$(1).so
|
|
endef
|
|
else # !CONFIG_DYNAMIC_ENGINES
|
|
|