fio/fio-3.29-link-t-io_uring-with-libaio.patch
Eric Sandeen f522f10886 New upstream version v3.29
Required two local fix-up patches, sent upstream
2022-01-26 09:36:34 -06:00

22 lines
507 B
Diff

[PATCH 1/2] t/io_uring: link with libaio when necessary
When CONFIG_LIBAIO is enabled, we need t/io_uring to link with it.
(libaio_LIBS only affects the aio engine, AFAICT.)
Signed-off-by: Eric Sandeen <sandeen@redhat.com>
---
diff --git a/Makefile b/Makefile
index 5d17bca..00e7953 100644
--- a/Makefile
+++ b/Makefile
@@ -99,6 +99,7 @@ endif
ifdef CONFIG_LIBAIO
libaio_SRCS = engines/libaio.c
cmdprio_SRCS = engines/cmdprio.c
+ LIBS += -laio
libaio_LIBS = -laio
ENGINES += libaio
endif