Update to .NET SDK 8.0.112 and Runtime 8.0.12

Resolves: RHEL-71555
This commit is contained in:
Omair Majid 2025-01-16 12:57:30 -05:00
parent cf1b299b17
commit 65c1f1a6a0
5 changed files with 17 additions and 68 deletions

2
.gitignore vendored
View File

@ -52,3 +52,5 @@
/dotnet-8.0.10.tar.gz.sig
/dotnet-8.0.11.tar.gz
/dotnet-8.0.11.tar.gz.sig
/dotnet-8.0.12.tar.gz
/dotnet-8.0.12.tar.gz.sig

View File

@ -12,10 +12,10 @@
# dotnet-host and netstandard-targeting-pack-2.1
%global is_latest_dotnet 0
%global host_version 8.0.11
%global runtime_version 8.0.11
%global host_version 8.0.12
%global runtime_version 8.0.12
%global aspnetcore_runtime_version %{runtime_version}
%global sdk_version 8.0.111
%global sdk_version 8.0.112
%global sdk_feature_band_version %(echo %{sdk_version} | cut -d '-' -f 1 | sed -e 's|[[:digit:]][[:digit:]]$|00|')
%global templates_version %{runtime_version}
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
@ -98,8 +98,6 @@ Patch4: msbuild-9449-exec-stop-setting-a-locale.patch
# digests used for the signature are not treated as fatal errors.
# https://issues.redhat.com/browse/RHEL-25254
Patch5: runtime-openssl-sha1.patch
# https://github.com/dotnet/runtime/pull/109198
Patch6: runtime-clang-19.patch
ExclusiveArch: aarch64 ppc64le s390x x86_64
@ -741,6 +739,10 @@ export COMPlus_LTTng=0
%changelog
* Thu Jan 16 2025 Omair Majid <omajid@redhat.com> - 8.0.112-2
- Update to .NET SDK 8.0.112 and Runtime 8.0.12
- Resolves: RHEL-71555
* Thu Nov 14 2024 Omair Majid <omajid@redhat.com> - 8.0.111-2
- Update to .NET SDK 8.0.111 and Runtime 8.0.11
- Resolves: RHEL-65367

View File

@ -1,10 +1,10 @@
{
"release": "8.0.11",
"release": "8.0.12",
"channel": "8.0",
"tag": "v8.0.11",
"sdkVersion": "8.0.111",
"runtimeVersion": "8.0.11",
"aspNetCoreVersion": "8.0.11",
"tag": "v8.0.12",
"sdkVersion": "8.0.112",
"runtimeVersion": "8.0.12",
"aspNetCoreVersion": "8.0.12",
"sourceRepository": "https://github.com/dotnet/dotnet",
"sourceVersion": "d5f3d652f9266d600777f626a9650a273419859b"
"sourceVersion": "ab5d79b36d4f8a16f9f91f53fd6504b354c977b1"
}

View File

@ -1,55 +0,0 @@
commit e356f564bf74909e77d000e3ad1b8b43c30d070c (HEAD -> release/8.0)
Author: Omair Majid <omajid@redhat.com>
Date: Tue Oct 15 14:53:33 2024 -0400
Fix clang19 build (#105141)
diff --git a/src/runtime/src/coreclr/vm/comreflectioncache.hpp b/src/runtime/src/coreclr/vm/comreflectioncache.hpp
index 08d173e6164..12db55251d8 100644
--- a/src/runtime/src/coreclr/vm/comreflectioncache.hpp
+++ b/src/runtime/src/coreclr/vm/comreflectioncache.hpp
@@ -26,6 +26,7 @@ public:
void Init();
+#ifndef DACCESS_COMPILE
BOOL GetFromCache(Element *pElement, CacheType& rv)
{
CONTRACTL
@@ -102,6 +103,7 @@ public:
AdjustStamp(TRUE);
this->LeaveWrite();
}
+#endif // !DACCESS_COMPILE
private:
// Lock must have been taken before calling this.
@@ -141,6 +143,7 @@ private:
return CacheSize;
}
+#ifndef DACCESS_COMPILE
void AdjustStamp(BOOL hasWriterLock)
{
CONTRACTL
@@ -170,6 +173,7 @@ private:
if (!hasWriterLock)
this->LeaveWrite();
}
+#endif // !DACCESS_COMPILE
void UpdateHashTable(SIZE_T hash, int slot)
{
diff --git a/src/runtime/src/native/libs/CMakeLists.txt b/src/runtime/src/native/libs/CMakeLists.txt
index b8ec2cf654c..ca8590985d6 100644
--- a/src/runtime/src/native/libs/CMakeLists.txt
+++ b/src/runtime/src/native/libs/CMakeLists.txt
@@ -128,6 +128,8 @@ if (CLR_CMAKE_TARGET_UNIX OR CLR_CMAKE_TARGET_BROWSER OR CLR_CMAKE_TARGET_WASI)
add_compile_options(-Wno-cast-align)
add_compile_options(-Wno-typedef-redefinition)
add_compile_options(-Wno-c11-extensions)
+ add_compile_options(-Wno-pre-c11-compat) # fixes build on Debian
+ add_compile_options(-Wno-unknown-warning-option) # unknown warning option '-Wno-pre-c11-compat'
add_compile_options(-Wno-thread-safety-analysis)
if (CLR_CMAKE_TARGET_BROWSER)
add_compile_options(-Wno-unsafe-buffer-usage)

View File

@ -1,2 +1,2 @@
SHA512 (dotnet-8.0.11.tar.gz) = 1bd689e560114d3cbe6a40d6608b0f5f493bef5e4d74f973c37d2e4bf88f999c769c12c390300f1d51094252a5791930c65547e1e4b8fa33387f995d296687f9
SHA512 (dotnet-8.0.11.tar.gz.sig) = 7faef7d2fc9728117425c489bc78014ac4017394946cfbb3699817e06ff1d18ada022bfcd1c5dd2898fdc41bc2b9ff3645b83e18f2d3653e3ae9008f0b296f8a
SHA512 (dotnet-8.0.12.tar.gz) = d770a6c37de5c657d306a070c4c02c8f96b52a89184d46b946154cfcf470390f7483f8e38ea3a662d8234bc9fe8d7a1d48bf4cd144e4d3ff29fd36d36889f3a5
SHA512 (dotnet-8.0.12.tar.gz.sig) = a52d08fad89dcb94442b51e6d8529ce0ada4c3f4a2ca7f64e6f9ca7d0dbbb35a47d6fc38e94b372341fdbaf41be622a66279928573252661c854b7f495a056e9