dotnet8.0/runtime-clang-19.patch
Omair Majid cf1b299b17 Update to .NET SDK 8.0.111 and Runtime 8.0.11
Resolves: RHEL-65367
2024-11-19 06:59:06 -05:00

56 lines
1.9 KiB
Diff

commit e356f564bf74909e77d000e3ad1b8b43c30d070c (HEAD -> release/8.0)
Author: Omair Majid <omajid@redhat.com>
Date: Tue Oct 15 14:53:33 2024 -0400
Fix clang19 build (#105141)
diff --git a/src/runtime/src/coreclr/vm/comreflectioncache.hpp b/src/runtime/src/coreclr/vm/comreflectioncache.hpp
index 08d173e6164..12db55251d8 100644
--- a/src/runtime/src/coreclr/vm/comreflectioncache.hpp
+++ b/src/runtime/src/coreclr/vm/comreflectioncache.hpp
@@ -26,6 +26,7 @@ public:
void Init();
+#ifndef DACCESS_COMPILE
BOOL GetFromCache(Element *pElement, CacheType& rv)
{
CONTRACTL
@@ -102,6 +103,7 @@ public:
AdjustStamp(TRUE);
this->LeaveWrite();
}
+#endif // !DACCESS_COMPILE
private:
// Lock must have been taken before calling this.
@@ -141,6 +143,7 @@ private:
return CacheSize;
}
+#ifndef DACCESS_COMPILE
void AdjustStamp(BOOL hasWriterLock)
{
CONTRACTL
@@ -170,6 +173,7 @@ private:
if (!hasWriterLock)
this->LeaveWrite();
}
+#endif // !DACCESS_COMPILE
void UpdateHashTable(SIZE_T hash, int slot)
{
diff --git a/src/runtime/src/native/libs/CMakeLists.txt b/src/runtime/src/native/libs/CMakeLists.txt
index b8ec2cf654c..ca8590985d6 100644
--- a/src/runtime/src/native/libs/CMakeLists.txt
+++ b/src/runtime/src/native/libs/CMakeLists.txt
@@ -128,6 +128,8 @@ if (CLR_CMAKE_TARGET_UNIX OR CLR_CMAKE_TARGET_BROWSER OR CLR_CMAKE_TARGET_WASI)
add_compile_options(-Wno-cast-align)
add_compile_options(-Wno-typedef-redefinition)
add_compile_options(-Wno-c11-extensions)
+ add_compile_options(-Wno-pre-c11-compat) # fixes build on Debian
+ add_compile_options(-Wno-unknown-warning-option) # unknown warning option '-Wno-pre-c11-compat'
add_compile_options(-Wno-thread-safety-analysis)
if (CLR_CMAKE_TARGET_BROWSER)
add_compile_options(-Wno-unsafe-buffer-usage)