Update to .NET SDK 8.0.111 and Runtime 8.0.11

Resolves: RHEL-65367
This commit is contained in:
Omair Majid 2024-11-19 00:57:29 -05:00
parent b563a624a0
commit cf1b299b17
5 changed files with 75 additions and 12 deletions

2
.gitignore vendored
View File

@ -50,3 +50,5 @@
/dotnet-8.0.8.tar.gz.sig
/dotnet-8.0.10.tar.gz
/dotnet-8.0.10.tar.gz.sig
/dotnet-8.0.11.tar.gz
/dotnet-8.0.11.tar.gz.sig

View File

@ -12,10 +12,10 @@
# dotnet-host and netstandard-targeting-pack-2.1
%global is_latest_dotnet 0
%global host_version 8.0.10
%global runtime_version 8.0.10
%global host_version 8.0.11
%global runtime_version 8.0.11
%global aspnetcore_runtime_version %{runtime_version}
%global sdk_version 8.0.110
%global sdk_version 8.0.111
%global sdk_feature_band_version %(echo %{sdk_version} | cut -d '-' -f 1 | sed -e 's|[[:digit:]][[:digit:]]$|00|')
%global templates_version %{runtime_version}
#%%global templates_version %%(echo %%{runtime_version} | awk 'BEGIN { FS="."; OFS="." } {print $1, $2, $3+1 }')
@ -57,7 +57,7 @@
Name: dotnet%{dotnetver}
Version: %{sdk_rpm_version}
Release: 3%{?dist}
Release: 2%{?dist}
Summary: .NET Runtime and SDK
License: 0BSD AND Apache-2.0 AND (Apache-2.0 WITH LLVM-exception) AND APSL-2.0 AND BSD-2-Clause AND BSD-3-Clause AND BSD-4-Clause AND BSL-1.0 AND bzip2-1.0.6 AND CC0-1.0 AND CC-BY-3.0 AND CC-BY-4.0 AND CC-PDDC AND CNRI-Python AND EPL-1.0 AND GPL-2.0-only AND (GPL-2.0-only WITH GCC-exception-2.0) AND GPL-2.0-or-later AND GPL-3.0-only AND ICU AND ISC AND LGPL-2.1-only AND LGPL-2.1-or-later AND LicenseRef-Fedora-Public-Domain AND LicenseRef-ISO-8879 AND MIT AND MIT-Wu AND MS-PL AND MS-RL AND NCSA AND OFL-1.1 AND OpenSSL AND Unicode-DFS-2015 AND Unicode-DFS-2016 AND W3C-19980720 AND X11 AND Zlib
@ -98,6 +98,8 @@ Patch4: msbuild-9449-exec-stop-setting-a-locale.patch
# digests used for the signature are not treated as fatal errors.
# https://issues.redhat.com/browse/RHEL-25254
Patch5: runtime-openssl-sha1.patch
# https://github.com/dotnet/runtime/pull/109198
Patch6: runtime-clang-19.patch
ExclusiveArch: aarch64 ppc64le s390x x86_64
@ -739,6 +741,10 @@ export COMPlus_LTTng=0
%changelog
* Thu Nov 14 2024 Omair Majid <omajid@redhat.com> - 8.0.111-2
- Update to .NET SDK 8.0.111 and Runtime 8.0.11
- Resolves: RHEL-65367
* Fri Oct 18 2024 Omair Majid <omajid@redhat.com> - 8.0.110-3
- Disable packages provided by another .NET version
- Related: RHEL-60801

View File

@ -1,10 +1,10 @@
{
"release": "8.0.10",
"release": "8.0.11",
"channel": "8.0",
"tag": "v8.0.10",
"sdkVersion": "8.0.110",
"runtimeVersion": "8.0.10",
"aspNetCoreVersion": "8.0.10",
"tag": "v8.0.11",
"sdkVersion": "8.0.111",
"runtimeVersion": "8.0.11",
"aspNetCoreVersion": "8.0.11",
"sourceRepository": "https://github.com/dotnet/dotnet",
"sourceVersion": "8922fe64a1903ed4e35e24568efb056b3e0fad43"
"sourceVersion": "d5f3d652f9266d600777f626a9650a273419859b"
}

55
runtime-clang-19.patch Normal file
View File

@ -0,0 +1,55 @@
commit e356f564bf74909e77d000e3ad1b8b43c30d070c (HEAD -> release/8.0)
Author: Omair Majid <omajid@redhat.com>
Date: Tue Oct 15 14:53:33 2024 -0400
Fix clang19 build (#105141)
diff --git a/src/runtime/src/coreclr/vm/comreflectioncache.hpp b/src/runtime/src/coreclr/vm/comreflectioncache.hpp
index 08d173e6164..12db55251d8 100644
--- a/src/runtime/src/coreclr/vm/comreflectioncache.hpp
+++ b/src/runtime/src/coreclr/vm/comreflectioncache.hpp
@@ -26,6 +26,7 @@ public:
void Init();
+#ifndef DACCESS_COMPILE
BOOL GetFromCache(Element *pElement, CacheType& rv)
{
CONTRACTL
@@ -102,6 +103,7 @@ public:
AdjustStamp(TRUE);
this->LeaveWrite();
}
+#endif // !DACCESS_COMPILE
private:
// Lock must have been taken before calling this.
@@ -141,6 +143,7 @@ private:
return CacheSize;
}
+#ifndef DACCESS_COMPILE
void AdjustStamp(BOOL hasWriterLock)
{
CONTRACTL
@@ -170,6 +173,7 @@ private:
if (!hasWriterLock)
this->LeaveWrite();
}
+#endif // !DACCESS_COMPILE
void UpdateHashTable(SIZE_T hash, int slot)
{
diff --git a/src/runtime/src/native/libs/CMakeLists.txt b/src/runtime/src/native/libs/CMakeLists.txt
index b8ec2cf654c..ca8590985d6 100644
--- a/src/runtime/src/native/libs/CMakeLists.txt
+++ b/src/runtime/src/native/libs/CMakeLists.txt
@@ -128,6 +128,8 @@ if (CLR_CMAKE_TARGET_UNIX OR CLR_CMAKE_TARGET_BROWSER OR CLR_CMAKE_TARGET_WASI)
add_compile_options(-Wno-cast-align)
add_compile_options(-Wno-typedef-redefinition)
add_compile_options(-Wno-c11-extensions)
+ add_compile_options(-Wno-pre-c11-compat) # fixes build on Debian
+ add_compile_options(-Wno-unknown-warning-option) # unknown warning option '-Wno-pre-c11-compat'
add_compile_options(-Wno-thread-safety-analysis)
if (CLR_CMAKE_TARGET_BROWSER)
add_compile_options(-Wno-unsafe-buffer-usage)

View File

@ -1,2 +1,2 @@
SHA512 (dotnet-8.0.10.tar.gz) = 5bb660d4bf750392d4022ceb02a7f76a04a8f789c9fbbde329019bc3e097fd7296984b52d29dfc027d31b7b4defdf3807f10e37a9696f8f0026c77cea6ad0d18
SHA512 (dotnet-8.0.10.tar.gz.sig) = 3c4ea982659f00d84528ac26493712d9f786d588797649bb4f551d8e5f7a0aca51a6e27dbe71b1979eeb3307acbac7306da83c14782bb944dd4510ea7761f8d8
SHA512 (dotnet-8.0.11.tar.gz) = 1bd689e560114d3cbe6a40d6608b0f5f493bef5e4d74f973c37d2e4bf88f999c769c12c390300f1d51094252a5791930c65547e1e4b8fa33387f995d296687f9
SHA512 (dotnet-8.0.11.tar.gz.sig) = 7faef7d2fc9728117425c489bc78014ac4017394946cfbb3699817e06ff1d18ada022bfcd1c5dd2898fdc41bc2b9ff3645b83e18f2d3653e3ae9008f0b296f8a