- Import new upstream 4.3.9
This commit is contained in:
parent
eb6b312446
commit
ec7299a738
@ -1 +1 @@
|
||||
zsh-4.3.6.tar.bz2
|
||||
zsh-4.3.9.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
16f399af1081ad3c303a794c9c7dc47e zsh-4.3.6.tar.bz2
|
||||
0539d0a590e545ad8c40ff8c97e94538 zsh-4.3.9.tar.bz2
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.6/Functions/Prompts/prompt_bigfade_setup
|
||||
--- zsh-4.3.6-orig/Functions/Prompts/prompt_bigfade_setup 2007-06-14 12:11:39.000000000 -0400
|
||||
+++ zsh-4.3.6/Functions/Prompts/prompt_bigfade_setup 2008-08-25 16:27:30.000000000 -0400
|
||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.9/Functions/Prompts/prompt_bigfade_setup
|
||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_bigfade_setup 2008-07-14 10:04:18.000000000 -0400
|
||||
+++ zsh-4.3.9/Functions/Prompts/prompt_bigfade_setup 2008-12-18 20:32:59.000000000 -0500
|
||||
@@ -7,7 +7,7 @@
|
||||
cat <<EOH
|
||||
This prompt is color-scheme-able. You can invoke it thus:
|
||||
@ -16,16 +16,16 @@ diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.6/Functio
|
||||
|
||||
+ if [[ $1 == '8bit' ]]; then
|
||||
+ shift
|
||||
local char_333 char_262 char_261 char_260
|
||||
autoload -U prompt_special_chars
|
||||
local -A schars
|
||||
autoload -Uz prompt_special_chars
|
||||
prompt_special_chars
|
||||
+ fi
|
||||
|
||||
PS1="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$userhost]$bg[$fadebar]%}%n@%m%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$date]$bg[grey]%} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%{$bold_color$fg[$cwd]$bg[grey]%}$PWD>%{$reset_color%} "
|
||||
PS2="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$bold_color$fg[$fadebar]%}>%{$reset_color%} "
|
||||
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.6/Functions/Prompts/prompt_elite2_setup
|
||||
--- zsh-4.3.6-orig/Functions/Prompts/prompt_elite2_setup 2007-06-14 12:11:39.000000000 -0400
|
||||
+++ zsh-4.3.6/Functions/Prompts/prompt_elite2_setup 2008-08-25 16:26:03.000000000 -0400
|
||||
PS1="%B%F{$fadebar}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$userhost}%K{$fadebar}%n@%m%b%k%f%F{$fadebar}%K{black}$schars[260]$schars[261]$schars[262]$schars[333]%b%f%k%F{$fadebar}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$date}%K{black} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%B%F{$cwd}%K{black}$PWD>%b%f%k "
|
||||
PS2="%B%F{$fadebar}$schars[333]$schars[262]$schars[261]$schars[260]%b%F{$fadebar}%K{black}$schars[260]$schars[261]$schars[262]$schars[333]%F{$fadebar}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$fadebar}>%b%f%k "
|
||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.9/Functions/Prompts/prompt_elite2_setup
|
||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_elite2_setup 2008-07-14 10:04:18.000000000 -0400
|
||||
+++ zsh-4.3.9/Functions/Prompts/prompt_elite2_setup 2008-12-18 20:33:31.000000000 -0500
|
||||
@@ -6,7 +6,7 @@
|
||||
cat <<EOH
|
||||
This prompt is color-scheme-able. You can invoke it thus:
|
||||
@ -41,16 +41,16 @@ diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.6/Function
|
||||
|
||||
+ if [[ $1 == '8bit' ]]; then
|
||||
+ shift
|
||||
local char_333 char_262 char_261 char_260
|
||||
autoload -U prompt_special_chars
|
||||
local -A schars
|
||||
autoload -Uz prompt_special_chars
|
||||
prompt_special_chars
|
||||
+ fi
|
||||
|
||||
local text="%{$fg_no_bold[$text_col]%}"
|
||||
local parens="%{$fg_bold[$parens_col]%}"
|
||||
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.6/Functions/Prompts/prompt_elite_setup
|
||||
--- zsh-4.3.6-orig/Functions/Prompts/prompt_elite_setup 2007-06-14 12:11:39.000000000 -0400
|
||||
+++ zsh-4.3.6/Functions/Prompts/prompt_elite_setup 2008-08-25 16:26:21.000000000 -0400
|
||||
local text="%b%F{$text_col}"
|
||||
local parens="%B%F{$parens_col}"
|
||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.9/Functions/Prompts/prompt_elite_setup
|
||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_elite_setup 2008-07-14 10:04:18.000000000 -0400
|
||||
+++ zsh-4.3.9/Functions/Prompts/prompt_elite_setup 2008-12-18 20:33:45.000000000 -0500
|
||||
@@ -6,7 +6,7 @@
|
||||
cat <<EOH
|
||||
This prompt is color-scheme-able. You can invoke it thus:
|
||||
@ -66,16 +66,16 @@ diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.6/Functions
|
||||
|
||||
+ if [[ $1 == '8bit' ]]; then
|
||||
+ shift
|
||||
local char_333 char_262 char_261 char_260
|
||||
autoload -U prompt_special_chars
|
||||
local -A schars
|
||||
autoload -Uz prompt_special_chars
|
||||
prompt_special_chars
|
||||
+ fi
|
||||
|
||||
PS1="%{$fg[$text]%}$char_332$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%n%{$fg[$punctuation]%}@%{$fg[$text]%}%m%{$fg[$punctuation]%})%{$fg[$text]%}-%{$fg[$punctuation]%}(%{$fg[$text]%}%D{%I:%M%P}%{$fg[$punctuation]%}-:-%{$fg[$text]%}%D{%m}%{$fg[$punctuation]$fg[$text]%}/%D{%d}%{$fg[$punctuation]%})%{$fg[$text]%}$char_304-%{$fg[$punctuation]]%}$char_371%{$fg[$text]%}-$char_371$char_371%{$fg[$punctuation]%}$char_372$prompt_newline%{$fg[$text]%}$char_300$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%1~%{$fg[$punctuation]%})%{$fg[$text]%}$char_304$char_371%{$fg[$punctuation]%}$char_372%{$reset_color%}"
|
||||
PS1="%F{$text}$schars[332]$schars[304]%F{$punctuation}(%F{$text}%n%F{$punctuation}@%F{$text}%m%F{$punctuation})%F{$text}-%F{$punctuation}(%F{$text}%D{%I:%M%P}%F{$punctuation}-:-%F{$text}%D{%m}%F{$punctuation}%F{$text}/%D{%d}%F{$punctuation})%F{$text}$schars[304]-%F{$punctuation}$schars[371]%F{$text}-$schars[371]$schars[371]%F{$punctuation}$schars[372]$prompt_newline%F{$text}$schars[300]$schars[304]%F{$punctuation}(%F{$text}%1~%F{$punctuation})%F{$text}$schars[304]$schars[371]%F{$punctuation}$schars[372]%f"
|
||||
PS2="> "
|
||||
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.6/Functions/Prompts/prompt_fade_setup
|
||||
--- zsh-4.3.6-orig/Functions/Prompts/prompt_fade_setup 2007-06-14 12:11:39.000000000 -0400
|
||||
+++ zsh-4.3.6/Functions/Prompts/prompt_fade_setup 2008-08-25 16:26:51.000000000 -0400
|
||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.9/Functions/Prompts/prompt_fade_setup
|
||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_fade_setup 2008-07-14 10:04:18.000000000 -0400
|
||||
+++ zsh-4.3.9/Functions/Prompts/prompt_fade_setup 2008-12-18 20:33:55.000000000 -0500
|
||||
@@ -7,7 +7,7 @@
|
||||
cat <<EOH
|
||||
This prompt is color-scheme-able. You can invoke it thus:
|
||||
@ -91,16 +91,16 @@ diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.6/Functions/
|
||||
|
||||
+ if [[ $1 == '8bit' ]]; then
|
||||
+ shift
|
||||
local char_333 char_262 char_261 char_260
|
||||
autoload -U prompt_special_chars
|
||||
local -A schars
|
||||
autoload -Uz prompt_special_chars
|
||||
prompt_special_chars
|
||||
+ fi
|
||||
|
||||
PS1="%{$fg[$fadebar_cwd]$bg[$fadebar_cwd]$bold_color%}$char_333$char_262$char_261$char_260%{$fg[$userhost]$bg[$fadebar_cwd]$bold_color%}%n@%m%{$reset_color$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$fg[$date]$bg[grey]$bold_color%} %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%{$fg[$fadebar_cwd]$bg[grey]$bold_color%}%~/%{$reset_color%} "
|
||||
PS2="%{$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$reset_color%}>"
|
||||
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.6/Functions/Prompts/prompt_fire_setup
|
||||
--- zsh-4.3.6-orig/Functions/Prompts/prompt_fire_setup 2007-06-14 12:11:39.000000000 -0400
|
||||
+++ zsh-4.3.6/Functions/Prompts/prompt_fire_setup 2008-08-25 16:27:09.000000000 -0400
|
||||
PS1="%F{$fadebar_cwd}%B%K{$fadebar_cwd}$schars[333]$schars[262]$schars[261]$schars[260]%F{$userhost}%K{$fadebar_cwd}%B%n@%m%b%F{$fadebar_cwd}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%F{$date}%K{black}%B %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%F{fadebar_cwd}%K{black}%B%~/%b%k%f "
|
||||
PS2="%F{$fadebar_cwd}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%f%k>"
|
||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.9/Functions/Prompts/prompt_fire_setup
|
||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_fire_setup 2008-07-14 10:04:18.000000000 -0400
|
||||
+++ zsh-4.3.9/Functions/Prompts/prompt_fire_setup 2008-12-18 20:34:04.000000000 -0500
|
||||
@@ -8,7 +8,7 @@
|
||||
cat <<EOH
|
||||
This prompt is color-scheme-able. You can invoke it thus:
|
||||
@ -116,10 +116,10 @@ diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.6/Functions/
|
||||
|
||||
+ if [[ $1 == '8bit' ]]; then
|
||||
+ shift
|
||||
local char_333 char_262 char_261 char_260
|
||||
autoload -U prompt_special_chars
|
||||
local -a schars
|
||||
autoload -Uz prompt_special_chars
|
||||
prompt_special_chars
|
||||
+ fi
|
||||
|
||||
local GRAD1="%{$char_333$char_262$char_261$char_260%}"
|
||||
local GRAD2="%{$char_260$char_261$char_262$char_333%}"
|
||||
local GRAD1="%{$schars[333]$schars[262]$schars[261]$schars[260]%}"
|
||||
local GRAD2="%{$schars[260]$schars[261]$schars[262]$schars[333]%}"
|
||||
|
9
zsh.spec
9
zsh.spec
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: A powerful interactive shell
|
||||
Name: zsh
|
||||
Version: 4.3.6
|
||||
Release: 5%{?dist}
|
||||
Version: 4.3.9
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: http://zsh.sunsite.dk/
|
||||
Group: System Environment/Shells
|
||||
@ -59,7 +59,7 @@ This package contains the Zsh manual in html format.
|
||||
%patch0 -p1 -b .serial
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
#patch6 -p1
|
||||
#autoconf
|
||||
|
||||
cp -p %SOURCE7 .
|
||||
@ -163,6 +163,9 @@ fi
|
||||
%doc Doc/*.html
|
||||
|
||||
%changelog
|
||||
* Mon Aug 25 2008 James Antill <james@fedoraproject.org> - 4.3.9-1
|
||||
- Import new upstream 4.3.9
|
||||
|
||||
* Mon Aug 25 2008 James Antill <james@fedoraproject.org> - 4.3.6-5
|
||||
- Import new upstream 4.3.6
|
||||
- Rebase 8bit prompt patch
|
||||
|
Loading…
Reference in New Issue
Block a user