- Import new upstream 4.3.6
- Rebase 8bit prompt patch.
This commit is contained in:
parent
87e381feb3
commit
9ed34dac5b
@ -1 +1 @@
|
|||||||
zsh-4.3.4.tar.gz
|
zsh-4.3.6.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
acc4fc85d18d7f914bb6705775c45bf2 zsh-4.3.4.tar.gz
|
16f399af1081ad3c303a794c9c7dc47e zsh-4.3.6.tar.bz2
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.4/Functions/Prompts/prompt_bigfade_setup
|
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.6/Functions/Prompts/prompt_bigfade_setup
|
||||||
--- zsh-4.3.4-orig/Functions/Prompts/prompt_bigfade_setup 2005-05-10 00:39:02.000000000 -0400
|
--- zsh-4.3.6-orig/Functions/Prompts/prompt_bigfade_setup 2007-06-14 12:11:39.000000000 -0400
|
||||||
+++ zsh-4.3.4/Functions/Prompts/prompt_bigfade_setup 2007-12-03 20:42:09.000000000 -0500
|
+++ zsh-4.3.6/Functions/Prompts/prompt_bigfade_setup 2008-08-25 16:27:30.000000000 -0400
|
||||||
@@ -7,7 +7,7 @@ prompt_bigfade_help () {
|
@@ -7,7 +7,7 @@
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -10,24 +10,23 @@ diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.4/Functi
|
|||||||
|
|
||||||
where the parameters are the colors for the fade-bar, user@host text,
|
where the parameters are the colors for the fade-bar, user@host text,
|
||||||
date text, and current working directory respectively. The default
|
date text, and current working directory respectively. The default
|
||||||
@@ -25,9 +25,12 @@ prompt_bigfade_setup () {
|
@@ -27,9 +27,12 @@
|
||||||
local date=${3:-'white'}
|
local date=${3:-'white'}
|
||||||
local cwd=${4:-'yellow'}
|
local cwd=${4:-'yellow'}
|
||||||
|
|
||||||
+ if [[ $1 == '8bit' ]]; then
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
+ shift
|
+ shift
|
||||||
for code in 333 262 261 260; do
|
local char_333 char_262 char_261 char_260
|
||||||
local char_$code=$(echo -n "\\0$code")
|
autoload -U prompt_special_chars
|
||||||
done
|
prompt_special_chars
|
||||||
+ fi
|
+ fi
|
||||||
|
|
||||||
PS1="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$userhost]$bg[$fadebar]%}%n@%m%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$date]$bg[grey]%} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%{$bold_color$fg[$cwd]$bg[grey]%}$PWD>%{$reset_color%} "
|
PS1="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$userhost]$bg[$fadebar]%}%n@%m%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$date]$bg[grey]%} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%{$bold_color$fg[$cwd]$bg[grey]%}$PWD>%{$reset_color%} "
|
||||||
PS2="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$bold_color$fg[$fadebar]%}>%{$reset_color%} "
|
PS2="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$bold_color$fg[$fadebar]%}>%{$reset_color%} "
|
||||||
Only in zsh-4.3.4/Functions/Prompts: prompt_bigfade_setup~
|
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.6/Functions/Prompts/prompt_elite2_setup
|
||||||
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.4/Functions/Prompts/prompt_elite2_setup
|
--- zsh-4.3.6-orig/Functions/Prompts/prompt_elite2_setup 2007-06-14 12:11:39.000000000 -0400
|
||||||
--- zsh-4.3.4-orig/Functions/Prompts/prompt_elite2_setup 2005-05-10 00:39:02.000000000 -0400
|
+++ zsh-4.3.6/Functions/Prompts/prompt_elite2_setup 2008-08-25 16:26:03.000000000 -0400
|
||||||
+++ zsh-4.3.4/Functions/Prompts/prompt_elite2_setup 2007-12-03 20:41:14.000000000 -0500
|
@@ -6,7 +6,7 @@
|
||||||
@@ -6,7 +6,7 @@ prompt_elite2_help () {
|
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -36,24 +35,23 @@ diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.4/Functio
|
|||||||
|
|
||||||
The default colors are both cyan. This theme works best with a dark
|
The default colors are both cyan. This theme works best with a dark
|
||||||
background.
|
background.
|
||||||
@@ -20,9 +20,12 @@ prompt_elite2_setup () {
|
@@ -21,9 +21,12 @@
|
||||||
local text_col=${1:-'cyan'}
|
local text_col=${1:-'cyan'}
|
||||||
local parens_col=${2:-$text_col}
|
local parens_col=${2:-$text_col}
|
||||||
|
|
||||||
+ if [[ $1 == '8bit' ]]; then
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
+ shift
|
+ shift
|
||||||
for code in 332 304 300; do
|
local char_333 char_262 char_261 char_260
|
||||||
local char_$code=$(echo -n "\\0$code")
|
autoload -U prompt_special_chars
|
||||||
done
|
prompt_special_chars
|
||||||
+ fi
|
+ fi
|
||||||
|
|
||||||
local text="%{$fg_no_bold[$text_col]%}"
|
local text="%{$fg_no_bold[$text_col]%}"
|
||||||
local parens="%{$fg_bold[$parens_col]%}"
|
local parens="%{$fg_bold[$parens_col]%}"
|
||||||
Only in zsh-4.3.4/Functions/Prompts: prompt_elite2_setup~
|
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.6/Functions/Prompts/prompt_elite_setup
|
||||||
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.4/Functions/Prompts/prompt_elite_setup
|
--- zsh-4.3.6-orig/Functions/Prompts/prompt_elite_setup 2007-06-14 12:11:39.000000000 -0400
|
||||||
--- zsh-4.3.4-orig/Functions/Prompts/prompt_elite_setup 2005-05-10 00:39:02.000000000 -0400
|
+++ zsh-4.3.6/Functions/Prompts/prompt_elite_setup 2008-08-25 16:26:21.000000000 -0400
|
||||||
+++ zsh-4.3.4/Functions/Prompts/prompt_elite_setup 2007-12-03 20:41:02.000000000 -0500
|
@@ -6,7 +6,7 @@
|
||||||
@@ -6,7 +6,7 @@ prompt_elite_help () {
|
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -62,24 +60,23 @@ diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.4/Function
|
|||||||
|
|
||||||
The default colors are red and blue respectively. This theme is
|
The default colors are red and blue respectively. This theme is
|
||||||
intended for use with a black background.
|
intended for use with a black background.
|
||||||
@@ -20,9 +20,12 @@ prompt_elite_setup () {
|
@@ -21,9 +21,12 @@
|
||||||
local text=${1:-'red'}
|
local text=${1:-'red'}
|
||||||
local punctuation=${2:-'blue'}
|
local punctuation=${2:-'blue'}
|
||||||
|
|
||||||
+ if [[ $1 == '8bit' ]]; then
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
+ shift
|
+ shift
|
||||||
for code in 332 304 371 372 300; do
|
local char_333 char_262 char_261 char_260
|
||||||
local char_$code=$(echo -n "\\0$code")
|
autoload -U prompt_special_chars
|
||||||
done
|
prompt_special_chars
|
||||||
+ fi
|
+ fi
|
||||||
|
|
||||||
PS1="%{$fg[$text]%}$char_332$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%n%{$fg[$punctuation]%}@%{$fg[$text]%}%m%{$fg[$punctuation]%})%{$fg[$text]%}-%{$fg[$punctuation]%}(%{$fg[$text]%}%D{%I:%M%P}%{$fg[$punctuation]%}-:-%{$fg[$text]%}%D{%m}%{$fg[$punctuation]$fg[$text]%}/%D{%d}%{$fg[$punctuation]%})%{$fg[$text]%}$char_304-%{$fg[$punctuation]]%}$char_371%{$fg[$text]%}-$char_371$char_371%{$fg[$punctuation]%}$char_372$prompt_newline%{$fg[$text]%}$char_300$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%1~%{$fg[$punctuation]%})%{$fg[$text]%}$char_304$char_371%{$fg[$punctuation]%}$char_372%{$reset_color%}"
|
PS1="%{$fg[$text]%}$char_332$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%n%{$fg[$punctuation]%}@%{$fg[$text]%}%m%{$fg[$punctuation]%})%{$fg[$text]%}-%{$fg[$punctuation]%}(%{$fg[$text]%}%D{%I:%M%P}%{$fg[$punctuation]%}-:-%{$fg[$text]%}%D{%m}%{$fg[$punctuation]$fg[$text]%}/%D{%d}%{$fg[$punctuation]%})%{$fg[$text]%}$char_304-%{$fg[$punctuation]]%}$char_371%{$fg[$text]%}-$char_371$char_371%{$fg[$punctuation]%}$char_372$prompt_newline%{$fg[$text]%}$char_300$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%1~%{$fg[$punctuation]%})%{$fg[$text]%}$char_304$char_371%{$fg[$punctuation]%}$char_372%{$reset_color%}"
|
||||||
PS2="> "
|
PS2="> "
|
||||||
Only in zsh-4.3.4/Functions/Prompts: prompt_elite_setup~
|
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.6/Functions/Prompts/prompt_fade_setup
|
||||||
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.4/Functions/Prompts/prompt_fade_setup
|
--- zsh-4.3.6-orig/Functions/Prompts/prompt_fade_setup 2007-06-14 12:11:39.000000000 -0400
|
||||||
--- zsh-4.3.4-orig/Functions/Prompts/prompt_fade_setup 2005-05-10 00:39:02.000000000 -0400
|
+++ zsh-4.3.6/Functions/Prompts/prompt_fade_setup 2008-08-25 16:26:51.000000000 -0400
|
||||||
+++ zsh-4.3.4/Functions/Prompts/prompt_fade_setup 2007-12-03 20:41:35.000000000 -0500
|
@@ -7,7 +7,7 @@
|
||||||
@@ -7,7 +7,7 @@ prompt_fade_help () {
|
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -88,24 +85,23 @@ diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.4/Functions
|
|||||||
|
|
||||||
where the parameters are the colors for the fade-bar and current
|
where the parameters are the colors for the fade-bar and current
|
||||||
working directory, user@host text, and date text respectively. The
|
working directory, user@host text, and date text respectively. The
|
||||||
@@ -27,9 +27,12 @@ prompt_fade_setup () {
|
@@ -27,9 +27,12 @@
|
||||||
local userhost=${2:-'white'}
|
local userhost=${2:-'white'}
|
||||||
local date=${3:-'white'}
|
local date=${3:-'white'}
|
||||||
|
|
||||||
+ if [[ $1 == '8bit' ]]; then
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
+ shift
|
+ shift
|
||||||
for code in 333 262 261 260; do
|
local char_333 char_262 char_261 char_260
|
||||||
local char_$code=$(echo -n "\\0$code")
|
autoload -U prompt_special_chars
|
||||||
done
|
prompt_special_chars
|
||||||
+ fi
|
+ fi
|
||||||
|
|
||||||
PS1="%{$fg[$fadebar_cwd]$bg[$fadebar_cwd]$bold_color%}$char_333$char_262$char_261$char_260%{$fg[$userhost]$bg[$fadebar_cwd]$bold_color%}%n@%m%{$reset_color$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$fg[$date]$bg[grey]$bold_color%} %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%{$fg[$fadebar_cwd]$bg[grey]$bold_color%}%~/%{$reset_color%} "
|
PS1="%{$fg[$fadebar_cwd]$bg[$fadebar_cwd]$bold_color%}$char_333$char_262$char_261$char_260%{$fg[$userhost]$bg[$fadebar_cwd]$bold_color%}%n@%m%{$reset_color$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$fg[$date]$bg[grey]$bold_color%} %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%{$fg[$fadebar_cwd]$bg[grey]$bold_color%}%~/%{$reset_color%} "
|
||||||
PS2="%{$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$reset_color%}>"
|
PS2="%{$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$reset_color%}>"
|
||||||
Only in zsh-4.3.4/Functions/Prompts: prompt_fade_setup~
|
diff -ru zsh-4.3.6-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.6/Functions/Prompts/prompt_fire_setup
|
||||||
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.4/Functions/Prompts/prompt_fire_setup
|
--- zsh-4.3.6-orig/Functions/Prompts/prompt_fire_setup 2007-06-14 12:11:39.000000000 -0400
|
||||||
--- zsh-4.3.4-orig/Functions/Prompts/prompt_fire_setup 2005-05-10 00:39:02.000000000 -0400
|
+++ zsh-4.3.6/Functions/Prompts/prompt_fire_setup 2008-08-25 16:27:09.000000000 -0400
|
||||||
+++ zsh-4.3.4/Functions/Prompts/prompt_fire_setup 2007-12-03 20:41:26.000000000 -0500
|
@@ -8,7 +8,7 @@
|
||||||
@@ -8,7 +8,7 @@ prompt_fire_help () {
|
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -114,17 +110,16 @@ diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.4/Functions
|
|||||||
|
|
||||||
where the parameters are the three fire colors, and the colors for the
|
where the parameters are the three fire colors, and the colors for the
|
||||||
user@host text, date text, and current working directory respectively.
|
user@host text, date text, and current working directory respectively.
|
||||||
@@ -28,9 +28,12 @@ prompt_fire_setup () {
|
@@ -29,9 +29,12 @@
|
||||||
local date=${5:-'white'}
|
local date=${5:-'white'}
|
||||||
local cwd=${6:-'yellow'}
|
local cwd=${6:-'yellow'}
|
||||||
|
|
||||||
+ if [[ $1 == '8bit' ]]; then
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
+ shift
|
+ shift
|
||||||
for code in 333 262 261 260; do
|
local char_333 char_262 char_261 char_260
|
||||||
local char_$code=$(echo -n "\\0$code")
|
autoload -U prompt_special_chars
|
||||||
done
|
prompt_special_chars
|
||||||
+ fi
|
+ fi
|
||||||
|
|
||||||
local GRAD1="%{$char_333$char_262$char_261$char_260%}"
|
local GRAD1="%{$char_333$char_262$char_261$char_260%}"
|
||||||
local GRAD2="%{$char_260$char_261$char_262$char_333%}"
|
local GRAD2="%{$char_260$char_261$char_262$char_333%}"
|
||||||
Only in zsh-4.3.4/Functions/Prompts: prompt_fire_setup~
|
|
12
zsh.spec
12
zsh.spec
@ -2,12 +2,12 @@
|
|||||||
|
|
||||||
Summary: A powerful interactive shell
|
Summary: A powerful interactive shell
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 4.3.4
|
Version: 4.3.6
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://zsh.sunsite.dk/
|
URL: http://zsh.sunsite.dk/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
Source0: ftp://ftp.zsh.org/pub/zsh-%{version}.tar.gz
|
Source0: ftp://ftp.zsh.org/pub/zsh-%{version}.tar.bz2
|
||||||
Source1: zlogin.rhs
|
Source1: zlogin.rhs
|
||||||
Source2: zlogout.rhs
|
Source2: zlogout.rhs
|
||||||
Source3: zprofile.rhs
|
Source3: zprofile.rhs
|
||||||
@ -18,7 +18,7 @@ Source7: zshprompt.pl
|
|||||||
Patch0: zsh-serial.patch
|
Patch0: zsh-serial.patch
|
||||||
#Patch1: zsh-4.0.6-make-test-fail.patch
|
#Patch1: zsh-4.0.6-make-test-fail.patch
|
||||||
#Patch3: zsh-4.0.7-bckgrnd-bld-102042.patch
|
#Patch3: zsh-4.0.7-bckgrnd-bld-102042.patch
|
||||||
Patch4: zsh-4.3.4-8bit-prompts.patch
|
Patch4: zsh-4.3.6-8bit-prompts.patch
|
||||||
Prereq: fileutils grep /sbin/install-info
|
Prereq: fileutils grep /sbin/install-info
|
||||||
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
BuildRequires: mktemp coreutils sed ncurses-devel libcap-devel texinfo tetex texi2html gawk
|
BuildRequires: mktemp coreutils sed ncurses-devel libcap-devel texinfo tetex texi2html gawk
|
||||||
@ -152,6 +152,10 @@ fi
|
|||||||
%doc Doc/*.html
|
%doc Doc/*.html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 25 2008 James Antill <james@fedoraproject.org> - 4.3.6-1
|
||||||
|
- Import new upstream 4.3.6
|
||||||
|
- Rebase 8bit prompt patch.
|
||||||
|
|
||||||
* Thu Jan 31 2008 James Antill <james@fedoraproject.org> - 4.3.4-7
|
* Thu Jan 31 2008 James Antill <james@fedoraproject.org> - 4.3.4-7
|
||||||
- Tweak /etc/zshrc to source /etc/profile.d/*.sh in ksh compat. mode
|
- Tweak /etc/zshrc to source /etc/profile.d/*.sh in ksh compat. mode
|
||||||
- Tweak /etc/zprofile to source /etc/profile in ksh compat. mode
|
- Tweak /etc/zprofile to source /etc/profile in ksh compat. mode
|
||||||
|
Loading…
Reference in New Issue
Block a user