auto-import changelog data from zsh-4.0.4-8.src.rpm
Fri Jun 28 2002 Trond Eivind Glomsrd <teg@redhat.com> 4.0.4-8 - Make it work with a serial port (#56353) - Add $HOME/bin to path for login shells (#67110)
This commit is contained in:
parent
4e02adcfb9
commit
92bd44f922
@ -3,3 +3,7 @@
|
|||||||
#
|
#
|
||||||
|
|
||||||
# all bourne shells should source /etc/profile
|
# all bourne shells should source /etc/profile
|
||||||
|
|
||||||
|
|
||||||
|
PATH="$PATH:$HOME/bin"
|
||||||
|
export PATH
|
||||||
|
65
zsh-serial.patch
Normal file
65
zsh-serial.patch
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
--- zsh-4.0.4/Src/builtin.c.open Tue Oct 16 02:49:17 2001
|
||||||
|
+++ zsh-4.0.4/Src/builtin.c Wed May 15 11:55:32 2002
|
||||||
|
@@ -3489,7 +3489,7 @@ bin_read(char *name, char **args, char *
|
||||||
|
if (!zleactive) {
|
||||||
|
if (SHTTY == -1) {
|
||||||
|
/* need to open /dev/tty specially */
|
||||||
|
- if ((SHTTY = open("/dev/tty", O_RDWR|O_NOCTTY)) != -1) {
|
||||||
|
+ if ((SHTTY = block_open("/dev/tty", O_RDWR|O_NOCTTY)) != -1) {
|
||||||
|
haso = 1;
|
||||||
|
oshout = shout;
|
||||||
|
init_shout();
|
||||||
|
--- zsh-4.0.4/Src/init.c.open Wed Oct 24 04:16:32 2001
|
||||||
|
+++ zsh-4.0.4/Src/init.c Wed May 15 12:00:07 2002
|
||||||
|
@@ -397,7 +397,7 @@ init_io(void)
|
||||||
|
if (isatty(0)) {
|
||||||
|
zsfree(ttystrname);
|
||||||
|
if ((ttystrname = ztrdup(ttyname(0)))) {
|
||||||
|
- SHTTY = movefd(open(ttystrname, O_RDWR | O_NOCTTY));
|
||||||
|
+ SHTTY = movefd(block_open(ttystrname, O_RDWR | O_NOCTTY));
|
||||||
|
#ifdef TIOCNXCL
|
||||||
|
/*
|
||||||
|
* See if the terminal claims to be busy. If so, and fd 0
|
||||||
|
@@ -438,7 +438,7 @@ init_io(void)
|
||||||
|
ttystrname = ztrdup(ttyname(1));
|
||||||
|
}
|
||||||
|
if (SHTTY == -1 &&
|
||||||
|
- (SHTTY = movefd(open("/dev/tty", O_RDWR | O_NOCTTY))) != -1) {
|
||||||
|
+ (SHTTY = movefd(block_open("/dev/tty", O_RDWR | O_NOCTTY))) != -1) {
|
||||||
|
zsfree(ttystrname);
|
||||||
|
ttystrname = ztrdup(ttyname(SHTTY));
|
||||||
|
}
|
||||||
|
@@ -1235,3 +1235,33 @@ zsh_main(int argc, char **argv)
|
||||||
|
: "use 'logout' to logout.", NULL, 0);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+/**/
|
||||||
|
+int
|
||||||
|
+block_open (const char *tty, int flags)
|
||||||
|
+{
|
||||||
|
+ int saved_errno;
|
||||||
|
+ int fd;
|
||||||
|
+
|
||||||
|
+ if ((flags & O_NONBLOCK) == 0) {
|
||||||
|
+ fd = open (tty, flags | O_NONBLOCK);
|
||||||
|
+ if (fd == -1)
|
||||||
|
+ return fd;
|
||||||
|
+ flags = fcntl(fd, F_GETFL);
|
||||||
|
+ if (flags == -1)
|
||||||
|
+ goto bad;
|
||||||
|
+ flags &= ~O_NONBLOCK;
|
||||||
|
+ if (fcntl(fd, F_SETFL, flags) == -1)
|
||||||
|
+ goto bad;
|
||||||
|
+ }
|
||||||
|
+ else
|
||||||
|
+ fd = open (tty, flags);
|
||||||
|
+
|
||||||
|
+ return fd;
|
||||||
|
+
|
||||||
|
+bad:
|
||||||
|
+ saved_errno = errno;
|
||||||
|
+ close (fd);
|
||||||
|
+ errno = saved_errno;
|
||||||
|
+ return -1;
|
||||||
|
+}
|
8
zsh.spec
8
zsh.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A shell similar to ksh, but with improvements.
|
Summary: A shell similar to ksh, but with improvements.
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 4.0.4
|
Version: 4.0.4
|
||||||
Release: 7
|
Release: 8
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
Source0: ftp://ftp.zsh.org/pub/zsh-%{version}.tar.bz2
|
Source0: ftp://ftp.zsh.org/pub/zsh-%{version}.tar.bz2
|
||||||
@ -10,6 +10,7 @@ Source2: zlogout.rhs
|
|||||||
Source3: zprofile.rhs
|
Source3: zprofile.rhs
|
||||||
Source4: zshrc.rhs
|
Source4: zshrc.rhs
|
||||||
Source5: zshenv.rhs
|
Source5: zshenv.rhs
|
||||||
|
Patch0: zsh-serial.patch
|
||||||
Prereq: fileutils grep /sbin/install-info
|
Prereq: fileutils grep /sbin/install-info
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
Requires: libcap
|
Requires: libcap
|
||||||
@ -26,6 +27,7 @@ mechanism, and more.
|
|||||||
%prep
|
%prep
|
||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1 -b .serial
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -97,6 +99,10 @@ fi
|
|||||||
%config(noreplace) /etc/*
|
%config(noreplace) /etc/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-8
|
||||||
|
- Make it work with a serial port (#56353)
|
||||||
|
- Add $HOME/bin to path for login shells (#67110)
|
||||||
|
|
||||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||||
- automated rebuild
|
- automated rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user