update to latest upstream release: 5.8.0
This commit is contained in:
parent
3eea62750b
commit
8dbf2fe7bf
@ -1,92 +0,0 @@
|
||||
From 15c190164c375cfe1772ebec92b544ca26a60e28 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 23 Jul 2019 14:45:48 +0200
|
||||
Subject: [PATCH 1/2] 44566: make sure Zle doesn't crash if history entry not
|
||||
found
|
||||
|
||||
Upstream-commit: f9cd2187875b6f2ebdb9b9a787fac20b2aaf745b
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
Src/Zle/zle_utils.c | 14 ++++++++++++--
|
||||
1 file changed, 12 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Src/Zle/zle_utils.c b/Src/Zle/zle_utils.c
|
||||
index c6df3d8..633f593 100644
|
||||
--- a/Src/Zle/zle_utils.c
|
||||
+++ b/Src/Zle/zle_utils.c
|
||||
@@ -1607,7 +1607,12 @@ static int
|
||||
unapplychange(struct change *ch)
|
||||
{
|
||||
if(ch->hist != histline) {
|
||||
- zle_setline(quietgethist(ch->hist));
|
||||
+ Histent he = quietgethist(ch->hist);
|
||||
+ if(!he) {
|
||||
+ dputs(ERRMSG("quietgethist(ch->hist) returned NULL"));
|
||||
+ return 1;
|
||||
+ }
|
||||
+ zle_setline(he);
|
||||
zlecs = ch->new_cs;
|
||||
return 0;
|
||||
}
|
||||
@@ -1647,7 +1652,12 @@ static int
|
||||
applychange(struct change *ch)
|
||||
{
|
||||
if(ch->hist != histline) {
|
||||
- zle_setline(quietgethist(ch->hist));
|
||||
+ Histent he = quietgethist(ch->hist);
|
||||
+ if(!he) {
|
||||
+ dputs(ERRMSG("quietgethist(ch->hist) returned NULL"));
|
||||
+ return 1;
|
||||
+ }
|
||||
+ zle_setline(he);
|
||||
zlecs = ch->old_cs;
|
||||
return 0;
|
||||
}
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
||||
From 10dedc96ce0de43372add239f8256e259ca1e04a Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Fri, 26 Jul 2019 17:24:59 +0200
|
||||
Subject: [PATCH 2/2] 44582: Fix foregoing commit to use DPUTS() better
|
||||
|
||||
Upstream-commit: d6a9e222ec6b006c09d6f84beae6ef488a19b214
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
Src/Zle/zle_utils.c | 10 ++++------
|
||||
1 file changed, 4 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/Src/Zle/zle_utils.c b/Src/Zle/zle_utils.c
|
||||
index 633f593..29dba08 100644
|
||||
--- a/Src/Zle/zle_utils.c
|
||||
+++ b/Src/Zle/zle_utils.c
|
||||
@@ -1608,10 +1608,9 @@ unapplychange(struct change *ch)
|
||||
{
|
||||
if(ch->hist != histline) {
|
||||
Histent he = quietgethist(ch->hist);
|
||||
- if(!he) {
|
||||
- dputs(ERRMSG("quietgethist(ch->hist) returned NULL"));
|
||||
+ DPUTS(he == NULL, "quietgethist(ch->hist) returned NULL");
|
||||
+ if(he == NULL)
|
||||
return 1;
|
||||
- }
|
||||
zle_setline(he);
|
||||
zlecs = ch->new_cs;
|
||||
return 0;
|
||||
@@ -1653,10 +1652,9 @@ applychange(struct change *ch)
|
||||
{
|
||||
if(ch->hist != histline) {
|
||||
Histent he = quietgethist(ch->hist);
|
||||
- if(!he) {
|
||||
- dputs(ERRMSG("quietgethist(ch->hist) returned NULL"));
|
||||
+ DPUTS(he == NULL, "quietgethist(ch->hist) returned NULL");
|
||||
+ if(he == NULL)
|
||||
return 1;
|
||||
- }
|
||||
zle_setline(he);
|
||||
zlecs = ch->old_cs;
|
||||
return 0;
|
||||
--
|
||||
2.20.1
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (zsh-5.7.1.tar.xz) = a6aa88e1955a80229a4784a128866e325f79a8b5f73c922ab480048411036f1835cbb31daa30ab38bd16ab2a50040eda8f4f1f64704b21b6acc3051b1dbf18d0
|
||||
SHA512 (zsh-5.8.tar.xz) = 96198ecef498b7d7945fecebbe6bf14065fa8c5d81a7662164579eba8206b79575812d292adea1864bc7487ac0818ba900e25f9ab3802449340de80417c2c533
|
||||
|
@ -1,11 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQEzBAABCAAdFiEEfKfsqvBiFrkPiUFGrPgUbK6Mu8QFAlxXSocACgkQrPgUbK6M
|
||||
u8SXPgf/Vw+pYfQXAlGy59MsmArJvU+72zP/Q8Cu9gSuLbNZetwR8Zkubibi1rpO
|
||||
zCFn0Ps9lR565k9ue+wPUtBhZjEPJVjNALdJK5YaKvh6Dir3/nhoVoS4kobJCHad
|
||||
k8X6ThID8zOwZ3E49n+2AiNxwKkSej6cUKzZ2CSGaZ077GgnY4M8y6ACSdwEp7w8
|
||||
f5W9gUMqxawx0PCfsxkoJNdNrWq0V2WAgVql3qqVqSvLzAijFXUqtDEauwHecDkw
|
||||
5NqWZVHLqJHWHyYImjo/RQnVcGHLCYLSOiHH9duo1VnLsXUNPC9+8yjTRkEte8UA
|
||||
38bf8N8gmpaI/sG1Z2v12VXqCV3eqA==
|
||||
=g3Uh
|
||||
-----END PGP SIGNATURE-----
|
11
zsh-5.8.tar.xz.asc
Normal file
11
zsh-5.8.tar.xz.asc
Normal file
@ -0,0 +1,11 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQEzBAABCAAdFiEEfKfsqvBiFrkPiUFGrPgUbK6Mu8QFAl5HHTEACgkQrPgUbK6M
|
||||
u8Ttmwf/U1HoG30yYZ4m3yxFZ8QGI0WwnV7/IAQ4rMBWo+31yijLrwnl8+WILVfi
|
||||
gRzskwTrVmLjklT4hnv3aSyO1KtQMDImCYw01JbK801JCnCRRRTKVTC69S1TQ9FI
|
||||
mp+GB+QemYAdDRZwIlZcuVmhL7MJS0IWZiwqzlvqyKGG4MCrzqPqKO3s/JgMisUG
|
||||
KLHZJWoUWidYfmuwkPRKXN+dcnZUF4B/jJbNwLRGhvySzpT6pAwI2SBWak+vUbs/
|
||||
UKal6pOHYv1zalMrh5as2/hAo4Rjpsgn0zRGiFsn5Ys9srB6XKhXifUP6d1g3cRj
|
||||
lH9B3QGrd1oh7u8IOjU29F8+DeeU+g==
|
||||
=+BhZ
|
||||
-----END PGP SIGNATURE-----
|
10
zsh.spec
10
zsh.spec
@ -1,7 +1,7 @@
|
||||
Summary: Powerful interactive shell
|
||||
Name: zsh
|
||||
Version: 5.7.1
|
||||
Release: 5%{?dist}
|
||||
Version: 5.8
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://zsh.sourceforge.net/
|
||||
Source0: https://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
||||
@ -12,9 +12,6 @@ Source4: zshrc.rhs
|
||||
Source5: zshenv.rhs
|
||||
Source6: dotzshrc
|
||||
|
||||
# make failed searches of history in Zle robust (#1722703)
|
||||
Patch1: 0001-zsh-5.7.1-zle-history-avoid-crash.patch
|
||||
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: coreutils
|
||||
BuildRequires: gawk
|
||||
@ -157,6 +154,9 @@ fi
|
||||
%doc Doc/*.html
|
||||
|
||||
%changelog
|
||||
* Mon Feb 24 2020 Kamil Dudka <kdudka@redhat.com> - 5.8-1
|
||||
- update to latest upstream release
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.7.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user