Add patch to fix VCS_INFO_nbvsformats bug.
This commit is contained in:
parent
d4994fb6d9
commit
6fca6daab2
31
zsh-5.2-vcs_info.patch
Normal file
31
zsh-5.2-vcs_info.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
Fix bug in VCS_INFO_nbcsformats which breaks my prompt....
|
||||||
|
|
||||||
|
Reported upstream in:
|
||||||
|
http://www.zsh.org/mla/users/2016/msg00007.html
|
||||||
|
And fix suggested in:
|
||||||
|
http://www.zsh.org/mla/users/2016/msg00008.html
|
||||||
|
|
||||||
|
diff --git a/Functions/VCS_Info/VCS_INFO_nvcsformats b/Functions/VCS_Info/VCS_INFO_nvcsformats
|
||||||
|
index 203a86d..581aa5a 100644
|
||||||
|
--- a/Functions/VCS_Info/VCS_INFO_nvcsformats
|
||||||
|
+++ b/Functions/VCS_Info/VCS_INFO_nvcsformats
|
||||||
|
@@ -4,7 +4,6 @@
|
||||||
|
|
||||||
|
setopt localoptions noksharrays NO_shwordsplit
|
||||||
|
local c v rr
|
||||||
|
-local -a msgs
|
||||||
|
|
||||||
|
if [[ $1 == '-preinit-' ]] ; then
|
||||||
|
c='default'
|
||||||
|
diff --git a/Functions/VCS_Info/vcs_info b/Functions/VCS_Info/vcs_info
|
||||||
|
index 628dde9..a44cd9e 100644
|
||||||
|
--- a/Functions/VCS_Info/vcs_info
|
||||||
|
+++ b/Functions/VCS_Info/vcs_info
|
||||||
|
@@ -10,6 +10,7 @@
|
||||||
|
|
||||||
|
setopt localoptions noksharrays extendedglob NO_shwordsplit
|
||||||
|
local file func sys
|
||||||
|
+local -a msgs
|
||||||
|
local -a static_functions
|
||||||
|
local -i maxexports
|
||||||
|
|
9
zsh.spec
9
zsh.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: Powerful interactive shell
|
Summary: Powerful interactive shell
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 5.2
|
Version: 5.2
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://zsh.sourceforge.net/
|
URL: http://zsh.sourceforge.net/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -24,6 +24,9 @@ Patch2: zsh-test-C02-dev_fd-mock.patch
|
|||||||
# update zsh completion script for dnf to the latest upstream version
|
# update zsh completion script for dnf to the latest upstream version
|
||||||
Patch3: zsh-5.2-comp-dnf.patch
|
Patch3: zsh-5.2-comp-dnf.patch
|
||||||
|
|
||||||
|
# Fix to a minor VCS_INFO bug from http://www.zsh.org/mla/users/2016/msg00008.html
|
||||||
|
Patch4: zsh-5.2-vcs_info.patch
|
||||||
|
|
||||||
BuildRequires: coreutils sed ncurses-devel libcap-devel
|
BuildRequires: coreutils sed ncurses-devel libcap-devel
|
||||||
BuildRequires: texinfo texi2html gawk hostname
|
BuildRequires: texinfo texi2html gawk hostname
|
||||||
Requires(post): info grep
|
Requires(post): info grep
|
||||||
@ -61,6 +64,7 @@ This package contains the Zsh manual in html format.
|
|||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
|
||||||
cp -p %SOURCE7 .
|
cp -p %SOURCE7 .
|
||||||
|
|
||||||
@ -164,6 +168,9 @@ fi
|
|||||||
%doc Doc/*.html
|
%doc Doc/*.html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 07 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 5.2-3
|
||||||
|
- Add patch to fix VCS_INFO_nbvsformats bug.
|
||||||
|
|
||||||
* Fri Dec 25 2015 Adrien Vergé <adrienverge@gmail.com> - 5.2-2
|
* Fri Dec 25 2015 Adrien Vergé <adrienverge@gmail.com> - 5.2-2
|
||||||
- update zsh completion script for dnf to the latest upstream version
|
- update zsh completion script for dnf to the latest upstream version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user