Update to latest upstream release: Zsh 5.2
This commit is contained in:
parent
b5cac6b431
commit
624aa08874
2
sources
2
sources
@ -1 +1 @@
|
|||||||
0e8ea3313300277a04cee80836507bae zsh-5.1.1.tar.xz
|
afe96fde08b70e23c1cab1ca7a68fb34 zsh-5.2.tar.xz
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -1,45 +0,0 @@
|
|||||||
From 12914ffb8af4f850637ee92bc2997218de6a179c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Stephenson <pws@zsh.org>
|
|
||||||
Date: Tue, 6 Oct 2015 09:28:07 +0100
|
|
||||||
Subject: [PATCH] 36780: Fix crash in ksh mode with -n and $HOME.
|
|
||||||
|
|
||||||
If home variable is NULL ensure HOME is unset.
|
|
||||||
|
|
||||||
Upstream-commit: 83a175795a444e8169fcb592a110d4d15a09b907
|
|
||||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
|
||||||
---
|
|
||||||
Src/params.c | 13 +++++++------
|
|
||||||
1 file changed, 7 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Src/params.c b/Src/params.c
|
|
||||||
index de151a4..a8abb28 100644
|
|
||||||
--- a/Src/params.c
|
|
||||||
+++ b/Src/params.c
|
|
||||||
@@ -775,17 +775,18 @@ createparamtable(void)
|
|
||||||
#endif
|
|
||||||
opts[ALLEXPORT] = oae;
|
|
||||||
|
|
||||||
+ /*
|
|
||||||
+ * For native emulation we always set the variable home
|
|
||||||
+ * (see setupvals()).
|
|
||||||
+ */
|
|
||||||
+ pm = (Param) paramtab->getnode(paramtab, "HOME");
|
|
||||||
if (EMULATION(EMULATE_ZSH))
|
|
||||||
{
|
|
||||||
- /*
|
|
||||||
- * For native emulation we always set the variable home
|
|
||||||
- * (see setupvals()).
|
|
||||||
- */
|
|
||||||
- pm = (Param) paramtab->getnode(paramtab, "HOME");
|
|
||||||
pm->node.flags &= ~PM_UNSET;
|
|
||||||
if (!(pm->node.flags & PM_EXPORTED))
|
|
||||||
addenv(pm, home);
|
|
||||||
- }
|
|
||||||
+ } else if (!home)
|
|
||||||
+ pm->node.flags |= PM_UNSET;
|
|
||||||
pm = (Param) paramtab->getnode(paramtab, "LOGNAME");
|
|
||||||
if (!(pm->node.flags & PM_EXPORTED))
|
|
||||||
addenv(pm, pm->u.str);
|
|
||||||
--
|
|
||||||
2.5.2
|
|
||||||
|
|
@ -6,7 +6,7 @@ diff --git a/Src/builtin.c b/Src/builtin.c
|
|||||||
index 9358e8b..ee14f91 100644
|
index 9358e8b..ee14f91 100644
|
||||||
--- a/Src/builtin.c
|
--- a/Src/builtin.c
|
||||||
+++ b/Src/builtin.c
|
+++ b/Src/builtin.c
|
||||||
@@ -5631,7 +5631,7 @@ bin_read(char *name, char **args, Options ops, UNUSED(int func))
|
@@ -5674,7 +5674,7 @@ bin_read(char *name, char **args, Options ops, UNUSED(int func))
|
||||||
if (!zleactive) {
|
if (!zleactive) {
|
||||||
if (SHTTY == -1) {
|
if (SHTTY == -1) {
|
||||||
/* need to open /dev/tty specially */
|
/* need to open /dev/tty specially */
|
||||||
@ -37,7 +37,7 @@ index 102276a..238f6ed 100644
|
|||||||
zsfree(ttystrname);
|
zsfree(ttystrname);
|
||||||
ttystrname = ztrdup(ttyname(SHTTY));
|
ttystrname = ztrdup(ttyname(SHTTY));
|
||||||
}
|
}
|
||||||
@@ -1711,3 +1711,33 @@ zsh_main(UNUSED(int argc), char **argv)
|
@@ -1713,3 +1713,33 @@ zsh_main(UNUSED(int argc), char **argv)
|
||||||
: "use 'logout' to logout.");
|
: "use 'logout' to logout.");
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
13
zsh.spec
13
zsh.spec
@ -2,12 +2,12 @@
|
|||||||
|
|
||||||
Summary: Powerful interactive shell
|
Summary: Powerful interactive shell
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 5.1.1
|
Version: 5.2
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://zsh.sourceforge.net/
|
URL: http://zsh.sourceforge.net/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}.tar.xz
|
Source0: http://www.zsh.org/pub/%{name}-%{version}.tar.xz
|
||||||
Source1: zlogin.rhs
|
Source1: zlogin.rhs
|
||||||
Source2: zlogout.rhs
|
Source2: zlogout.rhs
|
||||||
Source3: zprofile.rhs
|
Source3: zprofile.rhs
|
||||||
@ -21,9 +21,6 @@ Patch0: zsh-serial.patch
|
|||||||
Patch1: zsh-4.3.6-8bit-prompts.patch
|
Patch1: zsh-4.3.6-8bit-prompts.patch
|
||||||
Patch2: zsh-test-C02-dev_fd-mock.patch
|
Patch2: zsh-test-C02-dev_fd-mock.patch
|
||||||
|
|
||||||
# fix crash in ksh mode with -n and $HOME (#1269883)
|
|
||||||
Patch3: zsh-5.1.1-ksh-n-home.patch
|
|
||||||
|
|
||||||
BuildRequires: coreutils sed ncurses-devel libcap-devel
|
BuildRequires: coreutils sed ncurses-devel libcap-devel
|
||||||
BuildRequires: texinfo texi2html gawk hostname
|
BuildRequires: texinfo texi2html gawk hostname
|
||||||
Requires(post): info grep
|
Requires(post): info grep
|
||||||
@ -60,7 +57,6 @@ This package contains the Zsh manual in html format.
|
|||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
%patch2 -p1
|
||||||
%patch3 -p1
|
|
||||||
|
|
||||||
cp -p %SOURCE7 .
|
cp -p %SOURCE7 .
|
||||||
|
|
||||||
@ -164,6 +160,9 @@ fi
|
|||||||
%doc Doc/*.html
|
%doc Doc/*.html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 03 2015 Kamil Dudka <kdudka@redhat.com> - 5.2-1
|
||||||
|
- Update to latest upstream release: Zsh 5.2
|
||||||
|
|
||||||
* Thu Nov 05 2015 Kamil Dudka <kdudka@redhat.com> - 5.1.1-3
|
* Thu Nov 05 2015 Kamil Dudka <kdudka@redhat.com> - 5.1.1-3
|
||||||
- make loading of module's dependencies work again (#1277996)
|
- make loading of module's dependencies work again (#1277996)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user