improve signal name generation
Prevents Test/C03traps.ztst from failing.
This commit is contained in:
parent
f4499343c8
commit
53bf4e6df6
42
zsh-5.0.7-signal-name.patch
Normal file
42
zsh-5.0.7-signal-name.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From 9f9b98e0fe83c8aab493369c0671360ed06e138b Mon Sep 17 00:00:00 2001
|
||||
From: Peter Stephenson <pws@zsh.org>
|
||||
Date: Thu, 15 Jan 2015 13:50:09 +0000
|
||||
Subject: [PATCH] 34287: preprocessor for signal name generation.
|
||||
|
||||
Some gcc header files are difficult for the signames2.awk
|
||||
script to process, so if the preprocessor is gcc give the
|
||||
option -P to strip out the unwanted additions.
|
||||
|
||||
Upstream-commit: c7aa6443907ddd97b6b1e8729ce9c897de0d244c
|
||||
Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
||||
---
|
||||
Src/zsh.mdd | 11 ++++++++++-
|
||||
1 file changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Src/zsh.mdd b/Src/zsh.mdd
|
||||
index 9a8c923..469e91b 100644
|
||||
--- a/Src/zsh.mdd
|
||||
+++ b/Src/zsh.mdd
|
||||
@@ -21,9 +21,18 @@ hdrdeps="zshcurses.h zshterm.h"
|
||||
:<<\Make
|
||||
@CONFIG_MK@
|
||||
|
||||
+# If we're using gcc as the preprocessor, get rid of the additional
|
||||
+# lines generated by the preprocessor as they can confuse the script.
|
||||
+# We don't need these in other cases either, but can't necessarily rely
|
||||
+# on the option to remove them being the same.
|
||||
signames.c: signames1.awk signames2.awk ../config.h @SIGNAL_H@
|
||||
$(AWK) -f $(sdir)/signames1.awk @SIGNAL_H@ >sigtmp.c
|
||||
- $(CPP) sigtmp.c >sigtmp.out
|
||||
+ case "$(CPP)" in \
|
||||
+ gcc*) \
|
||||
+ $(CPP) -P sigtmp.c >sigtmp.out;; \
|
||||
+ *) \
|
||||
+ $(CPP) sigtmp.c >sigtmp.out;; \
|
||||
+ esac
|
||||
$(AWK) -f $(sdir)/signames2.awk sigtmp.out > $@
|
||||
rm -f sigtmp.c sigtmp.out
|
||||
|
||||
--
|
||||
2.1.0
|
||||
|
4
zsh.spec
4
zsh.spec
@ -35,6 +35,9 @@ Patch9: zsh-5.0.7-heredocs-sigsegv.patch
|
||||
# queue signals when manipulating global state to avoid deadlock
|
||||
Patch10: zsh-5.0.7-signal-safety.patch
|
||||
|
||||
# improve signal name generation (prevents Test/C03traps.ztst from failing)
|
||||
Patch11: zsh-5.0.7-signal-name.patch
|
||||
|
||||
BuildRequires: coreutils sed ncurses-devel libcap-devel
|
||||
BuildRequires: texinfo texi2html gawk hostname
|
||||
Requires(post): info grep
|
||||
@ -76,6 +79,7 @@ This package contains the Zsh manual in html format.
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
|
||||
cp -p %SOURCE7 .
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user