Related: #1162198 - update documentation of POSIX_JOBS in the zshoptions.1 man page
This commit is contained in:
parent
00e87b82c5
commit
5385c4a599
@ -15,12 +15,13 @@ Signed-off-by: Kamil Dudka <kdudka@redhat.com>
|
|||||||
---
|
---
|
||||||
Doc/Zsh/builtins.yo | 16 ++++++
|
Doc/Zsh/builtins.yo | 16 ++++++
|
||||||
Doc/Zsh/options.yo | 8 +--
|
Doc/Zsh/options.yo | 8 +--
|
||||||
|
Doc/zshoptions.1 | 8 +--
|
||||||
Src/exec.c | 2 -
|
Src/exec.c | 2 -
|
||||||
Src/init.c | 1 -
|
Src/init.c | 1 -
|
||||||
Src/jobs.c | 138 ++++++++++++++++++++++++++++++++++++++++++++--------
|
Src/jobs.c | 138 ++++++++++++++++++++++++++++++++++++++++++++--------
|
||||||
Src/linklist.c | 4 ++
|
Src/linklist.c | 4 ++
|
||||||
Src/signals.c | 14 +++---
|
Src/signals.c | 14 +++---
|
||||||
7 files changed, 148 insertions(+), 35 deletions(-)
|
8 files changed, 152 insertions(+), 39 deletions(-)
|
||||||
|
|
||||||
diff --git a/Doc/Zsh/builtins.yo b/Doc/Zsh/builtins.yo
|
diff --git a/Doc/Zsh/builtins.yo b/Doc/Zsh/builtins.yo
|
||||||
index 46f40cc..edc335e 100644
|
index 46f40cc..edc335e 100644
|
||||||
@ -68,6 +69,25 @@ index 068a253..452b258 100644
|
|||||||
)
|
)
|
||||||
enditem()
|
enditem()
|
||||||
|
|
||||||
|
diff --git a/Doc/zshoptions.1 b/Doc/zshoptions.1
|
||||||
|
index cc0bd7e..038e259 100644
|
||||||
|
--- a/Doc/zshoptions.1
|
||||||
|
+++ b/Doc/zshoptions.1
|
||||||
|
@@ -892,10 +892,10 @@ shell is saved for output within a subshell (for example, within a
|
||||||
|
pipeline)\&. When the option is set, the output of \fBjobs\fP is empty
|
||||||
|
until a job is started within the subshell\&.
|
||||||
|
.PP
|
||||||
|
-When the option is set, it becomes possible to use the \fBwait\fP builtin to
|
||||||
|
-wait for the last job started in the background (as given by \fB$!\fP) even
|
||||||
|
-if that job has already exited\&. This works even if the option is turned
|
||||||
|
-on temporarily around the use of the \fBwait\fP builtin\&.
|
||||||
|
+In previous versions of the shell, it was necessary to enable
|
||||||
|
+\fBPOSIX_JOBS\fP in order for the builtin command \fBwait\fP to return the
|
||||||
|
+status of background jobs that had already exited\&. This is no longer
|
||||||
|
+the case\&.
|
||||||
|
.RE
|
||||||
|
.PP
|
||||||
|
.SS "Prompting"
|
||||||
diff --git a/Src/exec.c b/Src/exec.c
|
diff --git a/Src/exec.c b/Src/exec.c
|
||||||
index d0fadd6..a9c4688 100644
|
index d0fadd6..a9c4688 100644
|
||||||
--- a/Src/exec.c
|
--- a/Src/exec.c
|
||||||
|
5
zsh.spec
5
zsh.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: Powerful interactive shell
|
Summary: Powerful interactive shell
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 5.0.7
|
Version: 5.0.7
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://zsh.sourceforge.net/
|
URL: http://zsh.sourceforge.net/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -190,6 +190,9 @@ fi
|
|||||||
%doc Doc/*.html
|
%doc Doc/*.html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 19 2014 Kamil Dudka <kdudka@redhat.com> - 5.0.7-4
|
||||||
|
- update documentation of POSIX_JOBS in the zshoptions.1 man page (#1162198)
|
||||||
|
|
||||||
* Tue Nov 18 2014 Kamil Dudka <kdudka@redhat.com> - 5.0.7-3
|
* Tue Nov 18 2014 Kamil Dudka <kdudka@redhat.com> - 5.0.7-3
|
||||||
- replace an incorrect comment in /etc/zshenv (#1164313)
|
- replace an incorrect comment in /etc/zshenv (#1164313)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user