- Fix 8bit chars in prompts.
- Resolves: 375211
This commit is contained in:
parent
7e544d9a13
commit
3e4841cabd
130
zsh-4.3.4-8bit-prompts.patch
Normal file
130
zsh-4.3.4-8bit-prompts.patch
Normal file
@ -0,0 +1,130 @@
|
|||||||
|
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.4/Functions/Prompts/prompt_bigfade_setup
|
||||||
|
--- zsh-4.3.4-orig/Functions/Prompts/prompt_bigfade_setup 2005-05-10 00:39:02.000000000 -0400
|
||||||
|
+++ zsh-4.3.4/Functions/Prompts/prompt_bigfade_setup 2007-12-03 20:42:09.000000000 -0500
|
||||||
|
@@ -7,7 +7,7 @@ prompt_bigfade_help () {
|
||||||
|
cat <<EOH
|
||||||
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
|
- prompt bigfade [<fade-bar> [<userhost> [<date> [<cwd>]]]]
|
||||||
|
+ prompt bigfade [8bit] [<fade-bar> [<userhost> [<date> [<cwd>]]]]
|
||||||
|
|
||||||
|
where the parameters are the colors for the fade-bar, user@host text,
|
||||||
|
date text, and current working directory respectively. The default
|
||||||
|
@@ -25,9 +25,12 @@ prompt_bigfade_setup () {
|
||||||
|
local date=${3:-'white'}
|
||||||
|
local cwd=${4:-'yellow'}
|
||||||
|
|
||||||
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
|
+ shift
|
||||||
|
for code in 333 262 261 260; do
|
||||||
|
local char_$code=$(echo -n "\\0$code")
|
||||||
|
done
|
||||||
|
+ fi
|
||||||
|
|
||||||
|
PS1="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$userhost]$bg[$fadebar]%}%n@%m%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$fg[$date]$bg[grey]%} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%{$bold_color$fg[$cwd]$bg[grey]%}$PWD>%{$reset_color%} "
|
||||||
|
PS2="%{$bold_color$fg[$fadebar]$bold_color%}$char_333$char_262$char_261$char_260%{$reset_color$fg[$fadebar]$bg[grey]%}$char_260$char_261$char_262$char_333%{$reset_color$fg[$fadebar]$bg[grey]%}$char_333$char_262$char_261$char_260%{$bold_color$bold_color$fg[$fadebar]%}>%{$reset_color%} "
|
||||||
|
Only in zsh-4.3.4/Functions/Prompts: prompt_bigfade_setup~
|
||||||
|
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.4/Functions/Prompts/prompt_elite2_setup
|
||||||
|
--- zsh-4.3.4-orig/Functions/Prompts/prompt_elite2_setup 2005-05-10 00:39:02.000000000 -0400
|
||||||
|
+++ zsh-4.3.4/Functions/Prompts/prompt_elite2_setup 2007-12-03 20:41:14.000000000 -0500
|
||||||
|
@@ -6,7 +6,7 @@ prompt_elite2_help () {
|
||||||
|
cat <<EOH
|
||||||
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
|
- prompt elite2 [<text-color> [<parentheses-color>]]
|
||||||
|
+ prompt elite2 [8bit] [<text-color> [<parentheses-color>]]
|
||||||
|
|
||||||
|
The default colors are both cyan. This theme works best with a dark
|
||||||
|
background.
|
||||||
|
@@ -20,9 +20,12 @@ prompt_elite2_setup () {
|
||||||
|
local text_col=${1:-'cyan'}
|
||||||
|
local parens_col=${2:-$text_col}
|
||||||
|
|
||||||
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
|
+ shift
|
||||||
|
for code in 332 304 300; do
|
||||||
|
local char_$code=$(echo -n "\\0$code")
|
||||||
|
done
|
||||||
|
+ fi
|
||||||
|
|
||||||
|
local text="%{$fg_no_bold[$text_col]%}"
|
||||||
|
local parens="%{$fg_bold[$parens_col]%}"
|
||||||
|
Only in zsh-4.3.4/Functions/Prompts: prompt_elite2_setup~
|
||||||
|
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.4/Functions/Prompts/prompt_elite_setup
|
||||||
|
--- zsh-4.3.4-orig/Functions/Prompts/prompt_elite_setup 2005-05-10 00:39:02.000000000 -0400
|
||||||
|
+++ zsh-4.3.4/Functions/Prompts/prompt_elite_setup 2007-12-03 20:41:02.000000000 -0500
|
||||||
|
@@ -6,7 +6,7 @@ prompt_elite_help () {
|
||||||
|
cat <<EOH
|
||||||
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
|
- prompt elite [<text-color> [<punctuation-color>]]
|
||||||
|
+ prompt elite [8bit] [<text-color> [<punctuation-color>]]
|
||||||
|
|
||||||
|
The default colors are red and blue respectively. This theme is
|
||||||
|
intended for use with a black background.
|
||||||
|
@@ -20,9 +20,12 @@ prompt_elite_setup () {
|
||||||
|
local text=${1:-'red'}
|
||||||
|
local punctuation=${2:-'blue'}
|
||||||
|
|
||||||
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
|
+ shift
|
||||||
|
for code in 332 304 371 372 300; do
|
||||||
|
local char_$code=$(echo -n "\\0$code")
|
||||||
|
done
|
||||||
|
+ fi
|
||||||
|
|
||||||
|
PS1="%{$fg[$text]%}$char_332$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%n%{$fg[$punctuation]%}@%{$fg[$text]%}%m%{$fg[$punctuation]%})%{$fg[$text]%}-%{$fg[$punctuation]%}(%{$fg[$text]%}%D{%I:%M%P}%{$fg[$punctuation]%}-:-%{$fg[$text]%}%D{%m}%{$fg[$punctuation]$fg[$text]%}/%D{%d}%{$fg[$punctuation]%})%{$fg[$text]%}$char_304-%{$fg[$punctuation]]%}$char_371%{$fg[$text]%}-$char_371$char_371%{$fg[$punctuation]%}$char_372$prompt_newline%{$fg[$text]%}$char_300$char_304%{$fg[$punctuation]%}(%{$fg[$text]%}%1~%{$fg[$punctuation]%})%{$fg[$text]%}$char_304$char_371%{$fg[$punctuation]%}$char_372%{$reset_color%}"
|
||||||
|
PS2="> "
|
||||||
|
Only in zsh-4.3.4/Functions/Prompts: prompt_elite_setup~
|
||||||
|
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.4/Functions/Prompts/prompt_fade_setup
|
||||||
|
--- zsh-4.3.4-orig/Functions/Prompts/prompt_fade_setup 2005-05-10 00:39:02.000000000 -0400
|
||||||
|
+++ zsh-4.3.4/Functions/Prompts/prompt_fade_setup 2007-12-03 20:41:35.000000000 -0500
|
||||||
|
@@ -7,7 +7,7 @@ prompt_fade_help () {
|
||||||
|
cat <<EOH
|
||||||
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
|
- prompt fade [<fade-bar-and-cwd> [<userhost> [<date>]]]
|
||||||
|
+ prompt fade [8bit] [<fade-bar-and-cwd> [<userhost> [<date>]]]
|
||||||
|
|
||||||
|
where the parameters are the colors for the fade-bar and current
|
||||||
|
working directory, user@host text, and date text respectively. The
|
||||||
|
@@ -27,9 +27,12 @@ prompt_fade_setup () {
|
||||||
|
local userhost=${2:-'white'}
|
||||||
|
local date=${3:-'white'}
|
||||||
|
|
||||||
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
|
+ shift
|
||||||
|
for code in 333 262 261 260; do
|
||||||
|
local char_$code=$(echo -n "\\0$code")
|
||||||
|
done
|
||||||
|
+ fi
|
||||||
|
|
||||||
|
PS1="%{$fg[$fadebar_cwd]$bg[$fadebar_cwd]$bold_color%}$char_333$char_262$char_261$char_260%{$fg[$userhost]$bg[$fadebar_cwd]$bold_color%}%n@%m%{$reset_color$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$fg[$date]$bg[grey]$bold_color%} %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%{$fg[$fadebar_cwd]$bg[grey]$bold_color%}%~/%{$reset_color%} "
|
||||||
|
PS2="%{$fg[$fadebar_cwd]$bg[grey]%}$char_333$char_262$char_261$char_260%{$reset_color%}>"
|
||||||
|
Only in zsh-4.3.4/Functions/Prompts: prompt_fade_setup~
|
||||||
|
diff -rup zsh-4.3.4-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.4/Functions/Prompts/prompt_fire_setup
|
||||||
|
--- zsh-4.3.4-orig/Functions/Prompts/prompt_fire_setup 2005-05-10 00:39:02.000000000 -0400
|
||||||
|
+++ zsh-4.3.4/Functions/Prompts/prompt_fire_setup 2007-12-03 20:41:26.000000000 -0500
|
||||||
|
@@ -8,7 +8,7 @@ prompt_fire_help () {
|
||||||
|
cat <<EOH
|
||||||
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
|
- prompt fire [<fire1> [<fire2> [<fire3> [<userhost> [<date> [<cwd>]]]]]]
|
||||||
|
+ prompt fire [8bit] [<fire1> [<fire2> [<fire3> [<userhost> [<date> [<cwd>]]]]]]
|
||||||
|
|
||||||
|
where the parameters are the three fire colors, and the colors for the
|
||||||
|
user@host text, date text, and current working directory respectively.
|
||||||
|
@@ -28,9 +28,12 @@ prompt_fire_setup () {
|
||||||
|
local date=${5:-'white'}
|
||||||
|
local cwd=${6:-'yellow'}
|
||||||
|
|
||||||
|
+ if [[ $1 == '8bit' ]]; then
|
||||||
|
+ shift
|
||||||
|
for code in 333 262 261 260; do
|
||||||
|
local char_$code=$(echo -n "\\0$code")
|
||||||
|
done
|
||||||
|
+ fi
|
||||||
|
|
||||||
|
local GRAD1="%{$char_333$char_262$char_261$char_260%}"
|
||||||
|
local GRAD2="%{$char_260$char_261$char_262$char_333%}"
|
||||||
|
Only in zsh-4.3.4/Functions/Prompts: prompt_fire_setup~
|
8
zsh.spec
8
zsh.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: A powerful interactive shell
|
Summary: A powerful interactive shell
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 4.3.4
|
Version: 4.3.4
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://zsh.sunsite.dk/
|
URL: http://zsh.sunsite.dk/
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
@ -18,6 +18,7 @@ Source7: zshprompt.pl
|
|||||||
Patch0: zsh-serial.patch
|
Patch0: zsh-serial.patch
|
||||||
#Patch1: zsh-4.0.6-make-test-fail.patch
|
#Patch1: zsh-4.0.6-make-test-fail.patch
|
||||||
#Patch3: zsh-4.0.7-bckgrnd-bld-102042.patch
|
#Patch3: zsh-4.0.7-bckgrnd-bld-102042.patch
|
||||||
|
Patch4: zsh-4.3.4-8bit-prompts.patch
|
||||||
Prereq: fileutils grep /sbin/install-info
|
Prereq: fileutils grep /sbin/install-info
|
||||||
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
BuildRequires: mktemp coreutils sed ncurses-devel libcap-devel texinfo tetex texi2html gawk
|
BuildRequires: mktemp coreutils sed ncurses-devel libcap-devel texinfo tetex texi2html gawk
|
||||||
@ -51,6 +52,7 @@ This package contains the Zsh manual in html format.
|
|||||||
|
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .serial
|
%patch0 -p1 -b .serial
|
||||||
|
%patch4 -p1 -b .8bit-prompts
|
||||||
#autoconf
|
#autoconf
|
||||||
|
|
||||||
cp -p %SOURCE7 .
|
cp -p %SOURCE7 .
|
||||||
@ -150,6 +152,10 @@ fi
|
|||||||
%doc Doc/*.html
|
%doc Doc/*.html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 3 2007 James Antill <jantill@redhat.com> - 4.3.4-5
|
||||||
|
- Fix 8bit chars in prompts.
|
||||||
|
- Resolves: 375211
|
||||||
|
|
||||||
* Thu Oct 11 2007 James Antill <jantill@redhat.com> - 4.3.4-4
|
* Thu Oct 11 2007 James Antill <jantill@redhat.com> - 4.3.4-4
|
||||||
- Fix login shell detection.
|
- Fix login shell detection.
|
||||||
- Resolves: 244684
|
- Resolves: 244684
|
||||||
|
Loading…
Reference in New Issue
Block a user