auto-import changelog data from zsh-4.0.6-5.src.rpm
Mon Feb 10 2003 Jens Petersen <petersen@redhat.com> - 4.0.6-5 - skip completion tests on s390 and s390x since they hang Wed Jan 22 2003 Tim Powers <timp@redhat.com> - rebuilt Wed Dec 25 2002 Florian La Roche <Florian.LaRoche@redhat.de> - fix adding zsh to /etc/shells Fri Nov 29 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.6-2 - make sure /bin/zsh is owned by root and not bhcompile - do not package zsh-4.0.6 into binary rpm Thu Nov 28 2002 Jens Petersen <petersen@redhat.com> 4.0.6-1 - define _bindir to be /bin and use it - use _sysconfdir and _libdir Mon Nov 25 2002 Jens Petersen <petersen@redhat.com> - 4.0.6 - add url - add --without check build option - don't autoconf - make "make test" failure not go ignored - move sourcing of profile from zshenv to new .zshrc file for now (#65509) - preserve dates when installing rc files Fri Nov 15 2002 Jens Petersen <petersen@redhat.com> - setup backspace better with tput in zshrc to please screen (#77833) - encode spec file in utf-8
This commit is contained in:
parent
92bd44f922
commit
2c8e3f3d9a
@ -1 +1 @@
|
||||
zsh-4.0.4.tar.bz2
|
||||
zsh-4.0.6.tar.bz2
|
||||
|
10
dotzshrc
Normal file
10
dotzshrc
Normal file
@ -0,0 +1,10 @@
|
||||
#
|
||||
# .zshrc is sourced in interactive shells.
|
||||
# It should contain commands to set up aliases,
|
||||
# functions, options, key bindings, etc.
|
||||
#
|
||||
|
||||
# source profile like .bashrc
|
||||
if [ -f /etc/profile ]; then
|
||||
source /etc/profile
|
||||
fi
|
2
sources
2
sources
@ -1 +1 @@
|
||||
a96a467d332071cad162b0b010f0d19e zsh-4.0.4.tar.bz2
|
||||
ec841e1c92a44879c503ffb32a3e5326 zsh-4.0.6.tar.bz2
|
||||
|
12
zsh-4.0.6-make-test-fail.patch
Normal file
12
zsh-4.0.6-make-test-fail.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -u zsh-4.0.6/Test/Makefile.in~ zsh-4.0.6/Test/Makefile.in
|
||||
--- zsh-4.0.6/Test/Makefile.in~ 2002-11-25 11:03:59.000000000 +0900
|
||||
+++ zsh-4.0.6/Test/Makefile.in 2002-11-25 11:03:59.000000000 +0900
|
||||
@@ -45,7 +45,7 @@
|
||||
cd $(dir_top) && DESTDIR= \
|
||||
$(MAKE) MODDIR=`pwd`/$(subdir)/Modules install.modules > /dev/null; \
|
||||
fi
|
||||
- -for f in $(sdir)/$(TESTNUM)*.ztst; do \
|
||||
+ for f in $(sdir)/$(TESTNUM)*.ztst; do \
|
||||
$(dir_top)/Src/zsh +Z -f $(sdir)/ztst.zsh $$f; \
|
||||
done
|
||||
rm -rf Modules .zcompdump
|
145
zsh.spec
145
zsh.spec
@ -1,8 +1,11 @@
|
||||
# this file is encoded in UTF-8 -*- coding: utf-8 -*-
|
||||
|
||||
Summary: A shell similar to ksh, but with improvements.
|
||||
Name: zsh
|
||||
Version: 4.0.4
|
||||
Release: 8
|
||||
Version: 4.0.6
|
||||
Release: 5
|
||||
License: BSD
|
||||
URL: http://www.zsh.org/
|
||||
Group: System Environment/Shells
|
||||
Source0: ftp://ftp.zsh.org/pub/zsh-%{version}.tar.bz2
|
||||
Source1: zlogin.rhs
|
||||
@ -10,12 +13,17 @@ Source2: zlogout.rhs
|
||||
Source3: zprofile.rhs
|
||||
Source4: zshrc.rhs
|
||||
Source5: zshenv.rhs
|
||||
Source6: dotzshrc
|
||||
Patch0: zsh-serial.patch
|
||||
Patch1: zsh-4.0.6-make-test-fail.patch
|
||||
Prereq: fileutils grep /sbin/install-info
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
Requires: libcap
|
||||
BuildRequires: libtermcap-devel libcap-devel
|
||||
|
||||
%{?_without_check: %define _without_check 1}
|
||||
%{!?_without_check: %define _without_check 0}
|
||||
|
||||
%description
|
||||
The zsh shell is a command interpreter usable as an interactive login
|
||||
shell and as a shell script command processor. Zsh resembles the ksh
|
||||
@ -28,43 +36,52 @@ mechanism, and more.
|
||||
|
||||
%setup -q
|
||||
%patch0 -p1 -b .serial
|
||||
%patch1 -p1 -b .fail
|
||||
|
||||
%build
|
||||
|
||||
autoconf
|
||||
%define _bindir /bin
|
||||
#autoconf
|
||||
# Avoid stripping...
|
||||
export LDFLAGS=""
|
||||
%configure --bindir=/bin --enable-etcdir=/etc
|
||||
%configure --enable-etcdir=%{_sysconfdir}
|
||||
|
||||
# gawk exits 1 on ia64 for no apparent reason
|
||||
make || make
|
||||
make
|
||||
# Run the testsuite
|
||||
make test
|
||||
%if ! %{_without_check}
|
||||
# the completion tests hang on s390 and s390x
|
||||
%ifarch s390 s390x
|
||||
( cd Test
|
||||
mkdir skipped
|
||||
mv Y*.ztst skipped )
|
||||
%endif
|
||||
make test
|
||||
%endif
|
||||
|
||||
%install
|
||||
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
mkdir -p $RPM_BUILD_ROOT/etc
|
||||
%makeinstall install.info bindir=$RPM_BUILD_ROOT/bin \
|
||||
fndir=$RPM_BUILD_ROOT/%{_datadir}/zsh/%{version}/functions \
|
||||
sitefndir=$RPM_BUILD_ROOT/%{_datadir}/zsh/site-functions
|
||||
%makeinstall install.info \
|
||||
fndir=$RPM_BUILD_ROOT%{_datadir}/zsh/%{version}/functions \
|
||||
sitefndir=$RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
|
||||
|
||||
chmod 755 ${RPM_BUILD_ROOT}/bin/zsh
|
||||
rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
|
||||
rm -f ${RPM_BUILD_ROOT}%{_bindir}/zsh-%{version}
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
|
||||
|
||||
for I in zshrc zlogin zlogout zshenv zprofile; do
|
||||
cp $RPM_SOURCE_DIR/${I}.rhs ${RPM_BUILD_ROOT}/etc/$I
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}
|
||||
for i in zshrc zlogin zlogout zshenv zprofile; do
|
||||
cp -p $RPM_SOURCE_DIR/${i}.rhs ${RPM_BUILD_ROOT}%{_sysconfdir}/$i
|
||||
done
|
||||
|
||||
mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/skel
|
||||
cp -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/skel/.zshrc
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
if [ ! -f /etc/shells ] ; then
|
||||
echo "/bin/zsh" > /etc/shells
|
||||
if [ ! -f %{_sysconfdir}/shells ] ; then
|
||||
echo "%{_bindir}/zsh" > %{_sysconfdir}/shells
|
||||
else
|
||||
! grep -q /bin/zsh /etc/shells && echo "/bin/zsh" >> /etc/shells
|
||||
grep -q "^%{_bindir}/zsh$" %{_sysconfdir}/shells || echo "%{_bindir}/zsh" >> %{_sysconfdir}/shells
|
||||
fi
|
||||
|
||||
/sbin/install-info %{_infodir}/zsh.info.gz %{_infodir}/dir \
|
||||
@ -78,12 +95,12 @@ fi
|
||||
|
||||
%postun
|
||||
if [ "$1" = 0 ] ; then
|
||||
if [ -f /etc/shells ] ; then
|
||||
TmpFile=`/bin/mktemp /tmp/.zshrpmXXXXXX`
|
||||
grep -v '^/bin/zsh$' /etc/shells > $TmpFile
|
||||
cp -f $TmpFile /etc/shells
|
||||
if [ -f %{_sysconfdir}/shells ] ; then
|
||||
TmpFile=`%{_bindir}/mktemp /tmp/.zshrpmXXXXXX`
|
||||
grep -v '^%{_bindir}/zsh$' %{_sysconfdir}/shells > $TmpFile
|
||||
cp -f $TmpFile %{_sysconfdir}/shells
|
||||
rm -f $TmpFile
|
||||
chmod 644 /etc/shells
|
||||
chmod 644 %{_sysconfdir}/shells
|
||||
fi
|
||||
fi
|
||||
|
||||
@ -91,15 +108,45 @@ fi
|
||||
%defattr(-,root,root)
|
||||
%doc README LICENCE Etc/BUGS Etc/CONTRIBUTORS Etc/FAQ Etc/FEATURES Etc/MACHINES
|
||||
%doc Etc/NEWS Etc/zsh-development-guide Etc/completion-style-guide
|
||||
/bin/zsh*
|
||||
%attr(755,root,root) %{_bindir}/zsh
|
||||
%{_mandir}/*/*
|
||||
%{_infodir}/*
|
||||
%{_datadir}/zsh
|
||||
/usr/lib/zsh
|
||||
%config(noreplace) /etc/*
|
||||
%{_libdir}/zsh
|
||||
%config(noreplace) %{_sysconfdir}/*
|
||||
|
||||
%changelog
|
||||
* Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-8
|
||||
* Mon Feb 10 2003 Jens Petersen <petersen@redhat.com> - 4.0.6-5
|
||||
- skip completion tests on s390 and s390x since they hang
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Dec 25 2002 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- fix adding zsh to /etc/shells
|
||||
|
||||
* Fri Nov 29 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.6-2
|
||||
- make sure /bin/zsh is owned by root and not bhcompile
|
||||
- do not package zsh-%{version} into binary rpm
|
||||
|
||||
* Thu Nov 28 2002 Jens Petersen <petersen@redhat.com> 4.0.6-1
|
||||
- define _bindir to be /bin and use it
|
||||
- use _sysconfdir and _libdir
|
||||
|
||||
* Mon Nov 25 2002 Jens Petersen <petersen@redhat.com>
|
||||
- 4.0.6
|
||||
- add url
|
||||
- add --without check build option
|
||||
- don't autoconf
|
||||
- make "make test" failure not go ignored
|
||||
- move sourcing of profile from zshenv to new .zshrc file for now (#65509)
|
||||
- preserve dates when installing rc files
|
||||
|
||||
* Fri Nov 15 2002 Jens Petersen <petersen@redhat.com>
|
||||
- setup backspace better with tput in zshrc to please screen (#77833)
|
||||
- encode spec file in utf-8
|
||||
|
||||
* Fri Jun 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-8
|
||||
- Make it work with a serial port (#56353)
|
||||
- Add $HOME/bin to path for login shells (#67110)
|
||||
|
||||
@ -109,67 +156,67 @@ fi
|
||||
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Fri Apr 5 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-5
|
||||
* Fri Apr 5 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-5
|
||||
- Source /etc/profile from /etc/zshenv instead of /etc/zprofile,
|
||||
to run things the same way bash do (#62788)
|
||||
|
||||
* Tue Apr 2 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-4
|
||||
* Tue Apr 2 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-4
|
||||
- Explicitly specify blank LDFLAGS to avoid autoconf thinking it
|
||||
should strip when linking
|
||||
|
||||
* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-3
|
||||
* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-3
|
||||
- Rebuild
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Fri Oct 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-1
|
||||
* Fri Oct 26 2001 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-1
|
||||
- 4.0.4
|
||||
- Don't force emacs keybindings, they're the default (#55102)
|
||||
|
||||
* Wed Oct 24 2001 Trond Eivind Glomsrød <teg@redhat.com> 4.0.3-1
|
||||
* Wed Oct 24 2001 Trond Eivind Glomsrød <teg@redhat.com> 4.0.3-1
|
||||
- 4.0.3
|
||||
|
||||
* Mon Jul 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Mon Jul 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- Fix typo in comment in zshrc (#50214)
|
||||
- Don't set environment variables in /etc/zshrc (#50308)
|
||||
|
||||
* Tue Jun 26 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Tue Jun 26 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 4.0.2
|
||||
- Run the testsuite during build
|
||||
|
||||
* Wed Jun 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Wed Jun 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- Add libtermcap-devel and libcap-devel to buildrequires
|
||||
|
||||
* Fri Jun 1 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Fri Jun 1 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 4.0.1
|
||||
|
||||
* Thu May 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Thu May 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 4.0.1pre4
|
||||
- zsh is now available in bz2 - use it
|
||||
|
||||
* Mon Apr 9 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Mon Apr 9 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 4.0.1pre3
|
||||
- remove the dir file from the info directory
|
||||
|
||||
* Wed Mar 21 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Wed Mar 21 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- Remove contents from /etc/zshenv file - no reason to duplicate things
|
||||
from /etc/profile, which is sourced from /etc/zprofile (#32478)
|
||||
|
||||
* Thu Mar 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Thu Mar 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 4.0.1pre2
|
||||
- remove some obsolete code in /etc/zprofile
|
||||
|
||||
* Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
|
||||
- noreplace config files.
|
||||
|
||||
* Thu Feb 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Thu Feb 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- Handle RLIMIT_LOCKS in 2.4 (#27834 - patch from H.J. Lu)
|
||||
|
||||
* Mon Jan 08 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Mon Jan 08 2001 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- rebuild to fix #23568 (empty signal list)
|
||||
|
||||
* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- fix the post script, so we only have only line for zsh
|
||||
and can remove the trigger
|
||||
- get rid of some instances of "/usr/local/bin/zsh"
|
||||
@ -180,10 +227,10 @@ fi
|
||||
* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
|
||||
- automatic rebuild
|
||||
|
||||
* Sun Jul 02 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Sun Jul 02 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- rebuild
|
||||
|
||||
* Tue Jun 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Tue Jun 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- 3.0.8
|
||||
- use %%configure and %%makeinstall
|
||||
- updated URL
|
||||
@ -192,7 +239,7 @@ fi
|
||||
- use %%{_mandir} and %%{_infodir}
|
||||
- use %%{_tmppath}
|
||||
|
||||
* Tue May 02 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
* Tue May 02 2000 Trond Eivind Glomsrød <teg@redhat.com>
|
||||
- patched to recognize export in .zshrc (bug #11169)
|
||||
|
||||
* Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
|
||||
|
@ -7,6 +7,3 @@
|
||||
# output or assume the shell is attached to a tty.
|
||||
#
|
||||
|
||||
# Sourcing here to get it done on all invocations of zsh,
|
||||
# like bash.
|
||||
source /etc/profile
|
||||
|
Loading…
Reference in New Issue
Block a user