Update to latest upstream release: Zsh 5.1.1
This commit is contained in:
parent
9335e8c240
commit
10ded2c11a
2
sources
2
sources
@ -1 +1 @@
|
|||||||
fbf736a6540873f4fb7bdaf70cafb1f0 zsh-5.1.tar.xz
|
0e8ea3313300277a04cee80836507bae zsh-5.1.1.tar.xz
|
||||||
|
@ -1,7 +1,8 @@
|
|||||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.9/Functions/Prompts/prompt_bigfade_setup
|
diff --git a/Functions/Prompts/prompt_bigfade_setup b/Functions/Prompts/prompt_bigfade_setup
|
||||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_bigfade_setup 2008-07-14 10:04:18.000000000 -0400
|
index 2d95f31..f2f27f4 100644
|
||||||
+++ zsh-4.3.9/Functions/Prompts/prompt_bigfade_setup 2008-12-18 20:32:59.000000000 -0500
|
--- a/Functions/Prompts/prompt_bigfade_setup
|
||||||
@@ -7,7 +7,7 @@
|
+++ b/Functions/Prompts/prompt_bigfade_setup
|
||||||
|
@@ -7,7 +7,7 @@ prompt_bigfade_help () {
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -10,7 +11,7 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.9/Functio
|
|||||||
|
|
||||||
where the parameters are the colors for the fade-bar, user@host text,
|
where the parameters are the colors for the fade-bar, user@host text,
|
||||||
date text, and current working directory respectively. The default
|
date text, and current working directory respectively. The default
|
||||||
@@ -27,9 +27,12 @@
|
@@ -27,9 +27,12 @@ prompt_bigfade_setup () {
|
||||||
local date=${3:-'white'}
|
local date=${3:-'white'}
|
||||||
local cwd=${4:-'yellow'}
|
local cwd=${4:-'yellow'}
|
||||||
|
|
||||||
@ -23,10 +24,11 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_bigfade_setup zsh-4.3.9/Functio
|
|||||||
|
|
||||||
PS1="%B%F{$fadebar}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$userhost}%K{$fadebar}%n@%m%b%k%f%F{$fadebar}%K{black}$schars[260]$schars[261]$schars[262]$schars[333]%b%f%k%F{$fadebar}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$date}%K{black} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%B%F{$cwd}%K{black}%d>%b%f%k "
|
PS1="%B%F{$fadebar}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$userhost}%K{$fadebar}%n@%m%b%k%f%F{$fadebar}%K{black}$schars[260]$schars[261]$schars[262]$schars[333]%b%f%k%F{$fadebar}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$date}%K{black} %D{%a %b %d} %D{%I:%M:%S%P}$prompt_newline%B%F{$cwd}%K{black}%d>%b%f%k "
|
||||||
PS2="%B%F{$fadebar}$schars[333]$schars[262]$schars[261]$schars[260]%b%F{$fadebar}%K{black}$schars[260]$schars[261]$schars[262]$schars[333]%F{$fadebar}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$fadebar}>%b%f%k "
|
PS2="%B%F{$fadebar}$schars[333]$schars[262]$schars[261]$schars[260]%b%F{$fadebar}%K{black}$schars[260]$schars[261]$schars[262]$schars[333]%F{$fadebar}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%B%F{$fadebar}>%b%f%k "
|
||||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.9/Functions/Prompts/prompt_elite2_setup
|
diff --git a/Functions/Prompts/prompt_elite2_setup b/Functions/Prompts/prompt_elite2_setup
|
||||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_elite2_setup 2008-07-14 10:04:18.000000000 -0400
|
index 754bf60..0006665 100644
|
||||||
+++ zsh-4.3.9/Functions/Prompts/prompt_elite2_setup 2008-12-18 20:33:31.000000000 -0500
|
--- a/Functions/Prompts/prompt_elite2_setup
|
||||||
@@ -6,7 +6,7 @@
|
+++ b/Functions/Prompts/prompt_elite2_setup
|
||||||
|
@@ -6,7 +6,7 @@ prompt_elite2_help () {
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -35,7 +37,7 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.9/Function
|
|||||||
|
|
||||||
The default colors are both cyan. This theme works best with a dark
|
The default colors are both cyan. This theme works best with a dark
|
||||||
background.
|
background.
|
||||||
@@ -21,9 +21,12 @@
|
@@ -21,9 +21,12 @@ prompt_elite2_setup () {
|
||||||
local text_col=${1:-'cyan'}
|
local text_col=${1:-'cyan'}
|
||||||
local parens_col=${2:-$text_col}
|
local parens_col=${2:-$text_col}
|
||||||
|
|
||||||
@ -48,10 +50,11 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite2_setup zsh-4.3.9/Function
|
|||||||
|
|
||||||
local text="%b%F{$text_col}"
|
local text="%b%F{$text_col}"
|
||||||
local parens="%B%F{$parens_col}"
|
local parens="%B%F{$parens_col}"
|
||||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.9/Functions/Prompts/prompt_elite_setup
|
diff --git a/Functions/Prompts/prompt_elite_setup b/Functions/Prompts/prompt_elite_setup
|
||||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_elite_setup 2008-07-14 10:04:18.000000000 -0400
|
index 0d57f50..e4b3fb1 100644
|
||||||
+++ zsh-4.3.9/Functions/Prompts/prompt_elite_setup 2008-12-18 20:33:45.000000000 -0500
|
--- a/Functions/Prompts/prompt_elite_setup
|
||||||
@@ -6,7 +6,7 @@
|
+++ b/Functions/Prompts/prompt_elite_setup
|
||||||
|
@@ -6,7 +6,7 @@ prompt_elite_help () {
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -60,7 +63,7 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.9/Functions
|
|||||||
|
|
||||||
The default colors are red and blue respectively. This theme is
|
The default colors are red and blue respectively. This theme is
|
||||||
intended for use with a black background.
|
intended for use with a black background.
|
||||||
@@ -21,9 +21,12 @@
|
@@ -21,9 +21,12 @@ prompt_elite_setup () {
|
||||||
local text=${1:-'red'}
|
local text=${1:-'red'}
|
||||||
local punctuation=${2:-'blue'}
|
local punctuation=${2:-'blue'}
|
||||||
|
|
||||||
@ -73,10 +76,11 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_elite_setup zsh-4.3.9/Functions
|
|||||||
|
|
||||||
PS1="%F{$text}$schars[332]$schars[304]%F{$punctuation}(%F{$text}%n%F{$punctuation}@%F{$text}%m%F{$punctuation})%F{$text}-%F{$punctuation}(%F{$text}%D{%I:%M%P}%F{$punctuation}-:-%F{$text}%D{%m}%F{$punctuation}%F{$text}/%D{%d}%F{$punctuation})%F{$text}$schars[304]-%F{$punctuation}$schars[371]%F{$text}-$schars[371]$schars[371]%F{$punctuation}$schars[372]$prompt_newline%F{$text}$schars[300]$schars[304]%F{$punctuation}(%F{$text}%1~%F{$punctuation})%F{$text}$schars[304]$schars[371]%F{$punctuation}$schars[372]%f"
|
PS1="%F{$text}$schars[332]$schars[304]%F{$punctuation}(%F{$text}%n%F{$punctuation}@%F{$text}%m%F{$punctuation})%F{$text}-%F{$punctuation}(%F{$text}%D{%I:%M%P}%F{$punctuation}-:-%F{$text}%D{%m}%F{$punctuation}%F{$text}/%D{%d}%F{$punctuation})%F{$text}$schars[304]-%F{$punctuation}$schars[371]%F{$text}-$schars[371]$schars[371]%F{$punctuation}$schars[372]$prompt_newline%F{$text}$schars[300]$schars[304]%F{$punctuation}(%F{$text}%1~%F{$punctuation})%F{$text}$schars[304]$schars[371]%F{$punctuation}$schars[372]%f"
|
||||||
PS2="> "
|
PS2="> "
|
||||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.9/Functions/Prompts/prompt_fade_setup
|
diff --git a/Functions/Prompts/prompt_fade_setup b/Functions/Prompts/prompt_fade_setup
|
||||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_fade_setup 2008-07-14 10:04:18.000000000 -0400
|
index d915cc0..ddd0162 100644
|
||||||
+++ zsh-4.3.9/Functions/Prompts/prompt_fade_setup 2008-12-18 20:33:55.000000000 -0500
|
--- a/Functions/Prompts/prompt_fade_setup
|
||||||
@@ -7,7 +7,7 @@
|
+++ b/Functions/Prompts/prompt_fade_setup
|
||||||
|
@@ -7,7 +7,7 @@ prompt_fade_help () {
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -85,7 +89,7 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.9/Functions/
|
|||||||
|
|
||||||
where the parameters are the colors for the fade-bar and current
|
where the parameters are the colors for the fade-bar and current
|
||||||
working directory, user@host text, and date text respectively. The
|
working directory, user@host text, and date text respectively. The
|
||||||
@@ -27,9 +27,12 @@
|
@@ -27,9 +27,12 @@ prompt_fade_setup () {
|
||||||
local userhost=${2:-'white'}
|
local userhost=${2:-'white'}
|
||||||
local date=${3:-'white'}
|
local date=${3:-'white'}
|
||||||
|
|
||||||
@ -98,10 +102,11 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fade_setup zsh-4.3.9/Functions/
|
|||||||
|
|
||||||
PS1="%F{$fadebar_cwd}%B%K{$fadebar_cwd}$schars[333]$schars[262]$schars[261]$schars[260]%F{$userhost}%K{$fadebar_cwd}%B%n@%m%b%F{$fadebar_cwd}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%F{$date}%K{black}%B %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%F{$fadebar_cwd}%K{black}%B%~/%b%k%f "
|
PS1="%F{$fadebar_cwd}%B%K{$fadebar_cwd}$schars[333]$schars[262]$schars[261]$schars[260]%F{$userhost}%K{$fadebar_cwd}%B%n@%m%b%F{$fadebar_cwd}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%F{$date}%K{black}%B %D{%a %b %d} %D{%I:%M:%S%P} $prompt_newline%F{$fadebar_cwd}%K{black}%B%~/%b%k%f "
|
||||||
PS2="%F{$fadebar_cwd}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%f%k>"
|
PS2="%F{$fadebar_cwd}%K{black}$schars[333]$schars[262]$schars[261]$schars[260]%f%k>"
|
||||||
diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.9/Functions/Prompts/prompt_fire_setup
|
diff --git a/Functions/Prompts/prompt_fire_setup b/Functions/Prompts/prompt_fire_setup
|
||||||
--- zsh-4.3.9-orig/Functions/Prompts/prompt_fire_setup 2008-07-14 10:04:18.000000000 -0400
|
index 7bb8367..3217980 100644
|
||||||
+++ zsh-4.3.9/Functions/Prompts/prompt_fire_setup 2008-12-18 20:34:04.000000000 -0500
|
--- a/Functions/Prompts/prompt_fire_setup
|
||||||
@@ -8,7 +8,7 @@
|
+++ b/Functions/Prompts/prompt_fire_setup
|
||||||
|
@@ -8,7 +8,7 @@ prompt_fire_help () {
|
||||||
cat <<EOH
|
cat <<EOH
|
||||||
This prompt is color-scheme-able. You can invoke it thus:
|
This prompt is color-scheme-able. You can invoke it thus:
|
||||||
|
|
||||||
@ -110,7 +115,7 @@ diff -ru zsh-4.3.9-orig/Functions/Prompts/prompt_fire_setup zsh-4.3.9/Functions/
|
|||||||
|
|
||||||
where the parameters are the three fire colors, and the colors for the
|
where the parameters are the three fire colors, and the colors for the
|
||||||
user@host text, date text, and current working directory respectively.
|
user@host text, date text, and current working directory respectively.
|
||||||
@@ -29,9 +29,12 @@
|
@@ -29,9 +29,12 @@ prompt_fire_setup () {
|
||||||
local date=${5:-'white'}
|
local date=${5:-'white'}
|
||||||
local cwd=${6:-'yellow'}
|
local cwd=${6:-'yellow'}
|
||||||
|
|
||||||
|
@ -6,7 +6,7 @@ diff --git a/Src/builtin.c b/Src/builtin.c
|
|||||||
index 9358e8b..ee14f91 100644
|
index 9358e8b..ee14f91 100644
|
||||||
--- a/Src/builtin.c
|
--- a/Src/builtin.c
|
||||||
+++ b/Src/builtin.c
|
+++ b/Src/builtin.c
|
||||||
@@ -5411,7 +5411,7 @@ bin_read(char *name, char **args, Options ops, UNUSED(int func))
|
@@ -5631,7 +5631,7 @@ bin_read(char *name, char **args, Options ops, UNUSED(int func))
|
||||||
if (!zleactive) {
|
if (!zleactive) {
|
||||||
if (SHTTY == -1) {
|
if (SHTTY == -1) {
|
||||||
/* need to open /dev/tty specially */
|
/* need to open /dev/tty specially */
|
||||||
@ -19,7 +19,7 @@ diff --git a/Src/init.c b/Src/init.c
|
|||||||
index 102276a..238f6ed 100644
|
index 102276a..238f6ed 100644
|
||||||
--- a/Src/init.c
|
--- a/Src/init.c
|
||||||
+++ b/Src/init.c
|
+++ b/Src/init.c
|
||||||
@@ -542,7 +542,7 @@ init_io(void)
|
@@ -545,7 +545,7 @@ init_io(void)
|
||||||
if (isatty(0)) {
|
if (isatty(0)) {
|
||||||
zsfree(ttystrname);
|
zsfree(ttystrname);
|
||||||
if ((ttystrname = ztrdup(ttyname(0)))) {
|
if ((ttystrname = ztrdup(ttyname(0)))) {
|
||||||
@ -28,7 +28,7 @@ index 102276a..238f6ed 100644
|
|||||||
#ifdef TIOCNXCL
|
#ifdef TIOCNXCL
|
||||||
/*
|
/*
|
||||||
* See if the terminal claims to be busy. If so, and fd 0
|
* See if the terminal claims to be busy. If so, and fd 0
|
||||||
@@ -583,7 +583,7 @@ init_io(void)
|
@@ -586,7 +586,7 @@ init_io(void)
|
||||||
ttystrname = ztrdup(ttyname(1));
|
ttystrname = ztrdup(ttyname(1));
|
||||||
}
|
}
|
||||||
if (SHTTY == -1 &&
|
if (SHTTY == -1 &&
|
||||||
@ -37,7 +37,7 @@ index 102276a..238f6ed 100644
|
|||||||
zsfree(ttystrname);
|
zsfree(ttystrname);
|
||||||
ttystrname = ztrdup(ttyname(SHTTY));
|
ttystrname = ztrdup(ttyname(SHTTY));
|
||||||
}
|
}
|
||||||
@@ -1707,3 +1707,33 @@ zsh_main(UNUSED(int argc), char **argv)
|
@@ -1711,3 +1711,33 @@ zsh_main(UNUSED(int argc), char **argv)
|
||||||
: "use 'logout' to logout.");
|
: "use 'logout' to logout.");
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
@ -5,7 +5,7 @@ diff --git a/Test/C02cond.ztst b/Test/C02cond.ztst
|
|||||||
index 02fa4d4..97f679c 100644
|
index 02fa4d4..97f679c 100644
|
||||||
--- a/Test/C02cond.ztst
|
--- a/Test/C02cond.ztst
|
||||||
+++ b/Test/C02cond.ztst
|
+++ b/Test/C02cond.ztst
|
||||||
@@ -204,7 +204,8 @@ F:Failures in these cases do not indicate a problem in the shell.
|
@@ -201,7 +201,8 @@ F:Failures in these cases do not indicate a problem in the shell.
|
||||||
print -u$ZTST_fd "Warning: not testing [[ -e /dev/fd/0 ]] (/dev/fd not supported)"
|
print -u$ZTST_fd "Warning: not testing [[ -e /dev/fd/0 ]] (/dev/fd not supported)"
|
||||||
true
|
true
|
||||||
else
|
else
|
||||||
@ -15,7 +15,7 @@ index 02fa4d4..97f679c 100644
|
|||||||
fi
|
fi
|
||||||
0dD:/dev/fd support in conds handled by access
|
0dD:/dev/fd support in conds handled by access
|
||||||
|
|
||||||
@@ -212,7 +213,8 @@ F:Failures in these cases do not indicate a problem in the shell.
|
@@ -209,7 +210,8 @@ F:Failures in these cases do not indicate a problem in the shell.
|
||||||
print -u$ZTST_fd "Warning: not testing [[ -O /dev/fd/0 ]] (/dev/fd not supported)"
|
print -u$ZTST_fd "Warning: not testing [[ -O /dev/fd/0 ]] (/dev/fd not supported)"
|
||||||
true
|
true
|
||||||
else
|
else
|
||||||
|
5
zsh.spec
5
zsh.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Summary: Powerful interactive shell
|
Summary: Powerful interactive shell
|
||||||
Name: zsh
|
Name: zsh
|
||||||
Version: 5.1
|
Version: 5.1.1
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://zsh.sourceforge.net/
|
URL: http://zsh.sourceforge.net/
|
||||||
@ -159,6 +159,9 @@ fi
|
|||||||
%doc Doc/*.html
|
%doc Doc/*.html
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 14 2015 Kamil Dudka <kdudka@redhat.com> - 5.1.1-1
|
||||||
|
- Update to latest upstream release: Zsh 5.1.1
|
||||||
|
|
||||||
* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> - 5.1-1
|
* Mon Aug 31 2015 Kamil Dudka <kdudka@redhat.com> - 5.1-1
|
||||||
- Update to latest upstream release: Zsh 5.1
|
- Update to latest upstream release: Zsh 5.1
|
||||||
- remove outdated workarounds in %%check
|
- remove outdated workarounds in %%check
|
||||||
|
Loading…
Reference in New Issue
Block a user