zlib/zlib-1.1.4-make-test.patch
cvsdist cac4362070 auto-import changelog data from zlib-1.1.4-2.src.rpm
Fri Apr 26 2002 Jakub Jelinek <jakub@redhat.com> 1.1.4-2
- remove glibc patch, it is no longer needed (zlib uses gcc -shared as it
    should)
- run tests and only build the package if they succeed
Thu Apr 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.4-1
- 1.1.4
2004-09-09 15:18:58 +00:00

24 lines
699 B
Diff

--- zlib-1.1.4/Makefile.in.jj Mon Mar 11 08:58:30 2002
+++ zlib-1.1.4/Makefile.in Fri Apr 26 06:53:12 2002
@@ -62,13 +62,16 @@ all: example minigzip
test: all
@LD_LIBRARY_PATH=.:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
- echo hello world | ./minigzip | ./minigzip -d || \
- echo ' *** minigzip test FAILED ***' ; \
+ ret=0; \
+ if ! echo hello world | ./minigzip | ./minigzip -d; then \
+ echo ' *** minigzip test FAILED ***'; ret=1; \
+ fi; \
if ./example; then \
echo ' *** zlib test OK ***'; \
else \
- echo ' *** zlib test FAILED ***'; \
- fi
+ echo ' *** zlib test FAILED ***'; ret=1; \
+ fi; \
+ exit $$ret
libz.a: $(OBJS) $(OBJA)
$(AR) $@ $(OBJS) $(OBJA)