auto-import changelog data from zlib-1.1.4-2.src.rpm

Fri Apr 26 2002 Jakub Jelinek <jakub@redhat.com> 1.1.4-2
- remove glibc patch, it is no longer needed (zlib uses gcc -shared as it
    should)
- run tests and only build the package if they succeed
Thu Apr 25 2002 Trond Eivind Glomsrd <teg@redhat.com> 1.1.4-1
- 1.1.4
This commit is contained in:
cvsdist 2004-09-09 15:18:58 +00:00
parent 60b7d1bc7d
commit cac4362070
4 changed files with 40 additions and 10 deletions

View File

@ -1 +1 @@
zlib-1.1.3.tar.gz
zlib-1.1.4.tar.gz

View File

@ -1 +1 @@
ada18615d2a66dee4d6f5ff916ecd4c6 zlib-1.1.3.tar.gz
abc405d0bdd3ee22782d7aa20e440f08 zlib-1.1.4.tar.gz

View File

@ -0,0 +1,23 @@
--- zlib-1.1.4/Makefile.in.jj Mon Mar 11 08:58:30 2002
+++ zlib-1.1.4/Makefile.in Fri Apr 26 06:53:12 2002
@@ -62,13 +62,16 @@ all: example minigzip
test: all
@LD_LIBRARY_PATH=.:$(LD_LIBRARY_PATH) ; export LD_LIBRARY_PATH; \
- echo hello world | ./minigzip | ./minigzip -d || \
- echo ' *** minigzip test FAILED ***' ; \
+ ret=0; \
+ if ! echo hello world | ./minigzip | ./minigzip -d; then \
+ echo ' *** minigzip test FAILED ***'; ret=1; \
+ fi; \
if ./example; then \
echo ' *** zlib test OK ***'; \
else \
- echo ' *** zlib test FAILED ***'; \
- fi
+ echo ' *** zlib test FAILED ***'; ret=1; \
+ fi; \
+ exit $$ret
libz.a: $(OBJS) $(OBJA)
$(AR) $@ $(OBJS) $(OBJA)

View File

@ -1,11 +1,10 @@
Summary: The zlib compression and decompression library.
Name: zlib
Version: 1.1.3
Release: 25.7
Version: 1.1.4
Release: 2
Group: System Environment/Libraries
Source: ftp://ftp.info-zip.org/pub/infozip/zlib/zlib-%{version}.tar.gz
Patch0: zlib-1.1.3-glibc.patch
Patch1: zlib-1.1.3-sec.patch
Patch0: zlib-1.1.4-make-test.patch
URL: http://www.gzip.org/zlib/
License: BSD
Prefix: %{_prefix}
@ -27,16 +26,16 @@ library.
%prep
%setup -q
%patch0 -p1 -b .glibc
%patch1 -p1 -b .free
%patch0 -p1 -b .make-test
%build
CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
make
make test
# now build the static lib
CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
make
make test
%install
rm -rf ${RPM_BUILD_ROOT}
@ -79,6 +78,14 @@ rm -rf ${RPM_BUILD_ROOT}
%{_mandir}/man3/zlib.3*
%changelog
* Fri Apr 26 2002 Jakub Jelinek <jakub@redhat.com> 1.1.4-2
- remove glibc patch, it is no longer needed (zlib uses gcc -shared
as it should)
- run tests and only build the package if they succeed
* Thu Apr 25 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.4-1
- 1.1.4
* Wed Jan 30 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.1.3-25.7
- Fix double free