adding forgotten patch
This commit is contained in:
parent
71c9339ff3
commit
a4cb032d83
77
zlib-1.2.3-autotools.patch
Normal file
77
zlib-1.2.3-autotools.patch
Normal file
@ -0,0 +1,77 @@
|
||||
--- /dev/null 2007-02-20 10:06:12.587494888 +0100
|
||||
+++ zlib-1.2.3/Makefile.am 2007-02-20 13:22:36.000000000 +0100
|
||||
@@ -0,0 +1,19 @@
|
||||
+lib_LTLIBRARIES = libz.la
|
||||
+
|
||||
+libz_la_SOURCES = \
|
||||
+ adler32.c \
|
||||
+ compress.c \
|
||||
+ crc32.c \
|
||||
+ gzio.c \
|
||||
+ uncompr.c \
|
||||
+ deflate.c \
|
||||
+ trees.c \
|
||||
+ zutil.c \
|
||||
+ inflate.c \
|
||||
+ infback.c \
|
||||
+ inftrees.c \
|
||||
+ inffast.c
|
||||
+
|
||||
+libz_la_LDFLAGS = \
|
||||
+ -version-info 1:0:0
|
||||
+
|
||||
--- /dev/null 2007-02-20 10:06:12.587494888 +0100
|
||||
+++ zlib-1.2.3/configure.ac 2007-02-20 13:22:46.000000000 +0100
|
||||
@@ -0,0 +1,52 @@
|
||||
+# -*- Autoconf -*-
|
||||
+# Process this file with autoconf to produce a configure script.
|
||||
+
|
||||
+AC_PREREQ(2.61)
|
||||
+AC_INIT([zlib], 1.2.3, [bugzilla.redhat.com])
|
||||
+AC_CONFIG_SRCDIR([minigzip.c])
|
||||
+AC_CONFIG_HEADER([config.h])
|
||||
+AM_INIT_AUTOMAKE([-Wall foreign])
|
||||
+
|
||||
+# Checks for programs.
|
||||
+AC_PROG_CXX
|
||||
+AC_PROG_CC
|
||||
+AC_PROG_CPP
|
||||
+AC_PROG_INSTALL
|
||||
+AC_PROG_LN_S
|
||||
+AC_PROG_MAKE_SET
|
||||
+AC_PROG_LIBTOOL
|
||||
+
|
||||
+# Checks for libraries.
|
||||
+# FIXME: Replace `main' with a function in `-lz':
|
||||
+AC_CHECK_LIB([z], [main])
|
||||
+
|
||||
+# Checks for header files.
|
||||
+AC_HEADER_STDC
|
||||
+AC_CHECK_HEADERS([fcntl.h limits.h malloc.h stddef.h stdlib.h string.h sys/file.h unistd.h utime.h])
|
||||
+
|
||||
+# Checks for typedefs, structures, and compiler characteristics.
|
||||
+AC_HEADER_STDBOOL
|
||||
+AC_C_CONST
|
||||
+AC_C_INLINE
|
||||
+AC_TYPE_OFF_T
|
||||
+AC_TYPE_SIZE_T
|
||||
+AC_STRUCT_TM
|
||||
+AC_C_VOLATILE
|
||||
+AC_CHECK_TYPES([ptrdiff_t])
|
||||
+
|
||||
+# Checks for library functions.
|
||||
+AC_FUNC_CHOWN
|
||||
+AC_FUNC_ERROR_AT_LINE
|
||||
+AC_FUNC_FSEEKO
|
||||
+AC_FUNC_MALLOC
|
||||
+AC_FUNC_MEMCMP
|
||||
+AC_FUNC_MKTIME
|
||||
+AC_FUNC_MMAP
|
||||
+AC_FUNC_REALLOC
|
||||
+AC_FUNC_STAT
|
||||
+AC_FUNC_UTIME_NULL
|
||||
+AC_FUNC_VPRINTF
|
||||
+AC_CHECK_FUNCS([ftruncate memmove memset mkdir munmap strdup strerror strrchr strtol utime])
|
||||
+
|
||||
+AC_CONFIG_FILES([Makefile])
|
||||
+AC_OUTPUT
|
Loading…
Reference in New Issue
Block a user