- consolidate the autoconfiscation patches into one and clean it up
- consequently, clean up the %build and %install sections
This commit is contained in:
parent
be65fc419d
commit
9bfa9f1c87
@ -1,211 +0,0 @@
|
|||||||
diff -rN -U 5 zlib-1.2.3.orig/contrib/minizip/autogen.sh zlib-1.2.3.patched/contrib/minizip/autogen.sh
|
|
||||||
--- zlib-1.2.3.orig/contrib/minizip/autogen.sh 1969-12-31 17:00:00.000000000 -0700
|
|
||||||
+++ zlib-1.2.3.patched/contrib/minizip/autogen.sh 2007-06-30 23:31:01.000000000 -0600
|
|
||||||
@@ -0,0 +1,53 @@
|
|
||||||
+#! /bin/sh
|
|
||||||
+set -e
|
|
||||||
+
|
|
||||||
+# $Id: autogen.sh,v 1.2 2006/09/07 22:19:58 rvinyard Exp $
|
|
||||||
+#
|
|
||||||
+# Copyright (c) 2002 Daniel Elstner <daniel.elstner@gmx.net>
|
|
||||||
+#
|
|
||||||
+# This program is free software; you can redistribute it and/or modify
|
|
||||||
+# it under the terms of the GNU General Public License VERSION 2 as
|
|
||||||
+# published by the Free Software Foundation. You are not allowed to
|
|
||||||
+# use any other version of the license; unless you got the explicit
|
|
||||||
+# permission from the author to do so.
|
|
||||||
+#
|
|
||||||
+# This program is distributed in the hope that it will be useful,
|
|
||||||
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
||||||
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
||||||
+# GNU General Public License for more details.
|
|
||||||
+#
|
|
||||||
+# You should have received a copy of the GNU General Public License
|
|
||||||
+# along with this program; if not, write to the Free Software
|
|
||||||
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
|
|
||||||
+# 02110-1301, USA.
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+dir=`echo "$0" | sed 's,[^/]*$,,'`
|
|
||||||
+test "x${dir}" = "x" && dir='.'
|
|
||||||
+
|
|
||||||
+if test "x`cd "${dir}" 2>/dev/null && pwd`" != "x`pwd`"
|
|
||||||
+then
|
|
||||||
+ echo "This script must be executed directly from the source directory."
|
|
||||||
+ exit 1
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
+LIBTOOLIZE=${LIBTOOLIZE:-libtoolize}
|
|
||||||
+AUTOCONF=${AUTOCONF:-autoconf}
|
|
||||||
+AUTOMAKE=${AUTOMAKE:-automake}
|
|
||||||
+AUTOHEADER=${AUTOHEADER:-autoheader}
|
|
||||||
+
|
|
||||||
+ACLOCAL=`echo $AUTOMAKE | sed s/automake/aclocal/`
|
|
||||||
+
|
|
||||||
+rm -f config.cache acconfig.h
|
|
||||||
+
|
|
||||||
+do_cmd() {
|
|
||||||
+ echo "- $@"
|
|
||||||
+ $@
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+do_cmd $ACLOCAL
|
|
||||||
+do_cmd $LIBTOOLIZE -c --force
|
|
||||||
+do_cmd $AUTOHEADER
|
|
||||||
+do_cmd $AUTOCONF
|
|
||||||
+do_cmd $AUTOMAKE -c --add-missing --foreign
|
|
||||||
+#do_cmd ./configure "$@"
|
|
||||||
diff -rN -U 5 zlib-1.2.3.orig/contrib/minizip/configure.ac zlib-1.2.3.patched/contrib/minizip/configure.ac
|
|
||||||
--- zlib-1.2.3.orig/contrib/minizip/configure.ac 1969-12-31 17:00:00.000000000 -0700
|
|
||||||
+++ zlib-1.2.3.patched/contrib/minizip/configure.ac 2007-06-28 14:57:39.000000000 -0600
|
|
||||||
@@ -0,0 +1,12 @@
|
|
||||||
+AC_INIT([minizip], 1.2.3, [info@winimage.com])
|
|
||||||
+
|
|
||||||
+AC_PROG_LIBTOOL
|
|
||||||
+
|
|
||||||
+AM_INIT_AUTOMAKE([1.9 tar-ustar dist-bzip2 dist-zip])
|
|
||||||
+AM_CONFIG_HEADER([config.h])
|
|
||||||
+
|
|
||||||
+AC_LANG_C
|
|
||||||
+AC_PROG_CC
|
|
||||||
+AC_PROG_INSTALL
|
|
||||||
+
|
|
||||||
+AC_OUTPUT(Makefile minizip.pc)
|
|
||||||
diff -rN -U 5 zlib-1.2.3.orig/contrib/minizip/Makefile.am zlib-1.2.3.patched/contrib/minizip/Makefile.am
|
|
||||||
--- zlib-1.2.3.orig/contrib/minizip/Makefile.am 1969-12-31 17:00:00.000000000 -0700
|
|
||||||
+++ zlib-1.2.3.patched/contrib/minizip/Makefile.am 2007-06-28 15:01:34.000000000 -0600
|
|
||||||
@@ -0,0 +1,39 @@
|
|
||||||
+METASOURCES = AUTO
|
|
||||||
+
|
|
||||||
+pkgconfigdir = $(libdir)/pkgconfig
|
|
||||||
+pkgconfig_DATA = minizip.pc
|
|
||||||
+
|
|
||||||
+lib_LTLIBRARIES = libminizip.la
|
|
||||||
+library_includedir = $(prefix)/include/minizip
|
|
||||||
+
|
|
||||||
+libminizip_la_SOURCES = \
|
|
||||||
+ ioapi.c \
|
|
||||||
+ mztools.c \
|
|
||||||
+ unzip.c \
|
|
||||||
+ zip.c
|
|
||||||
+
|
|
||||||
+libminizip_la_LDFLAGS = -version-number 1:0:1
|
|
||||||
+
|
|
||||||
+library_include_HEADERS = \
|
|
||||||
+ crypt.h \
|
|
||||||
+ ioapi.h \
|
|
||||||
+ mztools.h \
|
|
||||||
+ unzip.h \
|
|
||||||
+ zip.h
|
|
||||||
+
|
|
||||||
+EXTRA_DIST = \
|
|
||||||
+ crypt.h \
|
|
||||||
+ ioapi.h \
|
|
||||||
+ mztools.h \
|
|
||||||
+ unzip.h \
|
|
||||||
+ zip.h
|
|
||||||
+
|
|
||||||
+bin_PROGRAMS = miniunzip minizip
|
|
||||||
+
|
|
||||||
+miniunzip_SOURCES = miniunz.c
|
|
||||||
+miniunzip_LDADD = -L$(top_builddir) -lminizip -lz
|
|
||||||
+
|
|
||||||
+minizip_SOURCES = minizip.c
|
|
||||||
+minizip_LDADD = -L$(top_builddir) -lminizip -lz
|
|
||||||
+
|
|
||||||
+
|
|
||||||
diff -rN -U 5 zlib-1.2.3.orig/contrib/minizip/minizip.pc.in zlib-1.2.3.patched/contrib/minizip/minizip.pc.in
|
|
||||||
--- zlib-1.2.3.orig/contrib/minizip/minizip.pc.in 1969-12-31 17:00:00.000000000 -0700
|
|
||||||
+++ zlib-1.2.3.patched/contrib/minizip/minizip.pc.in 2007-06-28 14:55:38.000000000 -0600
|
|
||||||
@@ -0,0 +1,11 @@
|
|
||||||
+prefix=@prefix@
|
|
||||||
+exec_prefix=@exec_prefix@
|
|
||||||
+libdir=@libdir@
|
|
||||||
+includedir=@includedir@
|
|
||||||
+
|
|
||||||
+Name: @PACKAGE_NAME@
|
|
||||||
+Description: Minizip zip file manipulation library
|
|
||||||
+Requires:
|
|
||||||
+Version: @PACKAGE_VERSION@
|
|
||||||
+Libs: -L${libdir} -lminizip -lz
|
|
||||||
+Cflags: -I${includedir}
|
|
||||||
diff -rN -U 5 zlib-1.2.3.orig/contrib/minizip/minizip.spec zlib-1.2.3.patched/contrib/minizip/minizip.spec
|
|
||||||
--- zlib-1.2.3.orig/contrib/minizip/minizip.spec 1969-12-31 17:00:00.000000000 -0700
|
|
||||||
+++ zlib-1.2.3.patched/contrib/minizip/minizip.spec 2007-07-01 00:00:41.000000000 -0600
|
|
||||||
@@ -0,0 +1,76 @@
|
|
||||||
+Summary: Minizip manipulates files from a .zip archive
|
|
||||||
+Name: minizip
|
|
||||||
+Version: 1.2.3
|
|
||||||
+Release: 1
|
|
||||||
+License: BSD
|
|
||||||
+Group: System Environment/Libraries
|
|
||||||
+URL: http://www.winimage.com/zLibDll/minizip.html
|
|
||||||
+Source0: http://www.zlib.net/zlib-%{version}.tar.gz
|
|
||||||
+Patch0: minizip-%{version}-autotools.patch
|
|
||||||
+Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
||||||
+BuildRequires: automake, autoconf, libtool
|
|
||||||
+BuildRequires: zlib-devel >= %{version}
|
|
||||||
+
|
|
||||||
+%description
|
|
||||||
+Minizip manipulates files from a .zip archive
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%package devel
|
|
||||||
+Summary: Development files for the minizip library
|
|
||||||
+Group: Development/Libraries
|
|
||||||
+Requires: %{name} = %{version}-%{release}
|
|
||||||
+BuildRequires: zlib-devel >= %{version}
|
|
||||||
+
|
|
||||||
+%description devel
|
|
||||||
+This package contains the libraries and header files needed for
|
|
||||||
+developing applications which use minizip.
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%prep
|
|
||||||
+%setup -q -n zlib-%{version}
|
|
||||||
+%patch0 -p1
|
|
||||||
+
|
|
||||||
+%build
|
|
||||||
+cd contrib/minizip
|
|
||||||
+sh autogen.sh
|
|
||||||
+%configure --enable-static=no
|
|
||||||
+# SMP flags are explicitly omitted due to a libtool/autoconf
|
|
||||||
+# dependency race condition
|
|
||||||
+%{__make}
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%install
|
|
||||||
+cd contrib/minizip
|
|
||||||
+%{__rm} -rf %{buildroot}
|
|
||||||
+
|
|
||||||
+%{__make} DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
|
|
||||||
+find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%clean
|
|
||||||
+%{__rm} -rf %{buildroot}
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%post -p /sbin/ldconfig
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%postun -p /sbin/ldconfig
|
|
||||||
+
|
|
||||||
+
|
|
||||||
+%files
|
|
||||||
+%defattr(-,root,root,-)
|
|
||||||
+%doc contrib/minizip/ChangeLogUnzip
|
|
||||||
+%{_bindir}/minizip
|
|
||||||
+%{_bindir}/miniunzip
|
|
||||||
+%{_libdir}/libminizip.so.*
|
|
||||||
+
|
|
||||||
+%files devel
|
|
||||||
+%defattr(-,root,root,-)
|
|
||||||
+%{_includedir}/minizip
|
|
||||||
+%{_libdir}/libminizip.so
|
|
||||||
+%{_libdir}/pkgconfig/minizip.pc
|
|
||||||
+
|
|
||||||
+%changelog
|
|
||||||
+* Sat Jun 30 2007 Rick L Vinyard Jr <rvinyard@cs.nmsu.edu> - 1.2.3-1
|
|
||||||
+- Initial version
|
|
||||||
+
|
|
@ -1,77 +1,115 @@
|
|||||||
--- /dev/null 2007-02-20 10:06:12.587494888 +0100
|
diff -urN zlib-1.2.3.orig/Makefile.am zlib-1.2.3.kasal/Makefile.am
|
||||||
+++ zlib-1.2.3/Makefile.am 2007-02-20 13:22:36.000000000 +0100
|
--- zlib-1.2.3.orig/Makefile.am 1970-01-01 01:00:00.000000000 +0100
|
||||||
@@ -0,0 +1,19 @@
|
+++ zlib-1.2.3.kasal/Makefile.am 2009-03-17 17:58:36.000000000 +0100
|
||||||
|
@@ -0,0 +1,67 @@
|
||||||
|
+ACLOCAL_AMFLAGS = -I m4 --install
|
||||||
|
+
|
||||||
+lib_LTLIBRARIES = libz.la
|
+lib_LTLIBRARIES = libz.la
|
||||||
+
|
+
|
||||||
+libz_la_SOURCES = \
|
+libz_la_SOURCES = \
|
||||||
+ adler32.c \
|
+ adler32.c \
|
||||||
+ compress.c \
|
+ compress.c \
|
||||||
+ crc32.c \
|
+ crc32.c \
|
||||||
|
+ crc32.h \
|
||||||
+ gzio.c \
|
+ gzio.c \
|
||||||
+ uncompr.c \
|
+ uncompr.c \
|
||||||
+ deflate.c \
|
+ deflate.c \
|
||||||
|
+ deflate.h \
|
||||||
+ trees.c \
|
+ trees.c \
|
||||||
|
+ trees.h \
|
||||||
+ zutil.c \
|
+ zutil.c \
|
||||||
|
+ zutil.h \
|
||||||
+ inflate.c \
|
+ inflate.c \
|
||||||
|
+ inflate.h \
|
||||||
+ infback.c \
|
+ infback.c \
|
||||||
+ inftrees.c \
|
+ inftrees.c \
|
||||||
+ inffast.c
|
+ inftrees.h \
|
||||||
|
+ inffast.c \
|
||||||
|
+ inffast.h \
|
||||||
|
+ infflate.h
|
||||||
+
|
+
|
||||||
+libz_la_LDFLAGS = \
|
+# Use -version-number to match the file name used before autoconfiscation.
|
||||||
+ -version-number 1:2:3
|
+libz_la_LDFLAGS = -version-number 1:2:3
|
||||||
+
|
+
|
||||||
--- /dev/null 2007-02-20 10:06:12.587494888 +0100
|
+include_HEADERS = zlib.h
|
||||||
+++ zlib-1.2.3/configure.ac 2007-02-20 13:22:46.000000000 +0100
|
+nodist_include_HEADERS = zconf.h
|
||||||
@@ -0,0 +1,52 @@
|
+
|
||||||
|
+dist_man_MANS = zlib.3
|
||||||
|
+
|
||||||
|
+## libminizip:
|
||||||
|
+
|
||||||
|
+lib_LTLIBRARIES += libminizip.la
|
||||||
|
+
|
||||||
|
+libminizip_la_SOURCES = \
|
||||||
|
+ contrib/minizip/ioapi.c \
|
||||||
|
+ contrib/minizip/mztools.c \
|
||||||
|
+ contrib/minizip/unzip.c \
|
||||||
|
+ contrib/minizip/zip.c
|
||||||
|
+
|
||||||
|
+# do not build the static version of libminizip
|
||||||
|
+libminizip_la_CFLAGS = -shared
|
||||||
|
+libminizip_la_LDFLAGS = -version-info 1:0:0
|
||||||
|
+libminizip_la_LIBADD = libz.la
|
||||||
|
+
|
||||||
|
+minizip_includedir = $(includedir)/minizip
|
||||||
|
+minizip_include_HEADERS = \
|
||||||
|
+ contrib/minizip/crypt.h \
|
||||||
|
+ contrib/minizip/ioapi.h \
|
||||||
|
+ contrib/minizip/mztools.h \
|
||||||
|
+ contrib/minizip/unzip.h \
|
||||||
|
+ contrib/minizip/zip.h
|
||||||
|
+
|
||||||
|
+pkgconfigdir = $(libdir)/pkgconfig
|
||||||
|
+pkgconfig_DATA = minizip.pc
|
||||||
|
+
|
||||||
|
+EXTRA_PROGRAMS = miniunzip minizip
|
||||||
|
+
|
||||||
|
+miniunzip_SOURCES = contrib/minizip/miniunz.c
|
||||||
|
+miniunzip_LDADD = libminizip.la
|
||||||
|
+
|
||||||
|
+minizip_SOURCES = contrib/minizip/minizip.c
|
||||||
|
+minizip_LDADD = libminizip.la
|
||||||
|
diff -urN zlib-1.2.3.orig/configure.ac zlib-1.2.3.kasal/configure.ac
|
||||||
|
--- zlib-1.2.3.orig/configure.ac 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ zlib-1.2.3.kasal/configure.ac 2009-03-17 17:28:41.000000000 +0100
|
||||||
|
@@ -0,0 +1,13 @@
|
||||||
+# -*- Autoconf -*-
|
+# -*- Autoconf -*-
|
||||||
+# Process this file with autoconf to produce a configure script.
|
+# Process this file with autoconf to produce a configure script.
|
||||||
+
|
+
|
||||||
+AC_PREREQ(2.59)
|
+AC_INIT([zlib], [1.2.3], [bugzilla.redhat.com])
|
||||||
+AC_INIT([zlib], 1.2.3, [bugzilla.redhat.com])
|
|
||||||
+AC_CONFIG_SRCDIR([minigzip.c])
|
+AC_CONFIG_SRCDIR([minigzip.c])
|
||||||
+AC_CONFIG_HEADER([config.h])
|
+AC_CONFIG_MACRO_DIR([m4])
|
||||||
+AM_INIT_AUTOMAKE([-Wall foreign])
|
+AM_INIT_AUTOMAKE([foreign])
|
||||||
|
+LT_INIT
|
||||||
+
|
+
|
||||||
+# Checks for programs.
|
+AC_SUBST([HAVE_UNISTD_H], [0])
|
||||||
+AC_PROG_CXX
|
+AC_CHECK_HEADER([unistd.h], [HAVE_UNISTD_H=1], [])
|
||||||
+AC_PROG_CC
|
+AC_CONFIG_FILES([Makefile minizip.pc zconf.h:zconf.in.h])
|
||||||
+AC_PROG_CPP
|
|
||||||
+AC_PROG_INSTALL
|
|
||||||
+AC_PROG_LN_S
|
|
||||||
+AC_PROG_MAKE_SET
|
|
||||||
+AC_PROG_LIBTOOL
|
|
||||||
+
|
|
||||||
+# Checks for libraries.
|
|
||||||
+# FIXME: Replace `main' with a function in `-lz':
|
|
||||||
+AC_CHECK_LIB([z], [main])
|
|
||||||
+
|
|
||||||
+# Checks for header files.
|
|
||||||
+AC_HEADER_STDC
|
|
||||||
+AC_CHECK_HEADERS([fcntl.h limits.h malloc.h stddef.h stdlib.h string.h sys/file.h unistd.h utime.h])
|
|
||||||
+
|
|
||||||
+# Checks for typedefs, structures, and compiler characteristics.
|
|
||||||
+AC_HEADER_STDBOOL
|
|
||||||
+AC_C_CONST
|
|
||||||
+AC_C_INLINE
|
|
||||||
+AC_TYPE_OFF_T
|
|
||||||
+AC_TYPE_SIZE_T
|
|
||||||
+AC_STRUCT_TM
|
|
||||||
+AC_C_VOLATILE
|
|
||||||
+AC_CHECK_TYPES([ptrdiff_t])
|
|
||||||
+
|
|
||||||
+# Checks for library functions.
|
|
||||||
+AC_FUNC_CHOWN
|
|
||||||
+AC_FUNC_ERROR_AT_LINE
|
|
||||||
+AC_FUNC_FSEEKO
|
|
||||||
+AC_FUNC_MALLOC
|
|
||||||
+AC_FUNC_MEMCMP
|
|
||||||
+AC_FUNC_MKTIME
|
|
||||||
+AC_FUNC_MMAP
|
|
||||||
+AC_FUNC_REALLOC
|
|
||||||
+AC_FUNC_STAT
|
|
||||||
+AC_FUNC_UTIME_NULL
|
|
||||||
+AC_FUNC_VPRINTF
|
|
||||||
+AC_CHECK_FUNCS([ftruncate memmove memset mkdir munmap strdup strerror strrchr strtol utime])
|
|
||||||
+
|
|
||||||
+AC_CONFIG_FILES([Makefile])
|
|
||||||
+AC_OUTPUT
|
+AC_OUTPUT
|
||||||
|
diff -urN zlib-1.2.3.orig/minizip.pc.in zlib-1.2.3.kasal/minizip.pc.in
|
||||||
|
--- zlib-1.2.3.orig/minizip.pc.in 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ zlib-1.2.3.kasal/minizip.pc.in 2009-01-07 15:49:34.000000000 +0100
|
||||||
|
@@ -0,0 +1,11 @@
|
||||||
|
+prefix=@prefix@
|
||||||
|
+exec_prefix=@exec_prefix@
|
||||||
|
+libdir=@libdir@
|
||||||
|
+includedir=@includedir@/minizip
|
||||||
|
+
|
||||||
|
+Name: minizip
|
||||||
|
+Description: Minizip zip file manipulation library
|
||||||
|
+Requires:
|
||||||
|
+Version: @PACKAGE_VERSION@
|
||||||
|
+Libs: -L${libdir} -lminizip -lz
|
||||||
|
+Cflags: -I${includedir}
|
||||||
|
diff -urN zlib-1.2.3.orig/zconf.in.h zlib-1.2.3.kasal/zconf.in.h
|
||||||
|
--- zlib-1.2.3.orig/zconf.in.h 2005-05-28 08:40:35.000000000 +0200
|
||||||
|
+++ zlib-1.2.3.kasal/zconf.in.h 2009-03-17 17:17:11.000000000 +0100
|
||||||
|
@@ -284,7 +284,7 @@
|
||||||
|
typedef Byte *voidp;
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if 0 /* HAVE_UNISTD_H -- this line is updated by ./configure */
|
||||||
|
+#if @HAVE_UNISTD_H@ /* HAVE_UNISTD_H -- this line is updated by ./configure */
|
||||||
|
# include <sys/types.h> /* for off_t */
|
||||||
|
# include <unistd.h> /* for SEEK_* and off_t */
|
||||||
|
# ifdef VMS
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up zlib-1.2.3/contrib/minizip/minizip.pc.in.pom zlib-1.2.3/contrib/minizip/minizip.pc.in
|
|
||||||
--- zlib-1.2.3/contrib/minizip/minizip.pc.in.pom 2007-11-23 11:00:38.000000000 +0100
|
|
||||||
+++ zlib-1.2.3/contrib/minizip/minizip.pc.in 2007-11-23 11:01:37.000000000 +0100
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
prefix=@prefix@
|
|
||||||
exec_prefix=@exec_prefix@
|
|
||||||
libdir=@libdir@
|
|
||||||
-includedir=@includedir@
|
|
||||||
+includedir=@includedir@/minizip
|
|
||||||
|
|
||||||
Name: @PACKAGE_NAME@
|
|
||||||
Description: Minizip zip file manipulation library
|
|
49
zlib.spec
49
zlib.spec
@ -1,12 +1,10 @@
|
|||||||
Summary: The zlib compression and decompression library
|
Summary: The zlib compression and decompression library
|
||||||
Name: zlib
|
Name: zlib
|
||||||
Version: 1.2.3
|
Version: 1.2.3
|
||||||
Release: 20%{?dist}
|
Release: 21%{?dist}
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: http://www.zlib.net/zlib-%{version}.tar.gz
|
Source: http://www.zlib.net/zlib-%{version}.tar.gz
|
||||||
Patch3: zlib-1.2.3-autotools.patch
|
Patch3: zlib-1.2.3-autotools.patch
|
||||||
Patch4: minizip-1.2.3-autotools.patch
|
|
||||||
Patch5: zlib-1.2.3-minizip.patch
|
|
||||||
Patch6: minizip-1.2.3-malloc.patch
|
Patch6: minizip-1.2.3-malloc.patch
|
||||||
URL: http://www.gzip.org/zlib/
|
URL: http://www.gzip.org/zlib/
|
||||||
License: zlib
|
License: zlib
|
||||||
@ -58,9 +56,9 @@ developing applications which use minizip.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch3 -p1 -b .autotools
|
%patch3 -p1 -b .atools
|
||||||
%patch4 -p1 -b .autotools2
|
# patch cannot create an empty dir
|
||||||
%patch5 -p1 -b .inc
|
mkdir m4
|
||||||
%patch6 -p1 -b .mal
|
%patch6 -p1 -b .mal
|
||||||
iconv -f windows-1252 -t utf-8 <ChangeLog >ChangeLog.tmp
|
iconv -f windows-1252 -t utf-8 <ChangeLog >ChangeLog.tmp
|
||||||
mv ChangeLog.tmp ChangeLog
|
mv ChangeLog.tmp ChangeLog
|
||||||
@ -71,45 +69,18 @@ autoreconf --install;
|
|||||||
%configure
|
%configure
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
cd contrib/minizip
|
|
||||||
export CPPFLAGS="-I../.."
|
|
||||||
export LDFLAGS="-L../.."
|
|
||||||
sh autogen.sh
|
|
||||||
%configure --enable-static=no
|
|
||||||
make
|
|
||||||
|
|
||||||
%check
|
%check
|
||||||
make test -f Makefile.old
|
make test -f Makefile.old
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT libdir=/%{_lib}
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
|
|
||||||
mkdir $RPM_BUILD_ROOT%{_prefix}
|
mkdir $RPM_BUILD_ROOT/%{_lib}
|
||||||
mkdir $RPM_BUILD_ROOT%{_libdir}/
|
mv $RPM_BUILD_ROOT%{_libdir}/libz.so.* $RPM_BUILD_ROOT/%{_lib}/
|
||||||
mv $RPM_BUILD_ROOT/%{_lib}/libz.a $RPM_BUILD_ROOT/%{_libdir}/
|
|
||||||
mv $RPM_BUILD_ROOT/%{_lib}/libz.so $RPM_BUILD_ROOT/%{_libdir}/
|
|
||||||
|
|
||||||
ln -sf ../../%{_lib}/libz.so.%{version} $RPM_BUILD_ROOT/%{_libdir}/libz.so
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
|
||||||
mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
|
|
||||||
cp -p zconf.h ${RPM_BUILD_ROOT}%{_includedir}
|
|
||||||
cp -p zlib.h ${RPM_BUILD_ROOT}%{_includedir}
|
|
||||||
|
|
||||||
mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
|
|
||||||
cp -p zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
|
|
||||||
|
|
||||||
# Remove unuseful files created by libtool
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_lib}/libz.la
|
|
||||||
|
|
||||||
# install minizip subpackage
|
|
||||||
cd contrib/minizip
|
|
||||||
|
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_bindir}/miniunzip
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_bindir}/minizip
|
|
||||||
rm -f $RPM_BUILD_ROOT/%{_libdir}/libminizip.la
|
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -154,6 +125,10 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%{_libdir}/pkgconfig/minizip.pc
|
%{_libdir}/pkgconfig/minizip.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 17 2009 Stepan Kasal <skasal@redhat.com> - 1.2.3-21
|
||||||
|
- consolidate the autoconfiscation patches into one and clean it up
|
||||||
|
- consequently, clean up the %%build and %%install sections
|
||||||
|
|
||||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-20
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.3-20
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user