Fix the Crash in zlib deflateBound() function on s390x
Source: 113203437e..f6d382a91a
Resolves: #2193045
This commit is contained in:
parent
24443be426
commit
5fb24ceb29
@ -0,0 +1,17 @@
|
|||||||
|
--- zlib-1.2.11/contrib/s390/dfltcc_deflate.h.old 2023-05-04 09:39:23.423753908 +0000
|
||||||
|
+++ zlib-1.2.11/contrib/s390/dfltcc_deflate.h 2023-05-04 09:39:48.087753908 +0000
|
||||||
|
@@ -45,11 +45,11 @@ int ZLIB_INTERNAL dfltcc_deflate_get_dic
|
||||||
|
#define DEFLATE_DONE dfltcc_deflate_done
|
||||||
|
#define DEFLATE_BOUND_ADJUST_COMPLEN(strm, complen, source_len) \
|
||||||
|
do { \
|
||||||
|
- if (dfltcc_can_deflate((strm))) \
|
||||||
|
+ if (deflateStateCheck((strm)) || dfltcc_can_deflate((strm))) \
|
||||||
|
(complen) = DEFLATE_BOUND_COMPLEN(source_len); \
|
||||||
|
} while (0)
|
||||||
|
#define DEFLATE_NEED_CONSERVATIVE_BOUND(strm) (dfltcc_can_deflate((strm)))
|
||||||
|
#define DEFLATE_HOOK dfltcc_deflate
|
||||||
|
#define DEFLATE_NEED_CHECKSUM(strm) (!dfltcc_can_deflate((strm)))
|
||||||
|
|
||||||
|
-#endif
|
||||||
|
\ No newline at end of file
|
||||||
|
+#endif
|
10
zlib.spec
10
zlib.spec
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: zlib
|
Name: zlib
|
||||||
Version: 1.2.11
|
Version: 1.2.11
|
||||||
Release: 24%{?dist}
|
Release: 25%{?dist}
|
||||||
Summary: The compression and decompression library
|
Summary: The compression and decompression library
|
||||||
# /contrib/dotzlib/ have Boost license
|
# /contrib/dotzlib/ have Boost license
|
||||||
License: zlib and Boost
|
License: zlib and Boost
|
||||||
@ -57,6 +57,9 @@ Patch20: zlib-1.2.11-Fix-broken-libxml2-for-python311.patch
|
|||||||
# fixed covscan issues
|
# fixed covscan issues
|
||||||
Patch21: zlib-1.2.11-covscan-issues.patch
|
Patch21: zlib-1.2.11-covscan-issues.patch
|
||||||
|
|
||||||
|
# Fix for Crash in zlib deflateBound() function on s390x
|
||||||
|
# Resolves: #2193045
|
||||||
|
Patch22: zlib-1.2.11-IBM-Z-hw-accelrated-deflate-fix-crash-deflateBound.patch
|
||||||
|
|
||||||
BuildRequires: automake, autoconf, libtool
|
BuildRequires: automake, autoconf, libtool
|
||||||
|
|
||||||
@ -129,6 +132,7 @@ developing applications which use minizip.
|
|||||||
%patch19 -p1
|
%patch19 -p1
|
||||||
%patch20 -p1
|
%patch20 -p1
|
||||||
%patch21 -p1
|
%patch21 -p1
|
||||||
|
%patch22 -p1
|
||||||
|
|
||||||
|
|
||||||
iconv -f iso-8859-2 -t utf-8 < ChangeLog > ChangeLog.tmp
|
iconv -f iso-8859-2 -t utf-8 < ChangeLog > ChangeLog.tmp
|
||||||
@ -209,6 +213,10 @@ find $RPM_BUILD_ROOT -name '*.la' -delete
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 16 2023 Lukas Javorsky <ljavorsk@redhat.com> - 1.2.11-25
|
||||||
|
- Fix the Crash in zlib deflateBound() function on s390x
|
||||||
|
- Resolves: BZ#2193045
|
||||||
|
|
||||||
* Tue May 16 2023 Lukas Javorsky <ljavorsk@redhat.com> - 1.2.11-24
|
* Tue May 16 2023 Lukas Javorsky <ljavorsk@redhat.com> - 1.2.11-24
|
||||||
- Resolve fuzzing issue for unknown memory access
|
- Resolve fuzzing issue for unknown memory access
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user