bdc6cda6a9
- Adapt the "apropos" patch for 2.19.1. - The "posix-man" patch appears to no longer apply. - Update dependencies based on configure.ac.
13 lines
472 B
Diff
13 lines
472 B
Diff
--- yelp-2.19.1/src/yelp-search-parser.c.typo 2007-08-02 12:15:30.000000000 -0400
|
|
+++ yelp-2.19.1/src/yelp-search-parser.c 2007-08-02 12:18:05.000000000 -0400
|
|
@@ -398,6 +398,9 @@ hits_added_cb (BeagleQuery *query, Beagl
|
|
static gboolean
|
|
check_lang (const char *lang) {
|
|
int i;
|
|
+
|
|
+ const gchar * const * langs = g_get_language_names ();
|
|
+
|
|
for (i = 0; langs[i]; i++) {
|
|
if (!strncmp (lang, langs[i], 2)) {
|
|
debug_print (DB_DEBUG, "%s preferred\n", lang);
|