- Update to 2.19.1
- Adapt the "apropos" patch for 2.19.1. - The "posix-man" patch appears to no longer apply. - Update dependencies based on configure.ac.
This commit is contained in:
parent
9896e1dcb2
commit
bdc6cda6a9
@ -1 +1 @@
|
||||
yelp-2.18.1.tar.bz2
|
||||
yelp-2.19.1.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
84abbfe7e042706cbf21752957e29bf3 yelp-2.18.1.tar.bz2
|
||||
2febfd558fc7ccec592c2234c297f5df yelp-2.19.1.tar.bz2
|
||||
|
@ -1,30 +0,0 @@
|
||||
--- yelp-2.16.0/src/yelp-search-pager.c.apropos 2006-11-03 14:06:37.000000000 -0500
|
||||
+++ yelp-2.16.0/src/yelp-search-pager.c 2006-11-03 14:32:34.000000000 -0500
|
||||
@@ -2039,8 +2039,16 @@
|
||||
gchar *title = NULL;
|
||||
/*gint i;*/
|
||||
|
||||
- if (line == NULL || line[0] == NULL || line[1] == NULL)
|
||||
- continue;
|
||||
+ if (line == NULL || line[0] == NULL || line[1] == NULL)
|
||||
+ goto done;
|
||||
+
|
||||
+ /* RH man inserts rpm references into the whatis database */
|
||||
+ if (g_str_has_prefix (line[1], "rpm)"))
|
||||
+ goto done;
|
||||
+
|
||||
+ tmp = strchr (line[0], ' ');
|
||||
+ if (tmp)
|
||||
+ *tmp = '\0';
|
||||
|
||||
title = g_strdup (g_strstrip (line[0]));
|
||||
after = strstr (line[1], ")");
|
||||
@@ -2068,6 +2076,8 @@
|
||||
xmlNewChild (child, NULL, BAD_CAST "score",
|
||||
BAD_CAST "0.1");
|
||||
g_free (tmp);
|
||||
+
|
||||
+done:
|
||||
g_strfreev (line);
|
||||
}
|
||||
|
28
yelp-2.19.1-apropos.patch
Normal file
28
yelp-2.19.1-apropos.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- yelp-2.19.1/src/yelp-search-parser.c.apropos 2007-08-02 10:27:12.000000000 -0400
|
||||
+++ yelp-2.19.1/src/yelp-search-parser.c 2007-08-02 10:29:09.000000000 -0400
|
||||
@@ -1294,7 +1294,15 @@ process_man_result (YelpSearchParser *pa
|
||||
/*gint i;*/
|
||||
|
||||
if (line == NULL || line[0] == NULL || line[1] == NULL)
|
||||
- continue;
|
||||
+ goto done;
|
||||
+
|
||||
+ /* RH man inserts rpm references into the whatis database */
|
||||
+ if (g_str_has_prefix (line[1], "rpm)"))
|
||||
+ goto done;
|
||||
+
|
||||
+ tmp = strchr (line[0], ' ');
|
||||
+ if (tmp)
|
||||
+ *tmp = '\0';
|
||||
|
||||
title = g_strdup (g_strstrip (line[0]));
|
||||
after = strstr (line[1], ")");
|
||||
@@ -1322,6 +1330,8 @@ process_man_result (YelpSearchParser *pa
|
||||
xmlNewChild (child, NULL, BAD_CAST "score",
|
||||
BAD_CAST "0.1");
|
||||
g_free (tmp);
|
||||
+
|
||||
+done:
|
||||
g_strfreev (line);
|
||||
}
|
||||
|
12
yelp-2.19.1-typo.patch
Normal file
12
yelp-2.19.1-typo.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- yelp-2.19.1/src/yelp-search-parser.c.typo 2007-08-02 12:15:30.000000000 -0400
|
||||
+++ yelp-2.19.1/src/yelp-search-parser.c 2007-08-02 12:18:05.000000000 -0400
|
||||
@@ -398,6 +398,9 @@ hits_added_cb (BeagleQuery *query, Beagl
|
||||
static gboolean
|
||||
check_lang (const char *lang) {
|
||||
int i;
|
||||
+
|
||||
+ const gchar * const * langs = g_get_language_names ();
|
||||
+
|
||||
for (i = 0; langs[i]; i++) {
|
||||
if (!strncmp (lang, langs[i], 2)) {
|
||||
debug_print (DB_DEBUG, "%s preferred\n", lang);
|
41
yelp.spec
41
yelp.spec
@ -3,38 +3,41 @@
|
||||
%define WITH_MONO 0
|
||||
%endif
|
||||
|
||||
%define pango_version 1.0.99
|
||||
%define gtk2_version 2.6.0
|
||||
%define gecko_version 1.8.1.5
|
||||
%define gnome_doc_utils 0.11.1
|
||||
%define gnome_vfs2_version 2.0.0
|
||||
%define libgnomeui_version 2.0.2
|
||||
%define libbonobo_version 2.0.0
|
||||
%define gtk2_version 2.10.0
|
||||
%define libglade_version 2.0.0
|
||||
%define libgnomeui_version 2.14.0
|
||||
%define libxml_version 2.6.5
|
||||
%define libxslt_version 1.1.4
|
||||
%define desktop_file_utils_version 0.3-7
|
||||
%define gail_version 1.0
|
||||
%define startup_notification_version 0.8
|
||||
%define rarian_version 0.5.0
|
||||
%define gecko_version 1.8.1.5
|
||||
|
||||
%define pango_version 1.0.99
|
||||
%define desktop_file_utils_version 0.3-7
|
||||
|
||||
Summary: A system documentation reader from the Gnome project
|
||||
Name: yelp
|
||||
Version: 2.18.1
|
||||
Release: 7%{?dist}
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/yelp/2.18/%{name}-%{version}.tar.bz2
|
||||
Version: 2.19.1
|
||||
Release: 1%{?dist}
|
||||
Source: http://ftp.gnome.org/pub/GNOME/sources/yelp/2.19/%{name}-%{version}.tar.bz2
|
||||
URL: http://live.gnome.org/Yelp
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=319096
|
||||
Patch1: yelp-2.15.5-fedora-docs.patch
|
||||
Patch2: yelp-2.13.2-add-mime-handling.patch
|
||||
Patch3: yelp-2.15.91-use-pango.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=370167
|
||||
Patch5: yelp-2.16.0-apropos.patch
|
||||
Patch5: yelp-2.19.1-apropos.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=430365
|
||||
Patch6: yelp-2.18.1-info-bc-crash.patch
|
||||
Patch7: yelp-2.18.1-info-gnutls.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=431077
|
||||
Patch8: yelp-2.18.1-posix-man.patch
|
||||
# XXX Does this no longer apply to yelp >= 2.19.1 ?
|
||||
#Patch8: yelp-2.18.1-posix-man.patch
|
||||
# http://bugzilla.gnome.org/show_bug.cgi?id=431078
|
||||
Patch9: yelp-2.18.1-man-xrefs.patch
|
||||
Patch10: yelp-2.19.1-typo.patch
|
||||
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
@ -43,12 +46,11 @@ Requires: gtk2 >= %{gtk2_version}
|
||||
Requires: gnome-vfs2 >= %{gnome_vfs2_version}
|
||||
Requires: gecko-libs = %{gecko_version}
|
||||
Requires: libgnomeui >= %{libgnomeui_version}
|
||||
Requires: libbonobo >= %{libbonobo_version}
|
||||
Requires: libxml2 >= %{libxml_version}
|
||||
Requires: libxslt >= %{libxslt_version}
|
||||
Requires: libglade2 >= %{libglade_version}
|
||||
Requires: gnome-doc-utils-stylesheets
|
||||
Requires: scrollkeeper
|
||||
Requires: rarian >= %{rarian_version}
|
||||
Requires(pre): GConf2
|
||||
Requires(post): GConf2
|
||||
Requires(post): desktop-file-utils
|
||||
@ -59,11 +61,9 @@ BuildRequires: gtk2-devel >= %{gtk2_version}
|
||||
BuildRequires: gnome-vfs2-devel >= %{gnome_vfs2_version}
|
||||
BuildRequires: gecko-devel = %{gecko_version}
|
||||
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
|
||||
BuildRequires: libbonobo-devel >= %{libbonobo_version}
|
||||
BuildRequires: libglade2-devel >= %{libglade_version}
|
||||
BuildRequires: libxml2-devel >= %{libxml_version}
|
||||
BuildRequires: libxslt-devel >= %{libxslt_version}
|
||||
BuildRequires: gail-devel >= %{gail_version}
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: fontconfig
|
||||
BuildRequires: GConf2-devel
|
||||
@ -94,8 +94,9 @@ one central tool.
|
||||
%patch5 -p1 -b .apropos
|
||||
%patch6 -p1 -b .info-bc-crash
|
||||
%patch7 -p1 -b .info-gnutls
|
||||
%patch8 -p1 -b .posix-man
|
||||
#%patch8 -p1 -b .posix-man
|
||||
%patch9 -p1 -b .man-xrefs
|
||||
%patch10 -p1 -b .typo
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -160,6 +161,12 @@ update-desktop-database &> /dev/null ||:
|
||||
%{_datadir}/yelp
|
||||
|
||||
%changelog
|
||||
* Thu Aug 02 2007 Matthew Barnes <mbarnes@redhat.com> - 2.19.1-1
|
||||
- Update to 2.19.1
|
||||
- Adapt the "apropos" patch for 2.19.1.
|
||||
- The "posix-man" patch appears to no longer apply.
|
||||
- Update dependencies based on configure.ac.
|
||||
|
||||
* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 2.18.1-7
|
||||
- rebuild for toolchain bug
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user