Always install int10 and vbe sdk headers
This commit is contained in:
parent
7a546491ef
commit
f8a5524403
78
0001-Always-install-vbe-and-int10-sdk-headers.patch
Normal file
78
0001-Always-install-vbe-and-int10-sdk-headers.patch
Normal file
@ -0,0 +1,78 @@
|
|||||||
|
From a309d8f77319e88df9efa0fd2b2cdf0bc0ad7f0f Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Wed, 15 Aug 2012 12:35:21 -0400
|
||||||
|
Subject: [PATCH] Always install vbe and int10 sdk headers
|
||||||
|
|
||||||
|
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
||||||
|
---
|
||||||
|
hw/xfree86/Makefile.am | 12 ++----------
|
||||||
|
hw/xfree86/int10/Makefile.am | 8 ++++++--
|
||||||
|
hw/xfree86/vbe/Makefile.am | 2 ++
|
||||||
|
3 files changed, 10 insertions(+), 12 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
|
||||||
|
index c3899b5..f190b40 100644
|
||||||
|
--- a/hw/xfree86/Makefile.am
|
||||||
|
+++ b/hw/xfree86/Makefile.am
|
||||||
|
@@ -17,17 +17,9 @@ if VGAHW
|
||||||
|
VGAHW_SUBDIR = vgahw
|
||||||
|
endif
|
||||||
|
|
||||||
|
-if VBE
|
||||||
|
-VBE_SUBDIR = vbe
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
-if INT10MODULE
|
||||||
|
-INT10_SUBDIR = int10
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
-SUBDIRS = common ddc x86emu $(INT10_SUBDIR) os-support parser \
|
||||||
|
+SUBDIRS = common ddc x86emu int10 os-support parser \
|
||||||
|
ramdac $(VGAHW_SUBDIR) loader modes $(DRI_SUBDIR) \
|
||||||
|
- $(DRI2_SUBDIR) . $(VBE_SUBDIR) i2c dixmods \
|
||||||
|
+ $(DRI2_SUBDIR) . vbe i2c dixmods \
|
||||||
|
fbdevhw shadowfb exa $(XF86UTILS_SUBDIR) doc man
|
||||||
|
|
||||||
|
DIST_SUBDIRS = common ddc i2c x86emu int10 fbdevhw os-support \
|
||||||
|
diff --git a/hw/xfree86/int10/Makefile.am b/hw/xfree86/int10/Makefile.am
|
||||||
|
index f5ece69..9afad2f 100644
|
||||||
|
--- a/hw/xfree86/int10/Makefile.am
|
||||||
|
+++ b/hw/xfree86/int10/Makefile.am
|
||||||
|
@@ -1,7 +1,9 @@
|
||||||
|
-module_LTLIBRARIES = libint10.la
|
||||||
|
-
|
||||||
|
sdk_HEADERS = xf86int10.h
|
||||||
|
|
||||||
|
+if INT10MODULE
|
||||||
|
+
|
||||||
|
+module_LTLIBRARIES = libint10.la
|
||||||
|
+
|
||||||
|
EXTRA_CFLAGS =
|
||||||
|
|
||||||
|
libint10_la_LDFLAGS = -avoid-version
|
||||||
|
@@ -43,4 +45,6 @@ INCLUDES = $(XORG_INCS)
|
||||||
|
libint10_la_SOURCES = stub.c xf86int10module.c
|
||||||
|
endif
|
||||||
|
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
EXTRA_DIST = xf86x86emu.h INT10.HOWTO
|
||||||
|
diff --git a/hw/xfree86/vbe/Makefile.am b/hw/xfree86/vbe/Makefile.am
|
||||||
|
index 0b24faf..f0a9831 100644
|
||||||
|
--- a/hw/xfree86/vbe/Makefile.am
|
||||||
|
+++ b/hw/xfree86/vbe/Makefile.am
|
||||||
|
@@ -1,9 +1,11 @@
|
||||||
|
+if VBE
|
||||||
|
module_LTLIBRARIES = libvbe.la
|
||||||
|
libvbe_la_LDFLAGS = -module -avoid-version $(LD_NO_UNDEFINED_FLAG)
|
||||||
|
libvbe_la_SOURCES = vbe.c vbeModes.c vbe_module.c
|
||||||
|
if NO_UNDEFINED
|
||||||
|
libvbe_la_LIBADD = ../int10/libint10.la
|
||||||
|
endif
|
||||||
|
+endif
|
||||||
|
|
||||||
|
sdk_HEADERS = vbe.h vbeModes.h
|
||||||
|
|
||||||
|
--
|
||||||
|
1.7.7.6
|
||||||
|
|
@ -43,7 +43,7 @@
|
|||||||
Summary: X.Org X11 X server
|
Summary: X.Org X11 X server
|
||||||
Name: xorg-x11-server
|
Name: xorg-x11-server
|
||||||
Version: 1.12.99.904
|
Version: 1.12.99.904
|
||||||
Release: 1%{?gitdate:.%{gitdate}}%{dist}
|
Release: 2%{?gitdate:.%{gitdate}}%{dist}
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -98,6 +98,7 @@ Patch7020: xserver-1.12-xkb-fill-in-keycode-and-event-type-for-slow-keys-ena.pat
|
|||||||
Patch7022: 0001-linux-Refactor-xf86-En-Dis-ableIO.patch
|
Patch7022: 0001-linux-Refactor-xf86-En-Dis-ableIO.patch
|
||||||
Patch7023: 0002-linux-Make-failure-to-iopl-non-fatal.patch
|
Patch7023: 0002-linux-Make-failure-to-iopl-non-fatal.patch
|
||||||
Patch7024: 0003-xfree86-Change-the-semantics-of-driverFunc-GET_REQUI.patch
|
Patch7024: 0003-xfree86-Change-the-semantics-of-driverFunc-GET_REQUI.patch
|
||||||
|
Patch7025: 0001-Always-install-vbe-and-int10-sdk-headers.patch
|
||||||
|
|
||||||
%define moduledir %{_libdir}/xorg/modules
|
%define moduledir %{_libdir}/xorg/modules
|
||||||
%define drimoduledir %{_libdir}/dri
|
%define drimoduledir %{_libdir}/dri
|
||||||
@ -571,6 +572,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{xserver_source_dir}
|
%{xserver_source_dir}
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 15 2012 Adam Jackson <ajax@redhat.com> 1.12.99.904-2
|
||||||
|
- Always install int10 and vbe sdk headers
|
||||||
|
|
||||||
* Wed Aug 08 2012 Dave Airlie <airlied@redhat.com> 1.12.99.904-1
|
* Wed Aug 08 2012 Dave Airlie <airlied@redhat.com> 1.12.99.904-1
|
||||||
- rebase to 1.12.99.904 snapshot
|
- rebase to 1.12.99.904 snapshot
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user