rebase to 1.12.99.904 snapshot

This commit is contained in:
Dave Airlie 2012-08-08 19:40:42 +10:00
parent a33d443916
commit 7a546491ef
6 changed files with 22 additions and 136 deletions

1
.gitignore vendored
View File

@ -17,3 +17,4 @@ xorg-server-1.9.1.tar.bz2
/xorg-server-1.12.3.tar.bz2
/xorg-server-20120717.tar.xz
/xorg-server-20120726.tar.xz
/xorg-server-20120808.tar.xz

View File

@ -1 +1 @@
afa53fe7cffd430cf11f25ca818cb955a78c0c1c
c22c936b35cee60609041ccb7ee52c00b0634d7b

View File

@ -1 +1 @@
cf47efdea83833e3348f1f7adcd19d57 xorg-server-20120726.tar.xz
c6b0c5843a14b4d1ee967050a665ef64 xorg-server-20120808.tar.xz

View File

@ -9,7 +9,7 @@
# check out the master branch, pull, cherry-pick, and push. FIXME describe
# rebasing, add convenience 'make' targets maybe.
%define gitdate 20120726
%define gitdate 20120808
%define stable_abi 1
%if !0%{?gitdate} || %{stable_abi}
@ -42,8 +42,8 @@
Summary: X.Org X11 X server
Name: xorg-x11-server
Version: 1.12.99.903
Release: 6%{?gitdate:.%{gitdate}}%{dist}
Version: 1.12.99.904
Release: 1%{?gitdate:.%{gitdate}}%{dist}
URL: http://www.x.org
License: MIT
Group: User Interface/X
@ -95,8 +95,6 @@ Patch7017: xserver-1.12.2-xorg-touch-test.patch
# send keycode/event type for slow keys enable (#816764)
Patch7020: xserver-1.12-xkb-fill-in-keycode-and-event-type-for-slow-keys-ena.patch
Patch7021: xserver-1.12.99-glx-fix.patch
Patch7022: 0001-linux-Refactor-xf86-En-Dis-ableIO.patch
Patch7023: 0002-linux-Make-failure-to-iopl-non-fatal.patch
Patch7024: 0003-xfree86-Change-the-semantics-of-driverFunc-GET_REQUI.patch
@ -573,6 +571,9 @@ rm -rf $RPM_BUILD_ROOT
%{xserver_source_dir}
%changelog
* Wed Aug 08 2012 Dave Airlie <airlied@redhat.com> 1.12.99.904-1
- rebase to 1.12.99.904 snapshot
* Fri Aug 03 2012 Adam Jackson <ajax@redhat.com> 1.12.99.903-6
- Make failure to iopl non-fatal

View File

@ -1,117 +0,0 @@
From a1d813974e482efdc7010a31a18f651aba844f8e Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@redhat.com>
Date: Wed, 25 Jul 2012 13:25:04 +1000
Subject: [PATCH] glx: drop GLX_LIBS from X server and workaround sdksyms.
We've had reports of two copies of the GLX bits, one in the server
and one in libglx.so causing problems, I didn't understand why the
X server needed a copy so drop it, however then we have to fix a missing
GlxExtensionInit that comes from sdksyms, so work around it by moving
that one declaration into a header that sdksyms doesn't scan.
Thanks to Jon Turney for debugging the actual problem.
Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=52402
Signed-off-by: Dave Airlie <airlied@redhat.com>
---
configure.ac | 2 +-
glx/glxext.c | 1 +
hw/dmx/glxProxy/glxext.c | 1 +
hw/xfree86/dixmods/glxmodule.c | 1 +
hw/xwin/InitOutput.c | 1 +
include/extinit.h | 1 -
include/glx_extinit.h | 9 +++++++++
7 files changed, 14 insertions(+), 2 deletions(-)
create mode 100644 include/glx_extinit.h
diff --git a/configure.ac b/configure.ac
index bf6868e..78aeb34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1600,7 +1600,7 @@ if test "x$XORG" = xyes; then
XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
XORG_INCS="$XORG_DDXINCS $XORG_OSINCS"
XORG_CFLAGS="$XORGSERVER_CFLAGS -DHAVE_XORG_CONFIG_H"
- XORG_LIBS="$COMPOSITE_LIB $FIXES_LIB $XEXT_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $XI_LIB $XKB_LIB"
+ XORG_LIBS="$COMPOSITE_LIB $FIXES_LIB $XEXT_LIB $DBE_LIB $RECORD_LIB $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $XI_LIB $XKB_LIB"
dnl ==================================================================
dnl symbol visibility
diff --git a/glx/glxext.c b/glx/glxext.c
index 70f0df8..bc7fe82 100644
--- a/glx/glxext.c
+++ b/glx/glxext.c
@@ -40,6 +40,7 @@
#include "privates.h"
#include <os.h>
#include "extinit.h"
+#include "glx_extinit.h"
#include "unpack.h"
#include "glxutil.h"
#include "glxext.h"
diff --git a/hw/dmx/glxProxy/glxext.c b/hw/dmx/glxProxy/glxext.c
index 8122221..e72a040 100644
--- a/hw/dmx/glxProxy/glxext.c
+++ b/hw/dmx/glxProxy/glxext.c
@@ -45,6 +45,7 @@
#include "micmap.h"
#include "glxswap.h"
#include "extinit.h"
+#include "glx_extinit.h"
/*
** Forward declarations.
diff --git a/hw/xfree86/dixmods/glxmodule.c b/hw/xfree86/dixmods/glxmodule.c
index 5a9e845..c0c6114 100644
--- a/hw/xfree86/dixmods/glxmodule.c
+++ b/hw/xfree86/dixmods/glxmodule.c
@@ -43,6 +43,7 @@ SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
#include "globals.h"
#include "glxserver.h"
#include "extinit.h"
+#include "glx_extinit.h"
static MODULESETUPPROTO(glxSetup);
diff --git a/hw/xwin/InitOutput.c b/hw/xwin/InitOutput.c
index 538b2e1..37cd8b3 100644
--- a/hw/xwin/InitOutput.c
+++ b/hw/xwin/InitOutput.c
@@ -55,6 +55,7 @@ typedef WINAPI HRESULT(*SHGETFOLDERPATHPROC) (HWND hwndOwner,
DWORD dwFlags, LPTSTR pszPath);
#endif
+#include "glx_extinit.h"
/*
* References to external symbols
*/
diff --git a/include/extinit.h b/include/extinit.h
index 6c5337f..7f4718f 100644
--- a/include/extinit.h
+++ b/include/extinit.h
@@ -83,7 +83,6 @@ extern void GEExtensionInit(void);
#ifdef GLXEXT
extern _X_EXPORT Bool noGlxExtension;
-extern void GlxExtensionInit(void);
#endif
#ifdef PANORAMIX
diff --git a/include/glx_extinit.h b/include/glx_extinit.h
new file mode 100644
index 0000000..eef55eb
--- /dev/null
+++ b/include/glx_extinit.h
@@ -0,0 +1,9 @@
+#ifndef GLX_EXT_INIT_H
+#define GLX_EXT_INIT_H
+
+/* this is separate due to sdksyms pulling in extinit.h */
+#ifdef GLXEXT
+extern void GlxExtensionInit(void);
+#endif
+
+#endif
--
1.7.11.2

View File

@ -1,7 +1,7 @@
From d91c3a11db2657e33087464463c9aa44aaf5c8b8 Mon Sep 17 00:00:00 2001
From 291bc9f827188461ff9717efccec1e350db537e8 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Tue, 28 Jul 2009 11:07:13 -0400
Subject: [PATCH 4/7] RANDR: right-of placement by default
Subject: [PATCH 3/7] RANDR: right-of placement by default
[Enhanced to add a new prefer clone option for drivers. This
allows for servers like RN50 where two heads are disjoint. - airlied]
@ -11,10 +11,10 @@ allows for servers like RN50 where two heads are disjoint. - airlied]
2 files changed, 75 insertions(+), 9 deletions(-)
diff --git a/hw/xfree86/common/xf86str.h b/hw/xfree86/common/xf86str.h
index 6294845..7d1fbab 100644
index 0590262..d246634 100644
--- a/hw/xfree86/common/xf86str.h
+++ b/hw/xfree86/common/xf86str.h
@@ -497,10 +497,13 @@ typedef struct _confdrirec {
@@ -508,10 +508,13 @@ typedef struct _confdrirec {
} confDRIRec, *confDRIPtr;
/* These values should be adjusted when new fields are added to ScrnInfoRec */
@ -29,7 +29,7 @@ index 6294845..7d1fbab 100644
typedef pointer (*funcPointer) (void);
/* flags for depth 24 pixmap options */
@@ -758,6 +761,9 @@ typedef struct _ScrnInfoRec {
@@ -769,6 +772,9 @@ typedef struct _ScrnInfoRec {
ClockRangePtr clockRanges;
int adjustFlags;
@ -40,10 +40,10 @@ index 6294845..7d1fbab 100644
* These can be used when the minor ABI version is incremented.
* The NUM_* parameters must be reduced appropriately to keep the
diff --git a/hw/xfree86/modes/xf86Crtc.c b/hw/xfree86/modes/xf86Crtc.c
index 6d5e92f..7d560f4 100644
index 154f684..c58088d 100644
--- a/hw/xfree86/modes/xf86Crtc.c
+++ b/hw/xfree86/modes/xf86Crtc.c
@@ -1114,6 +1114,15 @@ xf86InitialOutputPositions(ScrnInfoPtr scrn, DisplayModePtr * modes)
@@ -1130,6 +1130,15 @@ xf86InitialOutputPositions(ScrnInfoPtr scrn, DisplayModePtr * modes)
int o;
int min_x, min_y;
@ -59,7 +59,7 @@ index 6d5e92f..7d560f4 100644
for (o = 0; o < config->num_output; o++) {
xf86OutputPtr output = config->output[o];
@@ -1982,6 +1991,57 @@ bestModeForAspect(xf86CrtcConfigPtr config, Bool *enabled, float aspect)
@@ -1998,6 +2007,57 @@ bestModeForAspect(xf86CrtcConfigPtr config, Bool *enabled, float aspect)
return match;
}
@ -117,12 +117,13 @@ index 6d5e92f..7d560f4 100644
static Bool
xf86TargetPreferred(ScrnInfoPtr scrn, xf86CrtcConfigPtr config,
DisplayModePtr * modes, Bool *enabled,
@@ -2058,13 +2118,9 @@ xf86TargetPreferred(ScrnInfoPtr scrn, xf86CrtcConfigPtr config,
@@ -2074,14 +2134,10 @@ xf86TargetPreferred(ScrnInfoPtr scrn, xf86CrtcConfigPtr config,
*/
if (!ret)
do {
- int i = 0;
float aspect = 0.0;
DisplayModePtr a = NULL, b = NULL;
- /* count the number of enabled outputs */
- for (i = 0, p = -1; nextEnabledOutput(config, enabled, &p); i++);
@ -132,7 +133,7 @@ index 6d5e92f..7d560f4 100644
break;
p = -1;
@@ -2365,6 +2421,8 @@ xf86InitialConfiguration(ScrnInfoPtr scrn, Bool canGrow)
@@ -2385,6 +2441,8 @@ xf86InitialConfiguration(ScrnInfoPtr scrn, Bool canGrow)
else {
if (xf86TargetUserpref(scrn, config, modes, enabled, width, height))
xf86DrvMsg(i, X_INFO, "Using user preference for initial modes\n");
@ -141,7 +142,7 @@ index 6d5e92f..7d560f4 100644
else if (xf86TargetPreferred
(scrn, config, modes, enabled, width, height))
xf86DrvMsg(i, X_INFO, "Using exact sizes for initial modes\n");
@@ -2384,9 +2442,11 @@ xf86InitialConfiguration(ScrnInfoPtr scrn, Bool canGrow)
@@ -2404,9 +2462,11 @@ xf86InitialConfiguration(ScrnInfoPtr scrn, Bool canGrow)
"Output %s enabled but has no modes\n",
config->output[o]->name);
else
@ -157,5 +158,5 @@ index 6d5e92f..7d560f4 100644
/*
--
1.7.10.1
1.7.10.4