updated to 1.24.1
This commit is contained in:
parent
1051106385
commit
fcc383c9df
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
|||||||
/xmlrpc-c-1.23.02.tar.xz
|
/xmlrpc-c-1.23.02.tar.xz
|
||||||
|
/xmlrpc-c-1.24.1.tar.xz
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
4bac3875a7fce8e6ec1ccf388a363e34 xmlrpc-c-1.23.02.tar.xz
|
75b39b63879aadda7978741edc57cff1 xmlrpc-c-1.24.1.tar.xz
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 6184291f61b4779feafb728b19cf2ed6806926f7 Mon Sep 17 00:00:00 2001
|
From 6c47c68ec5ab953c9846a9bb83cbe598e1a5802c Mon Sep 17 00:00:00 2001
|
||||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||||
Date: Sat, 5 Apr 2008 10:55:02 +0200
|
Date: Sat, 5 Apr 2008 10:55:02 +0200
|
||||||
Subject: [PATCH 1/7] make -> cmake transition
|
Subject: [PATCH 1/7] make -> cmake transition
|
||||||
@ -11,7 +11,7 @@ Subject: [PATCH 1/7] make -> cmake transition
|
|||||||
examples/config.h | 1 +
|
examples/config.h | 1 +
|
||||||
examples/cpp/CMakeLists.txt | 34 ++++
|
examples/cpp/CMakeLists.txt | 34 ++++
|
||||||
include/CMakeLists.txt | 3 +
|
include/CMakeLists.txt | 3 +
|
||||||
include/xmlrpc-c/CMakeLists.txt | 73 +++++++
|
include/xmlrpc-c/CMakeLists.txt | 74 +++++++
|
||||||
include/xmlrpc-c/config.h.cmake | 32 +++
|
include/xmlrpc-c/config.h.cmake | 32 +++
|
||||||
lib/CMakeLists.txt | 12 ++
|
lib/CMakeLists.txt | 12 ++
|
||||||
lib/abyss/CMakeLists.txt | 3 +
|
lib/abyss/CMakeLists.txt | 3 +
|
||||||
@ -62,7 +62,7 @@ Subject: [PATCH 1/7] make -> cmake transition
|
|||||||
version.h.cmake | 5 +
|
version.h.cmake | 5 +
|
||||||
xmlrpc-c-config | 105 ++++++++++
|
xmlrpc-c-config | 105 ++++++++++
|
||||||
xmlrpc_config.h.cmake | 145 ++++++++++++++
|
xmlrpc_config.h.cmake | 145 ++++++++++++++
|
||||||
58 files changed, 1524 insertions(+), 0 deletions(-)
|
58 files changed, 1525 insertions(+), 0 deletions(-)
|
||||||
create mode 100644 CMakeLists.txt
|
create mode 100644 CMakeLists.txt
|
||||||
create mode 100644 cmake/try-attr.cc
|
create mode 100644 cmake/try-attr.cc
|
||||||
create mode 100644 cmake/va-list-is-array.c
|
create mode 100644 cmake/va-list-is-array.c
|
||||||
@ -124,7 +124,7 @@ Subject: [PATCH 1/7] make -> cmake transition
|
|||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..e778403
|
index 0000000..2781200
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -0,0 +1,284 @@
|
@@ -0,0 +1,284 @@
|
||||||
@ -142,8 +142,8 @@ index 0000000..e778403
|
|||||||
+
|
+
|
||||||
+
|
+
|
||||||
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
|
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
|
||||||
+set(XMLRPC_C_VERSION_MINOR "23" CACHE STRING "Version (minor) of xmlrpc-c")
|
+set(XMLRPC_C_VERSION_MINOR "24" CACHE STRING "Version (minor) of xmlrpc-c")
|
||||||
+set(XMLRPC_C_VERSION_POINT "02" CACHE STRING "Version (point) of xmlrpc-c")
|
+set(XMLRPC_C_VERSION_POINT "1" CACHE STRING "Version (point) of xmlrpc-c")
|
||||||
+
|
+
|
||||||
+set(XMLRPC_C_VERSION
|
+set(XMLRPC_C_VERSION
|
||||||
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
|
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
|
||||||
@ -560,10 +560,10 @@ index 0000000..ebfdba5
|
|||||||
+add_subdirectory(xmlrpc-c)
|
+add_subdirectory(xmlrpc-c)
|
||||||
diff --git a/include/xmlrpc-c/CMakeLists.txt b/include/xmlrpc-c/CMakeLists.txt
|
diff --git a/include/xmlrpc-c/CMakeLists.txt b/include/xmlrpc-c/CMakeLists.txt
|
||||||
new file mode 100644
|
new file mode 100644
|
||||||
index 0000000..2b305b7
|
index 0000000..b9386b8
|
||||||
--- /dev/null
|
--- /dev/null
|
||||||
+++ b/include/xmlrpc-c/CMakeLists.txt
|
+++ b/include/xmlrpc-c/CMakeLists.txt
|
||||||
@@ -0,0 +1,73 @@
|
@@ -0,0 +1,74 @@
|
||||||
+# -*- cmake -*-
|
+# -*- cmake -*-
|
||||||
+
|
+
|
||||||
+macro(ensc_install_symlink src dst)
|
+macro(ensc_install_symlink src dst)
|
||||||
@ -576,6 +576,7 @@ index 0000000..2b305b7
|
|||||||
+ c_util.h
|
+ c_util.h
|
||||||
+ util.h
|
+ util.h
|
||||||
+ base.h
|
+ base.h
|
||||||
|
+ json.h
|
||||||
+ abyss.h
|
+ abyss.h
|
||||||
+ abyss_unixsock.h
|
+ abyss_unixsock.h
|
||||||
+ abyss_winsock.h
|
+ abyss_winsock.h
|
||||||
@ -1995,5 +1996,5 @@ index 0000000..bb5931a
|
|||||||
+
|
+
|
||||||
+#endif
|
+#endif
|
||||||
--
|
--
|
||||||
1.7.2.1
|
1.7.2.3
|
||||||
|
|
||||||
|
@ -1,12 +1,35 @@
|
|||||||
From ba314cf0305759708075fb52e67b4ac1183b02a8 Mon Sep 17 00:00:00 2001
|
From c06a722a77198ae42fb79b67d185556ac6c1e246 Mon Sep 17 00:00:00 2001
|
||||||
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
|
||||||
Date: Mon, 25 Feb 2008 17:48:25 +0100
|
Date: Mon, 25 Feb 2008 17:48:25 +0100
|
||||||
Subject: [PATCH 2/7] fixed broken format string modifiers for size_t typed arguments
|
Subject: [PATCH 2/7] fixed broken format string modifiers
|
||||||
|
|
||||||
---
|
---
|
||||||
|
examples/json.c | 4 ++--
|
||||||
tools/xmlrpc_pstream/xmlrpc_pstream.cpp | 2 +-
|
tools/xmlrpc_pstream/xmlrpc_pstream.cpp | 2 +-
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/examples/json.c b/examples/json.c
|
||||||
|
index 89fe82b..91ea50d 100644
|
||||||
|
--- a/examples/json.c
|
||||||
|
+++ b/examples/json.c
|
||||||
|
@@ -41,7 +41,7 @@ printAsXml(xmlrpc_value * const valP) {
|
||||||
|
printf("XML-RPC XML:\n");
|
||||||
|
|
||||||
|
printf("%.*s\n",
|
||||||
|
- XMLRPC_MEMBLOCK_SIZE(char, &out),
|
||||||
|
+ (int)XMLRPC_MEMBLOCK_SIZE(char, &out),
|
||||||
|
XMLRPC_MEMBLOCK_CONTENTS(char, &out));
|
||||||
|
|
||||||
|
XMLRPC_MEMBLOCK_CLEAN(char, &out);
|
||||||
|
@@ -70,7 +70,7 @@ printAsJson(xmlrpc_value * const valP) {
|
||||||
|
printf("JSON:\n");
|
||||||
|
|
||||||
|
printf("%.*s\n",
|
||||||
|
- XMLRPC_MEMBLOCK_SIZE(char, &out),
|
||||||
|
+ (int)XMLRPC_MEMBLOCK_SIZE(char, &out),
|
||||||
|
XMLRPC_MEMBLOCK_CONTENTS(char, &out));
|
||||||
|
|
||||||
|
XMLRPC_MEMBLOCK_CLEAN(char, &out);
|
||||||
diff --git a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
diff --git a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
||||||
index 1417708..0d6ec11 100644
|
index 1417708..0d6ec11 100644
|
||||||
--- a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
--- a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp
|
||||||
@ -21,5 +44,5 @@ index 1417708..0d6ec11 100644
|
|||||||
else {
|
else {
|
||||||
vector<unsigned char> byteString(valueString.length() / 2);
|
vector<unsigned char> byteString(valueString.length() / 2);
|
||||||
--
|
--
|
||||||
1.7.1.1
|
1.7.2.3
|
||||||
|
|
||||||
|
@ -1,11 +1,11 @@
|
|||||||
%global advanced_branch 1
|
%global advanced_branch 1
|
||||||
%global svnrev 1968
|
%global svnrev 1987
|
||||||
|
|
||||||
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
|
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
|
||||||
|
|
||||||
Summary: A lightweight RPC library based on XML and HTTP
|
Summary: A lightweight RPC library based on XML and HTTP
|
||||||
Name: xmlrpc-c
|
Name: xmlrpc-c
|
||||||
Version: 1.23.02
|
Version: 1.24.1
|
||||||
Release: %release_func 1500.svn%svnrev
|
Release: %release_func 1500.svn%svnrev
|
||||||
# See COPYING for details.
|
# See COPYING for details.
|
||||||
# The Python 1.5.2 license used by a few files is just BSD.
|
# The Python 1.5.2 license used by a few files is just BSD.
|
||||||
@ -123,7 +123,7 @@ rm doc/{INSTALL,configure_doc}
|
|||||||
%build
|
%build
|
||||||
mkdir -p fedora
|
mkdir -p fedora
|
||||||
cd fedora
|
cd fedora
|
||||||
export CFLAGS="$RPM_OPT_FLAGS"
|
export CFLAGS="$RPM_OPT_FLAGS -Wno-uninitialized"
|
||||||
export CXXFLAGS="$RPM_OPT_FLAGS"
|
export CXXFLAGS="$RPM_OPT_FLAGS"
|
||||||
export LDFLAGS="-Wl,-as-needed"
|
export LDFLAGS="-Wl,-as-needed"
|
||||||
cmake .. \
|
cmake .. \
|
||||||
@ -233,6 +233,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Oct 9 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.24.1-1500.svn1987
|
||||||
|
- updated to 1.24.1
|
||||||
|
- set -Wno-uninitialized CFLAGS; code contains lot of constructs
|
||||||
|
triggering this warning and the 'int a=a' defeaters have been
|
||||||
|
removed in this version
|
||||||
|
|
||||||
* Fri Aug 27 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.23.02-1500.svn1968
|
* Fri Aug 27 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.23.02-1500.svn1968
|
||||||
- updated to 1.23.02 (note: this breaks C++ ABI)
|
- updated to 1.23.02 (note: this breaks C++ ABI)
|
||||||
- added vasprintf patch
|
- added vasprintf patch
|
||||||
|
Loading…
Reference in New Issue
Block a user