- updated to 1.23.02 (note: this breaks C++ ABI)

- added vasprintf patch
This commit is contained in:
Enrico Scholz 2010-08-27 19:40:38 +02:00
parent 88ef8de651
commit 1051106385
6 changed files with 59 additions and 12 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
xmlrpc-c-1.22.01.tar.bz2
/xmlrpc-c-1.23.02.tar.xz

View File

@ -1 +1 @@
1958
1968

View File

@ -1 +1 @@
6187e37798c741367723186f73feabb6 xmlrpc-c-1.23.01.tar.xz
4bac3875a7fce8e6ec1ccf388a363e34 xmlrpc-c-1.23.02.tar.xz

View File

@ -0,0 +1,41 @@
From 122cc57fd2501cabdec64c56c01ebfd7d380cb72 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Thu, 29 Jul 2010 19:43:08 +0200
Subject: [PATCH 7/7] check vasprintf return value
---
lib/libutil/asprintf.c | 3 ++-
lib/util/casprintf.c | 3 ++-
2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/lib/libutil/asprintf.c b/lib/libutil/asprintf.c
index bb4ca56..2c5ce7f 100644
--- a/lib/libutil/asprintf.c
+++ b/lib/libutil/asprintf.c
@@ -100,7 +100,8 @@ xmlrpc_vasprintf(const char ** const retvalP,
char * string;
#if HAVE_ASPRINTF
- vasprintf(&string, fmt, varargs);
+ if (vasprintf(&string, fmt, varargs) < 0)
+ string = NULL;
#else
simpleVasprintf(&string, fmt, varargs);
#endif
diff --git a/lib/util/casprintf.c b/lib/util/casprintf.c
index 643f145..9139253 100644
--- a/lib/util/casprintf.c
+++ b/lib/util/casprintf.c
@@ -99,7 +99,8 @@ cvasprintf(const char ** const retvalP,
char * string;
#if HAVE_ASPRINTF
- vasprintf(&string, fmt, varargs);
+ if (vasprintf(&string, fmt, varargs) < 0)
+ string = NULL;
#else
simpleVasprintf(&string, fmt, varargs);
#endif
--
1.7.2.1

View File

@ -1,4 +1,4 @@
From 9e7ac208115346e42c70cd5c11f59898d2e3bda2 Mon Sep 17 00:00:00 2001
From 6184291f61b4779feafb728b19cf2ed6806926f7 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH 1/7] make -> cmake transition
@ -124,7 +124,7 @@ Subject: [PATCH 1/7] make -> cmake transition
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..88e70d3
index 0000000..e778403
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,284 @@
@ -143,7 +143,7 @@ index 0000000..88e70d3
+
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "23" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "01" CACHE STRING "Version (point) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "02" CACHE STRING "Version (point) of xmlrpc-c")
+
+set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -152,8 +152,8 @@ index 0000000..88e70d3
+set(XMLRPC_C_LIBVERSION "3.${XMLRPC_C_VERSION_MINOR}")
+set(XMLRPC_C_SOVERSION "3")
+
+set(XMLRPC_CXX_LIBVERSION "6.${XMLRPC_C_VERSION_MINOR}")
+set(XMLRPC_CXX_SOVERSION "6")
+set(XMLRPC_CXX_LIBVERSION "7.${XMLRPC_C_VERSION_MINOR}")
+set(XMLRPC_CXX_SOVERSION "7")
+
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_MAJOR_NUM "${XMLRPC_C_VERSION_MAJOR}")
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_MINOR_NUM "${XMLRPC_C_VERSION_MINOR}")
@ -1995,5 +1995,5 @@ index 0000000..bb5931a
+
+#endif
--
1.7.1.1
1.7.2.1

View File

@ -1,11 +1,11 @@
%global advanced_branch 1
%global svnrev 1958
%global svnrev 1968
%{!?release_func:%global release_func() %%{?prerelease:0.}%1%%{?prerelease:.%%prerelease}%%{?dist}}
Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c
Version: 1.23.01
Version: 1.23.02
Release: %release_func 1500.svn%svnrev
# See COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD.
@ -26,6 +26,7 @@ Patch102: xmlrpc-c-printf-size_t.patch
Patch105: xmlrpc-c-longlong.patch
Patch107: xmlrpc-c-uninit-curl.patch
Patch108: xmlrpc-c-30x-redirect.patch
Patch109: xmlrpc-c-check-vasprintf-return-value.patch
BuildRoot: %_tmppath/%name-%version-%release-root
@ -113,6 +114,7 @@ This package contains some handy XML-RPC demo applications.
%patch105 -p1
%patch107 -p1
%patch108 -p1
%patch109 -p1
## not needed...
rm doc/{INSTALL,configure_doc}
@ -198,7 +200,7 @@ rm -rf $RPM_BUILD_ROOT
%files c++
%defattr(-,root,root,-)
%_libdir/*.so.6*
%_libdir/*.so.7*
%exclude %_libdir/libxmlrpc_client++.so*
@ -231,6 +233,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Fri Aug 27 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.23.02-1500.svn1968
- updated to 1.23.02 (note: this breaks C++ ABI)
- added vasprintf patch
* Thu Jul 29 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.23.01-1400.svn1958
- updated to 1.23.01
- added patch to make curl follow HTTP POST 301 redirects (#618504)