- updated to 1.21.00 (rev 1851)

- removed curl-trace patch as applied upstream
- rediffed patches
This commit is contained in:
ensc 2010-01-14 21:27:46 +00:00
parent e904bc0f13
commit 0b94a9f14d
12 changed files with 111 additions and 90 deletions

View File

@ -1 +1 @@
xmlrpc-c-1.20.3.tar.bz2
xmlrpc-c-1.21.00.tar.bz2

View File

@ -1,9 +1,10 @@
# Makefile for source rpm: xmlrpc-c
NAME := xmlrpc-c
SPECFILE = $(firstword $(wildcard *.spec))
CVS ?= cvs
define find-makefile-common
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$d/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$d/Makefile.common ] ; then cd $$d ; $(CVS) -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
endef
MAKEFILE_COMMON := $(shell $(find-makefile-common))
@ -11,7 +12,7 @@ MAKEFILE_COMMON := $(shell $(find-makefile-common))
ifeq ($(MAKEFILE_COMMON),)
# attept a checkout
define checkout-makefile-common
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
test -f CVS/Root && { $(CVS) -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
endef
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))

View File

@ -1 +1 @@
1.20.03
1851

View File

@ -1 +1 @@
d987c3d989ca1a4774ce12fada437238 xmlrpc-c-1.20.3.tar.bz2
c0fe943c3097a50474de5728a1423b20 xmlrpc-c-1.21.00.tar.bz2

View File

@ -1,2 +1,2 @@
http://xmlrpc-c.sourceforge.net/change_advanced.html
Release (1\.[0-9.]+)[<>/h2p\s]*Released
http://xmlrpc-c.svn.sourceforge.net/viewvc/xmlrpc-c/advanced/
revision=([0-9]+)

View File

@ -1,10 +1,10 @@
From da14b3bc703ec3ec2b8332e2d9452d9526f3c1af Mon Sep 17 00:00:00 2001
From ea80db5265eac761ecb90c92ee7712fcaf014730 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 10:55:02 +0200
Subject: [PATCH 1/6] make -> cmake transition
Subject: [PATCH 1/5] make -> cmake transition
---
CMakeLists.txt | 279 +++++++++++++++++++++++++++
CMakeLists.txt | 286 +++++++++++++++++++++++++++
cmake/try-attr.cc | 3 +
cmake/va-list-is-array.c | 9 +
examples/CMakeLists.txt | 57 ++++++
@ -12,24 +12,24 @@ Subject: [PATCH 1/6] make -> cmake transition
examples/cpp/CMakeLists.txt | 34 ++++
include/CMakeLists.txt | 3 +
include/xmlrpc-c/CMakeLists.txt | 73 +++++++
include/xmlrpc-c/config.h.cmake | 30 +++
include/xmlrpc-c/config.h.cmake | 32 +++
lib/CMakeLists.txt | 12 ++
lib/abyss/CMakeLists.txt | 3 +
lib/abyss/src/CMakeLists.txt | 66 +++++++
lib/abyss/src/CMakeLists.txt | 66 ++++++
lib/abyss/src/xmlrpc_abyss.pc.cmake | 12 ++
lib/curl_transport/CMakeLists.txt | 20 ++
lib/expat/CMakeLists.txt | 9 +
lib/expat/gennmtab/CMakeLists.txt | 3 +
lib/expat/xmlparse/CMakeLists.txt | 7 +
lib/expat/xmlparse/xmlrpc_xmlparse.pc.cmake | 12 ++
lib/expat/xmltok/CMakeLists.txt | 22 ++
lib/expat/xmltok/CMakeLists.txt | 23 +++
lib/expat/xmltok/xmlrpc_xmltok.pc.cmake | 9 +
lib/libutil/CMakeLists.txt | 25 +++
lib/libutil/xmlrpc_util.pc.cmake | 10 +
lib/libwww_transport/CMakeLists.txt | 7 +
lib/util/CMakeLists.txt | 17 ++
lib/wininet_transport/CMakeLists.txt | 7 +
src/CMakeLists.txt | 121 ++++++++++++
src/CMakeLists.txt | 121 +++++++++++
src/cpp/CMakeLists.txt | 70 +++++++
src/cpp/test/CMakeLists.txt | 17 ++
src/cpp/xmlrpc++.pc.cmake | 12 ++
@ -60,9 +60,9 @@ Subject: [PATCH 1/6] make -> cmake transition
tools/xmlrpc_transport/config.h | 1 +
transport_config.h.cmake | 16 ++
version.h.cmake | 5 +
xmlrpc-c-config | 108 +++++++++++
xmlrpc_config.h.cmake | 105 ++++++++++
58 files changed, 1473 insertions(+), 0 deletions(-)
xmlrpc-c-config | 108 ++++++++++
xmlrpc_config.h.cmake | 141 +++++++++++++
58 files changed, 1519 insertions(+), 0 deletions(-)
create mode 100644 CMakeLists.txt
create mode 100644 cmake/try-attr.cc
create mode 100644 cmake/va-list-is-array.c
@ -124,10 +124,10 @@ Subject: [PATCH 1/6] make -> cmake transition
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..3b8ad6a
index 0000000..dd162fd
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,279 @@
@@ -0,0 +1,286 @@
+## -*- cmake -*-
+project(xmlrpc-c)
+include(FindPkgConfig)
@ -142,8 +142,8 @@ index 0000000..3b8ad6a
+
+
+set(XMLRPC_C_VERSION_MAJOR "1" CACHE STRING "Version (major) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "20" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "03" CACHE STRING "Version (point) of xmlrpc-c")
+set(XMLRPC_C_VERSION_MINOR "21" CACHE STRING "Version (minor) of xmlrpc-c")
+set(XMLRPC_C_VERSION_POINT "00" CACHE STRING "Version (point) of xmlrpc-c")
+
+set(XMLRPC_C_VERSION
+ "${XMLRPC_C_VERSION_MAJOR}.${XMLRPC_C_VERSION_MINOR}.${XMLRPC_C_VERSION_POINT}"
@ -157,7 +157,7 @@ index 0000000..3b8ad6a
+
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_MAJOR_NUM "${XMLRPC_C_VERSION_MAJOR}")
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_MINOR_NUM "${XMLRPC_C_VERSION_MINOR}")
+string(REGEX REPLACE "^0+" "" XMLRPC_C_VERSION_POINT_NUM "${XMLRPC_C_VERSION_POINT}")
+string(REGEX REPLACE "^0+(.)" "\\1" XMLRPC_C_VERSION_POINT_NUM "${XMLRPC_C_VERSION_POINT}")
+
+
+macro(ensc_set_bool NAME VALUE DESC)
@ -339,12 +339,19 @@ index 0000000..3b8ad6a
+ set(DIRECTORY_SEPARATOR "/")
+endif(WIN32)
+
+check_include_file(sys/filio.h HAVE_SYS_FILIO_H)
+check_include_file(sys/ioctl.h HAVE_SYS_IOCTL_H)
+check_include_file(sys/filio.h HAVE_SYS_FILIO_H)
+check_include_file(sys/ioctl.h HAVE_SYS_IOCTL_H)
+check_include_file(sys/select.h HAVE_SYS_SELECT_H)
+check_function_exists(setenv HAVE_SETENV)
+check_function_exists(strcasecmp HAVE_STRCASECMP)
+check_function_exists(_stricmp HAVE__STRICMP)
+check_function_exists(stricmp HAVE_STRICMP)
+check_function_exists(strtoll HAVE_STRTOLL)
+check_function_exists(__strtoll HAVE___STRTOLL)
+check_function_exists(strtoull HAVE_STRTOULL)
+check_function_exists(__strtoull HAVE___STRTOULL)
+check_function_exists(strtoq HAVE_STRTOQ)
+check_function_exists(strtouq HAVE_STRTOUQ)
+check_function_exists(gettimeofday HAVE_GETTIMEOFDAY)
+check_function_exists(setgroups HAVE_SETGROUPS)
+check_function_exists(asprintf HAVE_ASPRINTF)
@ -631,10 +638,10 @@ index 0000000..2b305b7
+endforeach(ln)
diff --git a/include/xmlrpc-c/config.h.cmake b/include/xmlrpc-c/config.h.cmake
new file mode 100644
index 0000000..b2d7373
index 0000000..80892e5
--- /dev/null
+++ b/include/xmlrpc-c/config.h.cmake
@@ -0,0 +1,30 @@
@@ -0,0 +1,32 @@
+/* --*- c -*-- */
+#ifndef XMLRPC_C_CONFIG_H_INCLUDED
+#define XMLRPC_C_CONFIG_H_INCLUDED
@ -658,10 +665,12 @@ index 0000000..b2d7373
+ #define XMLRPC_SOCKET SOCKET
+ #define XMLRPC_HAVE_TIMEVAL 0
+ #define XMLRPC_HAVE_TIMESPEC 0
+ #define XMLRPC_HAVE_PTHREAD 0
+#else
+ #define XMLRPC_SOCKET int
+ #define XMLRPC_HAVE_TIMEVAL 1
+ #define XMLRPC_HAVE_TIMESPEC 1
+ #define XMLRPC_HAVE_PTHREAD 1
+#endif
+
+#endif
@ -865,10 +874,10 @@ index 0000000..5b2a7e4
+Cflags:
diff --git a/lib/expat/xmltok/CMakeLists.txt b/lib/expat/xmltok/CMakeLists.txt
new file mode 100644
index 0000000..359c4e4
index 0000000..42406fb
--- /dev/null
+++ b/lib/expat/xmltok/CMakeLists.txt
@@ -0,0 +1,22 @@
@@ -0,0 +1,23 @@
+# -*- cmake -*-
+
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
@ -876,7 +885,8 @@ index 0000000..359c4e4
+add_definitions(-DXML_BYTE_ORDER=0)
+
+add_library(xmlrpc_xmltok STATIC
+ xmltok.c xmlrole.c ${CMAKE_CURRENT_BINARY_DIR}/nametab.h)
+ xmltok.c xmlrole.c xmltok_impl.c
+ ${CMAKE_CURRENT_BINARY_DIR}/nametab.h)
+
+set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/nametab.h
+ PROPERTIES
@ -1004,7 +1014,7 @@ index 0000000..17535ab
+endif(MUST_BUILD_WININET_CLIENT)
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..4c03b5b
index 0000000..ae20515
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,121 @@
@ -1024,7 +1034,7 @@ index 0000000..4c03b5b
+
+if(MUST_BUILD_WININET_CLIENT)
+ set(client_wininet_CFLAGS "")
+ set(client_wininet_LIBS "${WININET_LDADD}")
+ set(client_wininet_LIBS "${WININET_LDADD}" pthread)
+ list(APPEND transport_SOURCES
+ ${wininet_srcdir}/xmlrpc_wininet_transport.c ${wininet_srcdir}/xmlrpc_wininet_transport.h)
+endif(MUST_BUILD_WININET_CLIENT)
@ -1037,7 +1047,7 @@ index 0000000..4c03b5b
+
+if(MUST_BUILD_CURL_CLIENT)
+ set(client_curl_CFLAGS ${CURL_CFLAGS})
+ set(client_curl_LIBS ${CURL_LDFLAGS})
+ set(client_curl_LIBS ${CURL_LDFLAGS} pthread)
+ set(xmlrpc_client_pkgconfig_req libcurl)
+ list(APPEND transport_SOURCES
+ ${curl_srcdir}/xmlrpc_curl_transport.c
@ -1131,7 +1141,7 @@ index 0000000..4c03b5b
+enable_testing()
diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
new file mode 100644
index 0000000..345c5ac
index 0000000..3171156
--- /dev/null
+++ b/src/cpp/CMakeLists.txt
@@ -0,0 +1,70 @@
@ -1141,7 +1151,7 @@ index 0000000..345c5ac
+add_library(xmlrpc++ SHARED
+ base64.cpp env_wrap.cpp fault.cpp girerr.cpp girmem.cpp
+ outcome.cpp param_list.cpp value.cpp xml.cpp)
+target_link_libraries(xmlrpc++ xmlrpc)
+target_link_libraries(xmlrpc++ xmlrpc pthread)
+list(APPEND lib_TARGETS xmlrpc++)
+ensc_pkgconfig(xmlrpc++)
+
@ -1834,21 +1844,23 @@ index 0000000..327fad7
+exec pkg-config "$@" $comp
diff --git a/xmlrpc_config.h.cmake b/xmlrpc_config.h.cmake
new file mode 100644
index 0000000..e4454e8
index 0000000..1665576
--- /dev/null
+++ b/xmlrpc_config.h.cmake
@@ -0,0 +1,105 @@
@@ -0,0 +1,141 @@
+/* -*- c -*- */
+
+#ifndef H_XMLRPC_C_CONFIG_H
+
+#define HAVE_SYS_IOCTL_H 0@HAVE_SYS_IOCTL_H@
+#define HAVE_SYS_IOCTL_H 0@HAVE_SYS_IOCTL_H@
+#define HAVE_SYS_SELECT_H_DEFINE 0@HAVE_SYS_IOCTL_H@
+
+#define VA_LIST_IS_ARRAY @VA_LIST_IS_ARRAY@
+#define XMLRPC_HAVE_WCHAR @XMLRPC_HAVE_WCHAR@
+#define ATTR_UNUSED @ATTR_UNUSED@
+#define DIRECTORY_SEPARATOR "@DIRECTORY_SEPARATOR@"
+
+#cmakedefine HAVE_SYS_SELECT_H 1
+#cmakedefine HAVE_WCHAR_H 1
+#cmakedefine HAVE_SETENV 1
+#cmakedefine HAVE_STRCASECMP 1
@ -1861,6 +1873,12 @@ index 0000000..e4454e8
+#cmakedefine HAVE_WCSNCMP 1
+#cmakedefine HAVE_LOCALTIME_R 1
+#cmakedefine HAVE_GMTIME_R 1
+#cmakedefine HAVE_STRTOLL 1
+#cmakedefine HAVE___STRTOLL 1
+#cmakedefine HAVE_STRTOULL 1
+#cmakedefine HAVE___STRTOULL 1
+#cmakedefine HAVE_STRTOQ 1
+#cmakedefine HAVE_STRTOUQ 1
+
+#define HAVE_UNICODE_WCHAR HAVE_WCHAR_H
+
@ -1907,6 +1925,14 @@ index 0000000..e4454e8
+#endif
+
+#if MSVCRT
+ #define HAVE_WINDOWS_THREAD 1
+#else
+ #define HAVE_WINDOWS_THREAD 0
+#endif
+
+#define HAVE_PTHREAD 1
+
+#if MSVCRT
+ #define XMLRPC_VSNPRINTF _vsnprintf
+#else
+ #define XMLRPC_VSNPRINTF vsnprintf
@ -1942,6 +1968,26 @@ index 0000000..e4454e8
+#pragma warning(disable:4996)
+#endif
+
+#if HAVE_STRTOLL
+ # define XMLRPC_STRTOLL strtoll
+#elif HAVE_STRTOQ
+ # define XMLRPC_STRTOLL strtoq /* Interix */
+#elif HAVE___STRTOLL
+ # define XMLRPC_STRTOLL __strtoll /* HP-UX <= 11.11 */
+#elif HAVE__STRTOUI64
+ #define XMLRPC_STRTOLL _strtoui64 /* Windows MSVC */
+#endif
+
+#if HAVE_STRTOULL
+ # define XMLRPC_STRTOULL strtoull
+#elif HAVE_STRTOUQ
+ # define XMLRPC_STRTOULL strtouq /* Interix */
+#elif HAVE___STRTOULL
+ # define XMLRPC_STRTOULL __strtoull /* HP-UX <= 11.11 */
+#elif HAVE__STRTOUI64
+ #define XMLRPC_STRTOULL _strtoui64 /* Windows MSVC */
+#endif
+
+#endif
--
1.6.5.2

View File

@ -1,7 +1,7 @@
From fceba968292c52b67e331384206652350d5331ea Mon Sep 17 00:00:00 2001
From 17701db33a5bbf34861a4fffb174dc62907a57f4 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 5 Apr 2008 11:41:34 +0200
Subject: [PATCH 3/6] Use proper datatypes for 'long long'
Subject: [PATCH 3/5] Use proper datatypes for 'long long'
xmlrpc-c uses 'long long' at some places (e.g. in printf
statements with PRId64) under the assumption that it has a
@ -22,7 +22,7 @@ for now, the patch uses datatypes with exact widths.
3 files changed, 11 insertions(+), 9 deletions(-)
diff --git a/include/xmlrpc-c/base.h b/include/xmlrpc-c/base.h
index a768b70..0069fc2 100644
index 42808c8..bb5c348 100644
--- a/include/xmlrpc-c/base.h
+++ b/include/xmlrpc-c/base.h
@@ -5,7 +5,9 @@

View File

@ -1,7 +1,7 @@
From 39c5b1cac226afa9dd5511fc55886691473fc730 Mon Sep 17 00:00:00 2001
From 9244de2058c6e1119905de9cef5a0cd87c44a58f Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Mon, 25 Feb 2008 17:48:25 +0100
Subject: [PATCH 2/6] fixed broken format string modifiers for size_t typed arguments
Subject: [PATCH 2/5] fixed broken format string modifiers for size_t typed arguments
---
lib/abyss/src/socket_unix.c | 4 ++--
@ -21,7 +21,7 @@ Subject: [PATCH 2/6] fixed broken format string modifiers for size_t typed argum
14 files changed, 25 insertions(+), 25 deletions(-)
diff --git a/lib/abyss/src/socket_unix.c b/lib/abyss/src/socket_unix.c
index 3da48cc..51a32a7 100644
index f58efeb..42c2174 100644
--- a/lib/abyss/src/socket_unix.c
+++ b/lib/abyss/src/socket_unix.c
@@ -193,8 +193,8 @@ channelWrite(TChannel * const channelP,
@ -36,7 +36,7 @@ index 3da48cc..51a32a7 100644
if (rc <= 0)
/* 0 means connection closed; < 0 means severe error */
diff --git a/lib/libutil/memblock.c b/lib/libutil/memblock.c
index 0026ec3..b96cb89 100644
index 2993eae..9468217 100644
--- a/lib/libutil/memblock.c
+++ b/lib/libutil/memblock.c
@@ -74,7 +74,7 @@ xmlrpc_mem_block_init(xmlrpc_env * const envP,
@ -134,7 +134,7 @@ index 2a6baea..c9fd75c 100644
else {
memcpy(byteStringValue, contents, size);
diff --git a/src/xmlrpc_datetime.c b/src/xmlrpc_datetime.c
index e7160ac..f129671 100644
index 2a43c41..06e1c50 100644
--- a/src/xmlrpc_datetime.c
+++ b/src/xmlrpc_datetime.c
@@ -468,7 +468,7 @@ validateFormat(xmlrpc_env * const envP,
@ -169,7 +169,7 @@ index eeb3414..36e62f6 100644
else {
struct mbrDecomp * const mbrP =
diff --git a/src/xmlrpc_parse.c b/src/xmlrpc_parse.c
index 980e7cd..a7dd973 100644
index 197da97..20bc919 100644
--- a/src/xmlrpc_parse.c
+++ b/src/xmlrpc_parse.c
@@ -46,7 +46,7 @@
@ -181,7 +181,7 @@ index 980e7cd..a7dd973 100644
xml_element_name(elem), (count), \
xml_element_children_size(elem)); \
while (0)
@@ -295,7 +295,7 @@ xmlrpc_parse_call(xmlrpc_env * const envP,
@@ -296,7 +296,7 @@ xmlrpc_parse_call(xmlrpc_env * const envP,
if (xmlLen > xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID))
xmlrpc_env_set_fault_formatted(
envP, XMLRPC_LIMIT_EXCEEDED_ERROR,
@ -190,7 +190,7 @@ index 980e7cd..a7dd973 100644
xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID));
else {
xml_element * callElemP;
@@ -547,8 +547,8 @@ xmlrpc_parse_response2(xmlrpc_env * const envP,
@@ -548,8 +548,8 @@ xmlrpc_parse_response2(xmlrpc_env * const envP,
if (xmlDataLen > xmlrpc_limit_get(XMLRPC_XML_SIZE_LIMIT_ID))
xmlrpc_env_set_fault_formatted(
envP, XMLRPC_LIMIT_EXCEEDED_ERROR,
@ -202,7 +202,7 @@ index 980e7cd..a7dd973 100644
else {
xmlrpc_env env;
diff --git a/src/xmlrpc_server_abyss.c b/src/xmlrpc_server_abyss.c
index 4c8262d..6e2be53 100644
index 1001d15..50329c2 100644
--- a/src/xmlrpc_server_abyss.c
+++ b/src/xmlrpc_server_abyss.c
@@ -485,7 +485,7 @@ processCall(TSession * const abyssSessionP,
@ -215,7 +215,7 @@ index 4c8262d..6e2be53 100644
xmlrpc_mem_block * body;
/* Read XML data off the wire. */
diff --git a/src/xmlrpc_string.c b/src/xmlrpc_string.c
index 93ac6d0..f51fba7 100644
index 89eb128..100cd77 100644
--- a/src/xmlrpc_string.c
+++ b/src/xmlrpc_string.c
@@ -141,7 +141,7 @@ xmlrpc_read_string(xmlrpc_env * const envP,

View File

@ -1,7 +1,7 @@
From fa520fd88d776435c90e054601dddf06f7077254 Mon Sep 17 00:00:00 2001
From 2d65f75290dee356f8678f800cbdba62bc5e6660 Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 21 Nov 2009 14:12:41 +0100
Subject: [PATCH 5/6] fixed unitialized variable
Subject: [PATCH 5/5] fixed unitialized variable
Reported by Nikola Pajkovsky <npajkovs AT redhat.com>:
@ -12,10 +12,10 @@ Reported by Nikola Pajkovsky <npajkovs AT redhat.com>:
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/lib/curl_transport/curltransaction.c b/lib/curl_transport/curltransaction.c
index bf7fa99..4239385 100644
index 019c401..4e592da 100644
--- a/lib/curl_transport/curltransaction.c
+++ b/lib/curl_transport/curltransaction.c
@@ -555,6 +555,7 @@ curlTransaction_create(xmlrpc_env * const envP,
@@ -605,6 +605,7 @@ curlTransaction_create(xmlrpc_env * const envP,
curlTransactionP->curlSessionP = curlSessionP;
curlTransactionP->userContextP = userContextP;
curlTransactionP->progress = progress;

View File

@ -1,10 +1,10 @@
From 009465f70f4941968f0f8abbbc7e0ba9252f68b5 Mon Sep 17 00:00:00 2001
From aa0c7af2685446c8950bb31c88811745cf2696eb Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 15 Nov 2008 12:07:25 +0100
Subject: [PATCH 4/6] 'va_list' param must be non-const
Subject: [PATCH 4/5] 'va_list' param must be non-const
vasprintf(3) uses a non-const 'va_list ap' parameter.
Hence, do not accept a 'const' on in the wrapper function.
Hence, do not accept a 'const' in the wrapper function.
---
include/xmlrpc-c/util.h | 2 +-
lib/libutil/error.c | 2 +-

View File

@ -1,29 +0,0 @@
From 6e9ccf34512f878be1a98a6b007aa338e891180e Mon Sep 17 00:00:00 2001
From: Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de>
Date: Sat, 21 Nov 2009 14:21:13 +0100
Subject: [PATCH 6/6] added option to make curl verbose
With this patch, when the $XMLRPC_TRACE_CURL environment variable is
set, verbose curl output/debugging will be enabled. Based upon a
patch from John Dennis <jdennis AT redhat.com>
---
lib/curl_transport/curltransaction.c | 3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/lib/curl_transport/curltransaction.c b/lib/curl_transport/curltransaction.c
index 4239385..9089d04 100644
--- a/lib/curl_transport/curltransaction.c
+++ b/lib/curl_transport/curltransaction.c
@@ -503,6 +503,9 @@ setupCurlSession(xmlrpc_env * const envP,
curl_easy_setopt(curlSessionP, CURLOPT_SSL_CIPHER_LIST,
curlSetupP->sslCipherList);
+ if (getenv("XMLRPC_TRACE_CURL"))
+ curl_easy_setopt(curlSessionP, CURLOPT_VERBOSE, 1l);
+
if (curlSetupP->timeout)
setCurlTimeout(curlSessionP, curlSetupP->timeout);
--
1.6.5.2

View File

@ -1,11 +1,11 @@
%global advanced_branch 1
%global svnrev 1841
%global svnrev 1851
%{!?release_func:%global release_func() %1%{?dist}}
Summary: A lightweight RPC library based on XML and HTTP
Name: xmlrpc-c
Version: 1.20.3
Version: 1.21.00
Release: %release_func 1300.%svnrev
# See COPYING for details.
# The Python 1.5.2 license used by a few files is just BSD.
@ -22,7 +22,6 @@ Patch102: xmlrpc-c-printf-size_t.patch
Patch105: xmlrpc-c-longlong.patch
Patch106: xmlrpc-c-va_list.patch
Patch107: xmlrpc-c-uninit-curl.patch
Patch108: xmlrpc-c-verbose-curl.patch
BuildRoot: %_tmppath/%name-%version-%release-root
@ -110,7 +109,6 @@ This package contains some handy XML-RPC demo applications.
%patch105 -p1
%patch106 -p1
%patch107 -p1
%patch108 -p1
## not needed...
rm doc/{INSTALL,configure_doc}
@ -225,6 +223,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Jan 14 2010 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.21.00-1300.1851
- updated to 1.21.00 (rev 1851)
- removed curl-trace patch as applied upstream
- rediffed patches
* Sat Nov 21 2009 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 1.20.3-1.1841
- updated to rev1841
- rediffed patches